Getting Started for Design

Version 11
April 2015
12d Model 10 Getting Started for Design Manual

7 first released in January 2005
8 first released in April 2007
9 first released in May 2009
10 first released in March 2012
11 first released in October 2014

Disclaimer

12d Model is supplied without any express or implied warranties whatsoever.
No warranty of fitness for a particular purpose is offered.
No liabilities in respect of engineering details and quantities produced by 12d Model are accepted.

While every effort has been taken to ensure that the advice given in this manual and the program
12d Model is correct, no warranty is expressed or implied by 12d Solutions Pty Ltd.

Copyright

This manual is copyrighted and all rights reserved.

This manual may not, in whole or part, be copied or reproduced without the prior consent in writing from
12d Solutions Pty Ltd.

Copies of 12d Model software must not be released to any party, or used for bureau applications without
the written permission of 12d Solutions Pty Ltd.

Copyright (c) 1989-2015 by 12d Solutions Pty Ltd.
Sydney, New South Wales, Australia.
ACN 101 351 991
All rights reserved.
## Table of Contents

**Preface** ................................................................................................................................. 9
  - Training Material .................................................................................................................... 9
  - Getting Started for Surveying .................................................................................................. 9
  - Using the Practise and Small Versions of 12d Model............................................................. 9

1 **Installing 12d Model** ............................................................................................................. 11

2 **Before You Begin the Training** ............................................................................................ 13
  - 2.1 Installing the Training Files ............................................................................................... 13
  - 2.2 12d Icons on your Desktop .............................................................................................. 13
  - 2.3 Using the Practise Version ................................................................................................ 13
  - 2.4 Overview of 12d File and Folder Structures ..................................................................... 13
  - 2.5 Why Keep Projects in Separate Folders .......................................................................... 14
  - 2.6 File Backup Procedures .................................................................................................... 14

3 **12d Model Help** .................................................................................................................... 17
  - 3 Contents ............................................................................................................................... 19
  - 3 Index ..................................................................................................................................... 21
  - 3 Find ..................................................................................................................................... 22
  - 3 Panel Help Button ............................................................................................................... 24
  - 3 F1 Key .................................................................................................................................. 25
  - 3 Navigating in Help ............................................................................................................... 26
  - Extra Help .............................................................................................................................. 27

4 **Basic Operations** .................................................................................................................. 29
  - 4.1 The Mouse ......................................................................................................................... 29
  - 4.2 Starting Up - The Project Selection panel ........................................................................ 30
  - 4.3 The Initial Screen Layout .................................................................................................. 32
  - 4.4 How to Find Your Way Around 12d Menus ..................................................................... 34
  - 4.5 Toolbars and Controlbars ................................................................................................. 38
    - 4.5.1 CAD Toolbar and CAD Controlbar ............................................................................. 38
    - 4.5.2 CAD Text Toolbar and Text Controlbar ..................................................................... 41
    - 4.5.3 Symbol Controlbar ...................................................................................................... 44
    - 4.5.4 Search Toolbar ........................................................................................................... 45
    - 4.5.5 Snaps Toolbar ............................................................................................................. 45
  - 4.6 Status Bar .......................................................................................................................... 46
  - 4.7 Screen Message Box ......................................................................................................... 46
  - 4.8 View Coordinates Box ..................................................................................................... 47
  - 4.9 The Output Window ........................................................................................................ 48
  - 4.10 Introduction to Views ...................................................................................................... 50
    - 4.10.1 Basic View Operations ............................................................................................. 51
  - 4.11 Introduction to Models ..................................................................................................... 55
  - 4.12 Introduction to Strings .................................................................................................... 56
  - 4.13 Introduction to Panels ..................................................................................................... 57

5 **Starting the Tutorial** .............................................................................................................. 59
  - 5.1 Importing Point Data into 12d .......................................................................................... 59
  - 5.2 Plan View Operations ...................................................................................................... 67
  - 5.3 Birds-Eye Views and Throwing Between Views ............................................................... 69
  - 5.4 Rolling Middle Mouse Button to Zoom In and Out ......................................................... 73
  - 5.5 Deleting a Model .............................................................................................................. 74
  - 5.6 Redraw - Fixing up a Modified or Erroneous View ......................................................... 75
  - 5.7 View Tabs ........................................................................................................................ 75
  - 5.8 Saving a Project ................................................................................................................ 76
  - 5.9 Exit .................................................................................................................................... 76
  - 5.10 Starting 12d When Projects Already Exist ..................................................................... 76

6 **Basic Modelling** ..................................................................................................................... 79
  - 6.1 Alternative Data Entry ...................................................................................................... 79
  - 6.2 Saving a Model Listing to a File for Future Use ............................................................... 80
  - 6.3 Triangulation ..................................................................................................................... 81

---

5
6.4 Tin inquire.......................................................................................................................... 84
6.5 Fast Contours ..................................................................................................................... 86
6.6 Fast Flow Arrows ............................................................................................................... 88
6.7 Perspective View ................................................................................................................. 89
6.8 Pan and Zoom in Perspective Views .................................................................................... 90
6.9 Joy Panel .............................................................................................................................. 91
6.10 Orbit ................................................................................................................................. 92
6.11 Plan Camera ....................................................................................................................... 94
6.12 Fast Meshes in Perspective view ......................................................................................... 96
6.13 Fast Contours in Perspective Views .................................................................................... 99
6.14 Shaded Views ..................................................................................................................... 100

7 String Picking Concepts ........................................................................................................ 101
7.1 String Inquire ..................................................................................................................... 102
7.2 Use of Mouse Buttons and Enter Key when using Tentative Picking ..................... 104
7.3 Pick Operations Menu via the Right Mouse Button ....................................................... 104
7.4 Snap Settings ..................................................................................................................... 105
7.5 Models and Snap Settings ................................................................................................. 108
7.6 Fast Picking Snap (F) ........................................................................................................ 108
7.7 Fast Accept Snap (A) ......................................................................................................... 108
7.8 Modifying the String Highlighting Colour ......................................................................... 109

8 Creating Strings with CAD .................................................................................................. 113
8.1 Creating Points ................................................................................................................... 113
8.2 Creating Two Point Lines ................................................................................................. 118
8.3 Creating Line Strings ........................................................................................................ 119

9 Basic Road Design - Centreline String Creation and Editing ............................................. 121
9.1 Typed Input ......................................................................................................................... 121
9.2 Horizontal Geometry (HG) Edit ....................................................................................... 122
9.3 Section Views .................................................................................................................... 130
9.3.1 Profiling a String on a Section View ............................................................................ 131
9.4 Vertical Geometry (VG) Edit ............................................................................................ 135
9.5 Editing an Existing String ................................................................................................. 145
9.6 Using a Grid to Assist in Coordinate Entry ...................................................................... 146

10 Road Templates .................................................................................................................. 149
10.1 Creation of Basic Templates ............................................................................................ 149
10.2 Applying Templates ......................................................................................................... 154
10.3 Alternative Template Creation ....................................................................................... 157

11 Design Long Sections ......................................................................................................... 159
11.1 Section Profiles ............................................................................................................... 159

12 Viewing and Assessing the Design ..................................................................................... 163
12.1 Perspective View Operations ............................................................................................ 165
12.2 String Drive ....................................................................................................................... 166
12.3 Defining a New Perspective View using Eye and Target points .................................. 168

13 Design Cross Sections ......................................................................................................... 171
13.1 Model Profiles .................................................................................................................. 172
13.2 Quick Model Profile for the Section View ...................................................................... 174
13.3 Extend the Profile in the Section View ........................................................................... 175

14 Services Interference .......................................................................................................... 177
14.1 Addition of Services to the Terrain .................................................................................. 177
14.2 Profiling the Services ....................................................................................................... 178
14.3 View Services in Cross Section ....................................................................................... 179
14.4 Viewing Interference with Services in Long Section .................................................... 181
14.5 Setting Corridors ............................................................................................................. 182

15 Modification of Design Parameters ..................................................................................... 183
15.1 Modify Vertical Geometry ............................................................................................... 184
Preface

Why a ‘Getting Started for Design’ Manual?

12d Model is supplied with a comprehensive on-line Reference manual which describes the function of each menu option in detail. It is a Reference manual however and makes no attempt to describe how to use 12d for production surveying and civil engineering work.

The Getting Started for Design manual is designed to show you how to work with the context sensitive help system, and then as the first section of Training, help you start to learn how to use 12d to achieve typical civil engineering tasks. The Getting Started for Design manual uses examples where possible to clarify usage. It complements rather than replaces the Reference manual. In general, information in the Reference manual will not be duplicated here.

The Getting Started for Design manual is available as a printed manual and as a PDF file on the 12d Model 11 Installation DVD and the 12d Model Training DVD.

Training Material

The training tutorials assumes that a series of files are already on your hard disk. These tutorial files are automatically installed from the DVD during installation of the 12d Model software.

Getting Started for Surveying

There is also a Getting Started for Surveying which has the first seven chapters in common with the Getting Started for Design manual (context sensitive help and basic modelling) but then diverts to cover topics from the direction of a Surveyor whereas the Getting Started for Design manual continues on with alignment design techniques.

The Getting Started for Surveying manual is available as a printed manual and as a PDF file on the on the 12d Model 11 Installation DVD and the 12d Model Training DVD.

Using the Practise and Small Versions of 12d Model

IMPORTANT NOTE - The Practise Version is not yet available for 12d Model 11

The Practise version of 12d Model is limited to a maximum of 5,000 points. Following the procedures as stated in the Training Manual may create projects with more than 5,000 points.

Where appropriate, the text will suggest how to vary the input for each instruction so that the example feature can be completed within the limits of the 12d Model Practise version.

The number of points used at any time in the Practise and small versions can be displayed by the option Projects => Check base points

The easiest way to reduce the current point count is to delete any unwanted models with Models => Delete

The installed icon on your desktop for running the practise version of 12d with these training files is labelled 12d 11 Practise.

Please Note: Projects created by Practise versions of 12d Model cannot be accessed by Release versions of 12d Model and vice-versa.
1 Installing 12d Model

The 12d Model 11 Installation DVD can be used to install the Release and Practise versions of 12d Model 11.

IMPORTANT NOTE - The Practise Version is not yet available for 12d Model 11

The Practise version is limited to a maximum of 5,000 points and creates projects that cannot be accessed by the Release versions of 12d Model and vice-versa. However the Practise version can be used free of charge by 12d Solutions customers and registered Practise Users.

Installing the Release Version for Sites Not Running 12d Model 9 or 12d Model 10

For a new installation of the Release version of 12d Model 11, the user is provided with
(a) one 12d Model dongle
(b) one 12d Model 11 Installation DVD
(c) an email with the 12d Model 11 authorization file nodes.12d11n attached, or a folder with the 12d Model 11 authorization file nodes.12d11n or nodes.4d in it.

Please check that you have all three items before commencing the installation.

The notes and video for a new install of the Release version of 12d Model 10 are on the 12d Model 11 Installation DVD or can be downloaded from the 12d web site www.12d.com under the Updates area.

Installing the Release Version for Sites Already Running 12d Model 9 or 12d Model 10

Existing 12d Model 9 or 12d Model 10 users already have a dongle and so are only provided with
(a) one 12d Model 11 Installation DVD
(b) an email with the 12d Model 11 authorization file nodes.12d11n attached, or a folder with the 12d Model 11 authorization file nodes.12d11n or nodes.4d in it.

For existing 12d Model 9 and 10 users with a Wibu dongle, your existing dongle can be used with 12d Model 11. If 12d Model 11 is already running on your computer, please uninstall it before installing a new version of 12d Model 11.

For existing 12d Model 9 and 10 users with a Hardlock dongle, your existing dongle can NOT be used with 12d Model 11. Please contact your 12d Model 11 Reseller to obtain a new dongle.

The notes and video for a new install of the Release version of 12d Model 11 are on the 12d Model 11 Installation DVD or can be downloaded from the 12d web site www.12d.com under the Updates area.

Installing the Practise Version:

IMPORTANT NOTE - The Practise Version is not yet available for 12d Model 11

To install a Practise version of 12d Model 11, all that is needed is:

one 12d Model 11 Installation DVD

or 12d Model 11 Practise downloaded from www.12d.com

The Practise version must be Registered with 12D Solutions once it is installed on a computer. A new Registration is required for each computer that the Practise version is run on.

The notes and video for installing the practise version of 12d Model 11 are on the 12d Model 11 Installation DVD or can be downloaded from the 12d web site www.12d.com under the 12d Model 11 Practise area.
Chapter 2 Before You Begin the Training

2 Before You Begin the Training

2.1 Installing the Training Files

If you have installed Training from the 12d Model Installation DVD, then the Training folder will have been automatically created for you but where the files reside on the disk depends on whether you installed the Release version or the Practise version of 12d Model.

The Training manual dialogue assumes that the working folder (i.e. shortcut) of your 12d Model 11 or 12d Model 11 Practise icon is set to

c:\12d\11.00   for the Release version of 12d Model

and

c:\12 Model 11 Practise   for the Practise version of 12d Model

The training files can be placed in any sub-folder on your hard disk but for convenience in this manual, it is assumed that the training files are installed in

c:\12d\11.00\Training

All the required material is already in the Training folder.

2.2 12d Icons on your Desktop

It is recommended that you use the 12d Model 11 icon for the Release version or 12d Model 11 Practise icon for the Practise version whilst initially working with this training manual. The reason for this is that the icon points directly to the folder that containing the Training folder.

2.3 Using the Practise Version

IMPORTANT NOTE - The Practise Version is not yet available for 12d Model 11

Remember that the Practise version of 12d Model is limited to a maximum of 5,000 points.

Following the procedures as stated in the Training Manual may create projects with more than 5,000 points. Where appropriate, the text will suggest how to vary the input for each instruction so that the example feature can be completed within the limits of the 12d Model Practise version.

2.4 Overview of 12d File and Folder Structures

Before you begin using 12d, it is useful to understand how 12d uses the file and folder structure under Windows 7.

12d recognises long filenames up to 256 characters so you are not limited to the old DOS convention of 8.3 filenames.

The 12d software and its support files are installed on your hard disk, the program itself is installed into the folder c:\Program Files\12d or c:\Program Files (x86)\12d, and various subfolders below. The training data and user areas, are installed into the folder c:\12d\11.00 and subfolders below.

When the software was installed, the 12d Model 11 program icon is setup to point to the folder c:\12d\11.00.

The tutorial is about designing a road and the training the files have been set up in a folder c:\12d\11.00\Training\11.00\Design\Getting Started Basic.

As each 12d Model project you work on will have different files, it is strongly recommended that you keep each project in a separate subfolder. This can be anywhere on your hard disk or network. For convenience, you may prefer to keep them all under one major folder e.g. c:\12djobs.

In the general case for production work however, if you were about to start work on a new project by the name ‘Highway’, you would like it to be in a new folder under say 12djobs i.e. c:\12djobs\Highway. This is simply done from within 12d Model where a folder of the same name as the project is automatically
created with the project inside it.

Either numeric or alpha characters and spaces can be used in 12d Model project names so you may prefer to use your job name as the project name. Also 12d project names are not case sensitive so ‘Highway’ is seen as the same name as ‘highway’.

2.5 Why Keep Projects in Separate Folders

12d can have more than one project within the one Windows folder. For example, projects under ‘Highway’ might be ‘Stage 1’ and ‘Stage 2’ or ‘Fred’ and ‘Bill’. Each project has its own data and configuration setup which controls the number of views, which models are on display etc.

However although most internal 12d project files are kept separate another projects internal files, all input and output files, mtf files, chains, plots and reports go into the folder containing the project and are not held inside the project itself. Hence to prevent projects interfering with each other, it is best to create a separate folder and create each project in its own folder.

For example, if the Highway project has two stages, create the project Stage 1 in the folder Highway\Stage 1 and the project Stage 2 in the folder Highway\Stage 2

Once inside 12d, from within any one project, it is possible to import any or all data from another project so there is some flexibility on a major job to move/copy survey or design data between stages if staging is used and then have multiple users perform parallel development. Model and tin sharing could later be used to subsequently assemble staged project data at the completion of a major job. Within any one project, model names must be unique so some planning is necessary if parallel development streams are subsequently to be reassembled. Models can be renamed at any time. Models are discussed in See Chapter 4.11 (on page 55).

Provided no 12d user is currently accessing a particular project, the project (and the folder containing it) can be copied, renamed, moved and deleted from within 12d Model.

**WARNING** - information inside the project itself should not be manipulated except from within 12d Model since this may corrupt the project and data could be lost. For example, model names can only be renamed from within 12d Model.

If you need to manually place any files on disk for a project (e.g. survey files from a total station or CAD files to get data into 12d Model, it is recommended that you place them in the folder containing the project. that way all the data and the project are in the one folder.

2.6 File Backup Procedures

To ensure that you can retrieve any job or project at any time from backup procedures, it is important that a complete ‘set’ of files is taken whenever backup is created. To backup the files associated with the ‘Highway’, you would typically backup all files and sub-folders in and below

\c:\12djobs\Highway

There are configuration files used that may be used in the Highway job, that are supplied by 12D Solutions and are automatically installed from the 12d Model Installation DVD. These files are in

\c:\Program Files\12d\12dmodel\11.00\set_ups
\c:\Program Files\12d\12dmodel\11.00\library

There are other user configurable files that 12d may use and require to fully recreate all steps of a project. They are not supplied on the 12d Model Installation DVD. These files are typically in

\c:\12d\11.00\user
\c:\12d\11.00\user_lib

These folders may contain files that have been configured specifically for your site e.g. your corporate standard mapping, template and plot parameter files, your particular Total Station survey macros and any user defined macros etc. In general, such files are not project specific, however because these files are user configurable they may be changed at any time and hence particular project specific versions of them may
be needed as part of the complete file set of a project.

In the above case, the folders shown are for 12d Model 11. As implied, the files in these folders will never be changed automatically by the installation process when you reinstall a later version of 12d.

The above paths are indicative only. It is possible that folders have been setup at different places for your site. For more information on exactly where all library and user folders are located, refer to the section 39.1 Folder Structure Installed by 12d Model in the 12d Model Reference Manual and 12d Model Context Sensitive Help, and for information on the environment variables

USER_4D
USER_LIB_4D
SET_UPS_4D
LIB_4D

that control where the various files are, see 7.6.3 env.4d and 39.5 Environment Variables in the 12d Model Reference Manual and 12d Model Context Sensitive Help.
3 12d Model Help

Position of option on menu: Help => 12d Model

All the information in the 12d Model Reference manual is also available as electronic Help accessed from within 12d Model (also know as the 12d Model Context Sensitive Help).

The entire 12d Model Help manual can be accessed by selecting 12d Model on the Help menu item on the main 12d Model menu.

Clicking on 12d Model brings up Help Topics: 12d Model Reference

The panel Help Topics: 12d is actually using Microsoft’s WinHlp system and it allows you to look at the overall structure of the 12d Model Help and access any part of it. More information on
using the tabs Contents, Index and Find will follow in the next section.

Alternatively, individual topics for a panel or menu can be invoked by pressing the F1 key whenever the focus is on the menu or panel, or by clicking on the Help button on any 12d Model panel (see F1 Key). This is the context sensitive nature of the 12d Model Help.

For some options, there is also additional help files and videos. This is denoted by a * after Help on the Help button. That is Help* (see Extra Help).

It is also possible to have a Help button and F1 key available for 12d Model PLs (macro) programs written by 12d Solutions or by Users. Please see the 12d Model Programming Language manual for more information on this feature.

Note: The 12d Model Reference manual is available in pdf on the 12d Model installation DVD, or on the 12d web site www.12d.com.

More information on the Help system is given in the sections:

Contents
Index
Find
Panel Help Button
F1 Key
Navigating in Help
Extra Help
Contents

The Contents tab allows you to look at the overall structure of the 12d Model Help and access any part of it.

Warning - only topics in the Contents can be viewed in Help so any folders in Contents folders must be expanded until topics are displayed. Topics can be easily identified because they have a question mark beside them indicating that Help is available and can be viewed.

For example, double clicking on Tools and Concepts expands the next level of Tools and Contents.
and topics are *The Mouse, The Keyboard* etc.

Double clicking on the topic *Picking Strings* will then display the topic. The *Contents* then disappear leaving *Help* open at the selected topic.
Double clicking on **Contents** on the top of the *Help* will bring the Contents listing back up.
Continue to **Index** or return to **3 12d Model Help**.

**Index**

The *Index* tab searches through all entries in the Index of the Help.
As the first few characters of the required entry are typed in, the matching index entries are displayed.

Double clicking on the displayed entries will go to the topic in the Help containing the selected index entry. If more than one topic includes the index entry, then the list of topics is displayed.
If the index has sub-indices, they can be searched by first typing in the main index followed by a comma, then a space and the first few characters of the sub-index.
Continue to **Find** or return to **3 12d Model Help**.
Find

The most powerful searching method for the Help system is Find. Simply click on the Find tab to search for words or phrases that may be contained in a Help topic. If Find is being invoked for the first time, the Find Setup Wizard runs to create an index of every word in the Help.

From then on, selecting the Find tab goes straight to the Find screen.
Continue to Panel Help Button or return to 3 12d Model Help.
Panel Help Button

Every panel has a **Help** button which when selected goes to the *topic* describing that panel.

The default **12d Model Help** is all in one *Winhelp* file but a method for displaying additional help information exists so 12d Solutions, 12d Distributors and Users can supply additional (extra) *Help* information.

If there is extra help available for an option, then **Help** will appear instead of **Help** on the panel button.

Information on how the extra help is set up is given in the section **Extra Help**.

Continue to **F1 Key** or return to **3 12d Model Help**.
F1 Key

Another method of invoking Help is by using the F1 key as follows:

when a menu or panel is on the screen and has focus (the menu or panel title area will be highlighted), or the cursor is over an item on a toolbar, pressing F1 will bring up the help for that menu, panel or toolbar item.

**Warning** - some of the items on the Strings menu automatically start up a string select and change the focus from the panel to a View. This means that pressing F1 will bring up the Help for the View and not the Help for the panel.

To get Help for such a panel, click on the panel to bring the focus back to the panel before pressing F1. The top of the panel will highlight showing that it has focus.

Continue to [Navigating in Help](#) or return to [3 12d Model Help](#).
Navigating in Help

Once at a topic in the Help, the << and >> buttons at the top of the Help topic will go to the previous and next Help topics respectively.

Individual Help topics can be printed by clicking Print at the top of the Help page.

Because it is difficult to print large sections of Microsoft's Help system, a PDF file of the entire 12d Model Reference Manual has been created and can be used to print out large sections of the manual.


Continue to Extra Help or return to 3 12d Model Help.
Extra Help

The default context sensitive 12d Model Help is all in one help file supplied by 12d Solutions but a method for displaying additional help information exists so 12d Solutions, 12d Distributors and Users can supply additional (extra) Help information. This extra information can also be supplied by 12d Model PLs (macros) written by 12d Solutions or Users.

How to Set Up Extra Help

Any extra help for an inbuilt panel (that is, one not created by a macro) is placed in a folder with the same name as the dump name for the panel without the ending after the “.” (to get the dump name, see Dumping a Panel, Creating a Screen Layout File or Default File in 12d Help or the 12d Model Reference manual).

For macros, created by Users or 12d Solutions, there can only be the same Help button for any panels created by the macro and the extra help for the macro is placed in a folder with the same name as the macro without the ending "4do" after the "." and with any blanks or non alphanumeric characters replaced by a underscore ("_"). For example, the extra help files for the macro called "testing help (3) system.4do" go in a folder called testing_help__3__system. Note there is an underscore for the blanks and the "(" and ")" in the macro name.

The extra help files for an inbuilt panel or macro can have any name and can be a pdf, wmv, avi. txt etc.

For example, for the panel Project Tree brought up by selecting Project =>Tree, the extra documentation would be in a folder called Project_Tree.

The folder of extra help for a panel, is then placed in any one of the three places:
(a) in the Help folder in the 12d Model installation area: For example, for version 11
   c:\Program Files\12d\12d Model\11.00\Help
   c:\Program Files (x86)\12d\12d Model\11.00\Help

(b) in a folder called Help inside the Set_ups folder in the 12d Model installation area. For example
   c:\Program Files\12d\12d Model\11.00\Set_ups\Help
   c:\Program Files (x86)\12d\12d Model\11.00\Set_ups\Help
   or

(c) in a folder called Help inside the User folder in the 12d User area. For example
   c:\12d\11.00\User\Help

For an inbuilt panel an macro, each of these areas is searched and if any extra help is found, it is listed with the full path to each extra help file.

If there is any extra help for a inbuilt panel or macro, the Help button on the panel will be replaced with a Help * button. The * indicates that there is extra help available.

When you click on the Help * button, you will get a list of all the extra help files for that inbuilt panel or macro with the full pathname to the extra help. Clicking on the file name will bring up that extra help.

For example,
Users Own Extra Help Files

Note that users can also have their own extra help files and the files are simply placed in the correctly named folder under User\Help.
4 Basic Operations

4.1 The Mouse

12d works best with a three button mouse (preferable a wheel mouse). 12d will work with a (Microsoft) two button mouse but the lack of the middle button means that you have extra mouse clicks to perform. All 12d Documentation uses the following notation for mouse functions.

- **LB** = left mouse button - used for picking screen items, menus etc.
- **MB** = middle mouse button - used to accept the highlighted item
- **RB** = right mouse button - used to pop up a list of alternatives

The left button is the ‘Select’ button – typically used to select graphic items or text. The middle button (or wheel) is the ‘Accept’ button, used to confirm a selection. The right button is the ‘Menu’ button. It is context sensitive and often displays a list of alternatives available at that instant.

With a two button mouse you achieve this functionality by clicking the right mouse button to pop up the ‘Pick Operations’ menu and then clicking LB on **Accept** or by simply pressing the <Enter> key

The term ‘clicking’ a button means pressing it down and releasing it again. The position of the mouse is taken at the time the button is released. In this tutorial manual, items that are selected by a mouse click are in **bold**.

As we get more experienced, we will also introduce the term ‘dragging’ the mouse for some advanced 12d operations. We do this by pressing down a button and whilst still holding it down, moving the mouse so that the screen cursor moves. Once a definite distance has been achieved, just a millimetre or two is sufficient, release the button. 12d notes the vector you defined and can use this information to detect the direction in which you dragged the mouse.

Finally, we will use the term ‘double clicking’. This is where we press the button twice in quick succession. This is often used for short-cuts.
4.2 Starting Up - The Project Selection panel

If you installed 12d Model from the 12d Model Installation DVD, then a 12d Model 11 icon will have been created on your desktop. The 12d Model front screen will then appear.

Click LB on New button at the bottom of the panel to bring up the Open/Create panel with the New tab selected.

By clicking the LB on the folder icon, navigate to the folder C:\12d\11.0\Training\design\getting started basic

Type in STAGE 1 in to Project name

Leaving the Create working folder? check box ticked will create a new folder of the same name (the Working Folder) and then create the project folder inside the Working Folder.

Click LB on the folder icon at the end of the Folder name field and browse to:

C:\12d\11.0\Training\design\getting started basic.

Type STAGE 1 into the Project name field and tick on Create working folder.

Then click LB on the New button.

Then a folder with the same name as Project name is created (called the Working Folder), and a new project called Project name is created inside the Working Folder.

Note

It is important to select names that are meaningful to your job as you may have several projects associated with a large or complex job.

Once a project is selected, the graphics screen will display, with the Setup Project Details panel open. Fill in the panel with the relevant required details.
Click on Set to save the details and Finish to close the panel.

RULES FOR ENTERING DATA INTO PANELS

Important: The cursor must be locked into the appropriate data entry field when typing data into a 12d panel. Often this will happen automatically. If you cannot see the cursor flashing in the data field in which you want to enter data, use the mouse to position the cursor anywhere over the data field and click the LB to lock the cursor into the field before typing any data. Terminate the data entry sequence by pressing the <Enter> key.

If you make a mistake, you can always select the erroneous entry by double clicking over it with the mouse LB. The text should then appear highlighted. As you retype it, the old entry is deleted.

When filling in data in any 12d panel, it is not essential to terminate the entry of data by pressing <Enter>. You can use the <Tab> and <BackTab> keys to move from field to field. You can also use the mouse to move between fields.

If you do press <Enter> to terminate the entry of data into a field, 12d will immediately validate the data in that field and if required, write an error message.
4.3 The Initial Screen Layout

The default background colour for a view is black because black is the best colour for reducing eye strain and for distinguishing colours displayed in a view.

To make the Getting Started manuals easier to print on in-house printers, many of our illustrations have a white background colour.

The names we use for the various parts of the screen are shown on the diagram below. Your screen may not appear exactly as shown as most components on the screen can be moved or turned off by user configuration options, or you have a different screen resolution.

Note that the View in the image with the white background has a title and it is Plan 1. This says that it is a Plan view with the name 1. The View names must be unique.

Each View can be Minimised, Maximised or Closed.

The Plan View 1 can be maximised by clicking LB on the square button in the top right hand corner of the view menu.
This then takes up the entire viewing area. Alternatively, you can **double click LB** on the plan view title area to maximise the view (The blue area to the left of the View Minimise button).

To reduce it back to its original size you can hit the restore icon.

The **Recalc** panel is used to quickly rerun design calculations and will be discussed later. We will move the panel down to the bottom left of the screen by holding LB down over the menu title are Recalc and then moving the cursor to bottom left hand corner of the screen and then releasing LB wen the Recalc menu is where we want it to be.

The view should then look as shown below.
4.4 How to Find Your Way Around 12d Menus

12d options are run by a number of methods. The **Drop Down** Main Menu system from the bar running across the top of the screen is the main way we access 12d programs.

In addition to the **Drop Down** Main menu system, there is a floating **12d Model** menu that can be pinned. This is found at **Projects=>12d Model menu**.

12d has a unique graphical user interface (GUI) involving hundreds of menu items. These are logically grouped by function in a Walk Right and Tear Off menu system.

**Walk Right** menus are menus designed such that if you move the mouse cursor right on a menu item containing a right arrow, a further menu will pop up, usually on the right hand side.

**Tear Off** means that a menu can be torn off it’s parent menu and relocated elsewhere on the screen for clarity of operation. In general, it is possible to have multiple copies of the same Tear Off menu on the screen at one time.

Notice that the order of items left-to-right on the Drop Down **Main Menu** bar is the same as the top-to-bottom order on the Walk Right **12d Model** menu. You can select menu items from either one of these sources – the end result is the same.

The Drop Down menu bar conforms to normal Microsoft standards so it can be dragged and placed at any of the four sides of your desktop. It is probably most usable left at the top of your desktop.

The following comments apply to **ALL** menus. To move any menu around on the screen, you **drag** it by **depressing** the LB in the View Title area at the top of the menu, anywhere **other** than over the **X** in the top right hand corner. With the button still depressed, move the mouse to the desired location and release the button to repin the menu. The same procedures also apply when moving panels and views. When doing this just make sure that LB is clicked in the general heading area and not on a **View** button.
To ease the learning and usage process, a menu description system has been adopted in this manual that describes where to look to achieve a specific function. For instance, to import an AutoCAD DXF file of point and line data into 12d, you Walk Right on the 12d Model menu or from the Drop Down Main Menu bar, through two submenus and select DWG/DXF. This instruction is documented as…

**File => Data Input => DWG/DXF/DXB**

To display submenus from the Walk Right, you do not need to use the mouse buttons. Simply position the mouse cursor over the 12d Model menu and once File I/O is highlighted, slide the mouse right over the arrow and the File I/O menu will pop up. Slide further right on the Data input menu item and the Data Input menu will pop up.

Your screen should appear as follows

![Menu Screen](image)

Alternatively, you can use the Drop Down menu bar to get to the same point …

To get to this same point using the pull down system, you need to click LB on [File] on the Drop Down menu bar and then proceed as before on the walk rights as shown below.
Regardless of which menu selection method you used, place the cursor over the words **DWG/DXF/DXB** and click the left mouse button (LB) once. The **Read DWG/DXF Data** panel will appear.
Once the panel is selected, the Walk Right menu system should collapse and be removed from the screen. If you move and repin any of the menus however, they will not collapse automatically.

If a menu is in the way, you can move it as already described. Any menu can be removed by clicking LB on the X button in the top right hand corner.

You would normally now start entering data into the panel. At this time, we will not proceed further with this panel. Shut down the panel by clicking LB on the finish button or clicking LB on finish at the base of the panel.

The panel is placed on the screen at the location where the mouse cursor was when LB was clicked.
4.5 Toolbars and Controlbars

See

Chapter 4.5.1 CAD Toolbar and CAD Controlbar
Chapter 4.5.2 CAD Text Toolbar and Text Controlbar
Chapter 4.5.3 Symbol Controlbar
Chapter 4.5.4 Search Toolbar
Chapter 4.5.5 Snaps Toolbar

4.5.1 CAD Toolbar and CAD Controlbar

In 12d Model there are CAD options which are available under both the CAD menu and on the CAD Toolbar on the left hand side of the 12d Model screen.

The CAD options create various elements using a number of methods. These options make use of Toolbars and Controlbars. Toolbars just have icons on them but Controlbars have icons and also controls such as a model box on them. The method groupings are shown on the toolbars (e.g. Points, Lines etc.).

The user can select an icon on the toolbar and a Flyout for all options of the grouping are displayed. This can be done by selecting the appropriate group symbol by holding down the left mouse button on the icon. This shows all the different options for that grouping in a flyout panel. Whilst still holding down the left mouse button, the user can move along the flyout toolbar to the appropriate option.

The elements created from the CAD options will have attributes as defined by the Cad Control Bar. This control bar is placed on the top left hand side of the screen under the Main Menu control bar on the creation of a project.
The fields and buttons used in this control bar have the following functions.

<table>
<thead>
<tr>
<th>Field Description</th>
<th>Type</th>
<th>Defaults</th>
<th>Pop-Up</th>
</tr>
</thead>
<tbody>
<tr>
<td>name box</td>
<td>base</td>
<td>names.4d names</td>
<td></td>
</tr>
</tbody>
</table>

name of string. If a valid name already exists in names.4d, the [N] button can be used to bring up a choice box of available names. On selection of a valid name, the rest of the values in the control bar will be filled out. e.g. colour, linetype etc.

<table>
<thead>
<tr>
<th>model box</th>
<th>base</th>
<th>existing models</th>
<th></th>
</tr>
</thead>
</table>

this field can be recognised by the model icon button on the right hand side of the field. The user can select an existing model by selecting the model icon. If a new model is to be used, the user simply types the model name into the field.

<table>
<thead>
<tr>
<th>colour box</th>
<th>red</th>
<th>standard 12d colours</th>
<th></th>
</tr>
</thead>
</table>

this field can be recognised by the colour icon button on the right hand side of the field. The user can select a 12d standard colour model by selecting the colour icon, typing in a a colour name of number, or even typing in the RGB of a colour in the format rgb(red_integer,green_integer,blue_integer).

<table>
<thead>
<tr>
<th>height input</th>
<th>Measures menu</th>
<th></th>
</tr>
</thead>
</table>

this field allows a height or z value to be assigned to the created elements. If a valid value exists, this value will be applied to the created element. This is regardless if the z value was specified in an XYZ box.

If no value is specified, the level will be interpolated where possible. A value of null can be entered into the height field as well so that created points will be given a null height value.

<table>
<thead>
<tr>
<th>linetype box</th>
<th>1</th>
<th>valid linestyles</th>
<th></th>
</tr>
</thead>
</table>

this field can be recognised by the linestyle icon button on the right hand side of the field. The user can select a valid linestyle by selecting the linestyle icon

<table>
<thead>
<tr>
<th>weight box</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
</table>

this field allows the user to type in a line weight for the cad item created

<table>
<thead>
<tr>
<th>tinability box</th>
<th>no, yes, points</th>
<th></th>
<th></th>
</tr>
</thead>
</table>

the Tinable field sets whether:

- yes - the vertices and segments are tinable (used in triangulations)
- no - not tinable (not used in triangulations)
- points - only the vertices (points) are tinable.

same as

<table>
<thead>
<tr>
<th>button</th>
<th>same as</th>
<th></th>
<th></th>
</tr>
</thead>
</table>

the same as (or eye dropper) allows the user to select an existing element which will be used to define all the cad control bar values.
The CAD options are available from the CAD toolbar or from the CAD menu.

When options are chosen from the CAD Toolbar, help messages are written to the Screen Message Box at the bottom of the 12d Model screen.

Although there is no panel or menu involved with the CAD toolbar options, if the F1 key is pressed whilst the cursor is over an item on a toolbar, the context sensitive help will be called.

Alternatively all the CAD options are documented under each of the walk-right menus of the CAD menu.
4.5.2 CAD Text Toolbar and Text Controlbar

The various Text options are:

Text can occur as a text string, on vertices of a 4d string, and on vertices and segments of a super string. Each type of text has
(a) a vertex (these are displayed when Vertices are toggled on in a plan view)
(b) a justification point, a rotation
(c) an offset
(d) a raise value.

The vertex and justification point only coincide if the offset and raise values are both zero.

All text on a 4d string must have the same height, colour, angle, offset and raise.

Each part of the text on a super string vertex segment can be independently modified depending on the settings for the super string.

For text options, the created elements will have attributes as defined by the Text Control Bar. This control bar is placed at the top right of the screen under the main menu control bar on the creation of a project

The fields and buttons used in this control bar have the following functions.

<table>
<thead>
<tr>
<th>Field Description</th>
<th>Type</th>
<th>Defaults</th>
<th>Pop-Up</th>
</tr>
</thead>
<tbody>
<tr>
<td>Textstyle data box</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

On pressing the button a list of available textdata with predefined names read from the texstyle_names.4d file are displayed.
If you require a different text style, the user can edit the current settings by selecting the [Edit] button to bring up the **Textstyle Data** panel. This allows for definition of text style, units, height offset raise etc.
the user can select an existing textstyle by selecting the textstyle icon or entering a value into the input box to the left of the button.

the user can measure a height by selecting the text height icon or entering a value into the input box to the left of the button. The value units are defaulted to world units. This can be changed in the Textstyle Data box.
4.5.3 Symbol Controlbar

The **Symbol Controlbar** is normally at the top right of the **12d Model** screen.

Users can define their own symbols to draw at vertices of super strings. The definition of symbols are stored in a file called symbols.4d.

The fields and buttons used in this control bar have the following functions.

<table>
<thead>
<tr>
<th>Field Description</th>
<th>Type</th>
<th>Defaults</th>
<th>Pop-Up</th>
</tr>
</thead>
<tbody>
<tr>
<td>Symbol data box</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

On pressing the **Symbol data** button a panel appears.

If you require a different symbol, the user can edit the current settings by selecting the [Edit] button to bring up the **Symbol Information** panel (shown below).

The current symbol can be selected from the Symbols list and the colour, size and rotation can be manually set.

Alternatively the size and rotation (anti clockwise) can be entered manually into the boxes in the Control bar.
4.5.4 Search Toolbar

The Search bar is normally at the top right of the 12d Model screen.

By simply typing text into the Search Bar, the option searches for matches of the typed text amongst the full path names of all the options on the menus, and then lists the menu items and the position of the menu that contains the menu item.

For example, typing in volu will bring up the list shown below.

Double clicking on an item in the list brings up the panel for that item.

Note that case is ignored when searching for matches.

4.5.5 Snaps Toolbar

The Snaps Toolbar is normally at the top right hand corner of the 12d Model screen.

Snaps are used when picking strings - see Chapter 7.4 'Snap Settings'.
4.6 Status Bar

The Status Bar is an optional part of your desktop. It appears at the base of your desktop. The Status Bar contains the Screen Message Box and the View Coordinates Box. It is strongly recommended that you keep it turned ON.

If desired, the Status Bar may be turned OFF at any time.

From the View drop down menu bar, click LB on View, untick the Status Bar checkbox. To turn it back ON, repeat the selection but this time tick the checkbox.

4.7 Screen Message Box

The Screen Message Box contains messages that help you interact with the 12d menus. For instance, when importing a DWG/DXF/DXB file as shown previously, you have to select a file name to read. Let us investigate the messages 12d gives us to help us with this simple operation.

If the DWG/DXF/DXB Data panel is not already showing, select it again as shown previously.

Click in the ‘File’ name entry data field. Observe that the following response appears in the Screen Message Box:

You interpret this help message as follows. 12d is asking you to supply a file name. The three sets of square brackets [ ] correspond to your response via the three mouse buttons, LB, MB and RB.

The LB message ‘Caret’ indicates the position of the cursor if you want to type an answer using the keyboard. To type an answer, you must first make sure that the cursor is locked onto the field you wish to modify. The cursor must appear as a flashing vertical bar before 12d will accept any data from the keyboard.

You can reposition the caret anywhere in the existing word by using the LB. You could then edit it by using the <Backspace> key. Alternatively you can use the <Delete> key to delete the character to the right of the cursor or the Arrow keys to move within the word.

The <Home> and <End> keys take you to either end of the existing entry.

To delete the entire entry, double click anywhere in the text to highlight it. Then press the <Delete> key to erase the entry, or just start typing to replace it.

The MB message ‘Same As’ indicates that you can point at any existing item on your desktop. This would not normally be used for a file name.
The RB message ‘Menu’ puts up a menu. At this time, no items are available. If another filename was copied to the windows clipboard then the ‘Paste’ would be highlighted.

Or finally, you can click LB on the folder icon to locate the required file.

The Screen Message Box area changes dynamically with the position of the cursor on the screen so watch it closely for helpful messages.

4.8 View Coordinates Box

Note the location of the View Coordinates Box at the bottom right of the desktop (the right hand side of the Status Bar).

This box displays the X-Y coordinates of the cursor when in a Plan view and Chainage-Height-X coordinate-Y coordinate when in a Section view.
4.9 The Output Window

The Output Window appears as a tab at the bottom left of the screen and flashes if there are any messages that need to be reviewed.

By default the Output Window is in Auto-Hide mode and when you move your cursor over the Output Window tab, the Output Window appears.

Auto-Hide mode can be turned off by moving over the Output Window and pressing RB to bring up the Output Window menu. Click on Auto-Hide to remove the tick and Auto-Hide is no longer on.

When Auto-Hide is turned off, the Output Window stays open permanently.

The Output Window menu includes the options:

- **Clear** - clears the Output Window,
- **Copy to clipboard** - copy any selected text in the Output Window to the Clipboard.
- **Hide** - removes the Output Window.
- **Float** - makes the Output Window a floating window that can be docked on any of the sides of the 12d Model screen.
- **Convert to window** - turns the Output Window into a normal Window which then appears on your desktop. It may be moved by clicking LB in the Output Window heading area, then dragging the cursor to another part of your desktop and releasing the LB to pin it down.
When the Output Window is a normal Window or a floating window, then clicking on x at the top right of the window will remove the Output Window.

The Output Window can be made taller or shorter by moving the bar at the top of the Output Window.

The Output Window can be turned off by Hide but also unticking the Output Window on the Window Main Menu will remove the Output Window.

Once the Output Window is removed, the only way to turn it back on is to click on Output Window on the Window Main Menu.
4.10 Introduction to Views

There are three types available in 12d Model - Plan, Section, Perspective - and some subtypes. For example Perspective and Perspective OpenGL are both Perspective Views and most Perspective operations work identically on them.

It is possible to have multiple Plan, Section and Perspective views on the desktop at one time, each showing different information. There is no limit to the number of views you may create.

Each View has a View type icon and a must have a unique name such as SURVEY or 2 etc. The names can be any number of characters that must be either alphanumeric or spaces although for uniqueness upper and lower alphabetic characters are considered to be the same thing. View names will automatically have any leading or trailing spaces removed.

The name appears in the View Title Area. This is the heading at the top of each view.

Just below the name is the View Button Area which contains the most common View buttons (i.e. a subset of the complete list of view options). The View buttons appears horizontally after the view name. The View Button Area appears automatically with each view as the view is created and each view type has different view buttons that reflect its characteristics.

The View Name defaults to a number but can be over typed with any alphanumerics. The View Name must be unique for the project.

For example, the View Buttons shown on a Plan view called Survey to map to ADAC are:

Each view also has its own menu (the view menu) which can be brought up by clicking the LB on the view button called Menu.

The View menus can also be brought up in another special way:

if you click the RB in the View Button Area or the View Title Area, you will also get the View menu to pop up. Clicking RB again in the View Button Area or the View Title Area will remove the view menu.

So by using the RB, view menus can be accessed even if the Menu item is not visible in the View Button Area.

The View menu contains options available for that particular view type. It is a superset of the buttons that appear on the horizontal View Button Area. If the View is made very small or moved off the right hand side of the desktop, the various buttons on the horizontal View Button Area will not be selectable as they will not be visible. In such case, you have to use the RB in the View Button Area to get access to the various View menu items.

Hence there are four menu systems in 12d, one for each view type (Plan, Section and Perspective) and an
overall Main Menu.
Views may be created, resized, overlapped, moved, minimised, maximised and deleted.
When you create a new view, 12d will automatically supply it an ascending number for reference purposes e.g. Section 2. This automatic name can be changed to any other unique view name.
To make Menus and Panels easy to see they will always be displayed on top of any views.

4.10.1 Basic View Operations
We will now practice some basic View operations.
To create a new View, we can use the Views => New or the Views => Create option.
For example to create a new Plan view, select Views => New => Plan from the main menu to create a plan view with the next view number.
Alternatively, you can use Views => Create => Plan View. Pick Create with the LB after first supplying a View name or accepting the ‘number’ supplied by 12d as the View name.

Important note: Each view name must be unique.
Once the View is on display, the following operations can be performed from the View Button Area.
To MOVE a View to a new location on your desktop, depress the LB in the View Title Area – the area on
the top of the view showing the words Plan 2. Whilst you still have the mouse button depressed, drag the mouse and you will see the View move. Pin the View again by releasing the LB.

To **RESIZE a View**, use the standard Windows features to change the size of the View. Place the cursor near any corner or midside of the existing plan view and when the drag arrows popup, depress and hold down the LB and drag the mouse to see the Window size change. Pin the new location of the corner by releasing the LB.

A **DISPLAY a view ON TOP** of all the other views, click on any visible part of the view except in the view drawing area (the black part of the view). Or by clicking on the View tab for that view in the View tabs area at the bottom of the view display area.

To **MAXIMISE a view**, click on the **Maximise** button on the top right corner of the view. The view will then take the entire view display area and no other view will be visible.

If a view is maximised then clicking on any other View tab will bring that view to the TOP and hence it will become the MAXIMISED view.

When a view is maximised, the three buttons that normally appear in the top right hand corner now appear at the right hand side of the Main Menu area. Click on the **Restore** button to **UNMAXIMISE** the view.
To **MINIMISE a view**, click on the **Minimise** button on the top right corner of the view. The view will be reduced to just an icon at the bottom of the View Display Area. To **RESTORE** the **minimised view**, simply click on the Restore button on the view icon or click on the View tab of the minimised view.

To **DELETE a View** just click **LB** on the **X** button in the top right hand corner of the view. A **Yes-No Confirmation** panel will then appear and select **Yes** to delete the view.

Click **LB** on **Yes** to confirm the action.

For the purpose of the tutorial, delete all the existing views **EXCEPT** Plan View 1 and maximise it to
leave just large Plan View called 1 on the desktop.

In the following chapters we will create and demonstrate the use of all the different view types, and how the various views are linked together.
4.11 Introduction to Models

Models are a 12d concept and basically a model represents a repository for data. Each point or line that is created or imported into 12d is put into a model. A model is similar to the layering concept AutoCAD, or levels in Microstation.

By adding models to, or removing models from, a view, it is possible to change the amount of information that is displayed on a view. And it is possible to have different models on display in different views.

There is no limit to the number of models used in any one 12d Project.

If you want multiple copies of a certain line (i.e. string), it is possible to copy the line from one model to another. The lines can then be displayed independently. If both models were on at once, the information will appear as one line instead of two since the strings are coincident. It is possible to selectively snap to and edit either line in such a case.

At any time, individual models can be Renamed, Duplicated, Cleaned (removes all points and lines but the name of the model is retained) or Deleted.

By default, any deleted models will be stored in a Trash Bin as a back up. Models in the Trash Bin can be restored at a later time. An example of this will be shown later in the manual.

It is possible to copy models between projects (See Models=>Utilities=>Copy Project Models) or to Share Models from another project into your project so that you have the latest copy of the shared model. These are more advanced features of 12d that we will not look at in this manual.
4.12 Introduction to Strings

12d is very much a ‘strings’ rather than ‘points’ based system.

In it’s simplest form, a string can be just a single vertex (point), or a line between two or more vertices. A string may be made up of many vertices, joined by straight line segments or arc or transition segments.

Strings vary in complexity from 2d (x,y and constant z value) to multidimensional, and an alignment string that has both horizontal and vertical geometry independently defined.

In general, as well as x, y and z values, strings have properties such as string name, string type, string colour, line style, and chainage.

Strings also have a point/line property that can be set such that they appear as disconnected points or connected lines.

From a design point of view, strings are much more useful than points.
4.13 Introduction to Panels

A panel is the means of supplying all the information required for a **12d Model** option. Once a panel appears on the desktop, you can use the mouse or the Tab and BackTab keys (denoted by <Tab> and <Back tab>) to position the cursor over any data field. Remember, when typing data from the keyboard, the cursor **must** be flashing in the data field for characters to be accepted.

When supplying data to a 12d panel, you do not need to terminate the entry of data into a field by pressing the **Enter key** (<Enter>). For instance, you can use <Tab> and <BackTab> or the mouse to move to another field after entering data. If you do press <Enter> to terminate the entry of data into a field, 12d will immediately validate the data in that field and supply an error message if appropriate.

When validating supplied or previously entered data (i.e. where you do not need to **change** the data in a field), it is **not** necessary to place the cursor in the data field. Just press <Enter> to pass through each field in the panel in turn.

When typing data into a field, please observe that the Delete key (<Delete>) deletes a single character to the right of the cursor. The Backspace key is also active. If you need to delete multiple characters, drag the LB across the characters to highlight them (or double click over a word) and press <Delete> to delete them or start typing to replace them.

In general, 12d has been setup so that data can be selected from lists rather than typed from the keyboard. When entering data into a field, if there is a list of alternatives already known to 12d, pressing the LB on the icon at the end of the field will display the list.

To practice this, bring up the **Read xyzs Data** panel - from the Main menu, click LB on **File I/O => Data Input => xyz => xyzs**

Set the **Default line colour** in the above panel to **dark green** by clicking LB on the colour icon (the icon to the right of the word **red** in the fourth data field). A list of available colours will pop up. Use the mouse to click LB on **dark green** and then process it by clicking LB on the **Select** button at the base of the panel.

Alternatives: You can double click LB on **dark green** to short-cut this sequence. You could also have used the down arrow key to work your way down through the list to highlight the word **dark green** and then pressed < Enter>.

In a manner similar to the colour panel field just discussed, most panel fields have a pop-up list of choices available and the list is activated by clicking on the icon at the right hand end of the panel field. Some times there will be a special icon such as the **colour** icon in the previous example or the file box icon at the
end of the **File to read** field.

Some of the more common icons we will see are:

- **file/folder**
- **model**
- **colour**
- **line style**
- **tin**
- **choice**
- **colour when none selected**
- **textstyle info**
- **line weight**
- **view**
- **polygon**
- **symbol**

Note that there is a **Message Area** at the base of the panel (just above the **Read** button in the **Read xyzs Data** panel).

Each panel has its own message area to help you interact with 12d. If 12d does not appear to be working the way you think it should, you will often get helpful information in the Panel Message area. Look in the Screen Message Box as well as it may also be updated when interacting with panels.

If a panel is in the way, you can move it as stated above. Any panel can be removed (shut down) by clicking LB on the **X** button in the top right hand corner or by clicking on the **Finish** button.

If you want to keep a panel that is already filled in such that you can refer to it later, you may decide to temporarily minimise it by clicking LB on the ‘-‘ button. It can later be maximised again by clicking LB on the ‘overlapping windows’ button (where the ‘-‘ used to be).

As we don’t wish to proceed further with this panel click LB on **Finish** or click LB on the **X** button in the top right hand corner of the panel.
5 Starting the Tutorial

Before starting your tutorial, it is assumed that your overall desktop layout is as shown at the end of Chapter 4.10.1 Basic View Operations, i.e. one large Plan view on display called I.

5.1 Importing Point Data into 12d

The easiest way to understand the use of Models and Panels is to import some data into 12d and see by example.

Point and Line data can be imported into 12d from a variety of sources. For the purposes of the tutorial, we will use the simplest of these - a simple text file containing point number, x, y and z coordinates along with a code and string number.

We will begin by reading in a Points file called ‘DETAIL SURVEY.csv’.

This file lies in the folder C:\12d\11.00\Training\design\getting started basic

1, 42518.873, 36856.368, 71.833, DR, 1
2, 42538.222, 36909.942, 69.005, DR, 1
3, 42556.394, 36847.968, 69.349, DR, 1
4, 42572.709, 36848.796, 67.75, DR, 1
5, 42592.277, 36848.967, 65.879, DR, 1
6, 42606.098, 36848.526, 64.818, DR, 1
7, 42612.658, 3547.949, 64.739, DR, 1
8, 42410.27, 36954.217, 72.574, DR, 2
9, 42419.677, 36955.067, 71.904, DR, 2
10, 42433.789, 35955.863, 70.552, DR, 2
11, 42449.783, 35955.149, 69.777, DR, 2
12, 42460.181, 35955.284, 68.955, DR, 2
13, 42474.805, 35955.092, 68.24, DR, 2

The format is one point per line containing a point number, x, y and z coordinate, string name and string number all separated by commas.
To read in the file, click LB on File => Data Input => x y z => x y z general from the Main menu.

12d gives you the ability to fill in this panel once and then save the setup to a parameter file. This allows you, on subsequent occasions, to call up the parameter file and then you only need select the data file to be read.

To make things easier we have already created a parameter file and stored it in Getting Started Basic folder.

Click on the folder icon at the end of the Parameter file field.

A blank folder panel will pop up, but we will browse for the parameter file

Click LB on [Browse]

Click LB on the getting started basic to move back to the getting started basic folder

Note that if you have created the training project in a folder different to the one shown here then you will have to navigate to the required folder
Double click on the file
OR
Click LB on the file then click LB on [Open]

Click LB on Read icon to load the parameters

Using the folder icon browse to the same folder that held the parameter file (C:\12d\11.00\Training\design\getting started basic) and locate the file DETAIL SURVEY.csv. You will have to change the File type display to All files (*.*).
Select the Basic tab

You will notice that the panel is mostly filled in from the parameter file (such as red and yellow). However, you still need to set the default text field.

Select the choice icon then select any of the text style.
Select the **Format** tab

The format for the file values are already set up by the xyf file.

No user entry is needed for this tab

Select the **Mapfile** tab

A user defined Map File uses the code found in the data file to set the parameters for the strings including the model name, linestyle, colour and more.

The path name of the Map File GETTING STARTED.mapfile has also been set up by the xyf file.

"GETTING STARTED.mapfile" already exists in C:\12d\11.00\Training\design\getting started basic.

A model prefix "survey *" (note that there is a space after the word `survey`) is used to group the survey models together after the map file has set the model names. This will help keep the survey data separate from the design. Using lower case for the word will send the models to the bottom of the listing

We’ll have a look at the Map File so that you are aware of how it works and what the Map File is doing.
To open the map file

Select the folder icon then select [Open]

A tree structure is used to access the sections within the Map File

The Basic node sets the model, colour and more. It is shown in the next image.
Chapter 5 Starting the Tutorial

Page 65

Click LB on Finish to exit the mapping file

Now that we’ve had a look at the Map file, we’ll read the data in using the Read X Y Z General panel

On the Read X Y Z General panel, click on Read to import the data file.

You will notice that a new Plan view called 2 view has been created and the models containing the data read in have automatically been added to the view. This is the default action when reading data in.
Maximise Plan view 2 and the screen should look like:
5.2 Plan View Operations

Now that we have some data, we can begin to look at some more of the Plan view features of 12d.

Menu

Bring up the Plan view Menu.

Adding/Removing models

In the Plan View Button Area, you will observe a ‘+’ and ‘-’. This is a shorthand technique for turning models on and off.

Click on the ‘-’ sign button with LB. A list of available models to remove from the view pops up. Pick ‘survey VEG TREE’ and click LB on ‘Select’. You will observe the tree symbols in model ‘survey VEG TREE’ are removed from the view. The ‘+’ works in a similar way to add models to the View. Practice adding and removing models from the view with the + and -. Remember, the models are not being deleted with the ‘-’, merely removed from the current View. Turn back on the tree model survey VEG TREE.

Fit

After multiple pans and zooms, you sometimes wish to return to a point where all of your data appears in the view. This is equivalent to an AutoCAD Zoom-Extents. Click on Fit with LB to see all of your data.

Dynamic Pan

This facility allows you to move the centre of the view but retain the current zoom factor. Click on Pan with LB. You then press down LB on a point in the View and then drag the mouse. The data in the view will move with the mouse until LB is released.

Zoom

Select Zoom (to Zoom In) from the Plan View Button area with LB. Click LB on two diagonal points of a rectangle and then click LB once anywhere in the plan view. The information will appear enlarged based on the size of the rectangle.

MB Wheel Zoom

If your mouse has a wheel as part of the middle button, then it can be used to dynamically zoom in or out. Simply click LB in the plan view at the point you want to zoom about and then roll the wheel forward to zoom in and backwards to zoom out.

Shrink

This is equivalent to Zoom Out. It works just like Zoom but in reverse.

Previous

If you click LB on Previous, the view will appear as it was prior to the Zoom. 12d always keeps the details of the previous view setting available so that you can return to it quickly. Only one level of previous view settings is kept.

Toggle

There are multiple items under the Toggle Pop Up menu. At this time, we will try only one of them. Select Grid with the LB. A rectangular grid should appear. If you click LB on Toggle => Grid again, the Grid will be removed from the display.

The appearance of the grid can be changed by clicking LB on the Menu button in the View Button Area and click LB on Settings => Grid. You can change any of the settings in the panel. Try changing the grid.
spacing from 100 to 10 in both x and y directions and click LB on Set. You will notice that the Grid can be turned on and off from either the panel settings or the Toggle => Grid switch. Click LB on Finish to terminate the panel.

Refresh
All the information on the view will be redrawn. This can also be achieved by clicking MB anywhere in the View Title Area or anywhere in the View Button Area except over the ‘+’ or ‘-’ buttons.

Plot
Bring up the Plan view Plot Menu. This has options to generate a quick plot of what is on the screen, plot plot frames and drainage plan plots

Clone
Creates a copy of the view.

Properties
Brings up the Plan View Properties panel for this view.

If we clicking on the Fit icon on Plan 2, then we will get.
5.3 Birds-Eye Views and Throwing Between Views

To introduce some new concepts in 12d, we will need both of the Plan views on the screen at once.

First we’ll un-maximise Plan 2 by clicking on the Restore icon for the current maximised View (there can only be one maximised view).

Now resize and move the views around so that Plan 1 is on the left and takes up half the area and Plan 2 is on the right and only takes up around 2/3 of the area.

From the main menu, click LB on Views=>New=>Plan and place a small view about 50mm square in the top right hand corner of your desktop. This will create View ‘Plan 2’. See Chapter 4.10.1 for full details on how to create and resize Views.

In the View Plan 1, use the + view button to turn on all of the models. Do a Fit to both views.

Note: the quickest method of adding all the models on one view to another view is to use the option View => Models transfer.

From the Plan 2 View Button area, click LB on Zoom and click a point in the lower left corner of the View Plan 2. Before selecting the second point of the Zoom rectangle, move the cursor into the other View i.e. Plan 1.

Notice that the second point of the Zoom rectangle is being taken from the second view and the view box is drawing in both views.

Select the second point of the Zoom rectangle in either View, and take it at the bottom left hand corner of the data.

After selecting the second point of the Zoom rectangle, you will notice the prompt Select destination view - RB to cancel in the Screen Message Box.
12d is prompting you to select the View you want zoomed. That is, the view that you want to zoom rectangle to take up the entire view.

Click LB in View Plan 1. The zooming will then take effect in View Plan 1.

Notice that using this technique, it is possible to achieve a birds-eye effect where the smaller View displays the complete model whilst the larger working view is zoomed to an extent where it displays only the detail that you are currently working on. You would typically define all of your zoom rectangles in View Plan 2 but have the zoomed details updated in View Plan 1.
You can even do this with different models turned on in each view. For example, in the birds-eye view, you would typically only turn on sufficient detail to enable you to zoom on known features.

To see this, click LB over the - button on View Plan 2 and remove the model Survey TOPO SURFACE LEVEL. This will make the large scale details much easier to see on view Plan 1 and still have the full level of detail on the zoomed in view, Plan 2.

Please practice zooming and throwing between Views as it is a powerful concept in 12d.

After completing this exercise, delete View Plan 2 as it is no longer needed by using a second way to delete a View.

Click LB on the Menu button in the View Button Area of Plan 2 OR click RB anywhere in the View Button Area of Plan 2, to bring up the View Menu for the view.
Select **Delete** and then **Yes** to confirm the deletion.

Then maximise Plan 1 and do a **Fit**.
5.4 Rolling Middle Mouse Button to Zoom In and Out

The Zoom option was introduced so you could zoom in on a selected area.

Another method of zooming in and zooming out is to use when your mouse has a Roller Middle Button.

First click any button in the view to highlight the view (get focus on the view), rolling the middle button forward will zoom in about the position that you clicked inside the view to get focus.

Rolling the middle button backwards will zoom out about the position that you clicked inside the view to get focus.
5.5 Deleting a Model

As we now wish to look at an alternative (and preferred) way of importing data into 12d, we will delete the existing models as they will be recreated in the following option.

From the Main menu, click with LB on Models=>Delete=>Delete all models.

Click LB on Delete

Click LB on Yes to confirm

When Permanently delete? is NOT ticked on and models are deleted, they are sent to the Trash Bin in case they need to be restored at a later stage.

When there are models in the Trash Bin, a Trash Bin icon appears at the bottom right of the 12d screen.

To access the deleted models, double click LB on the icon or select Project =>Management =>Trash Bin

To restore models, click LB in the Select column next to the models that you want to restore to turn on ticks for the models, then click LB on the button Restore.

To permanently delete models in the Trash Bin, click LB in the Select column next to the models that you want to permanently delete to turn on ticks for the models, then click LB on the button Delete.

To permanently delete all the models in the Trash Bin (like emptying the Windows Recycle Bin), turn on ticks in all the rows in the Select column by clicking LB then RB over the top of the Select column to bring up the Column operations menu.
5.6 Redraw - Fixing up a Modified or Erroneous View
Whenever data is removed from a View e.g. turning off the display of a model, the view does not automatically get refreshed. 12d typically removes a model by overdrawing the information using the background colour, usually black. This operation can leave the view looking speckled and unclear.
You can force the view to refresh by clicking LB on the Refresh button, or click MB in the View Button Area anywhere other than over the ‘+’ or ‘-’ view buttons. The whole View will be repainted to display the corrected information.
It is also possible that some of the menus may at times become corrupted. Windows is a very complex multitasking environment and the menus are stored in memory which is being updated continuously. If you ever get parts of your desktop that don’t look correct, you can force your entire 12d screen area (all menus, views etc.) to be refreshed by holding the Ctrl and R keys down together (<Ctrl>+R).
Alternatively you can refresh just any one Menu by clicking MB in the Menu Title Area.

5.7 View Tabs
There is a tab for each view on a bar just above the Status Bar at the bottom of your 12d screen. If you have the Output Window in the default position (the tab at the bottom left of your desktop), the tabs bar is displayed just above the Output Window.
The View Tab has the icon for the view type and then the view name beside it.
Each tab corresponds to a 12d View.

To bring a 12d view to the top of all other views and to set the view as your active view, just click LB on the appropriate View Tab, or click LB in the view title area of the view.
Note that when a view is active, the View title highlights in blue.

When there is more than one view tab, the order of the View tabs can be changed by holding LB down on the View tab whose order you want to modify and then moving the cursor to the left or right until you reach the position that you want the selected view tab to be in.

5.8 Saving a Project

The current changes to the Project you are working on are only stored in memory. To make the changes permanent and update your files on disk you need to Save the Project. This can be done at any time by clicking LB on Save from the Projects Menu (Project =>Save), or by holding the Ctrl and S keys down together (<Ctrl>+S).

12d will also pop up a panel reminding you Do you want to save the project?

Click on Yes with LB to force a Save to occur.

The timing at which this message appears is set from the Defaults panel brought up by the menu item Project =>Management =>Defaults. The time in minutes is set in the field Save Interval (min) under the System Settings tab.

The default is every 15 minutes. Set the time interval to zero to turn this feature off altogether.

If you ever crash out of 12d due to a power failure for instance, any changes since your last Save operation will be lost.

5.9 Exit

To terminate a 12d Model session, click LB on Exit on the Project menu (Project =>Exit).

If you try to Exit 12d after changes have been made to your Project, 12d will remind you of the changes by prompting you for a further Save operation.

5.10 Starting 12d When Projects Already Exist

When 12d Model is started and projects already exist and have been opened in 12d, the most recent projects will be listed on the left hand side of the 12d Model Front Screen.

Double clicking on a project in the Recent Projects list will open the project.
Also when you are in *12d Model*, the walk right menu **Project => Recent projects** will also list the recent projects and clicking on a project in the list will exit the existing project (asking if a Save is wanted) and opens the selected project.

When you return to an existing project, the appearance of the views and toolbars on the screen will be just as you last left them.
6 Basic Modelling

6.1 Alternative Data Entry

We will now repeat the process of importing data into 12d but this time we will use a 12d Archive file. This option is the more common way of transferring data from Surveyor to Designer when both parties use 12d. The Archive format will often include all of the strings with the correct model, colour and other properties so that no mapping is required. Also a tin (triangulation) can be included in this file format so that the Designer has no need to create a new tin from the survey data. In this instance we will assume the coding is correct but the models are different so that mapping is required. Also a tin is not included.

We will import the file DETAIL SURVEY.12da. To read in the file, click LB on File => Data Input => 12d => 12d archive data from the Main menu.

Click LB on the File to read folder icon then browse back up to the folder C:\12d\11.00\Training\design\getting started basic

Double click LB on the file DETAIL SURVEY.12da and the file name will be piped into the field File to read

A map file is not required.

A model prefix "survey *" is again typed in to group the survey models away from the future design models.

Click on Read to read the data into 12d Model.

Again a new view Plan 2 is created with the models read in automatically added to it.

Transfer the models from View 2 to View 1 by using the option View => Model transfer.

Delete Plan 2 to just leave the one view, Plan 1.
Another great way to read in an existing 12da file into an existing project is to use **Drag and Drop**.
To Drag and Drop, in Windows Explorer, press LB down whilst over the file DETAIL SURVEY.12da and then move the cursor over the 12d screen area and then release LB.

A **Read 12d Solutions Archive Data** panel with the full path name to the file DETAIL SURVEY.12da automatically entered into the **File to read** field.

### 6.2 Saving a Model Listing to a File for Future Use

The current thirteen models on the view are exactly the models that are used to create the *natural surface* tin. We will now see how to record these models in a form that can be used in the future to restore those same models to another view.

To make the list, we first click on the Plan 1 view tab to make Plan View 1 the focus. The heading in view Plan 1 should appear coloured bright blue and if there were others views, will be brought to the forefront.

From the Main menu click LB on **View => Models Save/Restore**

![View (Save/Restore Models)](image)

Type in the file name **SURVEY**.
Pressing <Enter> will add the extension **.vml**
Click LB on the view icon then select view **1**
Click LB on **Save**
Click LB on **Finish** to exit the panel

This file can be read at any future time by use of the **Restore** tab on the **View (Save/Restore Models)** panel. This will add the models in the vml file to any view.
6.3 Triangulation

We will now use this point and line information to create a 3d surface or TIN (Triangulated Irregular Network).

One of the concepts in 12d is that a TIN can be created from a single model, a single view (and all the models on that view are used) or a model list.

In general, you will use Views to create models since you can control which models are on display in a View.

It is important to understand that when creating a TIN from a View, only those strings in models added to the View will be used in creating the TIN and only then if the strings have been set to tinable.

For instance, if you were forming a TIN representing the natural surface, you could only leave models that represented underground surfaces on the view used to create the TIN, if such data is non tinable (i.e. not used in a triangulation).

When using a mapping file to read in data, strings can be flagged as being tinable (and Breaklines) or non tinable. Only tinable strings are used in the triangulation.

Breaklines are used to pick up the topographical features accurately.

When forming triangles, 12d ensures that every straight segment in the breakline is the side of a triangle.

In this exercise we are assuming that the survey strings have already been checked for errors (See the Getting Started for Surveying manual on methods for checking the data).

For the purposes of the tutorial, please ensure that all models in view Plan 1 are on display prior to creating the TIN. Plan 1 should look as shown above.
From the Main menu, click LB on **Tins** =>**Create** =>**Triangulate data**

Fill in the first tab of the panel as shown.

The **Triangulation function** option is used to construct a function which, when recalculated, will run a retriangulation on the tin. Place the cursor in the data field with the LB and type in **TIN GROUND**

Each TIN requires a name. Position the cursor in the **New tin name** field and type in **GROUND**. If you press <Enter>, this name will also be used to fill in the **Model for tin** field but with the prefix "tin " (see panel). The TIN name is subsequently used to refer to this specific TIN.

Position the cursor in the **Model for Tin** field and type in the suffix ",1" after the name so that the model is added to the view 1, and hence displayed, as soon as the TIN is created.

There is no problem if you don’t add the ",1"because you can always add the model containing the tin to a view at any time.

Click on the **Data** tab.

As we wish to triangulate all the data in plan view 1 and leave the tinatability to determine which data to use, click LB on the view icon. Sel 1 from the list.

Click on the **Nulling** tab.

There are two options here, you can set the parameters to null the external triangles, and/or you can use a polygon to null all triangles outside this polygon.

The **DTMBDY** string will be used as the boundary for the tin.

Click LB on the **Null polygon** string icon then click LB on the **DTMBDY** string followed by clicking middle button (MB) to accept the string.

(We will cover selecting strings in **Chapter 7 String Picking Concepts**.)

Click LB on **Triangulate** to create the TIN. There will be a short delay and then your TIN will be created and displayed as shown in the next picture.

Click LB on **Finish** to terminate the panel.
If you didn’t use the ",1" after the model name in the Model for tin, now add the model tin GROUND to the view. View 1 should now look like:

![Plan 1](image)

Note that the TIN is clipped at the selected Null polygon ensuring only the surveyed data is included.

Now that we have a TIN we can display the TIN data in a variety of ways.

**Important Notes**

1. Tin names must be unique in the project.
2. A tin can only be displayed on a view by adding a model that contains the tin to a view.
3. A tin can be in more than one model. Or even in no model.
4. More than one tin can be in the one model.
5. Deleting a model DOES NOT delete any tins in the model. Tins are deleted with Tins ->Delete
6.4 Tin inquire

From the Main menu, click LB on **Tins => Inquire** to bring up the **Tin Inquire** panel.

Click LB in the menu title area (where it says Tin Inquire), move the menu and Pin it with the LB. This operation is necessary to stop the menu from being automatically removed after the first menu pick.

Click LB on **Aspect**, and the **Tin Aspect Inquire panel** will pop up.

Move the cursor over the *Tin* icon button at right end of the **Tin** field and use the LB to pop up a list of Tins. Double click LB on **GROUND**. Then click LB in the menu title area (where it says Tin Aspect Inquire), move the panel to a clear area of your screen and pin it with the LB.

Do **not** Click on the Finish button in the panel.

Notice that as you move your cursor over the tin, the aspect is being displayed in the panel message area. Repeat this procedure with both the **Height** and **Slope** menu items.

Once all three panels are on the screen, move the cursor anywhere over the TIN and observe what happens. When the cursor is positioned over any one triangle, the three point coordinates of the triangle are being
used to linearly interpolate *on the fly* to calculate the exact x,y,z coordinates of the cursor. Also the aspect and slope of the triangle is shown in the respective panels.

We’ll now look at one option that combines all three, as well as **Tin colour**, and does not even need a Tin to be set.

On the Tin Inquire panel, click on **Tins on a View (Tins =>Inquire =>Tins on a view)** to bring up the **Tins on View Inquire** panel.

Now move the cursor around the view and any tins under the cursor will be dynamically listed in the panel and at the (x,y) position of the cursor, display the height of the tin, and the triangle colour, slope and aspect.

Click LB on **Finish** on all four panels to put them away.

Also click LB on **X** on the **Tin Inquire** menu to shut it down.

We will now look at the various ways information in TINs can be viewed.
6.5 Fast Contours

We now want to remove all of the models from the View except tin GROUND. From the View menu (in the View Button area), click LB on the - sign to pop up the Models to Remove panel.

Click LB in the panel title area (over the words Models to Remove), move the panel and repin it with LB so that it doesn’t collapse after each selection.

Now click the LB on the first survey model. Drag the mouse down the list to highlight all the survey models and click on Select. Alternatively, you could double click LB on each model in turn except tin GROUND. Click LB on X to shut down the panel.

Now from the View buttons, click LB on the Toggle button to bring up the Toggle menu.

Then click LB on Tin contours. You should see the following red and green contour lines appear.
If you click **Toggle => Tin contours** again, the View will revert to the green triangle display.

The appearance of the contours can be changed by clicking LB on the **Plan 1 Menu** button in the View Button Area. Click LB on **Settings => Tins => Contours** and the following panel will pop up.

At the completion of experimenting it is suggested that you put the settings back to their default values (as above) at this time.

Click LB on **Finish** to terminate the panel. Your new settings will remain in effect indefinitely until changed.
6.6 Fast Flow Arrows

It is recommended that you turn on the drainage models for this exercise. From the View menu (in the View Button area), click LB on the ‘+’ sign button and double click LB on survey TOPO BANK BOTTOM, survey TOPO BANK TOP and survey TOPO DRAIN CL. Make sure that the tin GROUND model is also still turned on. The easiest way to confirm this is to click LB on the ‘-’ sign button in the View Button Area and look at the list of the models that could be turned off. Click LB on the X button to terminate the list.

Now from the Toggle button, click LB on Toggle =>Tin contours to turn OFF the contours and then Toggle =>Tin edges. The purpose of this is to outline each triangle.

Then click LB on Toggle =>Tin flow. You should now see an arrow appear at the centre of each triangle representing the direction of water flow.

Try zooming in on a section of the model for a closer look. When you have finished zooming, click on Fit to again fill the View window.

![Image of flow arrows]

The appearance of the flow arrows can be changed by clicking LB on the Plan 1 Menu button in the View Button Area. Click LB on Settings =>Tins =>Flow Arrows and the following panel will pop up.

![Flow Arrows settings panel]

You can change the size of the arrow heads and their colour. Click LB on the colour icon for the Colour for arrows field to popup a list of available colours. Select one by double clicking LB.

Try changing the arrow length from 10 to 5 world coordinates (in this case metres).

Click LB on Set to activate the changes. You will notice that the Flow arrows can be turned on and off from either the Draw triangles flow tick box setting in the panel or the Toggle =>Tin Flow switch.

Click LB on Finish to terminate the panel. Your new settings will remain in effect for this view until changed.

Click both Toggle =>Tin edges and Toggle =>Tin flow again and the View will revert to the green triangle display.
6.7 Perspective View

We will now look at the perspective view facilities in 12d to examine the surface we created above.

Create a new perspective view. Click LB on Views => New => Perspective from the Main menu and a new view pops up. Alternatively by selecting Views => Create => Perspective view from the Main menu, a panel pops up.

Note the new view is created immediately and is placed over the top of your existing windows. If a view is maximised then it will be unminimised when a new view is created.

You can use the standard windows features to Tile the views. For example, on the Main Menu select Window => Tile Vertical.

Your overall screen layout should now look something like this.

If necessary, put the cursor in the View name field, backspace over the existing entry (or use the Delete key) and type 2.

Click LB on Create.

Note that the highlighted view is placed on the left by Tile Vertical.
The view buttons on a Perspective view are

we now need to add the TIN to the perspective view. In the View Button Area of Perspective OpenGL 2, click LB on the ‘+’ sign button and double click LB on **tin GROUND**. Click LB on the **Fit** icon.

Note that Zoom using the Zoom option and rolling the middle mouse button both work in a Perspective view.

So after your **Fit**, zoom in so that the tin almost fills view 2.

---

6.8 **Pan and Zoom in Perspective Views**

**Pan** and **Zoom** both work for a Perspective View.

Trying Zooming in and panning around.
6.9 Joy Panel

The Joy View panel (short for Joystick) provides a quick way of orientating your eye in relation to your data when manipulating a Perspective view.

The Joy View panel is accessed from the View Buttons Area. Click LB on the Joy button in the View Button Area of Perspective 2 and the Joy View panel appears.

![Joy View Panel]

Try clicking LB on In and Out icons

and observe what is happening. Your eye is moving inwards or outwards from the data.

Also try Up, Down, Left and Right. icon

If you get lost or zoom in too far, you can always start again by clicking LB on Fit in the View Button Area.

The angular step between each up or down step defaults to 15 degrees. You can change this if you want smaller increments by entering a new value in the Angular Step field.

Similarly, the Distance changed on each In/Out movement defaults to 100 (metres in our case as all data is in metres).

The easiest way to reset a view so that you can see all of the data is to click LB on Fit from the View Button Area.
6.10 Orbit

The Orbit is another way to orient your eye in relation to your data when manipulating a Perspective view. The Orbit option is accessed from the View Buttons Area. Click LB on the Orbit button in the View Button Area of Perspective OpenGL 2.

By holding LB down and moving your cursor around you will see the effect Orbit has. The centre of the Orbit is displayed on view 2 as a white circle.

A message with the instructions for Orbit is also written to the Screen Message Area.

So try holding MB down and moving your cursor around and then holding RB down and moving your cursor around.

Notice there are also key commands w, a, s, d and f. Plus <Esc> to terminate Orbit.

If you had created a Perspective OpenGL view instead of a Perspective view, you will also see a set of
coordinate axes displayed in the bottom left hand corner to indicate the positive X, Y and Z directions.

You can use either a Perspective 2 or a Perspective OpenGl 2 in the training and if there is any major difference then it will be pointed out.
6.11 Plan Camera

The **Camera** button links the Perspective view to all the unminimised Plan views (we’ll refer to them as just the Plan views).

The Camera (Eye point) and Target point for the current perspective settings of the Perspective view are displayed as icons in the unminimised Plan view and moving the Camera and Target icons around in a Plan view controls the perspective settings for the linked Perspective view.

Click LB on the **Camera** button in the View Button Area of Perspective OpenGL 2 and the **Plan Camera** panel appears. This panel displays which Perspective view the Plan Camera is running for and the colour of the Camera and Target icons.

Select the colour magenta in the **Colour** field to display the camera and target, and then select **Set**.

**Important note** - leave the **Plan Camera** panel up because the option terminates when the panel is finished.

The camera and target that define the perspective view are now shown in all visible Plan views. You may have to zoom out to see them both.

Holding down LB on either the Camera or Target icons and moving them around in a Plan view dynamically changes the settings for the Perspective view.
Move both the camera and the target around in the view to see how the Perspective view is linked to the Plan views.

Notice that if you have the Plan Camera panel up with the camera and target icons showing and then perform any operation on the Perspective view to change the perspective settings, then the camera and target icons will move to reflect the new perspective settings. For example, using Fit, Zoom, Pan or Orbit. However after the other operations are completed, you will need to select the Set button again on the Plan Camera panel to be able to select and move the Camera and Target icons around.

When the Plan Camera panel is finished, the Camera and target icons are removed form the Plan views.

Note
If you have more than one Perspective view then you can have a set of Camera and Target icons for each of Perspective view and each set will be displayed on all visible Plan views. To avoid confusion between the Camera-Target sets, use a different colour for each set.

Although the Camera and Target icon sets are all visible, only one of them is can be active (and hence can be moved around) at the one time. To make set active, click on the Set button on the Plan Camera panel for that Camera-Target set.
6.12 Fast Meshes in Perspective view

We will now see how to quickly display the TIN in mesh form.

From the Perspective View menu, click LB on **Toggle =>Tin mesh**. You should see a coarse rectangular grid of red and green mesh lines appear.

The appearance of the mesh can be improved by reducing the mesh spacing.

Click LB on the Menu button in the View Button Area of the Perspective OpenGL 2 view and then click LB on **Settings => Tins =>Mesh**. The following panel will pop up.

Change the settings to those shown in the panel. Change the mesh spacing from 100 to 10 in both x and y directions and bold x and y spacing from 1000 to 100. Click LB on **Set** to activate the settings.

You will notice that the Mesh can be turned ON and OFF from either the **Draw triangles mesh** tick box in the panel or from the View menu via the **Toggle =>Tin Mesh** switch.
Click LB on **Finish** to terminate the Mesh settings panel.

The effect of the creeks superimposed on the TIN (shown above) is created by turning on the Drainage models. Click LB on the + sign button in the View Button Area and double click LB on **survey TOPO BANK BOTTOM**, **survey TOPO BANK TOP** and **survey TOPO DRAIN CL**.

Note that 12d always displays the models in the order that they are turned on with the + and - buttons. Thus to get the effect of survey DRAIN CL (and any other models) superimposed on your TIN, you first turn all models off, then turn the TIN on first and then any other models to be superimposed last.

The drawing order on a view can also be modified by using the option from the View Menu **Models => Model order**.
Note that the **Models** walk right menu has a number of useful options, too many to have as button in the View Button Area.

For example **Models => Remove all models** is a fast way to turn all models off.

The perspective view orientation will stay as it is unless changed by further **Joy** or equivalent perspective view operations.

Toggle off the tin mesh via **Toggle => Tin Mesh**.
6.13 Fast Contours in Perspective Views

Sometimes it is useful to display contours in perspective views. You do this using the Toggle button like we did for the Plan view - simply click LB on **Toggle =>Tin Contours**.

![Perspective OpenGL 2 view with contours](image)

The contour spacing and colours of the Perspective view can be changed just as we did before in the Plan view. This time however you would click LB on the Menu button in the View Button Area of the Perspective Open GL 2 view.

As before then click LB on **Settings =>Tins =>Contours**. See 6.5 Fast Contours on page 86 for more details.

Click **Toggle =>Tin contours** again to revert to the green triangles display.
6.14 Shaded Views

It is also useful to view a perspective as a colour shaded view.

In a shaded view, the angle that each triangle makes with the sun (a point light source at infinity) is used to define a different shade of green. The angle of the Sun can be varied but 45 degrees (the default) gives the maximum contrast.

To quickly shade all the TINs on the perspective view, simply click LB on Toggle => Shade.

To access the Shade View panel to modify the shade settings, click LB on the Menu button in the View Button Area of ’Perspective OpenGL 2 and then click LB on Settings => Shade.

Clicking LB in the Shade tins tick box will toggle on and off the shading. A tick indicates the shade is activated.

Click LB on Set to create the shaded view.

All TINs in the view will be shaded using the faces in order furthest to nearest the viewer. This has the effect of removing faces that are hidden from view.

Click LB on Finish to terminate the panel.

Now every time the view is refreshed or the view changed, the shaded view will reappear.

To get back to a green triangles rather than a shaded view, click LB on Toggle => Shade to toggle the shade off.
Chapter 7 String Picking Concepts

We will now investigate picking concepts and how the mouse is used to interact with 12d when pointing to and selecting items on your screen. Initially, do all picking (i.e. mouse clicking) with the LB. This uses the 12d Model Tentative pick. Later we will look at Fast picking using MB (F snap) and Fast Accept (A snap).

In Plan View turn on all the models except the triangulation (tin GROUND).

Check that Point snap, Line snap, Cursor snap and Info are on, and Fast snap and fast Accept) snap are both turned off.

![String Picking Concepts Diagram]

Zoom in to the left dam. Your overall screen layout including the ‘Plan 1’ view should now look as shown below.

![Plan View Layout]

Whilst the string picking concepts are used throughout 12d, especially during construction of design features where we want to connect into existing geometry, we will learn about them by example through the relatively simple String Inquire feature.
7.1 String Inquire

String Inquire is used to inquire and view the details of a typical line (i.e. string) that is already present in the View. From the Main menu, click LB on **Strings=>Inquire** to bring up the following panel.

**NOTE**: the **String Inquire** panel can also be brought up by pressing the F2 key. This has been defined in the standard 12d Model function key short cuts (userkeys.4d).

Click LB on **Pick** and then move the cursor anywhere over one of the bank strings and **click LB** (press and release LB).

If you placed the cursor over a line segment between two vertices:
you should see the string go light yellow and a yellow square box appear at the location where you clicked LB.

If you placed the cursor over a vertex at the end of a line segments:
if you happened to snap to a vertex rather than a segment, you will see the string go light yellow and a yellow diamond appear at the location where you clicked LB.
The last pick couldn’t find any more strings to snap to (adjacent strings were outside snapping distance) and so no more information panels popped up. Instead, a circle showed at the pick location to indicate that a snap to the cursor location had occurred. That is, the only thing that 12d could find at the pick location was the cursor.

The above sequence will only happen this way if Point, Line and Cursor snaps are on. See below for more about snap settings.

If you move the cursor away from the string and pick with the LB again, you will notice that the Information panel changes, the string goes back to its original orange colour and the cursor is now replaced with a light yellow circle.

In either case, an Information panel will pop up as shown at right (provided the Info snap is ON - See 7.4 Snap Settings on page 105). It reports such information as the name of the Model which contains the selected string (survey TOPO BANK TOP), the string name (TBR), the type of string (Super), colour and linestyle. The number of points in the line are also returned along with it’s length.

The x, y and z coordinates are those of the string where the pick occurred. And in this case the panel shows that the string was accessed via a Point snap.

The purpose of this behaviour is so that if there are (say) three lines on top of the other, it is possible to sequentially snap to each one in turn by looking at the Information panel details as you perform each LB mouse click. Even with the one string, the closest snap point may be a line snap, and when you click again you may get a Point snap on the same string.

This sequence may seem strange at first. What has happened is that the first pick located a string within snapping distance of the cursor so the string highlighted in light yellow and the Information panel for this string popped up. The pick location showed a diamond to indicate that a snap to the nearest vertex had occurred. 12d is in effect asking you ‘Is this the string you want?’. To reject the currently highlighted string, without moving your mouse, simply pick with LB again.

The last pick couldn’t find any more strings to snap to (adjacent strings were outside snapping distance) and so no more information panels popped up. Instead, a circle showed at the pick location to indicate that a snap to the cursor location had occurred. That is, the only thing that 12d could find at the pick location was the cursor.

The above sequence will only happen this way if Point, Line and Cursor snaps are on. See below for more about snap settings.

Now if click LB a number of times on the same string without moving your cursor, you will end up getting the light yellow circle indicating a cursor snap.

The reason for this is that when you click LB the first time, 12d finds all the strings and pick types in the picking distance of the cursor and highlights the closest string with the closest pick type.

If you click LB again without moving the cursor, the next closest string and pick type is displayed. And if click LB again, the next closest string and pick type is displayed. This continues until there are no strings left that have not been rejected by clicking LB again.

The purpose of this behaviour is so that if there are (say) three lines on top of the other, it is possible to sequentially snap to each one in turn by looking at the Information panel details as you perform each LB mouse click. Even with the one string, the closest snap point may be a line snap, and when you click again you may get a Point snap on the same string.

The fact that we could only snap to one string confirms that there is only one string present at this location.

A quick method of restarting a pick sequence is to move the mouse (i.e. cursor) a short distance from the last pick point. The picking mechanism is then reset and all strings can then be picked again.

The next section shows how the mouse buttons can also be used to restart a pick sequence.

To terminate the String Inquire, click LB on Finish in the String Inquire panel.
7.2 Use of Mouse Buttons and Enter Key when using Tentative Picking

The three mouse buttons and the Enter key all have a function when picking strings. Those functions are:
- LB - Left Button: Select the nearest string
- MB - Middle button: Accept the current highlighted string. This will also terminate the current pick sequence.
- RB - Right button: Bring up the Pick Ops menu
- Enter key (<Enter>): Accept the current highlighted string. This will also terminate the current pick sequence. This is the same as MB and is very useful if you only have a two-button mouse (not advisable).

7.3 Pick Operations Menu via the Right Mouse Button

We will now focus on the use of the RB. Repeat the above picking sequence but now after getting the yellow square cursor (i.e. picking the string), click the RB and the Pick Ops menu will pop up.

Click with LB on Restart. This resets the pick sequence to start over as if the previous pick sequence had never occurred.

If you now click on the string with LB, you will notice that the string can now be picked again with the LB. The lesson here is that if you ever get confused during a picking sequence, the picking operation can be reset and start over again by either moving the cursor a given distance or click RB to bring up the Pick Ops menu and select Restart.

The Accept menu item needs special mention. During a picking sequence, once you have located the string you are after, you normally terminate the sequence by clicking the MB. This accepts the current string and terminates the pick sequence.

The Accept menu item has the same function as clicking the MB during the pick sequence i.e. it is used to indicate to 12d that the string found is the one that you wanted. If you are using a 2-button mouse, this is another way around the lack of the middle button (using <Enter> for accepting was described in the previous section). You can accept a string by using the RB to bring up the Pick Ops menu and click LB on Accept. If you have a 3-button mouse, it is easier to use the MB to accept the string directly.

The Info menu item also has a special function. The Information panel that pops up when a string highlights is only displayed temporarily. If you move the mouse cursor a small distance, the information panel will disappear. This occurs even if you don’t click any mouse buttons. The Info menu item is used to pop up the Information panel (again) for the currently highlighted string.

The Cancel menu item is used to terminate many of the operations that are recursive. For instance when creating a string, 12d assumes that it will involve multiple line segments so it stays in create mode after each segment is placed. After the last point on the string is placed, use the RB to pop up the Pick Ops menu and click LB on Cancel to terminate the creation.
7.4 Snap Settings

In the context of String Inquire, the snap settings are used to selectively choose from 12d data sets when inquiring on existing items. The snap settings can be toggled on and off from the snaps toolbar.

If you are new to 12d, it is easiest to first start using the full snaps menu until you get used to the abbreviations in the Snaps toolbar. To bring up the full Snaps menu, click LB on Utilities=>Snaps=>Snaps.

On the Snaps menu, at any one time each snap setting is toggled either ON or OFF. If a tick appears, the snap setting is toggled ON. The settings shown are the default settings when starting 12d.

To change a snap setting, click LB anywhere from the snap name text to the snap tick box. The setting will toggle ON or OFF.

As shown above, it is possible to have multiple snap settings on simultaneously. For instance, if you want to be able to select a string on either the segments of the string, or the vertices of the string (the ends of the segments), you need both Point and Line snap ON.

You can generally leave Cursor snap ON. Most times, if all other snaps fail or are not set, you want the mouse cursor position returned. This is useful when free handing into 12d strings that are not connected to existing features e.g. the centreline of a new road. If you don’t have Cursor Snap ON, you will get a Failed Snap error message whenever all other snap settings fail.

Near the bottom of the Snaps menu is an Information tick box labelled Info. If this box is NOT ticked, the Information panel will NOT pop up as each string is selected.

Above the Information tick box is the menu item Pt tolerance 10. This figure indicates the current point snap tolerance setting is 10. To change the snap setting, click on Pt tolerance 10 with LB and the following panel pops up

The point snap tolerance is measured in screen pixels. In 1024 resolution, a point snap tolerance of 10 represents about one hundredth of your screen width. If point snap is set, then the closest vertex within this distance of the cursor will be selected.
To change the tolerance, lock the cursor in the Tolerance field by highlighting (double clicking on) the existing text, press <Delete> and type a new Tolerance value. Click LB on Set to activate the new setting. Click on Finish to terminate the panel.

Similarly for the Tolerance menu item - click on Tolerance and the Snap Tolerance panel pops up

**NOTE** - When Point snap is set on, any vertex of a string within the point snap tolerance box around the cursor when LB is clicked, is considered for selection before any other type of snap is considered. Centres of circles, centres of arcs and arc end points are considered to be vertices.

When Line snap is set on, the cursor only needs to be within the snap tolerance distance of any visible segment of a string when LB is clicked, and that string is considered for selection. Also arcs and circles are considered for selection.

In the area between the point snap box and the snap box, vertices and line snap positions are treated equally and the closest one to the cursor is selected.

As you use 12d you need quick access the turning snaps on and off but it is not that often that you need to change the other settings. So rather than having the large Snaps menu on display at all times, the Snaps toolbar and Snaps (Vertical) menus are available as abbreviated forms of the full Snaps menu. They take up less room on your screen and hence are useful to the experienced user.

The Snaps toolbar is normally in the top section of the screen but if it has been deleted, it can be brought back again by clicking on View => Toolbars to bring up the Customize Toolbars panel and ticking on H (for Horizontal snaps).
The **Snaps** toolbar will then appear on the screen

![Snaps toolbar](image)

Similarly selecting **Utilities => Snaps => Snaps (vert)** on the Main Menu) will bring up a Vertical snaps menu. Unlike the **Snaps** toolbar, the **Snaps Vertical** menu can not be docked.

![Snaps Vertical menu](image)

At any one time each snap setting is toggled either ON or OFF. For the **Snaps** toolbar and the **Snaps Vertical** menu, the snap setting is OFF when the button is depressed or appears clear and ON when the button appears raised or blue.

To practice this further, do a **Fit** on your current View. Pick a feature in the view where lots of lines meet and without moving the mouse, do a series of **String Inquires** by repeated use of the LB and observe how 12d will snap to adjacent items near to the mouse cursor. Note the cursor shapes returned that indicate that sometimes you are getting a **Point snap** and sometimes a **Line snap**.

Remember points are just a special type of string.
7.5 Models and Snap Settings

Whilst it may appear obvious, it is important to remember that you can only snap to data that is currently on display. Models that are currently turned off will not participate in the selection process during snapping. If you find that you are snapping to unwanted items, consider turning off models that are irrelevant to your current operations.

7.6 Fast Picking Snap (F)

If Fast Snap (F) is on, instead of clicking LB to select a string, click MB or press <enter>, and the nearest string to the cursor satisfying the snap conditions is selected.

Hence using MB alone replaces a LB followed by an MB.

Note: If you are using F snap then you get the first string only.

7.7 Fast Accept Snap (A)

If Fast Accept (A) snap is on, then if there is only one string that satisfies the snap conditions, then that string is automatically accepted.

However if there is more than one string then the normal snap selection is followed.

Note: A snap is a good compromise - if there is only one possible string then it is immediately accepted. If there is more than one possible string, then you get the choice to select which one.
7.8 Modifying the String Highlighting Colour

12d has various default parameters for the display of data including the string highlighting colour. This is the colour a string is changed to whilst it is selected.

The default highlight colour is white but this is not be very useful if you want to draw strings in white, or if you use a white background colour. In either case, it is important to change the highlight colour to a colour other than the white.

To check the highlight colour for the project, we select from the main menu Project => Management => Defaults and the Defaults panel pops up.

![Defaults panel]

From this panel, the user can change various parameters for this project that 12d uses for calculations, display and data handling.

To change the default highlight colour, select the Systems Settings tab by clicking LB on the Systems Settings tab.
The following panel should appear:

![Default Settings Panel](image)

Note that the Highlight colour is set to off yellow.
To change this, LB click on the colour icon adjacent to the Highlight colour input box and select another colour such as cyan from the colour choice box. Then press **Select** on the colour choice box panel. Colours can more quickly be selected from the choice box by double clicking LB on the desired colour - the Select button is not required.

To set the current values for the defaults press the **Set** button.

**NOTE:** When a new project is created, the values in the **Defaults** panel are loaded from the set-ups file `defaults.4d` which 12d Model looks for on start up in the standard 12d location (for more information on the search order, see 39.8 Defaults File in 39 Setting Up & Configuring 12d in the context sensitive 12d Model Reference manual). For an existing project, all the values in the **Defaults** panel are saved with the project so if any have been changed in the project after the project was first created, then the defaults for the project will differ from those in the `defaults.4d` file.

If you wish to keep the current defaults for a project to use as the initial defaults for future new projects, you can save the file `defaults.4d` to a suitable location by clicking on the `defaults.4d` tab and then the **Write defaults** button to bring up the Write Setup File "defaults.4d" panel.
Specify where you wish the defaults.4d file to be saved and then click on Write.

In this example select Current folder. If you wanted the changes to apply to any new project you create then you would select User folder and it would save the changes to the User folder.

Click on Finish to close the Write Setup File "defaults.4d" panel, and then Finish on the Defaults panel.
8 Creating Strings with CAD

We will now investigate creating strings using the CAD options. We will create points (one point strings), a 2 point line (single segment string) and a line string (multiple segments in the string).

First we will create a new plan view to work in.

From the main menu, click LB on Views =>New =>Plan. This will create View Plan 3.

Maximise the view by clicking on the Maximise icon on the top right hand corner of the view or by double clicking on the plan view title area.

8.1 Creating Points

The CAD options to create points, lines etc. can be done by using the main menu system or by the use of the CAD toolbar, which is displayed on the left of the screen at start-up. Regardless of the method used to activate the CAD commands, the CAD controlbar as outlined on in 4.5 Toolbars and Controlbars on page 38, will be used to define the characteristics of the created elements. We will change the values in the controlbar as follows.

Click LB in the model field and type in CAD. Click LB on the colour icon and choose the colour red from the choice box by double clicking on red in the pop-up list of colours. Enter 20 into the height box and leave the linestyle type as 1.

Note: We are only using red because it will show up on a white background in the images. Use whatever colour you prefer.

To create a point string (i.e. one vertex string) we will use the CAD toolbar flyout. Pick the points section of the toolbar by clicking LB over the CAD Point symbol and keep LB depressed.

The points flyout menu is displayed which has all the options in the points section of the CAD creation tools. This is displayed as a horizontal bar consisting of all the icons that make up all the options in the points section of the CAD tools. Whilst holding down LB move the cursor over each of the icons and the tooltip function tells what each of the options does.

To select an option, keep the LB depressed until the cursor is placed over the specific option you want and then release the LB. We will select the Point option which is the first icon in the flyout.
On selecting the **Point** option, or any other CAD option, the user is prompted for the relevant data in the screen message box located on the bottom left hand corner of the 12d Model application window.

The user can select a position with the mouse and on accepting that point (Middle mouse button or enter) the point is created at the selected position. The model, colour, height etc. are defined in the **Cad Controlbar**.

The snap mode will influence the mouse selection. For example if Cursor snap is on, the user can choose a position not yet defined. If Point snap is on and the selection snaps to an existing point, the option will place another point at that location.

Ensure that the **Cursor** snap is activated in the Snaps toolbar. Click LB at a position roughly in the middle of the view.

Click MB. The point is then created with the model CAD being added to the view automatically.

To see the height of the point we must toggle on the Z values. To do this click LB on the toggle button on the view menu to bring up the toggle menu. Then click LB on the **Z values [off]** position.

Don’t walk right on the arrow near this position - this is to specify individual models to turn the Z values on or off. By clicking LB on the Toggle menu, you turn on (or off) all Z values in that view for all models.
The default colour for the height text is yellow but to make it clearer on our white background, we will change the text colour to red (as depicted in the image above).

To change the colour of the height text, click LB on the menu icon from the Plan 3 View menu to bring up the Plan View menu. From that menu click LB on Settings =>Z values =>Single to bring up the Z Values for Plan View panel.

From this panel, for the Draw textstyle data field, select the Textstyle Data icon and then click on [Edit].
Change the **Colour** field to red and then click **Set** and **Finish** to close the panel.

Finally click **Set** on the **Z Values for Plan View** panel and **Finish** to close the panel. The colour of the height text will then be red.

The change is made only for View 3 and when any other points are added to the view, they will also have their height text shown in red.

There are various ways of selecting a position when creating a point. For the first point we just selected anywhere on the view.

Specification of a position can also be done by the direct input of the xyz coordinate of the point.

Select CAD Point again to begin creating a new point and when over the view either press the space bar or start typing the x value and the **Enter XYZ** panel will come up.

The user then enter the X, Y and Z values into the box each value separated by a space. e.g. 200 150 40. As we have already set a Z value in the CAD controlbar, you only have to specify a X and Y value into the box. **NOTE:** The Z value will default to the value entered into the CAD controlbar whether or not it is specified in the XYZ box. If no height value exists in the CAD controlbar or the XYZ box, then a value will be interpolated if possible, otherwise a 0 value will be assigned.

We will again create a point by using the CAD toolbar.

Firstly, change the Z value in the CAD controlbar to 50. Then repeat the steps outlined above to choose the CAD Point option. Instead of selecting a point with the mouse we will type in the coordinate values.

To pop up the XYZ box, press the spacebar. Then type into the box, 200 100 and then press <Enter>. We did not have to specify a Z value in XYZ box as it was already defined in the CAD controlbar. **NOTE:** A space must be placed between the X and Y values.

![Enter XYZ panel](image)

A new point is created. Click LB on the **Fit** icon on the view menu to fit the data in the view.

It should now look like as shown below:
8.2 Creating Two Point Lines

We will now create a simple one segment line. To do this we will again use the CAD toolbar but this time use the CAD Line flyout.

Pick the Cad Line section of the toolbar by clicking LB over the CAD Line symbol and keep LB depressed.

The Cad Line flyout menu is displayed which has all the options in the lines section of the CAD creation tool. Select the 2 points option which is the first icon in the flyout.

On selecting the 2 points option, the user is prompted for the relevant data in the screen message box located on the bottom left hand corner of the 12d Model application window

We will pick a position with the mouse to define the start of the line. Pick a position with LB about halfway between the two existing points and then MB to accept. After accepting the start point, the user is told in the message area to pick the second position (the end of the line). You will also notice when you move the mouse around that a line is drawn rubber banding to the cursor position.

We now select a point going south east to define the end of the string with LB and MB to accept. The created string will be shown using the parameters given in the CAD controlbar at the time of construction.
8.3 Creating Line Strings

We will now create a multi-segment string.

Although we could use Line String option on the CAD Line flyout, this time we will use the CAD menu from the Main Menu system rather than from the CAD toolbar.

From the Main Menu, click LB on Cad => Line => Line string. The Line String option will now be running. NOTE: These CAD options have no panels.

On selecting Line String the user is prompted for the relevant data in the screen message box located on the bottom left hand corner of the 12d Model application window.

We will pick a position with the mouse to define the start of the line.

Pick a position with LB any where on the view and accept with MB. Then move the cursor to a new position and pick and accept a second point. Pick and accept a third point and so on.

To finish the string simply press <Esc> on the keyboard, or alternatively RB to bring up the Pick Ops menu and then select Cancel from it.

The string will be created using the parameters given in the CAD Controlbar at the time of construction.

This has given a small introduction to the use of the CAD options. For a more detailed explanation of these tools see the chapter CAD in the 12d Model Reference manual.

We will now finish this section by deleting the current view. As the view is maximised, select View => Delete and select view 3. Alternatively, we could have restored the view and clicked LB on the X icon at the top right of the view.

This should then leave two views, Plan 1 and Perspective 2. If either Plan 1 or Perspective 2 are left maximised, select the restore button on the top right hand side of that view to leave two views as they were at the start of this chapter.

Clear the value for the default height in the Cad Controlbar. Leaving the height there may create problems when creating strings at a later stage. Also change the default model to one of the existing survey models as we will be deleting the CAD model and don’t want it being created again.
Finally, to delete the CAD model click LB on the Delete model option from the Main Menu Models => Delete => Delete a Model.

This brings up the Delete Model panel.

Select the Model icon with LB and then double click LB on CAD.

Tick on Permanently delete? and then click on the Delete button, and answer Yes to the confirmation panel for Delete Model.

This then deletes the model from the project.
9 Basic Road Design - Centreline String Creation and Editing

We will now begin our first Road Design with 12d. Before we can begin, we need to review other techniques for getting data into 12d.

By use of the Snap settings, we have seen how to snap to existing points and lines. This is useful when inserting strings into your model that must exactly join existing strings. There are times however when we wish to place a feature in the model exactly by absolute or relative coordinate entry. We do this by typed input.

9.1 Typed Input

In general, whenever 12d is prompting you for a cursor pick in a Plan view, you have the option of either

Clicking LB with the mouse to return the x and y coordinates OR

Typing the x, y (and maybe z) coordinates

To enter typed coordinates, you simply start typing, or click RB and select Typed Input from the pop up list. A **Typed Input** panel will pop up as you begin typing.

If you wanted to enter the coordinates of the point (100, 200, 50.5) you would type

Just separate the values with a space between each item. Terminate the entry of data from the keyboard by pressing the Enter key (<Enter>). If you only supply two values and press Enter, 12d will assign a Z coordinate of zero.

If you ever accidentally touch a key when performing cursor input via the mouse, the **Typed Input** panel will pop up. To remove it so that you can revert to cursor input, backspace over any digits that appear in the input window until the field is clear and press <Enter>. The panel will disappear.

Whilst there are also other ways of entering typed input e.g. by bearing-distance, relative xyz increments etc. we will not pursue these at this time.

For example, it is possible to turn on a grid and with the appropriate grid snap setting, snap to only the grid points when entering points and strings. We will look at the grid at the end of this chapter. See 9.6 Using a Grid to Assist in Coordinate Entry on page 146.
9.2 Horizontal Geometry (HG) Edit

Before creating an alignment string, we’ll first set up our views the way we want them.

For the View Plan 1, click LB on the Menu button in the View Button area (or click RB in the View Button Area) and the View menu will pop up. Click LB on Models=>Remove All Models.

Then in the View Button Area, click LB on the + sign button and select all survey models EXCEPT the models survey TOPO SURFACE LEVEL and survey STN.

From the Snap Toolbar, turn all Snaps OFF except Point, Line, Cursor, Information, Fast pick and Fast snaps cad accept.

In View Plan 1, click LB on Fit. Your view should look like:

We will now bring up the Super Alignment panel and look at some of the features prior to creating the alignment.

From the Main menu, click LB on Strings => Super alignments => Create super alignment. The Create Super Alignment panel will appear.
Click on the **General** node

The General node deals with the basic features of the alignment appearance. The super alignment is given a name and model along with other standard features such as colour, linestyle and weight.

Fill out the panel as shown. These settings tell 12d that our new road centreline is to be called **RS1** and it is to be placed in a new model called **ALIGNMENT**.

Click on the **Chainage** node

The mode option allows the user to set where the chainage is to be measured from.

With the given settings, the road will start at chainage 0 and the chainage will be calculated from the start point.
Click on the **Interval** node

The optional Horizontal and Vertical chainage interval is used for a sample interval which can be used if triangulating the alignment string.

As a general preference the design strings created from the apply many are used in the tin instead of the alignment string.

The interval is also used to create vertices on the string when exporting to another string type.

The Chord-arc tolerance adds additional chainages where the perpendicular distance between the arc and a chord drawn between the points exceeds the input value.

If left blank the defaults are 10 metres for the intervals and 0.1 for the chord-arc tolerance.

Click on the **Label** node

Set the label style to **full** to see both horizontal and vertical tangent points and other features.

Type in 10 for the **Major interval** which says that labels will be displayed every 10 metres.
Click on the **IP defaults** node

Click on **Create** and the Super Alignment Editor for RS1 will appear.

It is suggested that you move the **Super Alignment editor**, the **Edit SA** menu (or **Edit SA** toolbar) to the top right of your screen to get it out of the way when creating your new centreline.

To move the **Edit SA** menu, press LB somewhere over the words ‘**Edit SA ALIGNMENT.....**’ to pick up the menu, move the cursor and pin the menu down by releasing LB.

We will initially define the horizontal alignment of the road in the View **Plan 1**. We need to tell 12d that we are defining Horizontal Intersection Points (HIPs).

To select options from the **Edit SA** menu hold down the left button over the relevant icon (**Add/Remove IPs**) on the toolbar to activate a drop down menu.

To select options from the editor panel hold down the left button over the relevant icon (**Add/Remove IPs**) on the toolbar to activate a drop down menu.

Click LB on the relevant icon. The data tip displays for a few seconds which is used to select the required option.

Click LB on **Append HIP**
12d is waiting for you to select the starting point of your road. You can choose to either (1) select an existing point (2) enter coordinates exactly or (3) freehand in the points.

If you do a **Fit** on the view you will see the three HIPs already entered and the alignment rubber bands to where the cursor is as the possible next HIP. We will position the last HIP at the intersection of the roads in the bottom right corner.

Type the X and Y coordinate in turn for the next two IP points:

**IP 2**
X = 42697.941  
Y = 37350.926  
Press <Enter>

**IP 3**
X = 42552.804  
Y = 37099.542  
Press <Enter>
TERMINATING THE "RUBBER BAND"

The last HIP is the intersection of the roads in the south east corner.

Click on the intersection and accept the position. After the fourth HIP is defined, it will remain rubber banded to the cursor.

Pressing the Esc key (<Esc>) terminates the String creation process and removes the rubber band. Your centreline should now comprise of four points connected by three segments.

On doing a Fit, your view should now look as shown below.

Note that in the images the labels for the Super Alignment are shown in red instead of yellow so that they are visible on a white background.

Don’t put the Edit SA menu away yet as we will need it further. Just leave it in the view. Remember this menu is referring explicitly to the Alignment we are currently creating (ALIGNMENT =>RS1).

To make the road alignment easier to see, we will turn off all the survey models except the survey ROAD CROWN, survey ROAD PAVEMENT EDGE and survey TOPO TIN BDY.
The Screen Message Box area advises

<Pick IP to change curve info>[picks][Fast][Menu]

Click with LB in the vicinity of HIP 2 and MB to accept the highlighted HIP. A panel will pop up prompting Radius. The cursor should already be locked into the data field.

Type 200 and then press <Enter>

Observe that a horizontal curve of radius 200 is now inserted and the tangent points have symbols and chainages with user defined prefixing e.g. TC for Tangent Curve.

The insertion of curves is setup to handle multiple insertions. If you now position the cursor in the vicinity of HIP 3 and click with the LB, accept with MB, type 100 for the new radius and press Enter, a further radius will be inserted.

To terminate the radius insertion process, press <Esc> (or click RB to pop up the Pick Ops menu and click LB on Cancel).
Your plan view should now look as follows.

We’ll now look at interactively obtaining information about the created Super Alignment.

To do this, click on the **Information** icon on the **Edit SA** menu.

This brings up the **Super Alignment Info** panel that displays information about your string geometry. If necessary, move the panel away from your road centreline.
Move your cursor along the new road and you will see the information in the panel change. The panel shown was created by pointing at HIP 2. It gives you the coordinates of the cursor dropped onto the road centreline along with the instantaneous direction, arc length and radius.

Click LB on [X] to close the Super Alignment Info panel.

To complete our new road, we now need to define its vertical geometry but to do this we first need to create a new Section View.

So we will close down the Super Alignment editor for RS1 and look at creating and using a section view before coming back to creating the vertical geometry for RS1.

To exit the editor, just click on the Finish button which is the Finish. You can also hold LB down on the Finish button and the fly out toolbar with Finish and Quit buttons will appear and Finish can be chosen from there. Important - don’t choose Quit because that will throw away any of the editing that you have done.

The Finish Edit panel will then appear

Click LB on Yes to confirm and the edits to RS1 will be saved.

9.3 Section Views

A section view is a view with the coordinate system of chainage along a selected string along the horizontal axis and height for the vertical axis. The selected string is called the profiled string.

If there are any models including tins added to the section view, then sections along the selected string through the tins will be displayed in the section view. For any strings in models added to the section view, cuts through that string by the profile string will be displayed.

Given that vertical geometry is defined in terms of chainage along a string then a section view is exactly what is needed to interactively create vertical geometry.

To create a section view, from the Main menu, click LB on Views =>Create =>Section view.

When the panel appears, highlight the current entry in the view name field by double clicking the LB, and type LONG for Long Section. Click LB on Create to create the view.

The new view will pop up as a window overlaying your other 12d windows. Firstly, minimise the perspective view 2. Then click LB on the plan view title area and select Window =>Tile Vertical.

Note: Views =>New =>Section view also creates a new section view but it does not ask you for a name and creates it with the next available view number.

The View buttons on the Section view are:
Chapter 9 Basic Road Design - Centreline String Creation and Editing

The first Model to turn on in a section view is always the TIN. The reason for this is to establish the vertical geometry in the section view. Remember we gave the TIN a name called GROUND and we placed it in a model called tin GROUND. Add this model (turn this model ON) by clicking LB on the + sign in the View Button Area of Section LONG. The screen will still appear blank at this stage.

As previously described, a section view has the chainage of a selected string as its horizontal axis and the height of the string as its vertical axis. Hence we need to tell Section View LONG that we wish to construct a section view along a given string (in this case our new road centreline RS1).

For an alignment string like RS1 there is the special Section View option

Section View =>Utilities =>VG edit

that does both the profiling of the Alignment string and brings up the Super Alignment editor but before we do that we will look at how to profile any string for a Section View.

In general for any Section View we profile a string by selecting the string to profile by clicking on the Profile icon on the Section View and then selecting a string to profile. 12d then does a section through the TIN along the selected string. That is, using the x and y coordinates of the selected string, it calculates z values from the TIN. 12d then uses the z values (heights) from the TIN and the string’s chainage to construct the Section view.

9.3.1 Profiling a String on a Section View

From the Section LONG View Button Area, click LB on Profile icon .

The Screen message Box displays

<Profile>[picks][][Menu]

12d is asking you to select the string you wish to profile.
In the view Plan 1, click with LB on the string that is the boundary around the data.

Provided your snap settings have at least Line snap ON, the string will highlight and the Information panel will display.

The Screen Message Box advises

<Profile>[picks][accepts][Menu]"survey TOP TIN BDY->DTMBDY"

Use the name and model in the Information panel to confirm that you indeed have highlighted the correct string and then click MB to accept the highlighted string.

The section view will now be refreshed and will contain a red string corresponding to the section along the string DTMBDY and a green string where DTMBDY cuts the TIN as defined in model tin GROUND.
After accepting DTMBDY, your Section LONG view should now look as follows:

The green section through the tin does not appear because DTMBDDY was included in the triangulation and so lies exactly on the tin and so the red section through the tin is identical to the profile of DTMBDY. And because the profile of the string is drawn last, you only see the red string. When we profile RS1 in the next section, we will be able to see a section the through a tin.

When the string DTMBDY was defined, it starting near the bottom middle of the view and proceeded in an counter clockwise direction so this is the direction of increasing chainage along the string.

We will now examine some of the information features of 12d.

When the cursor is in the Plan 1 view you will notice that the View Coordinates Box at the bottom of the desktop shows the x and y coordinates of the position of the cursor in the plan view.

When the cursor is placed in the section view LONG, the View Coordinates Box displays the chainage (ch) of the selected string, the cursor height (ht) and the x and y coordinates of the profiled string. The start chainage for DTMBDY was zero at the bottom middle of the view.

If you place the cursor in the section view LONG and move the cursor backward and forward laterally via the mouse, you will see a yellow cross moving along the string DTMBDY in plan view 1. 12d recognises that the same string is appearing in both views and links the information in the views accordingly. The yellow cross is positioned in the plan view 1 based on the chainage (i.e. the position of the cursor laterally) along the string in the section view LONG.

Section Views default to a vertical exaggeration of 10 to 1 but you can change the exaggeration at any time by clicking on the View Exaggeration or the Toggle button and selecting the required exaggeration.

If you require an exaggeration other than those listed, you can click on Exaggeration from the list and type in the required value.
9.3.1.1 Turning Off the Information Panel

Sometimes the Information panel is always getting in the way of your picking process.

At any time the Information panel can be toggled off to get it out of the way for the duration of a set of pick operations. You do this by unticking the Info or I tick box on the Snaps menu or Snaps toolbar.

Although the Information panel does not then appear, the name of the highlighted string is still displayed in the Screen Message Box.

Alternatively, if you leave Information panel turned on, moving the cursor slightly on the screen is the easiest way of removing it after each pick. See 4.4 How to Find Your Way Around 12d Menus on page 34 for more information on moving menus and panels.

9.3.1.2 For Advanced Users

If multiple TINs are present, any TINs in models added to the view are also sectioned as the string is profiled. Also the section view has a Corridor Width so any other strings crossing the corridor will also appear provided their various models are turned on.
9.4 Vertical Geometry (VG) Edit

We will now define our road’s vertical geometry. We do this by defining Vertical Intersection Points (VIPs) and then placing vertical curves between the VIPs.

To define the VIP’s we need to have the alignment editor running for the alignment and also the alignment profiled in a Section View. We can do these in the one operation by selecting the following Section View option on Section view LONG:

**Section View => Utilities => VG edit**

The **VG Edit String** panel then appears, already in picking mode,

![VG Edit String panel](image)

and the **Screen Message Box** advises

<Edit String>[picks][fast][Menu]

In the view Plan 1, click with LB on the alignment string RS1.

![String RS1](image)

Provided your snap settings have at least Line snap ON, the string will highlight and the Information panel will display:

![Information panel](image)

The Screen Message Box advises

<Edit String>[picks][fast][Menu]"ALIGNMENT->RS1"

Use the name and model in the **Information** panel to confirm that you indeed have highlighted the correct string and then click MB to accept the highlighted string.
After accepting RS1, the Edit SA editor is again opened for the string RS1 and your Section LONG view should look as follows

Unlike the previous string being profiled, this string has no z-values and so nothing shows on the section view for it. What is displayed as the green string is the section through the tin GROUND along the alignment string.

The figures of -200 and -100 in the view correspond to the radii of the two horizontal curves defined along the centreline. The R indicates that the curve is an arc and the value is the radius. The negative sign in the radius indicates that a curve goes to the left when going along the string in the direction of increasing chainage. Positive curves go to the right. The arrows show the chainage extents of the curves in the section view.

When we defined the string in the Plan view, we defined it in order starting near the top of the view and proceeded towards the bottom so by default, this is the direction of increasing chainage along the string.

We can now use the Editor to create vertical geometry in the Section View LONG.

To ensure that the complete road centreline, as defined in the Plan view, is also defined in elevation, and matches neatly with the existing roads, we can add the model survey ROAD CROWN to the section view and in the section view, the places where the strings in the model survey ROAD CROWN cut RS1 will appear as crosses and lines if they run along RS1. These crosses and lines can be selected in the Editor and so get their exact z value.
If we zoom into the cross at the beginning and remove the model **tin GROUND** to make things a bit clearer, we can see that there is a cross and lines at either end of the section. These represent the crows of existing sections of the road that we want to match.

From the Edit SA menu, click LB on **Add/Remove IPs=>Append VIP**.

The message in the Screen Message Box is:

"<Pick start IP location>[picks][fast][Menu]

12d is asking you where you want to place the first VIP. Select and accept the intersection point in the survey **ROAD CROWN** model at the start of the profile.

Your first pick will not necessarily be the ROAD CROWN so be sure to cycle through the picks until you..."
have the right point. The line will then rubber band from the previously placed VIP to the cursor position in the Section View.

Now select and accept as the second VIP the end of the CR strings that is on top of RS1 at the beginning of RS1. We have now placed two VIP points which exactly match the existing road at the start of our design. The line will then rubber band from the previously placed VIP 2 to the cursor position in the Section View.

We will now add in two more VIP points by typed input before tying into the existing road at the end of our design in a similar fashion to the beginning of the vertical geometry.

Type the chainage and level in turn for the next two VIP points, the same as we did with the X and Y coordinates of the HIP's:

**IP 3** Ch = 412  RL = 49.667
Press [Enter]

**IP 4** Ch = 600  RL = 66.333
Press [Enter]

Tie the last two VIP points (5 and 6) into the existing road at the end of the design in the same manner as we did previously with the start of the design.

After the sixth point is placed, press <Esc> to terminate the rubber band (or click RB to pop up the Pick Ops menu and select Cancel). Click LB on the Refresh button in the View Button Area to refresh the view.

As the VIPs were placed, 12d has annotated the view showing the grades defined between the VIPS.
12d has many other facilities to accurately place vertical geometry. We are now going to insert a new VIP point on the same grade as VIP 2 but 40 m from the intersection to allow us enough room to place a vertical curve.

To do this, we click on:

**Add/Remove IPs => Insert VIP Grade.**

As we wish to extend the grade from VIP 1 through VIP 2, our starting VIP # will be 2.

The grade will be the grade between VIP 1 and VIP 2, which we can read from the section view as -0.681.

The **Mode** will be **distance** as we want the new VIP to be 40 m from the end of the existing road to allow enough room to add a vertical curve.

The distance as stated above will be 40 m.

Click LB on **Insert** then **Finish**

Your view should now have an extra VIP as shown below.
We will now insert another VIP to once again allow enough room to insert a vertical curve before finishing on the existing road at the end of our design. This time we will intersect two grades from existing VIP points. Click on Add/Remove IPs => Intersect VIP Grades.

This time we will be starting from VIP 5

The mode will be grade for manual entry of the grade

Type in the value -5

The second grade is calculated from VIP 6 to VIP 7

The mode is VIP# so the grade will be calculated between the nominated VIP points 6 and 7.

Click LB on Insert then Finish

Your view should now have an extra VIP as shown below
As we have inserted two new VIP’s on the same grade as existing VIP’s we end up with redundant VIP’s which can now be deleted. Click on Delete and select and accept VIP 2.

12d will renumber the remaining VIP’s and hence the second point to be deleted will be VIP 6.

The resultant alignment then has 6 remaining VIPs.
We will now place some vertical curves in the design. We will use parabolas to define the vertical curves and place them via their length.

From the Alignment Edit menu, click LB on Move/Edit icon then select **Change Curve**

Click with LB on VIP 2 and confirm it with MB. A **Typed Input** panel will pop up prompting ‘Length’.

Click with LB on VIP 2 and confirm it with MB. A **Typed Input** panel will pop up prompting Length.

Position the cursor in the data field then type 50 and then press <Enter>.

Observe that a vertical parabola of length 50 is now inserted and the position of the VIP is still shown.

The insertion of vertical parabolas is setup to handle multiple insertions. If you now point in the vicinity of VIP 3 and click with the LB, accept with MB, type 150 for the new length and press <Enter>, another parabola will be inserted.

You can insert the remaining parabolas in the same fashion with VIP 4 having a length of 200m and VIP 5 a length of 100m.

To terminate the parabola insertion process, press <Esc> or click RB to pop up the **Pick Ops** menu and select **Cancel**. Click LB on the Refresh button in the View Button Area to refresh the view and revise the annotation.

Your Section LONG view should now look as follows.
Note that on the Section View the length of each parabola re is given followed by an L, and there are arrows to indicate the extent of the Vertical curves.

We can now use the Information panel to show the details of our vertical geometry. From the Alignment Edit menu, click LB on Info to pop up the Information Panel.

Move the cursor in the Section View along the Road centreline string. The data in the Information panel changes dynamically as the cursor is moved.

The results in this panel are from placing the cursor near VIP 3.

We have now finished defining our horizontal and vertical geometry and wish to exit from the alignment editor. To do so, as before we click LB on the Finish button or press LB down on the Finish icon and select Finish from the drop down toolbar.
The Finish Edit panel will then appear

![Finish Edit panel]

Click LB on Yes to confirm and the edits to RS1 will be saved.

**WARNING**: Do not select Quit from the alignment editor. Quit will throw away all the changes made to the string since the alignment editor was started.

NOTE: We don’t have to exit from the alignment editor for the string RS1. We could simply leave the Edit SA menu on the screen and return to it later.
9.5 Editing an Existing String

Now that we have left the alignment editor, we need to know how to go back into the editor to make future modifications to the alignment string. In fact, what we now do applies to editing any existing string, not just an alignment string.

To edit an existing string, simply click LB on the option Strings => Editor which brings up the Edit String panel.

Now pick and accept the string you want to edit, in this case, the string RS1. The appropriate editor for the selected string will then be started. Note that RS1 can be selected in the Plan View or the Section View.

QUICKER METHOD OF GETTING THE STRING EDIT PANEL

In 12d you can define function keys and combinations of Shift, <Ctrl> and a function key to bring up 12d options. In the standard install, F6 brings up the Edit String panel.

So to bring up the String Edit panel, simply press F6.
9.6 Using a Grid to Assist in Coordinate Entry

For the work so far we have been using typed entry to enter coordinates however for some work you want to be able to snap to the intersection of Grid lines to get the coordinates.

So we will now quickly look at how you can turn on a grid in a Plan View and use it to snap to. The same can be done for a Section view for laying down VIP points.

First we’ll create a new view using the option from the Main Menu, View =>New =>Plan.

A new plan view called 3 will be automatically created. In the View Button Area for Plan View 3, click LB on the + sign button and select all survey models.

Now let us set our grid settings so that they are suitable for grid snap purposes.

From the Plan 3 view, click LB on the Menu button in the View Button Area to pop up the View menu. Select Settings =>Grid and the Grid on View panel pops up.

Plan View 3 will now look like:

Tick on the grid draw box

Note the default value for Grid mode setting. The choices are either full lines, crosses, marks or marks and crosses.

Click LB on the Choice icon if you want to change the value.

Note the default grid x setting. You can change this setting by placing the cursor into the grid x field, press the Backspace key (or the Delete key) and typing the required number.

Similarly for the grid y field.

The text x field has the choices text off, text at bottom, text at top and text at bottom & top.

If you don’t want text on the grid, click LB on text off.

Similarly for text y.

Click LB on Set to activate the change.
To use the intersection of the grid lines, we use Grid Snap we simply set Grid snap ON.

So on either on the Snaps toolbar toggle on G for Grid snap, or on the Snaps menu, toggle on Grid. Whenever one of them is changed, the other will be automatically changed to the same setting.

When creating new strings you would probably want Point and Line snap OFF so that you don’t inadvertently snap to features in the view.

Any of the Snaps menus or the Snaps toolbar can be used to toggle Grid snap on.

If you want to use the Snaps menu and it is not already on display, click LB on Utilities⇒Snaps⇒Snaps from the Main menu.
If a grid is not already on display on a view, then in the View Button Area of the view, click LB on **Toggle =>Grid** to turn on the grid with the current grid settings.

If you want to turn a grid OFF for a view, then in the View Button Area of the view click LB on **Toggle =>Grid** to turn OFF the grid.

So for any view, a grid can be quickly turned on and off by using the **Toggle =>Grid**.

You only need to bring up the **Grid on View** panel if you want to change some of the setting for the grid.

With **Grid Snap** turned on and a grid on the view, if we were now to start creating strings, then with each position pick we could snap to a grid intersection.

The purpose of introducing this here is to show you how you can set up and a grid.

At this stage we will not be using it so we will delete Plan View 3 by clicking on the **X** in the top right hand corner of the view.

Also from the **Snap** toolbar, turn Grid Snaps OFF.

Then on the View **Plan 3**, click LB on the **Menu** button in the **View Button** area (or click RB in the View Button Area) and the **View** menu will pop up. Click LB on **Models=>Remove All Models**. In the View Button Area, click LB on the + sign button and select all **survey** models EXCEPT the models **survey TOPO SURFACE LEVEL** and **survey STN**.
10 Road Templates

The simplest way that 12d can create a road design is to calculate the effect of passing a user defined cross section template along the alignment and the interface between the new template and the existing terrain.

12d has Templates that are always defined for half of the road. When used on the left, the template is applied on the left hand side of the road. When used on the right, the template is applied to the right hand side of the road.

Each template has various parts to it. There is a **Fixed** part that is always used in applying the template. Then there is a **Cut/Fill** part that is variable. As many links in this part are used as is necessary to reach the intersection with the natural surface. If after using all of the Cut/Fill links, the road profile still has not intersected with the surface, a **Final Cut/Fill** slope is used to try to calculate the intersection. All parts of the template are optional.

10.1 Creation of Basic Templates

Template creation is a mechanical process of filling widths, crossfall (slopes) and delta heights into a panel and the created Template data is stored in files.

A typical use of templates files is to store standard templates as required by a particular road authority. These can then be read in and modified to suit each particular job as required - quicker than starting from scratch each time.

For the purpose of the tutorial, we will use an existing template to save time. Previously stored template values will be read in from file "ROAD TEMPLATES.tpl". This is one of the files supplied with the Training disk.

From the Main menu, click LB on **File** => **Templates** => **Templates input**. The **Read Templates** panel pops up.

Handy Aside:
For any File field (File ox) on any panel, you can drag the file from Windows Explorer onto the File field and the full path name of the file will written to the File field.

Our Template file contains a number of templates. Initially we will look at the templates called **FULL LEFT** and **FULL RIGHT**. The various parts of the template just read in will now be displayed. These are just arbitrary names that have been assigned to these particular templates. There can be many templates in just one file, and in general any template can be applied to either side of the centreline. In this case we will use the convention to have left and right suffixes _l_ and _r_ in the names and to use these templates on the left and right respectively.

An alternative to creating a left and right template is discussed in **10.3 Alternative Template Creation on page 157.**
We will now investigate the template **FULL LEFT**.
From the Main menu, click LB on **Design=>Templates=>Create/edit**.

In the template panel that pops up, place the cursor on the Information button for the **Template name** field and click the LB to pop up a list of templates.

Double click LB on **FULL LEFT**

Each template has up to five parts. We will only use **Fixed**, **Cut** and **Final Cut/Fill**. This means that in a fill situation, the final fill batter will join onto the fixed part of the road template since we are not defining a variable fill template. If a template panel contains blank fields, 12d will such fields in its processing of the various template parts.

**Fixed Part of Template**
From the **Template Create/Edit** panel, click LB on **Fixed** and the fixed template panel pops up.

This section is called Fixed because all the links in this section of the template are always used.
A large number of fixed links can be defined but we will only need five.
Note that the name of each link in the left template has been given a suffix _l_.

Chapter 10  Road Templates

The template defines a carriage way width of 3.5 metres at -3% crossfall to the kerb line $lok_l$. This is followed by a kerb and channel, $iok_l$, $tok_l$ and $bok_l$ and then out to the back of the footpath $bofpl$.

The sign convention is $+$ve is up and $-$ve is down. Each width defines a link from the previous link so the order is important i.e. links are defined relative to one another, not from the template centreline.

As you will see later, this is one of the features that makes 12d so powerful - the ability to use string handling to automatically perform total road redesign after any geometry or template link changes.

These template link values could now be changed. At completion of any changes, select Apply to implement the changes but leave the panel on the screen. Select OK to implement and terminate the panel.

**Variable Part of Template**

The Cut and Fill sections are called the Variable part of the template because depending on the terrain, a different number of links may be used.

Note that the links in the Variable part of the template connect onto the Fixed part i.e. the first variable link follows immediately after and connects to the last fixed link. The Fixed part always appears so it is normal to put kerbing etc. in the fixed part.

The variable Cut part only appears if at the end of the Fixed part of the template is in a cut region. That is, the end of the Fixed links is under the ground and you need to cut into the terrain to reach that point.

Each of the links in the Cut part is then be used until the surface is reached. No more of the Cut links are then used.

It is normal to put benching in the variable part of the template when battering is required.

Similarly, if the end of the Fixed links is in fill, then the variable Fill part of the template is used.

**Variable Cut Template**

From the Template Create/Edit panel, click LB on Cut and the Variable Cut Template panel pops up.

Again a large number of links can be defined here. We will use six to define our batter slopes. Slopes are defined by giving a horizontal width x where the slope is 1 vertical in x horizontal.

The sign convention for slope in Cut section is $+$ve is upwards.

Unique names are given for each link in the template. Note the $l$ suffix in each link name

**Warning:** in the Fill section, the sign convention for slope is $+$ve is downwards.

These values could now be changed. At completion click LB on Draw to preview the template.

Click LB on Apply to implement any changes. Click LB on OK to implement any changes and close the panel. In the Template Create/Edit panel, click LB on Finish to close the panel.
**Variable Fill Template**

Whilst we are not using one here, this section is included to define the rules of usage.

By leaving the panel blank, 12d understands that the variable fill template feature is not to be used.

The sign convention for slope in a Fill template is +ve is downwards.

**Final Cut/Fill Template**

From the Template Create/Edit panel, click LB on Final Cut/Fill and the Final Cut/Fill Template panel pops up.

![Final Cut/Fill Template](image)

These values could now be changed. At completion click LB on **Apply** to test out any changes. Click LB on **OK** to implement any changes and terminate the panel.

In the Template Create/Edit panel, click LB on **Finish** to close the panel.

Note that apart from the suffix l or r, the FULL RIGHT template is identical to FULL LEFT.

![Fixed Template](image)

The links in the left and right templates are identical except that links in the FULL LEFT template have a suffix of l and those on the FULL RIGHT template have a suffix of r.

This ensures that links on either side of the centreline have unique names – essential for string modifiers and applying boxing as we shall see later.

After the Variable part of the template, 12d will use the final cut and fill slopes to calculate the intersection with the natural surface. This only occurs if the Variable part hasn’t yet reached the natural surface. 12d will examine a corridor up to 100 metres from the previous link to achieve this. An interface string named `intl` will be placed on the TIN at the intersection. Again note the suffix l.
Variable Cuts for right side have suffix r.

The interface name intr has suffix r.
10.2 Applying Templates

Before we apply the template to the road centreline, let us rearrange our views so that we can see what is happening more clearly.

The design can be applied in two ways.

The simplest way is to create an **Apply function** which uses the templates for the length of the alignment without any modifications such as widening or superelevation. This is also useful for users who don’t have the **Alignment** module.

The other more typical way for most design applications is to create an MTF file (Modifiers and Template File) which allocates and allows modifications of templates and strings. This is then processed using the **Apply MTF Function**.

**IMPORTANT NOTE:**
The **Apply MTF Function** requires the **Alignment** module. The **Apply MTF Function** is not in the **Getting Started for Design** manual but is covered in the non-Introductory Design courses.
We will now create an **Apply Template** function to apply the template to the road centreline.

From the Main menu, click LB on **Design => Apply => Apply template**.

The **Apply Template Function** panel pops up.

Fill in the panel as shown.

A function name is needed so that the process of applying this particular template to this piece of centreline can be referred to later in any redesign. In the **Function name** field, type **RS1** and then press <Enter>. On the **Models** tab the Model names will be automatically filled in after you press <Enter>. This is based on the function name. In the **Tin** field, click LB on the tin icon to pop up a list of available TINs. Double click LB on **GROUND**

In the Left and Right template fields, click LB on button to pop up a list of templates. Double click LB on **FULL LEFT** and **FULL RIGHT** respectively.

Select the **Reference** pick icon and then select the alignment string in the plan view.

As we already have existing road at the start and end of our design we do not want to start and end the template at the beginning or end of the alignment string. Type in the chainages shown to ensure the design matches up with the existing road surface.

**NOTE FOR PRACTISE VERSION:**

The default **Section separation** is 10 but for the Practise Version use a **Section separation of 20** and an **End chainage of 400**. This will keep the number of points under 5,000.

Click on the **Models** tab and note that the model names are already filled in. If they are not go back to the **Main** tab and press <Enter> after RS1 in the **Function name** field.

The other tabs we don’t need to worry about at this stage.

**Note:** If desired, use the shorthand suffix notation of ",1" after each model name to automatically add the model to View 1 as the template is applied. If this is not done, the strings and sections will still be updated but will not be on view. In such case they can be turned ON manually from the View Button area with the + sign button after the template is applied.

**Explanatory Note:** 12d permits the chainage of a road to be defined by a string called the Reference string. The template is always applied at right angles to the Reference string. To cater for complex projects, the centreline of the template is not necessarily located on the Reference string. Another string called the Hinge string is used for this purpose. The Hinge string and the Reference string do not necessarily coincide. If there is no Hinge string, the Reference string is used as the Hinge string.
In simple projects such as our new road, the Reference string and the Hinge string coincide. By default, 12d assumes the Hinge string defaults to the Reference string so we do not need to click the Hinge button in this case.

When the panel is complete, apply the template by clicking LB on **Apply**

There is now a short delay whilst 12d performs the calculation. The message box at the base of the panel will advise the current chainage as the template is applied. As the calculation completes, the view 1 will be updated with the new road strings and cross sections.

The panel message box now displays the cut, fill and balance volumes resulting from the application of the template. The default convention is negative for cut and positive for fill. Interpret these as follows

<table>
<thead>
<tr>
<th></th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>c</td>
<td>-35281.620 cubic meters of cut</td>
</tr>
<tr>
<td>f</td>
<td>7149.330 cubic metres of fill</td>
</tr>
<tr>
<td>b</td>
<td>-28132.290 balance in cubic metres showing surplus of cut over fill</td>
</tr>
</tbody>
</table>

Clearly we have too much cut at this stage. We will subsequently improve the design to minimise this.

**NOTE**

You volumes may vary slightly from these depending on the exact position of the initial first two and last two VIPS that where selected from the existing road.

Click LB on **Finish** to terminate the **Apply Template Function** panel.
10.3 Alternative Template Creation

12d can use just the one template for both sides of the road. The templates would be set up with no suffix after the link names.

From the Main menu, click LB on Design=>Templates=>Create/edit

Type in the template name **FULL**.

Select **Fixed**

Here the values are shown in the table without an *l* or *r* suffix

Select **Draw**

Select **OK** to implement any changes and finish panel

Select **Cut**

Again the panel appears similar to the Full left but without the suffix *l* or *r*

Select **Draw**

Select **OK** to implement any changes and finish panel
Select Final Cut/Fill
One template is defined
Note no suffix \textit{l} or \textit{r}
Select OK to implement any changes and finish panel

From the Main menu, click LB on Design \Rightarrow Apply \Rightarrow Apply Template

The Apply Template Function panel pops up.

The panel is filled in the same as shown in \ref{Applying_Templates} on page 154, with the exception of the \textbf{Left} and \textbf{Right template} names which are both \textbf{FULL}.

The prefixes need to be added. For the entry of the LHS prefix type \textit{*l} and for the RHS prefix type \textit{*r}.
Note that these will actual be suffixes of \textit{l} and \textit{r}.

\textbf{NOTE FOR PRACTISE VERSION:}
The default \textbf{Section separation} is 10 metres but for the Practise Version use a \textbf{Section separation} of 20 and an \textbf{End chainage} of 400. This will keep the number of points under 5,000.

This action will suffix all road string names with \textit{l} for the left side strings and \textit{r} for the right side strings.
The advantage of this method is the reduction in number of templates created.
The advantage of the previous system is the ability to pick strings from the view to match names which is useful when modifying templates and boxing.
Each method has its own merits but the \textbf{first method} is probably the best for future advanced work using \textbf{Modifiers} and the \textbf{Apply MTF}. 

\hspace{1cm}
11 Design Long Sections

11.1 Section Profiles

We will now focus on the sectioning facilities available in 12d. As we already have our Section LONG view displaying our road centreline, there are also many other ways in which information can be viewed.

In subsequent operations we will be picking strings. To help make this easier from our Plan 1 view we need to zoom it as before. Zoom in on the area shown so that each string is visible in the Plan view.

We will now section a series of strings that were created during our road design.

In the Section LONG View Button Area, click LB on the Menu button to bring up the View menu. Walk right on Profile => Many strings. (Note: This option can also be selected by clicking RB on the Profile button to bring up the Profiling menu. Click LB on Many strings.)

The Screen Message Box advises
<Profile>[picks][][Menu]

12d is asking you which string you wish to profile. In the zoomed Plan 1 view, click with LB on the cyan string just above the magenta centreline. The string should highlight and the Information panel will display (see right). Click MB to confirm the string selected.
The string will now appear in the Section LONG view.

The Screen Message Box is immediately prompting you for another string to profile.

<Profile>[picks][Menu]

In the Plan 1 view click LB on the intr interface string between the road formation and the existing terrain. This is the red-green string (shown highlighted below). Click MB to confirm the selected string.

The Section LONG view will refresh as below.
You will notice that for the section along \textit{intl}, you can’t see the section through the tin. That is because each vertex of the interface string \textit{intl} is ON the tin and so the two sections coincide at every vertex of \textit{intl}.

So using \textbf{Profile $\Rightarrow$ Many strings} you can rapidly look at the profiles of any string.

To terminate the \textbf{Profile $\Rightarrow$ Many strings} feature, press <Esc> or click RB whilst the cursor is anywhere in the Section LONG view to bring up the \textit{Pick Ops} menu, and click LB on \textbf{Cancel}.

Whilst the various strings have been profiled, clearly they are being scaled to fit the size of the Section view. To begin to get a feel for the scale of these strings, we can turn on a grid.

Firstly, let us make sure our grid settings are suitable. From the Section LONG view, click LB on the Menu button in the View Button Area to pop up the View menu. Click LB on \textbf{Settings $\Rightarrow$ Grid} and the following panel pops up.

Click LB on the \textbf{Grid draw} field to tick the tick box. This activates the grid.

Note the \textbf{Grid y} setting. If it is set to 100, move the cursor into the \textbf{Grid y} field by clicking with the LB at the right end of the "100", press the <Backspace> key followed by <Enter> (or double click with LB anywhere on the 100 and type 10 and press <Enter>).

Click LB on \textbf{Set} to activate the change.

Click LB on \textbf{Finish} to terminate the panel.

Note that you can turn the grid on with the above tick box or alternatively in the View Button Area of Section LONG, you could have clicked LB on \textbf{Toggle $\Rightarrow$ Grid}.

BUT you need to bring up the \textbf{Grid on View} panel to change any setting.
The Section LONG view will refresh as follows.

Depending upon what other information you wanted to display or create in this sectional view, the vertical scale may be too great. There are a variety of ways of changing the vertical scale.

The default vertical scale uses an exaggeration of 10 to 1. This can readily be changed by clicking LB on **Toggle** from the View Button Area to pop up the Toggle menu.

Click LB on **5x** to change the vertical exaggeration 5 to 1.

In the View Button Area, click LB on **Fit** to fill the view.

Change the Vertical Exaggeration **back** to **10x** (10 to 1).
12 Viewign and Assessing the Design

Remove any models on the Perspective view and then add the models survey ROAD CROWN and survey ROAD PAVEMENT EDGE in the perspective view.

Now that we have run the Apply, we have new design models RS1 Strs and RS1 Sects. Add both these models to the plan and perspective views.

The centreline model ALIGNMENT should be turned off in the plan view and turned on in the perspective view.

Set up the views on the screen up as shown below.
To begin assessing the design, click LB on **Zoom** in the Plan 1 view as shown below.

![Diagram of Plan 1 view with various interface strings highlighted in red and green](image)

Note that the interface strings between the road template and the existing terrain are coloured red in cut areas and green in areas of fill. This can be confirmed by placing the cursor in the Section LONG view and moving the cursor backwards and forwards across the view (to change the chainage of the cursor). Observe the corresponding movement of the yellow cross in both the Plan 1 view and the Perspective OpenGL 2 view.

Also note the various coloured strings that have been inserted in Plan 1.

From the main menu, click LB on **Strings => Inquire** and inquire on the various strings in Plan 1. Make sure that your Point and Line snaps are set ON. Place the cursor in an area near the road, click LB repeatedly and observe what happens. With each click a new string is selected. As the information panel pops up each time, note the various string names and the fact that each one now has a profile chainage (prof ch) and profile Z coordinate (prof z). These are now three dimensional strings and can be observed in the Perspective OpenGL 2 view.

You will observe that the cross sections are also strings with their own unique names that are used when referring to cross sectional views. For instance ‘design 130’ refers to the section string at chainage 130.0

**QUICKER METHOD OF GETTING THE STRING INQUIRE PANEL**

In the standard install, F2 brings up the **String Inquire** panel.

Whilst the View is zoomed try panning along the road to assess the interaction of the template with the existing terrain. From the Plan 1 View Button Area, click LB on the **Pan** button. Position the cursor on the centreline of the road near one edge of the view and press LB down. Drag the cursor across the view and the image will pan with the cursor until LB is released. Keep positioning the cursor on the road centreline each time and clicking LB down and move down the road whilst in the zoomed state.

Press `<Esc>` or RB to cancel **Pan**.
12.1 Perspective View Operations

In Section 6.10 Orbit on page 92, we saw how Orbit could be used to orientate your eye in relation to your data in a perspective view. We will now use this facility again to observe our design.

The Orbit option is accessed by clicking LB on Orbit in the View Button Area of Perspective Open GL 2. Make sure that models RS1 Strs, RS1 Sects and the survey ROAD CROWN and survey ROAD PAVEMENT EDGE are turned on.

Try hold LB down in the perspective view and moving it around to rotate the image, and also using the mouse wheel to zoom in and out to, get a view of the intersection at the end of the design.

You will notice that this facility gives you a good feel for the design you have created. You will see perspective views similar to that shown above.
12.2 String Drive

String Drive allows you to nominate a string and a speed and 12d simulates driving down the road. We will drive down the centre of the road with our eye height 10.0 metres above the road.

The string drive facility is accessed from the Perspective view by selecting the Drive button in the View Button Area of Perspective 2. The **String Drive for View** panel pops up.

Set the **Eye height** to 10 metres. The default values for the other items are OK. Note that the speed is set for 100 kph.

To repeat the drive once the end of the string is reached tick on the **Repeat** check box.

Click LB on the **String to drive along** icon and then select the centreline of the road. The easiest way to do this is to pick it from the Section LONG view.

Click LB on **Drive** to begin the string drive process. The image in Perspective will now change to that at chainage zero, looking down the centreline.

The image will repaint automatically multiple times as the drive proceeds. Each image will be calculated such that the viewer appears to be travelling down the road at 100 kph. The following are two typical images.

Observe that extra crosses appear on any plan or perspective views that the alignment string RS1 is on and any section view where RS1 is the profiled string. The **red** cross, is the **Eye** (or **Camera**) point and the **green** cross is the **Target** point for the perspective view of the drive.

On the perspective view that you are driving along (if the string ALIGMENT is on the view), you will only see the target cross because the eye point is not in the Perspective view. The target cross is 40 metres chainage further down RS1 and 0.3 above the z-value of RS1 at that chainage.

Observe the locations of the eye and target crosses on the other views that the alignment is on. These crosses move as the drive progresses.

You can stop the drive at any time by pressing <ESC> or RB. To resume the drive, select the **Drive** button again on the **String Drive for View** panel.
Once the drive has finished, you can replay it again by resetting the chainage to 0 (or any legitimate value along the road) and clicking LB on Drive again. Note that both the eye and target points must be on the string at all times for the Drive to work.

If the Repeat button is ticked on the String Drive for View panel then the drive will automatically start at the beginning of the alignment once the target point is at the end of the alignment.

It is possible to enter negative values for both the Target distance and Speed. A negative Target distance (-40) is equivalent to looking out the back window of the truck as you drive down the road. Set the chainage to 40 to start.

Similarly, a negative Speed (-100) can be used to drive back up the road in the opposite direction (i.e. in the direction of decreasing chainage). To do this you need to set the Chainage to somewhere near the end of the road (say 870) before you start the drive and also set the Target dist to -40.

Click LB on Finish to terminate the string drive.

Note
It is also possible to have negative values for Eye height, Eye offset, Target height and Target offset.
12.3 Defining a New Perspective View using Eye and Target points

Sometimes it is desirable to locate your perspective view exactly. For example, you wish to locate your eye at a particular point and look to a particular point.

To do this, click LB on the Eye button in the View Button Area of Perspective 2 and the Perspective View panel pops up.

Ignore the current values in the panel. They are left over from our string drive.

Click LB on Eye Target. 12d asks you to locate your first point on the view line. Make sure that your Point and Line snaps are ON.

In Plan 1 click LB on Fit to fill the view. Select the first point by clicking LB on the intersection of the existing road at the end of our design. Confirm the point with MB.

When the Enter height panel pops up backspace over the existing height and overwrite the value with 95 and press <Enter> since we wish to look down slightly on the design.

12d then prompts you for the second point on the view line. Click LB approximately in the centre of the road as shown. Confirm with MB. This time when the Enter height panel pops up, just press <Enter> to accept the value.

Your Perspective 2 should now look as shown here.
In the **Perspective View** panel, lock the cursor in the **Move distance** field by double clicking the existing entry with the LB and type 50.

Now every time that you click LB on **View**, the view will be advanced 50 metres along the eye-target view line. If you zoom in five times you will see a view like the one below.

![Perspective View Panel](image)

Clearly this facility gives you the opportunity to orientate your eye point accurately in any perspective view.

Click LB on **Finish** to terminate the panel.

That completes a brief look at some of the facilities in 12d that can be used to visually verify your design parameters using plan, section and perspectives. We will now look at more traditional ways of displaying design data - long sections and cross sections.
13 Design Cross Sections

12d has many facilities for displaying and plotting design cross sections. We will look at one of these called Model profiles. This name is derived from the fact that when we passed the template down our road, we created and stored our cross sections in a model. Model profile allows us to display this data by profiling the cross sections one at a time.

We now need a Section view in which to display the cross sections. As we still need our existing Section LONG view for our long sections, we will create another Section view.

From the Main menu, click LB on Views => Create => Section view. When the New Section View panel appears, place the cursor in the View name field, press the Delete key and type CROSS. Click LB on Create to create a view which will now be referred to as Section CROSS.

As before, you need to drag the border to resize the view. Stretch the Section view out so that it is approximately the same size as the Section LONG view we created earlier. Click and hold LB over the name Section CROSS and drag the view to the bottom right of your desktop as shown below. Pin it by releasing the LB. The View will initially be blank as no models are turned on.

Make sure that Point and Line snaps are set ON. Your overall desktop layout should now look something like this.
13.1 Model Profiles

In the Section CROSS View Button Area, click LB on the Menu button to bring up the View menu. Click LB on Profile ⇒ Model strings. The Profile Model on Section panel will display.

If necessary, move the panel away from your Section CROSS view so that it does not obstruct the view.

Place the cursor on the model icon for the Model field and click LB. A list of available models will pop up. Double click LB on RS1 Sects.

Now click LB on Next and observe the Section CROSS view. The first design cross section will now be on display and highlighted white.

Your Section CROSS view will look as follows.

This is the cross section through your road at chainage 21.86 (the first section along our design).

Now each time you click LB on Next, the next cross section along the road will be displayed. Try doing this a few times and observe what happens. Observe that the view is refreshed each time so that the cross section fully fills the window.

Try clicking LB on the Highlight tick box to turn highlighting OFF. You will notice that the cross section string displays its normal colour (cyan) rather than the highlighted colour.

The Item no. field in the Profile Model on Section panel just gives the number in the list of the profile string in its model. It will increment/decrement as the Next and Prev (for Previous) buttons are selected.

The Item chainage field in the Profile Model on Section panel displays the current chainage of the profile section. This field allows the input of a chainage from typed entry. A value can be typed in, followed by <Enter> and if there is a section of the entered chainage then that section is profiled. For example, typing 100 <Enter> moves the profile to chainage 100.

Also note that when the Highlight field is ticked on in the Profile Model on Section panel, the profiled...
section will also highlight in any Plan view that the model RS1 Sects in on, for example Plan 1.

We have the ability to link the Section view to Plan views by ticking on Dynamic profile in the Profile Model on Section panel.

Then when you move your cursor along the sections from the model RS1 Sects in the view Plan 1, the closest section will be profiled in view Section CROSS.

As we asked for cross sections at 10 metre intervals when we generated the road, that is the increment that sections are being displayed at. There will also be additional cross sections at tangent points etc.

We will now improve the legibility of our view. From the View Button Area of Section CROSS, click LB on Toggle. Move and pin the menu to one side so that it stays visible.

Click LB on Grid to turn the grid on. The spacing of the grid will default to 100 in both x and y directions. Set the Grid x spacing to 5 and the Grid y spacing to 2 metre. (See 11.1 Section Profiles on page 159, for information on how to access and change your grid settings).

Click LB on 2x to change your vertical exaggeration to 2 to 1.

Click LB on Grades to annotate the section.

From the View Button Area of Section CROSS, click LB on the + sign button and turn on model tin GROUND. This will display the natural surface (the green string) on the cross section. The cross section string is cyan.

Your view should now look as follows
From the Profile Model on Section panel for CROSS, click LB on Next a number of times and observe your road sections.

If preferred, you can untick the Fit View tick box in the Profile Model on Section panel and the scale will remain the same as you go from section to section. This can be useful when you have the grid turned on. If your sections are on a longitudinal slope, the sections may walk off the view as you go from section to section. Normally you will want the Fit View tick box turned on so leave it that way when finished.

Note that the various views are still linked. To see this properly, you will need to turn off unnecessary models in your Plan 1 view. In the View Button Area of Plan 1, click LB on - and click LB on RS1 Strs.

Put the cursor back in your Section CROSS view and move the cursor backwards and forwards laterally. You will see a cross in the plan view moving along the section string of the section you are currently viewing in Section CROSS.

Another way of selecting the model of strings and the first string to profile for the Profile Model on Section panel is to actually pick the string. This is what the Pick button is for on the pane.

To try it, in the Profile Model on Section panel click LB on Pick. Then move the cursor to the Perspective 2 view and click LB on any one of the cyan cross section strings. Click MB to accept the string chosen. The Section CROSS view will refresh with the chosen cross section and the model containing the selected string is written to the Model field on the panel. The Item no. and Item chainage fields will also be updated.

You can combine Prev and Next commands with Picks to move around your sections.

Click LB on Finish to terminate the Profile Model on Section panel.

13.2 Quick Model Profile for the Section View

There is also a quick method for profiling model strings.

If a string is selected for profiling using the standard Profile button in the View Button Area of the Section View, the model containing the profiled string is also recorded by the view.

Clicking LB on the Previous String and the Next String buttons in the View Button Area of the section view then profiles the previous/next string in the model in the same way as the Prev and Next buttons on the Profile Model on Section panel. The profile sections are automatically fitted to the section view but are not highlighted.
13.3 Extend the Profile in the Section View

It is possible to see more of your natural surface than is currently on display. To see how this works we will extend our view 5 metres on the left and 5 metres on the right.

In the Section CROSS View Button Area, click LB on the Menu button to bring up the View menu. Click LB on Settings ➔ Extend. The Section Profile Extend panel will pop up.

Place the cursor in the Extend Left field and type 5 and press <Enter>. Then type 5 for the Extend Right field. Click LB on Set to activate the settings. Click LB on Finish to terminate the panel.

To see the new settings in action click LB on Fit in the View Button Area. As shown below, the view now extends beyond the extremes of the section being profiled. This can be useful in checking how the new design encroaches on other existing constraints. Remember that it is possible to turn on any other models in this view and 12d will show where the strings in these models cross this particular section. We will investigate this further in the next Chapter 14 Services Interference on page 177.
Chapter 14 Services Interference

12d provides facilities that permit you to check for interference between existing constraints such as underground services and your new road design. Any underground pipes or cabling for instance can be included as strings in your overall terrain model. It is then possible to check the clearances in any of the 12d views.

14.1 Addition of Services to the Terrain

Most of the breaklines and points that we imported at the start of our design were on the natural surface, however there was also some underground features, namely two strings that represent a 250 mm water pipe and a 225mm diameter underground sewer.

These strings were mapped as super strings with an associated diameter when we import them into 12d, however they could be converted to pipe strings inside 12d.

In view Plan 1, turn on the models ALIGNMENT, survey SEWER PIPE and survey WATER PIPE.

Turn off the road strings and sections models RS1 Sects and RS1 Strs.

The blue line is the 250 mm water pipe and the brown line is the 225mm sewer.

The make things easier to see at this large scale, toggle off Text by clicking on the Toggle button and then clicking on Text [on]

To check the diameter of each string go to Strings => Inquire (or press F2) and select one of the pipe string segments. The information panel pops up, but it gives us no information about the diameter. To see the diameter information, click the RB anywhere on the screen. Walk right on the Segment menu and the diameter of the string is shown.

You can click on this or any of the other options to make changes to the string properties.
14.2 Profiling the Services

It is possible to get a quick picture of the services just imported by profiling them on a section view.

From the View Button Area in Section LONG click LB on Profile. Put the cursor over the blue pipe string in the Plan 1 view and click LB. Then click MB to accept the highlighted string. Your Section LONG view will appear as follows.

![Diagram of a longitudinal section through a pipe showing the depth below natural surface.](image)

This is a longitudinal section through the pipe showing the depth below natural surface. If we turn on the design strings, RS1 Strs, in the section view, we can instantly see that we have a problem.

![Diagram showing design strings and points on screen.](image)

The points on the screen represent the design strings at right angles to the profiled water pipe and hence we can see that the water pipe is above the road design.
14.3 View Services in Cross Section

We will now look at our underground services in cross section in the Section CROSS view.

First we need to modify our Plan 1 view to add the string we wish to select. Click LB on the + sign button in Plan 1 and turn on RS1 Sects. Then Zoom in on Plan 1 view so that we can pick cross section strings in the vicinity of where the underground services cross our new road. Zoom in on the area shown. When you zoom in far enough you will notice that the pipe strings now appear as two parallel lines i.e. they have a diameter in Plan.

We currently have the text turned off on Plan 1 so the alignment string chainages are not being displayed so we now show another method of displaying some information about the strings on a view without using String Inquire using Data Tip.

On the Snaps toolbar turn on D snap (or on the Snaps menu, turn on Data tip):

and as you hover near strings in a Plan view, a Data tool tip will be displayed showing information such as the name, model and x, y and z value of the string near the cursor.

From the Data tip we can see that the name of the section closest to where the water pipe crosses the alignment string is design 180. This means that it is the section at alignment string chainage 180.

Now we will set up Section CROSS to display the appropriate cross section and pipes.

In the View Button Area of Section CROSS, click LB on Profile and point to the cross section string in the Plan 1 view that is closest to where the cyan string crosses the road centreline. From the Data tip it can be seen to be the section design 180. Pick and accept this string.

Now add the models survey SEWER PIPE and survey WATER PIP to Section CROSS. You should
now see a small blue dot on the view at level 64. This is where the 250 mm water pipe crosses the section. Your Section CROSS view should now look as follows:

Zooming in closer the pipe is shown as

What this represents is not only where the section cuts the Water pipe but also where a parallel section a little bit to the left and the right of the section also cuts the Water pipe. This will be discussed in more detail in **14.5 Setting Corridors** on page 182.
14.4 Viewing Interference with Services in Long Section

We can also check for interference in the long section. The invert of kerb string is the lowest point in the fixed portion of our road cross section. We will now profile this string and look where the services appear in our long section to check for interference. Turn on the model RS1 Strs in view Plan 1.

From the View Button Area in Section LONG click LB on Profile. Put the cursor over the dark blue iokr string in the Plan 1 view and click LB. Unless you zoom right in, you may need to press the LB several times to cycle through the selections until you get the iokr string. Remember to keep looking in the info panel to ensure you have the correct string, then click MB to accept the highlighted string.

In the same Section LONG view, click LB on the + sign button and add the models survey SEWER PIPE and survey WATER PIPE to your view. You may see some orange and cyan dots added to the view Section LONG as it refreshes. At this scale they are very small so zoom in around the 200 x grid line and they will start to appear.

First note that the pipes appear in the section views. The reason that they appear as ovals and not circles is that we have a vertical exaggeration of 10 to 1 set on the view.
14.5 Setting Corridors

Rather than seeing just a thin slice where the pipe crosses the section, 12d has the concept of setting a corridor width along a profiled string. Then whenever you profile a string in a section view, everything that appears within the corridor width will be projected onto the view and drawn. We will set a corridor width of 20 metres either side of the string being profiled to see this more clearly.

In the Section LONG View Button Area, click LB on the Menu button to pop up the View menu. Click LB on Settings => Corridor and the Section Corridor panel will pop up. Note that the values for Width Left and Width Right are currently 0.01.

Double click the LB in the Width Left field and type 20. Press the Tab key to go down a field and type 20 for the Width Right. This has now defined a corridor 40 metres wide.

Click LB on Set and the view will be updated. Click LB on Finish to terminate the panel.

The Section LONG view should now look as follows.

Whilst it may not appear obvious, the blue string now appears in the view as a tube. This is because much of the pipe appears in the 40 metre corridor is shown in the view. Zoom in on the pipe for a closer view. Click Fit when finished Zooming.

Remember that once a corridor for a view is set, it continues to remain set until changed, regardless of which strings are subsequently profiled.
15 Modification of Design Parameters

We will now perform a typical redesign operation and see how efficiently 12d handles such tasks. We will modify the vertical geometry of our road centreline to pass over rather than through our services.

We will rearrange the views and the information on display in our views.

Minimise the views Section CROSS and Perspective 2 leaving the views Plan 1 and Section LONG. Then tile them vertically.

**Helpful Tip:** Before Tiling, click on the View that you want to be on the left hand side of the tiling. That will give that view the focus and **Tile Vertical** puts the view with the focus as the first view.

In the Plan 1 view, ensure that the ROAD 1 Sects and Strs are turned on.

In Section LONG reset the corridor to the default values of 0.01. Also set the Exaggeration to 5x. Ensure that the alignment string is profiled and that the survey SEWER PIPE and survey WATER PIPE models are turned on.

We will now profile the road centreline RS1 on the Section LONG view and also bring up the Edit SA menu for the RS1 in the one step.

On the Section LONG view, bring up the view menu and select **Utilities => VG edit**.

The **VG Edit String** panel then appears asking you to select the string to be profiled and edited. In the Plan 1 view, pick and accept select the string RS1. You may need to zoom in to make it easier to select RS1.

The **Edit SA** menu for RS1 will pop up.

Move the **Edit SA** menu to the upper left area by clicking and holding LB over the words **Edit SA**, moving the cursor and pinning it by releasing LB.

Your overall screen layout should now look something like this.
15.1 Modify Vertical Geometry

We are now ready to begin modifying the road geometry. We will raise the level of the road in the vicinity of the pipes by inserting a new VIP into the alignment. We could do this by Inserting a VIP using the cursor but it is more realistic to add it in at the same grade as already exists between VIP’s 1 and 2.

Note that this grade is displayed at top of the view Section LONG and is \(-0.681\%\).

So from the Edit SA menu click LB on Add/Remove IPs => Insert VIP Grade.

Fill in the panel as shown

We will insert a new VIP on the same grade as VIP1 to VIP 2 and at a chainage of 202.

Click on Insert then Finish once you have filled in the panel.

The Section LONG view should now look as follows

We will now insert a curve at this new VIP 3.
From the Edit SA menu press LB on the Move/Edit icon then select Change Curve.

Point to VIP 3 and click LB and confirm it with MB. A panel will pop up prompting New length. Type in the value shown.

Press <Enter> to terminate data entry. A vertical curve will appear in the view. Click LB on Fit to ensure that all information in the view is updated.

As VIP 2 is on grade between VIP 1 and VIP 3 it is not needed and hence we can delete it from the section view. Press LB on the Add/Remove IPs icon and select Delete from the toolbar, and then select VIP 2.

Note that the vertical curve on VIP2 is also removed.

The Section LONG view should now look as follows
15.2 Recalc after Modifying Vertical Geometry

We will investigate one of the most powerful features of 12d. You will remember that earlier we defined a template to be passed down our road centreline. When we filled in the template panel we gave the template function a name - we called it RS1. The purpose of that name will now be shown.

We can now refer to the template function by name and get it to reprocess the series of steps it needed to calculate the road geometry from a single menu click!

From the main menu, click LB on Utilities => Recalc => Recalc => RS1. You can also walk right on Recalc in the Recalc Panel and select the function RS1.

You will notice that 12d goes into a heavy compute operation. After a few seconds, the various plan and perspective views are all updated and now display the redesigned road. At the end of the calculation, the Apply Template panel will pop up

12d advises you of the new cut and fill volumes associated with this recalculation.

Click LB on OK to remove the panel.

If we now repeated any of the operations we did earlier such as the string drive down the road or the profiling of sections, we would be looking at the revised data. It is strongly suggested you try this in your own time to convince yourself that all of the data have in fact changed!

If you unminimise the view Section CROSS you will see that during a recalc, the view Section CROSS goes blank and is then redrawn. This because the string being profiled (design 180) is deleted and is recreated as a new string when the function RS1 is rerun. The section view senses that the original string has been deleted and finds the string with the same name in the same model and profiles it.

It is worth noting that if we had used multiple templates and restricted each template application by chainage to only part of the road, we may have needed multiple template functions to achieve our full road design. This is more typical of what happens in a real world situation. In such case, it is possible to process all template application functions in sequence with a single menu click.

You would do this from the Main menu by clicking LB on Utilities => Recalc => Recalc all or click on Recalc all in the Recalc Panel.

OR better still, use the option Design => Apply => Apply MTF which is part of the Alignment Module.

Important: Each time you perform a recalc, all of the string data that is calculated by 12d is automatically deleted and replaced by new data. This is unlike most other processes in 12d where if you repeat an operation such as importing a string or creating a string manually, you end up with multiple copies of coincident strings.

We saw above how we can modify vertical geometry and get 12d to automatically recalculate our revised road design. We can also change the horizontal geometry and get 12d to update our section view. We will now perform a series of more complex changes that are typical of the redesign steps required in a real world situation
15.3 Modifying a Vertical curve by Moving the Tangent Points

We will now look at how we can pick up points with the cursor and use the mouse to visually place curves. First **Zoom** in on the area shown in the example below.

**VCT 33**

From the Edit SA menu click LB on **Move/Edit => Move Tangent**. Place the cursor on point VCT 3 (Vertical Curve to Tangent point) as shown above and click LB. Click MB to confirm the selection. Then move the cursor to the left and right and observe what happens. Through excessive movement of the cursor it is possible to create a vertical curve that interferes with its adjoining vertical curve. Whilst 12d will permit you to make such a change, the template function will not proceed when you attempt to create the road. To ensure that the template function can work, it is essential that your vertical geometry is meaningful.

Move the cursor to the right slightly to minimise the length of tangent between adjoining curves i.e. minimise the distance from VCT 5 to VTC 6 (Vertical Tangent to Curve point). Pin the tangent point down by clicking LB. Click LB on **Fit** to fill the view.

Alternatively to get the tangent point to exactly match the chainage of VTC 6 use the Tangent Wizard option.
The curve length will change so that the two tangent points are at the same chainage. This may be either VTC 3 or VCT 3 depending on the geometry.

View Section LONG should now look similar to this.

After practising moving TP’s with the mouse, you should reset your VC length back to 150 metres. Click LB on Move/Edit => Change Curve from the Edit SA menu, click LB on the VIP you just modified and MB to confirm the selection.

Type 150 and press <Enter>. Click LB on Fit to refresh the view.
15.4 Changing Template Widths and Introducing a Table Drain

The following steps are designed to show you how to modify template values and how to introduce new links in a template. We will make a copy of your existing templates and then edit the copies to make the template changes. This way your original templates are left unchanged should you need them again.

**PERFORMING TEMPLATE CHANGES MANUALLY**

From the main menu, click LB on Design => Templates => Copy and the Template Copy panel will pop up.

In the Copy Template panel, click on the Old template icon and select the FULL LEFT template.

In the New template name field type the name FULL LEFT W TABLE DRAIN. Click LB on Copy.

Repeat the process and copy FULL RIGHT to FULL RIGHT W TABLE DRAIN. Click LB on Finish to terminate the Copy Template panel.

From the main menu, click LB on Design => Templates => Create/Edit and the Template Create/Edit panel will pop up.

In the Template name field, click on the icon and select the FULL LEFT W TABLE DRAIN template.

We will confine our changes to the Fixed part of the template. Click LB on Fixed.

The Fixed Template panel pops up. The panel displays the template links we used earlier in the tutorial (see 10.1 Creation of Basic Templates on page 149).
Type in the details for the row 6 for the table drain string iodl as shown in the example. Click LB on Draw to update the diagram.

Position the cursor over the Width entry on line 5 and click LB to lock the cursor into the field. Decrease the footpath width from 4.16 to 3.5 metres.

Press < Enter> 5 times so that a new line appears in the template, or click on the Inset row below icon.

Select OK to exit the panel.
Repeat for the fixed part of the FULL RIGHT W TABLE DRAIN template (shown below)

That completes the changes to our templates. Select **OK** to exit the panel.

Click on **Finish** to close the Template Create/Edit panel.
15.5 Recalc after Modifying the Template and Other Geometry Changes

Clearly we have now made significant design changes to the template and to the vertical geometry of the road centreline. We need to get 12d to update the views to reflect these changes. Regardless of how complex the changes are, all we have to do normally to perform a complete redesign is run the **Recalc** function.

Since we have changed the names of our templates however, we must make minor edits to our **Apply Template Function** to point to the new templates.

Before recalculating the changes, turn on the **RS 1 Sects and Strs** models in the Plan 1 view.

From the main menu, click LB on **Utilities =>Recalc =>Edit fun =>RS1**

The Apply Templates panel will pop up with the values in each field already filled in. 12d remembers the values you entered earlier. You can now make any required changes.

![Apply Template Function](image)

In the **Left template** field select the **FULL LEFT W TABLE DRAIN** template.

In the **Right template** field select the **FULL RIGHT W TABLE DRAIN**

When complete, reapply the function with the new templates by clicking LB on **Apply then Finish**

At the end of the calculation, the revised cut, fill and balance volumes appear in the message line.

This time the cut and fill volumes are smaller and more closely balanced.

Note that in the views Section CROSS and Perspective OpenGL 2 you will now see the open channel v drain running through the areas of cut. In the areas of fill, the drain will blend into the final fill slope.
Now profile the invert of kerb string on view Section LONG to confirm that the road now lies above the services.

From the View Button Area of ‘Section LONG’, click LB on Profile and LB on the iokr string from Plan 1 view. You may have to zoom to pick the right string.

![Diagram of Section LONG showing Profile and iokr strings with indication of pipes still under iokr.]

Clearly the road now lies above the services.

Finally click LB on Finish icon in the Edit SA panel. Click LB on Yes to confirm.
16 Using 12d on Typical Projects Involving Volume Cals

16.1 General Cut and Fill Calculations

12d has many features that enable accurate cut and fill calculations to be performed. The easiest way to manipulate data for volume calculations is via surfaces (i.e. TINs). For instance, a simple way to calculate the cut and fill volumes on an earthworks project is to create a TIN of the natural surface and a TIN of the finished design surface and get 12d to calculate the volume between the TINs.

We will now demonstrate how to do this with a practical example - designing a pad footing for a commercial building.

16.2 Pad Footing Design Prerequisites

Note that if you are jumping to this Chapter of the Training manual rather than working through it sequentially, the only prerequisite for this Chapter is that the tin GROUND must already exist. This TIN was created in 6.3 Triangulation on page 81. All other data related to Pad Footing design is created from scratch.

Alternatively, you can import the 12da ascii file Chapter_16.12da which contains all the models, strings and tins created to date.

16.3 Pad footing Design using the Interface Function

The Interface function is the simplest form of geometry construction within 12d Model. Generally, it is applicable whenever the batter lines are at a constant slope from top to bottom (no benching) and the constant slope applies in all directions (i.e. a constant batter slope at right angles to the alignment string).

We will use a super alignment for our pad footing

We will generate this alignment in order 1, 2, 3, … 6.

The alignment will be a closed alignment so once the IP at position 6 has been created the string will automatically join back to position 1.
From the Main menu, click LB on Strings =>Super Alignments =>Create super alignment. The Create Super Alignment panel will appear.

Select the General node

Type in the name PAD1 and the model name PAD ALIGNMENT

Select colour yellow

Select Label node

Select no labels for Label style

Select Closure node
Click on Create and the Edit SA toolbar will appear.

Tick check box **Close string** to create a close the string

Select **Append HIP**

The message at the bottom of the screen is

```
<Pick start IP location> [picks][fast][Menu]
```

Type in the start point coordinate **42560 36970** then press **<Enter>** (the Enter X Y Z box comes up when you press 4)

```
Enter X Y Z : 42560 36970
```

The first HIP point is then created and the message at the bottom of the screen is then

```
<Pick IP location or (r)elative, (d)isplacement/dist [picks][fast][Menu]
```
We are now going to create the rest of the lines of the pad using **Bearing** and **Distance** rather than picking points or typing in coordinate values.

First type `b` to put the editor into bearing distance mode

The bottom left of the screen prompts for a bearing

Type in the bearing **90** \(<Enter>\) (the **Typed Input** box comes up when you press 9)

The bottom left of the screen then prompts for the distance

Type in distance value of **50** then press **<Enter>** (the **Typed Input** box comes up when you press 555)

The second HIP is then created and the select reverts to cursor pick again.

The message at the bottom of the screen is then

We will continue typing in **Bearing** and **Distances** to go round the pad.

To type in another bearing and distance in we type `b` again and then **180** \(<Enter>\) followed by **15** \(<Enter>\)

Then type in the following values of **Bearing Distance** values to finish the pad
Press <Escape> after placing the sixth HIP to terminate the addition of HIPs (or click RB to bring up the Pick Ops menu and select Cancel from it).

To see the string you just created zoom in on the pad footing area as shown below.

We now need to define the height of the pad. Firstly we need to get an idea of an approximate Z value to be used for our pad footing elevation.
From the main menu click LB on **Tins => Inquire => Height**

Click LB on the icon for the **Tin** field and click LB on **GROUND** from the pop up list.

Now place the cursor in the Plan 1 view inside the pad footing and note that the Z values on the tin range from about 63 to 67.

To roughly balance cut and fill let us make an initial guess to set the pad footing at height Z=64.

Click LB on **Finish** to terminate the **Tin Height Inquire** panel.

We now need to give the alignment the height of **64**. This is done in the **Section view LONG**.

Profile the alignment string in the **Section view LONG**.

Click LB on the **Append VIP** icon in the **Edit SA** panel.
Over the Section view LONG, type in 0 64. This will bring up the Enter Ch Ht panel with the values in it. Press <Enter>.
Then press <Escape> to finish the VIP entry. Because the alignment is closed, just the one VIP will suffice to define the height 64 for the entire string.
Select Finish on the Edit SA panel.

To see how the pad footing aligns with the natural surface, click LB on the + sign button in the Plan 1 view and double click LB on tin GROUND. From the View menu for Plan 1, click LB on Toggle =>Tin contours. Your view should now look as follows.

Let us assume that it is important to have side 1-2 aligned as closely as possible with the natural surface contours.
To achieve this we will rotate our pad footing clockwise by 40 degrees about point 2 (top right corner) so that side 1-2 is close to parallel with the natural surface contours in the vicinity of point 2.

Select String =>Super alignments =>Tools =>Rotate.
Or if you turn on the Super Alignment Tools toolbar, Rotate can be selected from there.

In either case, the Rotate Super Alignment panel is displayed.
Your **PAD1** string should now appear rotated.

Your revised Plan 1 view should look as follows.

We will now translate the PAD1 string +20m in the X direction and -30m in the Y direction to get our pad footing away from the valley and more onto the ridge of the natural surface contours.

Select **String** =>**Super alignments** =>**Tools** =>**Translate**. Or select Translate from the **Super Alignment Tools** toolbar.

In either case, the **Translate Super Alignment** panel is displayed.

Click LB on the **Super alignment** pick icon and then select the **PAD1** string from the view.

Click LB on the **Rotation Centre** icon and select point 2.

Type in the rotation angle to -40 degrees clockwise.

Click LB on **Rotate** to activate the rotation.

Click LB on **Finish** to terminate the panel.

Delete the previous alignment using option **Strings =>Delete**.

Click LB on the **Super alignment** pick icon and then select the **PAD1** string from the view.

Type in 20 for the **Delta x** and -30 for the **Delta y**.

Click LB on **Translate** to activate the translation.

Click LB on **Finish** to terminate the panel.

Delete the previous alignment using option **Strings =>Delete**.
Your **PAD1** string should now have moved downwards and to the right.

Move your cursor over the Section view LONG and you will notice that the view automatically re-profiles for the new string **PAD1**.

This is because the previous two options have created new alignments and the string originally profiled on the section view had been deleted. But even through the original string no longer exists, the section view remembers the model and name of the profiled string and when the cursor is moved over the view, another string of the same name and model is automatically searched for and profiled.
We can now have our first trial run to see how well our pad footing fits in with the existing natural surface. Firstly we will set up the default corner angle for sections to be created at corners

From the Main menu, click LB on **Project** => **Management** => **Defaults**

From the Main menu, click LB on **Design** => **Apply** => **Interface**

The **Interface Function** panel appears.

Change the **Corner angle** to 15

Click LB on **Set** then **Finish**

From the Main menu, click LB on **Design** => **Apply** => **Interface**

We need to give our interface function a name so that we can refer to it later. Type in the name **PAD1**.

Select the alignment string as the **String Interface**

The default **Section separation** is 10 metres. Set this to 2 metres.

As our pad PAD1 string has been generated in a clockwise manner (from starting point 1 to 2 to 3 etc.), we are looking to calculate the intersection of our batter lines with the **GROUND** tin on the left of the string (left as we proceed in a positive direction along the string. Positive direction is always in the direction of increasing chainage).

Click LB on the **Tin** button and double click LB on **GROUND** from the popup list.

Finally supply the name **PAD1 INT** to the **Model for interface** field. The interface string corresponding to where our batter lines meet the **GROUND** tin are placed in model **PAD1 INT**. (Optional) Slope lines are placed in model **PAD1 SECTIONS**.

Tick on **Remove loops**.

Then press the **Interface** button to generate the Interface string.

After a short delay, the panel message box advises ‘finished interface’. Click LB on **Finish** to terminate the panel.
Chapter 16 Using 12d on Typical Projects Involving Volume Cals

We will now observe a very powerful design feature of 12d Model. We will make some major changes to our pad footing and see how quickly 12d can redo its calculations with a minimum of effort.

First, we will change the shape of our pad string. Remember that we rotated our pad footing 40 degrees. We will now change point 4 by moving it 10m towards point 3. Because of the rotation, line 4-3 is at a bearing of 130 degrees.

Go back into the Super alignment editor

To see the interface that has been calculated, click LB on the + sign button in the Plan 1 view to pop up a list of models. Double click LB on models PAD1 INT and PAD1 SECTIONS.

We will now observe a very powerful design feature of 12d Model. We will make some major changes to our pad footing and see how quickly 12d can redo its calculations with a minimum of effort.

First, we will change the shape of our pad string. Remember that we rotated our pad footing 40 degrees. We will now change point 4 by moving it 10m towards point 3. Because of the rotation, line 4-3 is at a bearing of 130 degrees.

Go back into the Super alignment editor

Click LB on the Extend by Length icon
Pick near IP at position 4 but on the straight leading from position.
The Typed Input panel for Length comes up.

Type in -10 <Enter>
Finish the alignment Editor
The Interface function can now be recalculated by selecting Utilities =>Recalc =>Recalc =>PAD1.
12d will now recalculate the pad interface using the same properties set in the Interface Function panel previously.

As the Horizontal Geometry of PAD1 was modified, the profile through the tin was automatically updated in view Section LONG. And although we didn’t have Vertical synch turned on for PAD1, because the VG was a constant z-value for the entire HG, the VG is still in the correct position. If for some reason the modified HG and VG appeared incorrect, the profile can be updated in the Section LONG view by simply clicking LB on the Regen icon.
16.4 Volume Calculations from Surfaces Created with the Interface Function.

Now that we have batter, pad and interface strings, it is a simple matter to create a TIN of our finished design surface and perform volume calculations.

16.5 Creating a TIN of the Finished Quick Pad Footing Surface

Rather than specifying a list of models, we are going to use the data on a view to create the triangulation. That way we can visually check that we have the correct models.

To ensure that only the correct strings are used in the creation of our finished TIN, we will first take all the models off the view and then selectively add the appropriate pad footing strings and sections models to the view.

The fastest way to do this is to click LB on the Menu button in the View Button Area of the Plan 1 view to popup the View menu and click LB on Models => Remove all models. Then place the cursor over the + sign button in the Plan 1 view and double click LB on PAD ALIGNMENT, PAD1 INT and PAD SECTIONS.

Since these are the only models on display in View Plan 1, we can confidently build our TIN by triangulating the view.

From the main menu, click LB on Tins => Create => Triangulate data

Give the triangulation the function name TIN PAD1

Position the cursor in the New tin name field and type in PAD1 and press <Enter>. This name will also be used to fill in the Model for tin field but with the prefix "tin ".

Click LB on the colour icon and select orange.

Click on the Data tab and set the Data to triangulate to View 1.

Click on the Nulling tab. To ensure that the pad TIN is restricted to within the bounds of the interface string defining where our pad footing intercepts the natural surface, click LB on the Null polygon button and select with LB the red-green closed interface string surrounding the pad footing.

Make sure that the string you select has the correct string name PAD1->interface and is of type Interface.
as shown in the Nulling tab. If necessary, keep clicking LB until you get this string. Once you have it, click MB to confirm the selection.

Then click LB on **Triangulate** to create the TIN.

The triangulation will occur and the **Triangulate a Data Source** panel replaced by the **Retriangulate Tin** panel for Tin PAD1 in case you want to modify any of the parameters. Select **Finish** to remove the panel.

To display the TIN, click LB on the + sign button in the Plan 1 view and double click LB on **tin PAD1** from the pop up list.

The TIN on the view will currently be displayed with contours and not triangles

To see the triangles, click on the toggle icon and turn off **Tin contours**.

The finished TIN should appear as shown below.

---

### 16.6 Volume Calculations Between Surfaces

Now that we now have two tins, **GROUND** and **PAD1**, we can get 12d to calculate the volume between the TIN surfaces. 12d provides two methods of calculating such volumes:

**End Area:** Here parallel sections are taken at a constant user defined angle from the X axis (angles are measured anticlockwise from the X axis) with sections a user defined distance apart. When calculating end area volumes, the quality of the answer is highly dependant on the values chosen for the angle of the sections and the distance between sections.

**Exact:** In this method exact volumes are calculated by summing the volumes of the various prisms between the triangulated surfaces. This method is exact in that it is as accurate as the TINs themselves. Depending upon the overlap between triangles in each TIN, each triangle may be split up into multiple prisms. All prisms are accounted for hence the term **exact**.

We will use both methods and compare any differences.
### 16.7 End Area Volume Calculations

To enable string selection to be easier, first turn off the tin of the PAD. So click LB on the - sign button in the Plan 1 view and double click LB on tin PAD from the pop up list.

To calculate volumes between TINs using end areas, from the Main menu, click LB on Design =>Volumes =>End Area =>Tin to tin

A closed polygon can be defined to restrict the extents where the calculations will be performed. If a string is selected that is not closed then the first and last points of the string are automatically joined to form a closed polygon.

We can use the interface polygon for this purpose i.e. use the string which is the intersection of the pad footing with the existing ground. Click LB on the select icon at the end of the Poly field then select the red-green interface polygon in the Plan 1 view.

By entering a name in the Report file field, a report can be created showing the details of the end area volumes. Enter PAD1 VOLUMES and press <Enter>. The suffix ".rpt" is appended by 12d. Set the report mode to summary as we don’t need to see the volumes for each section. This would only be used if an alignment is used for the section creation.

Click LB on Volume to cause the end area volumes to be calculated.

If a name is entered in the Report file field, 12d will immediately jump to the Editor and display the report:

**File <PAD1 VOLUMES.rpt> will be created**

A closed polygon can be defined to restrict the extents where the calculations will be performed. If a string is selected that is not closed then the first and last points of the string are automatically joined to form a closed polygon.

### Fill the panel in as shown. Place the cursor on the tin icon for the Original tin field and click LB to popup a list of the available TINs. Double click LB on GROUND. Repeat the process for New tin and set it to PAD1

Leave the angle for sections at 90 degrees. This will make the sections at 90 degrees to the X axis i.e. parallel to the Y axis.

Set the Distance between sections to 2 as this is a relatively small site.

Enter three new model names - xs ground, xs pad1 and xs diff for Original, New and Difference sections respectively. The cross sections corresponding to each of these profiles will then be stored. Entering a name in the Difference model causes a series of sections to be created that correspond to the depth differences between the Original and Final cross sections. Note that all these model fields are optional.

Set the Difference colour to magenta.

Tick the checkbox for Clean section models beforehand to clean out the section models before running the option.
Click LB on File => Exit to terminate the Editor and return to 12d.

Note that once the calculation is finished, the Cut, Fill and Balance volumes are displayed in the Panel’s message line.

Click LB on Finish to terminate the End Area Volumes Between Tins panel.

NOTE: We used a polygon for the End Area volumes but a polygon does not have to be used. If no polygon is used then the volume calculations are restricted to the regions where both TINS exist.

It is possible to view the sections that were calculated during the end area calculations and it is always a good quality check to see that the sections look reasonable both in plan and section.

From the View Button Area of the Plan 1 view, click LB on the + sign button and turn on model xs ground.

Note that the various cross section strings display in green.

We can now profile any of these cross section strings. We will use view Section CROSS for this purpose.
From the View Button Area for the Section CROSS view, click LB on Profile and then click LB on the string top sect 23 in view Plan 1. Click MB to confirm the selection. Add the model tin PAD1 to the view so you can see the section through the tin of the pad.

Toggle off the Grades and set the vertical exaggeration to 5. Use the menu on view Section LONG to select the option Settings => Grid and change Grid y value to 1.

The following view shows the profile of cross section 23 and its section through tin PAD1.

The tin GROUND is also on the view Section LONG but you won’t see it because the sections in the model xs ground should be exactly on the tin GROUND.

If the model xs pad1 is also added to the view Section LONG, the section in xs pad 1 at chainage 23 will also be drawn because it will be in the corridor around the profiled string 23 in the model xs ground. This string will also not be seen because it is on the tin PAD1 however you will see crosses where the vertices of the string are.

By clicking on the Next and Previous buttons on the view Section LONG, you can look at the sections from xs ground and xs pad1 and quickly see that they all lie on the appropriate tin.

Note that for the End Area calculation, the cut and fill area for a section are the cut and fill areas between the two sections shown in the section view. For this section, it is all in cut.

From the report there is not much fill so we will move the pad up to reduce the difference between cut and fill (the balance). Then we will show how the Exact volumes calculations are done on the same pad.
16.8 Modifying Pad an Redoing End Area Volume Calculations

We will now move the pad up to reduce the amount of cut and achieve a better cut to fill balance. But moving the pad will require a number of options to be repeated. They are:

1. Raise the Alignment PAD1
2. Run the Interface function
3. Retriangulate the tin PAD1 using the new Alignment, Interface string and sections
4. Calculate the end area volume between the new tin PAD1 and tin GROUND.

Step 1: Raise the Pad

First profile and edit string PAD1 by selecting Section LONG menu Utilities =>VG edit and then selecting PAD1. Or if PAD1 is already profiled on the Section Long then edit the string PAD1 by pressing F6, or select Strings =>Editor on the Main menu, to bring up the Edit String panel. Then pick the string PAD1 from the view Plan 1.

The see the z-values more clearly on Section LONG, bring up the Grid panel by the Section LONG menu option Setting =>Grid and set Grid y to 1.

In the Super alignment editor for PAD1, select the icon Change Height.

Then in the view Section LONG, select anywhere on the vertical geometry of PAD1.

The Height Typed Input panel will then come up with the current height of 64.

Type in 65 and press <Enter>

The height of PAD1 will then change to 65.
Step 2: Run the Interface Function

Because the creation of the Interface and the sections was a function, it only needs to be Recalced and the new Interface and Sections will be created for the modified alignment PAD1.
So walk right on Recalc =>Recalc and double click on the function name PAD1.

The new Interface and sections are created.

Step 3: Retriangulate the tin PAD1

Creating the tin PAD1 was also done as the function TIN PAD1 and although the strings in the models have changed, the new tin will be made up of exactly the same models as before. So recalcing TIN PAD1 will update the tin PAD1.
So walk right on Recalc =>Recalc and double click on the function name TIN PAD1.
Step 4: Calculate the New End Area Volume

The End Area Volume Between Tins panel is not a function and so will need to be brought up, filled in again and run again.

So select Design => Volumes => End Area => Tin to tin to bring up the End Area Volume Between Tins panel.

So select Design => Volumes => End Area => Tin to tin to bring up the End Area Volume Between Tins panel again.

Fill in all the fields as before.

Notice that we ticked on Clean section models beforehand. This is important now that we are rerunning the option because it means the section models are cleaned from the first run before the rerun.

Once the panel is filled in, select Volume and the new volumes will be calculated.

Because the Report file already exists, you are asked whether you want to Append to the existing file or Replace it. Select Append.
The **Cut, Fill** and **Balance** volumes displayed in the Panel’s message line and the report are now:

Note that the cut and fill now differ by **547** cubic metres but this time there is more fill than cut. Click LB on **Finish** to terminate the **End Area Volumes Between Tins** panel and close the report file editor.

If you move the cursor over the view **Section CROSS** the new **top sect 23** string will be automatically profiled.

Notice that some of the section is now in cut and some is in fill.
16.9 Chains

Although the four steps to recalculate the volumes don’t take too long to go through, it would save time and errors if the process could be automated, especially the volume calculation which is not a function.

To make things easy, 12d has the concept of Chains. Chains allow you to define a series of 12d options that can be automatically run one after. Chains can recalc function, and also record and run most 12d options.

So to automate the volume calculations, after we have modified the alignment PAD1 (Step 1), we need the chain to:

2. Run the Interface function
3. Retriangulate the tin PAD1 using the new Alignment, Interface string and sections
4. Calculate the end area volume between the new tin PAD1 and tin GROUND.

To create a Chain, select Utilities => Chains => Create from the Main menu to bring up the Create/Edit Chain panel.

Fill in the name of the Chain file as:
PAD1 End Area Volumes
and then press Write.

The file ending ".chain" well be appended to the name and a Chain file created.

We will now add the recalcing of the functions PAD1 and TIN PAD1.

First click on the Insert icon to add a new Chain command

Click on the icon at the end of the Type field and expand the + in front of Execution and then double click on Function from the Select Choice pop up.
Click on the icon at the end of the **Function** field and then double click on **PAD1** from the **Select Function** pop up.

Click on **Write**

A **Chain File** panel warning you that the chain already exist is displayed.

Click on **Replace**

The chain now includes Step 2 - run the Interface Function:

We will now repeat the process but this time select the Function TIN PAD1.

Click on **Insert**.

For the **Function** field select **TIN PAD1**.

Click on **Write**.

When the Chain File warning appears, click on **Replace**.

The chain now includes Steps 2 and 3.

The **Volumes** option is not a function so to add it to the Chain, we **Record** it.

To Record, we simply click on the **Record** icon and the Create/Edit Chain panel is temporarily removed and the **Chain Recorder** toolbar appears.

12d options can now be run and they are automatically added to the Chain until the **Stop** icon is pressed.
So again select 
**Design => Volumes => End Area => Tin to tin**
to bring up the **End Area Volume Between Tins** panel.

Fill in all the fields as before.

Once the panel is filled in, select **Volume** and the new volumes will be calculated. Click on Finish to remove the panel.

Then click on the **Stop** recording icon and the **Create/Edit Chain** panel will reappear with the recorded options in it.

Click on **Write**.

When the Chain File warning appears, click on **Replace**.

The chain now includes Steps 2, 3 and 4.

Click on **Finish** to remove the **Create/Edit Chain** panel.
To use the Chain, first use the **SA Editor Change Height** command to change the height of the VIP for PAD1 to say 64.5.

Then run the chain by walking right on **Recalc => Run chain** and double clicking on the chain name **PAD1 End Area Volumes.chain**

The chain then runs repeating Steps 2, 3 and 4 for the pad with height 64.5

Looking at the report, the balance is now down to 352.349.

```
BEGIN TIN-TIN VOLUME REPORT

surface to surface volume report - (with plan polygon "PAD1 INT->interface")

original tin GROUND
new tin PAD1
separation 2.000
angle 90°00'00"
methed Average end area
extrapolated no

cut volumes and areas are negative
fill volumes and areas are positive

total plan area 1791.593

total cut -750.080

total fill 397.682

ie excess of cut over fill 352.349

END TIN-TIN VOLUME REPORT
```
16.10 Exact Volume Calculations

Now go back to the Plan 1 view and remove any extra models so that only the models PAD ALIGNMENT, PAD1 INT and PAD1 SECTIONS are on the view. Click LB on Fit to fill the view.

To calculate exact volumes between TINs, from the Main menu, click LB on Design=>Volumes=>Exact=>Tin to tin.

Fill the panel in as shown. Place the cursor on the tin icon for the Original tin field and click LB to popup a list of the available TINs. Double click LB on GROUND. Repeat the process for New tin and set it to PAD1.

By entering a name in the Report file field, a report can be created showing the details of the end area calculations. Type in the name PAD1 EXACT VOLUMES.rpt.

Click LB on the Poly icon and then select String icon. Select the red-green interface polygon in the Plan 1 view with LB. Confirm the selection with MB.

The report will be calculated and immediately display. The following is a typical report:

```
Project: STAGE 1
User: 1ig
Organization: 12b Solutions - Lee
Date: MON Nov 24 03:18:17 2014
Report File: PAD1 EXACT VOLUMES.rpt

Volumes from tin "GROUND" to tin "PAD1" - (with plan polygon "interface")

    cut volumes are negative
    fill volumes are positive

Total cut      -750.898
Total fill     397.776
Total balance  -353.122
10 excess of cut over fill  353.122
Polygon plan area = 1791.593
```

Note the cut, fill and balance volumes are also display in the message area of the Exact Volumes Between Tins panel.
Click LB on **Finish** to terminate the panel.

We used a polygon for the exact volumes but like the End Area volumes, a polygon does not have to be used. If no polygon is used then the volume calculations are restricted to the regions where both TINS exist.
16.11 Comparison of End Area Verses Exact Volume Calculations

In the above examples where the height of the pad was 64.5, the end area calculation for balance of volumes was \(-352.349\) verses \(-353.122\) for the exact calculation, a negligible difference.

On a large site, you may notice a significant discrepancy between your answers from both these methods. In such case, try performing your end area calculations with a smaller Distance between sections. Also try to orientate your sections at right angles to the major direction of cut/fill movement. These steps will minimise errors inherent in the end area method.

It is possible to perform end area calculations such that all sections are at right angles to an arbitrary string, just as you would with template generated sections in normal road design. See Design => Volumes => End Area => String Tin to Tin for how to do this.

Apart from being a double check on the calculated volumes, the End Area and Exact also provide different types of information.

The End Area calculations are the more important if you required section by section volumes such as used in mass haul calculations.

The Exact calculations can provide volumes split up by depth ranges between the two tins used in say isopach analysis.

16.12 Sign Conventions for Cut and Fill

The entire tutorial on volume calculations so far has been performed assuming the convention that Cut volumes are negative and Fill volumes are positive. However this is a user definable convention. If preferred, Cut volumes can be made positive and Fill volumes negative in the Defaults panel.

This convention is set in the Defaults panel which is on the Main menu at Project => Management => Defaults

The field Cut volume sign near the bottom of the panel defines the sign for the Cut volumes, and the sign for the Fill volumes is the opposite.

Place the cursor on the choice icon for the Cut volume sign field and click LB to pop up a list of alternatives. Click LB on either positive or negative. At this time, leave the value negative.

Click LB on Set to activate any changes.

Click LB on Finish to terminate the panel.
16.13 Advanced - Difference Sections

This section will explain what the Difference model is that was generated by the End Area Volume Between Tins panel.

The difference sections are the depths from the Original tin to the New tin. That is, the value on the difference section is:

\[ Z_{\text{diff}} = (\text{Z-value of original tin}) - (\text{Z-value of new tin}). \]

We will now look at a section though the New tin, the Original tin and the corresponding difference section.

The difference sections can not easily be displayed on the same Section view as the sections between the tins because the Z-values through the tins are around 60 to 70 and the Z-values for the difference sections are between -1 and 1.

So we will display the sections through the tins on one Section view and the corresponding difference section on a different Section view.
On the view Section CROSS organise things so that only the models \texttt{tin GROUND}, \texttt{tin PAD1} and \texttt{xs PAD1} are added to it: Then profile the string \texttt{top sect 23} from the model \texttt{xs ground}.

Create a new section view and profile the string \texttt{diff sect 23} from the model \texttt{xs diff} on it. To find the string \texttt{diff sect 23} it is probably easiest to create a new Plan view, add the model \texttt{xs diff} and then select the string \texttt{diff sect 23} on the new Plan view. The plan position of the string will be exactly the same as the string \texttt{top sect 23} on Plan 1.

Looking the magenta string you will easily see that the z-value a each chainage along the section is the depth between the GROUND tin and the PAD1 tin at that chainage.

That is the difference section is a schematic where a positive Z ordinate represents cut and a negative Z ordinate represents fill. The datum for change from cut to fill is at Z=0.
17  Plotting

THE REWRITE OF THIS CHAPTER FOR V11 HAS NOT YET BEEN FINISHED
The rewrite currently stops at 17.16 The Rewrite for V11 Stops Here on page 284.

17.1 Overview

This chapter is arranged so that relevant sections appear in blocks for easy reference.

The layout of this chapter is as follows:

  17.14 Plotting sheets of Long sections on page 248, relates to long section plotting.
  17.15 Plotting Sheets of Cross Sections on page 272, relates to cross section plotting.

For user convenience, each plotting section is self contained (requiring some duplication).

The data used for the plotting has been built up by working through the Getting Started manual. If you have not worked through the Getting Started Manual to this point then, you can import the 12da file Chapter_17.12da, which will bring you up to this point. This is in the folder

C:\12d\11.00\Training\design\getting started basic

You also need to copy the file

C:\12d\11.00\Training\design\getting started basic\RS1 Vol.rpt

into the working folder for your project.
17.2 Triangulating the Road

In order to calculate the volumes and display the quantities in the long section plots we need to create a tin of the surface of the road which is made up of the data in the models RS1 Sect and RS1 Strs.

To create the tin, use the option Tins => Create => Triangulate data

Fill in the Retriangulate function with TIN DESIGN and the New tin name as DESIGN followed by <Enter>.

The model for tin will then be automatically filled in as tin DESIGN.

Set the Tin colour to magenta.

To select the data to triangulate and create the tin, we can either

(a) add the models we wish to include in the tin onto a View and select the View as the Data to triangulate,

or

(b) we could use the Models icons and list the models.

We will use the View method so that we can quickly see that the data to triangulate is the correct data.

So remove all the models from the view Plan 1 and then add just the models RS1 Sects and RS1 Strs.

So on the Data tab, select the View icon

and then either type in 1 in the View field, or select 1 from its pop up, or click MB in the View field and select a string in Plan View 1.
On the **Nulling** tab, we could use the polygon that encases the road in the **RS1 Polys** model as the **Null polygon**. Or alternatively we can set the **Length** field to 1 and 12d Model will null out all the triangles with an external side longer than 1 (that should be all the triangles outside the interface strings).

So tick on **Apply nulling** and type 1 into **Length**.

Click on **Triangulate**.

The data is triangulated and the **Retriangulate a Tin** panel displayed in case you wish to make any changes. Click on **Finish** to close the panel.

Add the model **tin DESIGN** onto the View 1 to check the result of the triangulation.

**PRACTISE VERSION:** To keep the number of points below 5,000, the road data has been created with sections at a 50m interval rather than 5m. This means that the pictures are not exactly as they appear in the manual when running with the Practise version.
17.3 Plot devices

12d can generate plots to various devices. Firstly, it supports a full interface to Windows so it can create plots on any device that is supported by Microsoft Windows.

12d also supports various popular plotting devices in their native format so it can plot directly to Hewlett Packard pen, inkjet and laserjet printers/plotters, although today, most plotter are driven as a Windows plotter. 12d supports Postscript, HPGL2 and PCL5 plotters directly and plotters that emulate these devices.

We also talk about the concept of **plotting to CAD** where we treat CAD as just another plot device. This process generates a native CAD file which can subsequently be read in by your CAD system, manipulated further if required and then plotted from your CAD system. However please note that when plotting there is an origin of (0,0) in the bottom left hand corner and the units are in millimetres. As such a plot, we can plot to AutoCAD (DWG, DXF or DXB) or Microstation (DGN).

There is **plotting to a model**. This is a technique for previewing a plot. See 17.10 Previewing Plots on page 231, for more information on previewing plots.

There is **plotting to a pdf file**. In this case a physical plot is not generated but a pdf file. PDF has become an industry standard and many companies no longer produce physical plots and only pdfs. PDF’s are also a good technique for previewing a plot.

The list on the right shows the default set of **Plotter types** shipped with 12d Model. To keep the pop-up list a reasonable length, the plotter choices have been grouped together but clicking on a + will expand any of the groups allowing an individual plotter to be selected.

The popup list of plotter types is customisable so the list can include line items such as "Mary’s inkjet – 2nd floor". You can remove plotter types that are irrelevant to your organisation.

There is extra information that can be set for a user defined plotter such a colour mapping files and pen thickness files. All of this customisation of the available plotter types is implemented via the **plotters.4d** file which is documented in the 12d Reference manual in the chapter **Plotters and Plotting**.
### 17.4 Plot Parameters

The appearance of most of the plots generated by 12d Model is user definable.

There are simple plots such as plotting what you see on a 12d Model view but most users need to generate special plots such as a road longsection, or pages of cross section plots, or a drainage plan plots.

For these special plots there are a large number of plot parameters that govern what is included on the plot and how it appears. These parameters are stored in plot parameter files, known as ppf files for short.

Each parameter has a default value so that even if you perform a plot without supplying a ppf, you will still get a plot.

Part of the configuration of 12d is deciding which parameters you require to achieve your drawing standard. Once the standard is achieved you can save the parameters away in a ppf with the name of your choosing so that you can use the same ppf files from job to job with minimal or no changes. One advantage of this approach is that regardless of the skills of the operator, a common presentation standard of plotted documentation is achieved.

The training data gives you samples of typical ppf’s to achieve common engineering standards for plan, long and cross section plots. It is recommended that users new to 12d take a copy of these and use them as a starting point for their own customisation.

### 17.5 Plotting Text from a Plan View

Whilst some plotting of a Plan View is WYSIWYG (What you see is what you get), the millimetre size of the text on a plot will depend on the units that the text is defined in. That is, if it is defined as World, Screen or Paper units.

For text that is defined in World units, the size is defined when displayed on any plan view and when in a plot, the Scale of the plot determines the size of the text in the plot.

Text that is defined in Screen (device) units is defined in pixels so that is has a fixed size on a Plan view, regardless of how much you zoom in or out on the view. However there is no corresponding size on a plot. For some Screen text, there are separate sizes that are used when the text appears on a plot. For example for the text labelling the grid lines on a view, there is not only a size in pixels but also a size in millimetres that is used whenever the grid is plotted.

For text defined in Screen units that has no plot parameter defining it’s plotted size, there is an overall Factor that the screen size is multiplied by to give a millimetre size on a plot. This Factor is set by

**Plot => Plotting setups => Pixels to mm**

which brings up the panel

![Pixels to Millimetres Plot Factor](image)

A value of 0.5 means that screen text that is 10 pixels high will plot at 5 mm high.

The default value is 0.5 but you can set this to whatever value you require.

Text that is defined in Paper units already has a millimetre size and that is the size it will be on the plot regardless of the Scale of the plot.

However unlike text defined in World or Screen units, for Paper units there is no way of determining what size it should appear on a Plan view. So each Plan view has a Plan Plotting Scale with a default value of 1000 and this is used to convert the millimetre size to a world size for displaying on that Plan view.

If the Plan Plotting Scale for a view is the same as the Scale used when plotting a view, then the text will appear at the same size on the view as on the proposed plot.
Note however that the **Plan Plotting Scale** can be set to a different value for each Plan view so the Paper text can be a different size on each Plan view.

To set the plot scale for Plan view, select the Menu icon on the relevant Plan view and then select

**Settings** ⇒ **Plotting scale**

to bring up the panel

![Plan Plotting Scale](image)

Type the required plot scale into the field **Scale** and then press **Set**.

### 17.6 Text Fonts

12d Model supports Windows True Type fonts and most AutoCAD .shp files as well. The standard install supplies you with sufficient fonts to get started – typically ISO, ISOEQ, GOTHIC, HELV, HELVL, MONO, ITALICC, SCRIPT, ROMANC and ROMANS. See the 12d Model Reference manual or context sensitive help for more information on the files **textstyl.4d** and **fonts.4d**.

### 17.7 Mapping Line Colours to Pen Thickness

In the days of pen plotters, the plotter contained pens of different colours and line thicknesses and these were used to create the plot.

Today with plot devices such as raster plotters, inkjet printers and pdf files, there is almost an unlimited choice of colours and line thicknesses.

When plotting from 12d to such plot devices, it is possible to map 12d colours to user defined line (pen) thickness or weight in millimetres. It is also possible to easily override the default weight for a particular string.

### 17.8 Plot Files and Queues

In general, whenever 12d creates a finished plot file for a hard copy device, it will only place the file in the local working folder (one level up from the .project folder). The exception to this is when plotting to the Microsoft Windows interface. In such case Windows takes over the control of the file and sends it to the device automatically.

Thus in general, plot files are not automatically submitted to any plot queue. It is the users responsibility to then place the plot in an appropriate queue, decide when it will be plotted, decide on the number of copies etc.

It is possible to have Windows run a background batch file that will automatically place any plot files in a plot queue.

Similarly, when the plot device is a PDF file or CAD system, the PDF or CAD file will be written to the local working folder. After writing the PDF/CAD file, the user can then use PDF viewer or their CAD system to examine the file.

### 17.9 Windows Based Plotting

In the list of **plotter types** shown in [17.3 Plot devices on page 228](#), there is **windows and windows_mono**. These devices interface directly with Microsoft Windows. This allows you to plot direct to any Windows device on the network. All plot queue issues are handled direct by Windows. The plot file
is deleted at the end of the plot.

17.10 Previewing Plots

To save wasting paper when producing actual paper plots, we strongly recommend that all such plots be previewed before producing the plot on paper.

We can do this in two ways - by plotting to a PDF file or by plotting to a model.

17.10.1 Plotting to a PDF File

We plot to a PDF file by selecting any of the Plotter Type that produce a PDF file. For example `pdf_12d` or `PDF black`.

17.10.2 Plotting to a Model

When the plotter type `model` is selected, an actual 12d model is created instead of a file. This model is stored in the normal 12d database just like any other string data.

A physical plot is a simple 2D drawing in the X-Y plane with (0,0) in the bottom left hand corner, and the plot itself in the positive quadrant. The industry standard for units in a plot are millimetres.

So for convenience, when `12d Model` plots to a model, the sizes are multiplied by a thousand. So an A4 Landscape plot will be 280 units wide by 210 units high. That way, when the model of a plot is added to a Plan view, the units can be read as though they are millimetres. No matter how any text was defined (screen, paper or world), when it is plotted it is converted to millimetres so when it is plotted to a model, it is created as world text with the final millimetre size multiplied by a 1000.

Because of the multiplication by 1000, it is important that you turn all other models off when previewing models of plots in a Plan view. If you don’t, your plot may well be mixed in with real world coordinate data. This will make the plot appear very small and probably in the extreme lower left corner of your screen, near the origin (0,0).

A major reason for plotting to a model is that it is then possible to make changes to the model of the plot
and then do a ‘plot of a plot’. For example when you want to make minor changes to a long section plot by adding some new line work or new text.

In that case it is important to remember that the plot in the model has the size multiplied by 1000 and so if you add line work, you need to think in units of millimetres rather than metres. For example, you would create text 5 high so it would be the same as 5 mm on the finished sheet.

**Important Note:**
After making changes to a model of a plot and it is time to create a ‘plot of the plot’, you must use a Scale of **1:1000** so that the ‘plot of the plot’ of the plot comes out in millimetres.
17.11 Overview of Plotting
We will look at six of the many types of plots available.
1. Quick Plan plots - see 17.12 Quick plots on page 233.
2. Quick Section plots - see 17.12.1 Quick Plan Plots on page 233.
3. Quick Perspective plots - see 17.12.3 Quick Perspective OpenGL Plots on page 244.
5. Sheets of Cross Sections - see 17.15 Plotting Sheets of Cross Sections on page 272.
6. Sheets of Plan plot frames
Each of these plot types will now be discussed in detail.
Apart from these six plot types, there are also others such as Drainage plots, Sewer plots and Pipeline plots which will not be discussed in this Chapter.
To preview any plots we make by plotting to a model, we will create a Plan view called PREVIEW that we will know is for only viewing models of plots and not for displaying any real world data.
So before continuing, create a new Plan view with the name PREVIEW using View=>Create=>Plan view.

17.12 Quick plots
The key purpose of Quick Plots is for occasions where the scale of the plot is less important than the contents. For example, if you needed to table a drawing at a meeting showing a certain detail, all that is needed is that you get the detail up on your screen and zoom in on it until you see the extents of your area of interest. You then create a plot and you will get exactly what you saw on the screen.

17.12.1 Quick Plan Plots
In 12d Model there are two ways to create a quick plan plot - Quick Plot and Quick Sheet Plot.
We will use the option Quick Sheet Plot because it allows us to choose the size of the sheet of paper and it dynamically displays what the plot will contain on the selected Plan view.

17.12.1.1 Quick sheet Plot
For view Plan 1, make sure it has the models ALIGNMENT, RS1 Sects, RS1 Strs, Survey ROAD CROWN and ROAD PAVEMENT EDGE on it. If this is not the case, add and/or remove models until only those models are on the view.
The cut down on the amount of information on the view, we will also turn text off on Plan 1 by clicking the Toggle icon and then on Text [on] to toggle it to Text [off].
In Plan 1 view zoom in to the area as shown below.

From the View Button Area for view Plan 1, click LB on the Printer icon in the view buttons area and select Quick Sheet Plot to bring up the Quick Sheet Plot panel.

We will plot to a model and also to a PDF file.
Pick 1 for View and select the Plotter Type model.
Type in preview plot for the model name
Select *always clean* as Clean model beforehand mode
Select A4 for Sheets size, 5 for Plot Sheet Margin and 0 for Rotation Angle.
Then click on **Fixed in View - Scale Zooms**
The Scale 1: and Origin X and Y coordinates are automatically calculated so that an A4 sheet will fit as much as possible in the view.
A representation of the A4 sheet is drawn on view Plan 1.
Pick 1 for View and select the Plotter Type model. Type in preview plot for the model name. Select always clean as Clean model beforehand mode. DO NOT ENTER SCALE. Select A4 for Sheets size, 5 for Plot Sheet Margin and 0 for Rotation Angle.

DO NOT ENTER ORIGIN.

Then click on Fixed in View - Scale Zooms. The Scale 1: and Origin X and Y coordinates are automatically calculated so that the A4 sheet will fit as large as possible in the area visible on the view. A representation of the A4 sheet is drawn on view Plan 1.

Note: Using Fixed in View - Scale Zooms means that if you zoom in and out in the view, the scale and Origin change so that the A4 sheet stays exactly as it now is in relation to the view edges.

For Fixed in Data - Scale Fixed, the plot frame keeps its size relative to the data when zooming and panning.
Select Arial for Text style.
Now type 2.5 for Text height (mm) and press <Enter>.
The cut marks stay in the same place but the upper rectangle gets larger and the title rectangle gets smaller.

Fill in Title line 1 and Title line 2.
Click on the button **Plot** and the model **preview plot** will be created.

Add the model **preview plot** to the view Plan PREVIEW and click on **Fit**.

Your finished plot should look like the one shown below.
To plot to a PDF file:
Simply select the **Plotter type** to be say **pdf_12d** and the **Plot file name** will automatically have the ending ".pdf" attached to it.

The press the **Plot** button.

A pdf file will then be created and opened in your default PDF Viewer.
17.12.2 Quick Section Plots

This is very similar to the Quick Plan plot we have just finished.

We will investigate this facility by profiling our RS1 centreline string in view Section LONG. From the View Title Area of view Section LONG, click LB on the Profile button and select the centreline string on display in view Plan 1.

Note: if you have just read in the data for Chapter 17 then a section view called LONG needs to be created, with a exaggeration of 5 and a Gird turned on with gird x 100 and grid y 1.

Set the corridor back to the values defined in 14.5 Setting Corridors on page 182, using the option on the View Title Area of LONG: View LONG menu =>Settings =>Corridor with a Width Left and Width Right of 20.

If you add the models tin GROUND model along with the pipes, survey SEWER PIPE and survey WATER PIPE and ensure that your grid is still toggled on, then your section view should be as shown below.

Zoom in on the portion of the profile where the services cross under the road.
Your view should look like the one shown below.

Note the services under the road.

If you add the models Survey SEWER PIPE and survey WATER PIPE onto View 1 you can check that is where the services do go under the road.

Also note that even though we asked for the vertical grid to be 1 m apart, the grid will only display in full at this separation when the view is uncluttered as it is in the zoomed in view. If 12d thinks the view will be too cluttered when you are Zoomed out, it will only display some of the requested grid lines as seen above.

From the View Title Area of view Section LONG, click LB on Menu=>Settings=>Geom annot
We will now create a plot of what is on the Section view.

From the View Button Area for View Section LONG, click LB on 
Plot => Plot

Fill in the panel as shown. Make sure that the plotter type is model or pdf_12 so that we can preview the plot.

Fill in the panel as shown.
Select the plotter type model so that we can preview the plot on a Plan view.

Type in preview quick section for the Plot file

Select always clean for Clean model beforehand

In the Scale 1: field, type 500 and press <Enter key>

Using the aspect ratio of the Section LONG view and the scale, the sheet width and height is then calculated and written to their fields.

Note: It is possible to type in any one of the three numbers Scale, Sheet width and Sheet height and press <Enter>, and 12d will calculate the other two. For instance to fill the width of a Landscape A1 sheet where you are not interested in the scale of the plot, type in a width of 841 and press <Enter>.

Tick on Title and border, Text style of ISO, Text height of 5 and a simple title.

Click LB on the Plot button.

Now go to the View PREVIEW and use the - sign to take OFF model preview plot and then add ON the model preview quick section.
Note that, in general, the plotted text may have a different height to that in the Section view and all the text plotted to the model will be turned into world text.

If the plot is satisfactory, the user can send the plot to another plotter type. Simply select an appropriate device from the Plotter icon at the end of the Plotter type field and then Click LB on the Plot button.
17.12.3 Quick Perspective OpenGL Plots

This is very similar to the Plan and Section plots above. The Orbit, Joystick, String Drive or String Walk options can be used together with the Zoom options to establish the extents of what you can see. To get a plot of this is very similar to the above except with regard to the plot size. The plot size can only be established by trial and error.

To start off, just use any of the above tools to get some data on display in your Perspective OpenGL 2 view. In our case we turned on the model tin DESIGN after doing a String Drive. Let us assume that this is the data we wish to plot.

Click LB on **Plot** from the View Button Area of View Perspective OpenGL 2.
Now go to Pan view **PREVIEW** and remove any models on it and add on the model **preview quick perspective**. Your previewed plot should look like:

For **Plotter type** select **model**.

For **Plot file**, type in **preview quick perspective**.

For **Clean model beforehand**, select **always clean**.

Note that the **Sheet width** and **height** have already been filled in. They are in the ratio of the aspect of the Perspective view.

If your plot is too large, you can change either **Sheet width** or **Sheet height** and press <Enter>. The other one will be calculate keeping the same aspect ratio.

To change the aspect ration, you need to change the shape of your **Perspective OpenGL** view.

For **Title colour** select **white**.

Once you are happy with the plot size, click LB on the **Plot** button to generate the plot.
In the Perspective OpenGL view 2, **Toggle->Shade**. Your view should now look like:

If on the **Perspective Plot** panel, the **Plot** button is clicked again, the Plan view PREVIEW will change to:
If the plot is satisfactory, the user can send the plot to a device.
So for example on the **Perspective Plot** panel select **PDF colour** for the **Plotter type** and click LB on the **Plot** button.

This particular plotter choice will map the white text to black but keep the other couloirs as they are so the pdf file will look like.
17.13 Plotting Using Plot Parameters

Often a more detailed plot is required than the "what you see is what you get" plots of views already described can produce.

This is especially true for long sections and cross section plots where many pages of plots are required and the layout includes large amounts of additional information such as the labelling of chainages, heights, depths, alignment geometry and services.

In 12d Model, the way more complex plots can be produced is controlled using files called plot parameter files (ppf’s for short).

PPF’s consist of a large number of parameters and values which gives the user tremendous flexibility on the way the plots.

To make plot parameters accessible to all users, 12d Model has interactive PPF editors to create, modify and store the plot parameters in a binary plot parameter file (or ppf) format.

See

17.14 Plotting sheets of Long sections on page 248, relates to long section plotting.

17.15 Plotting Sheets of Cross Sections on page 272, relates to cross section plotting.

17.14 Plotting sheets of Long sections

Although long section plots of an alignment can be produced with no 12d Model view involved, if you have a section view with the alignment string profiled on it, then many of the plot parameters are taken straight from the section view and don’t have to be entered separately.

So we will use the view Section LONG to illustrate the plotting of long sections that involve multiple sheets.

View Section LONG should still be set up with the alignment RS1 already profiled on it, but if that is not the case, make sure that the models tin GROUND, survey SEWER PIPE and survey WATER PIPE have been added to the view and the string RS1 is profiled on the view.

Set the corridor back to the values defined in 14.5 Setting Corridors on page 182, using the option on the View Title Area of LONG: View LONG menu =>Settings =>Corridor with a Width Left and Width Right of 20.

Also change the vertical exaggeration of the view Section LONG to 2 and toggle the Grid OFF using Toggle=>Grid.
The Long Section Plot PPF Editor can be brought up by either
(a) clicking LB on the Printer icon in view Section LONG and then selecting Long plot (i.e. view Long menu Plot => Long plot),
or
(b) by clicking LB on the Main menu option Plot => Plot and PPF editors => Long Sections.

Note that if you selected the option from the Section View LONG then a number of the fields are already filled in. For example, View, Name of string to profile and Vertical Exaggeration.

If you selected the option from the main Plot menu, View and Name of string to profile will be blank and Vertical Exaggeration set to a default value of 1. For this case we will discuss filling in the View field shortly.

In the Plot parameter file box we want to select the file
C:\12d\11.00\Training\design\getting started basic\longsection_intro.lplotppf.

We can do that by either:
(a) dragging
and dropping it into the Plot parameter file field which will automatically fill in the name. Then click LB on [Read].

Or

(b) in the Plot parameter file box, click LB on the folder icon to bring up the lplotppf Choice box:

Then click on [Browse] and browse to the folder C:\12d\11.00\Training\design\getting started basic\longsection_intro.lplotppf and select the file longsection_intro.lplotppf. Finally click LB on [Read]

Reading in the plot ppf file sets up many of the plot parameters so that you don’t have to fill them in. For example, the Horizontal scale has been set the 500 and the Vertical exaggeration to 2.

In both cases after [Read] is clicked, the next thing to check is the View field.

The ppf did not have a View name in it so the View field has been set to blank.

Select the section view from which the plot is to be generated by clicking LB click on the View icon button adjacent to the View box near the top of the panel. Select the view LONG.
Or the name LONG can be typed into the field and the <Enter> key pressed.

**Note:** If a value is typed then the user must then press the <Enter> key so that the view information is automatically loaded into other fields of the panel.

Selecting the view will also automatically set some plot parameters if they don’t already have a value. For example the **Vertical exaggeration** field will be changed to that of the selected Section view.

Now we’ll look at the **Plotter parameters** to define what device the data is plotter to.

The plot parameter file has already set the **Plotter type** to model and the **Plot stem name** the **preview long section**

Set the **Digits in plot file number** to 2.

We have enough information to generate the long section plots so new click on **Plot**.

Because of the length of the alignment and the **Pagination** settings (we’ll look at those shortly), four models containing a plot will generated:

`preview long section01`, `preview long section02`, `preview long section03` and `preview long section04`.

The number 01, 02, 03 and 04 have two digits because **Digits in plot file number** is 2.

We’ll look at the first plot by removing any models from **Plan view** PREVIEW and then adding on the model **preview long section01**. Our view should then look like:
Notice that the plot is a combined Long Section plot, and a Plan plot of the relevant section of the alignment in the Long section of the plot. This is all controlled by the Plot Parameters.

17.14.1 Looking at Some Long Section Plot Parameters

The long section plot parameters can be edited by moving through the various levels of the PPF editor by using the tree structure shown on the left of the panel. The tree structure can be expanded by LB click on a + symbol (node) to show underlying levels which may consist of various other nodes. To shrink underlying levels, LB click on the - symbol.

We will have a look at a few of the plot parameters that are available in the Long Section plot.

There are number of ways to find plot parameters.

You can simply examine the tree, and click on the + to expand the nodes looking for the parameters you are after. For example, looking at the tree you will see the word Plot to models not far below Section Long Plot.

Clicking on Plot to models will display the Pagination parameters on the right had side of the panel.
Parameters may not be so easy to find so another way is to use the **Find** button.

Click LB on [Find] at the bottom of the PPF editor panel to bring up the **PPF Editor Find Parameter** panel. This will find any plot parameter in the panel that you know the full name of, which is rare, but it also has some regularly used selections built into the choice box for it.

For example double click LB on **Pagination** or **Upright chainages** will go straight to the relevant node in the tree and display the relevant parameters on the right hand side of the panel.
For more information on some of the nodes go to:

17.14.1.2 Title Info on page 254.
17.14.1.5 Adding a Plan Plot to the Long Section on page 261.

17.14.1.1 Pagination

If Use pagination is ticked on then the plot fill be broken into a number of pages depending on the length of the alignment string and the Pagination mode and values for Chainage length and Chainage overlap. For our long section plot, it was paginated and we ended up with four pages of plots.

17.14.1.2 Title Info

Click LB on the Title block node (+ symbol) to expand the next level of the tree to show the nodes User title info and Symbols.

Click LB on User title info to display its parameters.

The parameters on the right of the panel include the User title block parameters.

The Title file name was in the ppf file that was read in and the title file defines line work and text for the user defined title block.
The title block file also includes user parameters that are displayed in the grid with the names of the user text shown in the **Name** column, and the values the be entered by us will go in the **Value** column. For example in the title block file the entry

```
        text "$user_text<2,Sub title1>"
```

created the text **Sub title1** as row two in the grid.

If valid values are entered into the grid, they will be automatically be substituted into the title block at the time of plotting.

This panel can be resized by moving the mouse to the extremities of the panel and whilst holding down the LB near the edge, moving the outline to the required size just like resizing any view. Resize the panel in both the horizontal and vertical so that it takes up most of the screen. **Note** Like any panel it can be minimised by using the standard windows minimise button.

As the default size for the **Value** column has been set to the width of the column heading, it may be necessary to resize the column to see all of the text we will be typing in. To do this, move the cursor over the vertical dividing line of the grid, near the right hand end of the **Value** column heading. You will see a resizing arrow appear and you can use it to drag the column out wider. Note that if there is text in the Value column then double clicking LB whilst this arrow appears will automatically resize the column to be wide enough to show all the text in the column, including the column title.

The value **LONGITUDINAL SECTIONS** was already entered into the grid from the ppf file but this can be changed and/or new values entered into the grid. We’ll enter some other values to show how they are substituted into the title box at the time of plotting. LB click in the value filed adjacent to the **Main Title 1** name field, then type **ROAD DESIGN**. Complete the rest of the grid as follows:

```
<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Main Title</td>
<td>ROAD DESIGN</td>
</tr>
<tr>
<td>Sub title 1</td>
<td>LONGITUDINAL SECTIONS</td>
</tr>
<tr>
<td>Sub title 2</td>
<td>RSL</td>
</tr>
<tr>
<td>Drawing Number</td>
<td></td>
</tr>
<tr>
<td>Sheet</td>
<td></td>
</tr>
<tr>
<td>Revision</td>
<td>A</td>
</tr>
</tbody>
</table>
```

Note that not all the value fields have to be filled out.

To see what affect this has on the plot, click of the **Plot** button again.

The plots will be redone and the new page 1 drawn in the PREVIEW view. Zoom into the bottom right hand corner of the plot and you will see the entered title block information.
If you Pan to middle of the Title Block, you will notice that 12d has automatically calculated the Horizontal and Vertical scales (the position is given in the title block file) and on the right 12d Model has automatically calculated the chainage range appearing on each sheet (the position is given in the title block file).

The title block can also contain items such as Drawing numbers (which automatically increment with each sheet), Job numbers, Company Logos and Plot date.

All of this has happened automatically during the generation of the plot.

In general, the text in the Title block is entered in a panel once per project. It can often be entered for long-section plots and reused for cross-section and plan plots.
17.14.1.3 Adding Tins and Services to the Long Section Plot

When 12d Model creates a long section plot, it draws the long section of the primary string but it can also draw sections through tins and draw the projection of strings that are in the road corridor onto the long section.

For example, in the long section plot you will notice a section through the tin GROUND and that services appeared on the long section plot wherever the services were in the road corridor.

The models containing the tins to section through and strings in the corridor to project onto the long section are given in the node

Corridor >Model selection

The models in the Corridor >Model selection grid are automatically taken from the Section view entered into the View field. So in our job, the models tin GROUND, survey SEWER PIPE and survey WATER pipe were on Section view LONG, and so they were automatically added as Corridor models.

This list of Corridor models can be edited and added to and/or have entries deleted.

Note: for a tin to be sectioned through, a model containing the tin must be added as a Corridor model.

12d Model automatically works out where these services are in the road corridor and projects them onto the section along the primary string.

If you have a Vertical Exaggeration on the view other than 1, the pipe will appear as an ellipse rather than a circle.

Note that more of the pipe is displayed than where it cuts the primary string because we have a wide corridor set for Section view LONG so all of the pipe in the corridor is projected onto the primary string. In fact, the string only has to be in the corridor and does not even have to cross the primary string.
This is very useful for finding strings that may not actually cross the primary string but would still be a problem if there were close by.

The corridor width is set in the node **Corridors** and is currently 20 world units left and right.

This means that any string in the corridor 20 world units to the left and the right of the alignment will be projected back onto the long section and displayed.
17.14.1.4 Cuts - Automatic Labelling of Crossing Services on Long Sections

In the long section plot you will notice that services were labelled wherever the services crossed the profiled string, which in our case the road centreline.

The models that contained the services were:

- survey SEWER PIPE
- survey WATER PIPE

We will now look at what plot parameters control the labelling of these services.

There are parameters to define which models contain the strings are checked for cuts with the primary string and also Masks (optionally using wild cards) that can be used in a match on the string name so that only certain strings in the models are labelled.

To view the parameters that control the labelling of the crossing services, go to the Cuts section of the Long Plot and PPF editor, or click on Find and select Cuts annotation from the pop-up list.

The node Cuts defines multiple sets of model/mask combinations.

The user can select a whole model or certain strings from that model by specifying a mask. In this example, any strings from the survey SEWER PIPE model and survey WATER PIPE will be included in the cuts plotting.

The children under the Cuts node relate to how the Chainage, Heights, Diameters, Labels and Symbols information is placed on the plot when a cut is found for a string in a particular selection set.
Again *12d Model* automatically works out where these services cross the road centreline (in plan) and if there is a cross then labels it appropriately.

**Important Note**

The **Cuts** node only controls the **labelling** of a cut. The fact that the pipe is drawn is because it is in a **Corridor** model. So a cut can be labelled without the pipe being drawn.
17.14.1.5  Adding a Plan Plot to the Long Section

You will notice that there was a Plan drawing on the top of the Long Section plot. The parameters to add the Plan plot are set in the Plan Plotting node near the bottom of the Section Long Plot tree.

Notice that Use plan plotting is ticked on and the View to plot field is set to 1 which is why we had a plan plot on the top of our long section plot using the models on Plan view 1.
17.14.1.6 Plotting all the Sheets to One Model

Rather than plotting the long section sheets to separate models, to work with some CAD systems it is easier to have all the sheets plotted to the one model.

There are parameters to do this and they set in the Plot to models node near the top of the Section Long Plot tree. The Mode in Translate and merge plot models is currently set to row-wise translation, all the plot sheets will go to the one model with a spacing between them of 1000 mm.

By changing this to row-wise translation, all the plot sheets will go to the one model with a spacing between them of 1000 mm.

Note that this parameter will only take affect when the Plotter type is model.

Also note that in the Plot to models node, there is also a field Clean plot models beforehand which is set to always clean. That is why each time you plot to a model, the original plot data in the model is first cleaned out.

The other choices for are Clean plot models beforehand are:
17.14.1.7 Plotting the Long Section as a Black and White PDF

To see this plot as a black and white PDF, click on the Section Long Plot node to go back to the top of the tree and for Plotter type, select PDF Black.

Then click on Plot to generate four pages of pdfs.

The first page looks like

To go back to plotting to a model again, simply reselect model for the Plotter type.
17.14.2 Writing Out a New Long Section PPF

At any stage of the editing process, the user can write a PPF file in the project with all the information that the Section Long Plot PPF Editor panel contains so that it can be read in again at a later time. This is helpful if you want to close the Long plot and PPF editor panel but want to save the changes.

To write a new parameter file to project:

Click LB on the Plot parameter file folder icon and select [Browse]. This will open the folder STAGE_1.project.

Type TRAINING LONG SECTION into the File name field of the Microsoft Select a file to open dialogue and then click on Open.

Then press the Write button at the top of the Section Long Plot PPF Editor panel.

To read an existing PPF file in the project, clicking on the folder icon for the Plot Parameter File field and the Folder *.lplotppf choice panel will list them

Double click on the file name to select it and Read button. This loads the parameters into the grid.
17.14.3 Changing to a Different Long Plot PPF File

We have generated a set of long section plots using one layout but often another client wants something completely different. However to change layouts you simply change the lplot ppf file.

For example, if this time is the **Plot parameter file** box we select the file

C:\12d\11.00\Training\design\getting started basic\Long Sections.lplotppf.

and then click LB on **Read**. Then for **View** select LONG.

Check that the **Plotter type** is set to **model** and **Digits in plot file number** is 2.

Then click on **Plot** and the plot displayed in **Plan** view **Preview** is:
17.14.4 Advanced - Setting Up a More Comprehensive Plan View to Plot

We have kept the data on Plan view 1 fairly simple but in this section we will go through the processes that you would normally do to have a more realistic plan section of the plot.

First we will create a Supertin of the tins **GROUND** and **DESIGN** to create a Supertin (a Super Tin dynamically combines two or more tins). We will use the Supertin to display fast contours for the design combined with the ground.

To create a Supertin, select the option

**Tins => Create => Supertin**

Type in **SUPER DESIGN** for the **Super tin** field and if you press <Enter> the **Model for tin** will be automatically filled in with tin **SUPER DESIGN**.

Fill in the other panel fields as shown.

Aside: if **Mode** and **Active** are left blank then they will default to **replace** and **yes** respectively.

Click LB on **Create**.

The Super tin is then created and the **Edit Super Tin** panel replaces the **Create Super Tin** panel in case you want to make any further changes. Click on **Finish** to remove the **Edit Super Tin** panel.

Add the model **tin SUPER DESIGN** to Plan view 1.

The Super tin will be magenta where the tin DESIGN exists and green elsewhere where ever tin GROUND exists.
On the View menu for Plan view 1, select \textit{Settings} $\Rightarrow$ \textit{Tins} $\Rightarrow$ \textit{Contours}

\begin{figure}
\includegraphics[width=0.5\textwidth]{tin_draw_contours.png}
\caption{Tin Draw Contours for View}
\end{figure}

Fill in the panel fields as shown

\textbf{Aside: View} is be automatically filled in as 1 because the option was selected from view 1.

Click LB on \textit{Set}.

The Super tin is covering everything else so we need to change the model drawing order on the view to put the supertin at the back.

You can do this by selecting the option from the View menu for Plan view 1,
\begin{quote}
\textit{Models} $\Rightarrow$ \textit{Models to back} $\Rightarrow$ \textit{tin SUPER DESIGN}
\end{quote}

\begin{figure}
\includegraphics[width=0.5\textwidth]{plan_view.png}
\caption{Plan View}
\end{figure}

We will also give the Super Alignment \textit{RS1} a better style for plotting.

To do this press F6 to bring up the \textit{Edit String} panel and then select \textit{RS1}. Note - it is probably easiest to pick \textit{RS1} from the Section view LONG where it is being profiled.

\begin{figure}
\includegraphics[width=0.5\textwidth]{edit_string.png}
\caption{Edit String}
\end{figure}

Click on the \textit{Properties} icon to bring up the \textit{Super Alignment Properties} panel
Finally we’ll add the models survey VEG TREE and survey TOPO DRAING CL but take off the model RS1 Sects.

We now have nine models on the view but the important information is not necessarily visible because other data may be written on top of it. Although we could move various model to the back or to the front in the drawing order, the quickest way to prioritise the drawing order is to use the Plan view 1 View Menu option

**View Menu: Models => Model order**

This option allows you to move models up and down in the Visibility Viewing order, and also remove models from the view.

For Label style, select **DESIGN PLOT RHS 100** for Major interval and **20** for Minor interval. Then click **Set**.
To move models up or down, highlight the model in the list and then click on the Up arrow or the Down arrow.

This is a Model Visibility order so the model ALIGNMENT is to always visible and hence is drawn last.

So the drawing order is for tin SUPER DESIGN to be drawn first, then survey VEG TREE, then survey ROAD CROWN and so on up the list until ALIGNMENT is drawn last.

Move the models up and down on your list until you have the order shown.

Now in the Section Long Plot PPF Editor panel, and select and read in the Plot parameter file TRAINING LONG PLOT.lplotppf that we just wrote out.

Change the Plotter type to PDF colour.

And then click on Plot to generate the four long section pdf files.
The first and third of the four pages of long section plots are:

Notice how the North Arrow in the Title Block has automatically rotated with the Plan Section of the Plot.
17.15 Plotting Sheets of Cross Sections

In your Section view CROSS, profile any valid cross section from the model of cross sections called RS1 Sects. that is, from the View Title Area for Section view CROSS, click LB on the Profile button and click LB on any cyan cross section string you can see in any view. Confirm the selection with MB.

Also add the model tin GROUND, survey WATER PIPE, and survey SEWER PIPE to Section view CROSS.

Also make sure that the vertical exaggeration of Section view CROSS is set to 2. The large range of cut and fill in the training data files will reduce the number of sections per sheet if you have the vertical exaggeration set any larger than 2.

To run the Section X Plot PPF Editor, from the View Button Area for Section view CROSS click LB on the Printer Icon and select X plot.

Alternatively you can click on the option Plot => Plot and PPF editors => Cross Sections.

In the Plot parameter file box located at the top of the panel, LB click on the folder icon to bring up the folder choice box.
Browse to the folder C:\12d\11.00\Training\design\getting started basic and select the file xsection_intro.lplotppf. Click LB on Read

Select the Section view CROSS from which the plot is to be generated from by clicking LB on the View icon button adjacent to the View to load details from box near the top of the panel, and select CROSS.

Note: If a value is typed then the user must then press the <Enter> key to accept the view.

Go to the Title block >User title info node by navigating the tree control as described previously for long sections and fill in the Value fields for ROAD DESIGN for Main Title, RS1 for Sub title2 and A for Revision.

At any stage of the editing process, the user can write a X Plot PPF file that can be read into a panel at a later time. This is helpful if you want to close the Section X Plot PPF Editor panel but want to save the changes. Simply type a new file name into the Plot Parameter File box at the top of the Section X plot PPF editor and press the enter key.

This assigns the relevant file extension. Then press the Write button at the top of the panel.

To read an existing PPF file, the user can choose the file from the Plot Parameter File box, then press the Read button. This loads any existing parameters into the grid.

To generate a plot, return to the front screen and check that the Plotter type is model then press the Plot button at the bottom of the panel.
12d Model calculates that there needs to be multiple sheets to complete the job.

With the supplied Plot file stem of preview cross section and Digits in plot file number of 2, 12d Model will create three sheets and the models preview cross section01, preview cross section02 and preview cross section03.

In Plan view PREVIEW, remove all models on the view and then add on the model preview cross section01.

If you zoom in and pan around the plot you will notice that 12d Model starts each sheet by assembling cross sections in the bottom left corner and working upwards. When it can no longer fit more sections in that column, it will move to the right and, starting at the bottom of the sheet, work upwards again. When it fills a sheet, it will automatically go to the next sheet.

All cross sections are presented in increasing chainage order and the Chainage of the x section is shown underneath the plot of each x section.
Note the annotation in the boxes area, the labelling of the datum, the X, Y, Z of the centreline, the labelling of the grades on the x section, the hatching between the design and the ground and the labelling of the water string where it crosses the road cross section.

Finally, **Zoom** in at the right hand side of the base of the sheet and observe the Title block text. The start and end chainages for the sheet and automatically calculated for inclusion in the title block.

The other sheets will contain similar sections.
17.15.1 Plotting the X Sections as a Black and White PDF

To see this plot as a black and white PDF, click on the Section Long Plot node to go back to the top of the tree and for Plotter type, select PDF Black.

Then click on Plot to generate three pages of pdfs.

The first page looks like

![Plot of X Sections](image)

To go back to plotting to a model again, simply reselect model for the Plotter type.
17.15.2 Adding Tins and Services to the Cross Section Plot

When 12d Model creates x section plot, it draws the section of each of the string in the model of x sections (the primary strings) but for each x section, it can also draw sections through tins and draw the projection of strings that are in the road corridor onto the x section.

For example, in the x section plots you will notice a section through the tin GROUND and that services appeared on the x section plot wherever the services were in the x section corridor.

The models containing the tins to section through, and strings in the corridor to project onto the long section are given in the node Corridor >Model selection

The models in the Corridor >Model selection grid are automatically taken from the Section view entered into the View field. So in our job, the models tin GROUND, survey SEWER PIPE and survey WATER pipe were on Section view CROSS. and so they were automatically added as Corridor models.
This list of Corridor models can be edited and added to and/or have entries deleted.

**Note:** for a tin to be sectioned through, a model containing the tin must be added as a Corridor model. **12d Model** automatically works out where these services are in the road corridor and projects them onto the section along the primary string.

If you have a Vertical Exaggeration on the view other than 1, the pipe will appear as an ellipse rather than a circle.

Note that more of the pipe is displayed than where it cuts the primary string but much less so than in the Long Section plots (see 17.14.1.3 Adding Tins and Services to the Long Section Plot on page 257.).

This is because the corridor is set to 20 world units left and right in the long section but only 0.01 world units left and right for the x section plot.

So only the parts of strings in the corridor 0.01 world units to the left and the right of the x section will be projected back onto the x section and displayed.

Having such differences between the corridors for the long section and x section plots is very useful because the long section will show you that there are problems in a wide corridor, and the x-sections will show you exactly where the problem pipes are in offset and height from the alignment.
17.15.3 Cuts - Automatic Labelling of Crossing Services on Cross Sections

In the x section plots you will notice that services were labelled wherever the services crossed the x sections.

The models that contained the services were:

survey SEWER PIPE
survey WATER PIPE

We will now look at what plot parameters control the labelling of these services.

As for Long sections, there are parameters to define which models contain the strings are checked for cuts with the x-sections and also Masks (optionally using wild cards) that can be used in a match on the string name so that only certain strings in the models are labelled.

To view the parameters that control the labelling of the crossing services, go to the Cuts section of the Section X Plot and PPF editor, or click on Find and select Cuts annotation from the pop-up list.

The node Cuts defines multiple sets of model/mask combinations.
The children under the Cuts node relate to how the Offset, Heights, Diameters, Labels and Symbols information is placed on the plot when a cut is found for a string in a particular selection set.

The user can select a whole model or certain strings from that model by specifying a mask. In this example, any strings from the survey SEWER PIPE model and survey WATER PIPE will be included in the cuts plotting.

Again 12d Model automatically works out where these services cross the x section (in plan) and if there is a cross then labels it appropriately.
**Important Note**

The **Cuts** node only controls the **labelling** of a cut. The fact that the pipe is drawn is because it is in a **Corridor** model. So a cut can be labelled without the pipe being drawn.
17.15.4 Extending the Natural Surface Beyond the Cross Section

By default the plot of a x section only goes from the beginning of the x section on the left to the end of the cross section on the right.

It is possible to vary this in two ways.

On the Plot sheet layout node are the Plot width parameters.

If Absolute extension is not ticked, the width of the section is extended by Left extension units to the left of the beginning of the x section and Right extension units to the right of the end of the x section. The section through any tins is and services is done with respect to the extended section as well as cuts. This is very useful to see what the terrain and services are like outside the width of the x sections.

If you were to set the LHS extension to 30 world units, you get extremely wide of x section plots.
If **Absolute extension** is ticked, the width of the section goes from **Left extension** units to the left of the 0 offset (where the centreline is) to **Right extension** units to the right of the 0 offset.

For example, with **Absolute extension ticked** and a left and right extension of 5, the x section plots would look like:
17.16 The Rewrite for V11 Stops Here
THE REST OF THIS CHAPTER HAS NOT YET BEEN REWRITTEN FOR V11
AND IS A "WORK IN PROGRESS"
Chapter 17  Plotting

17.17 Plan Plotting Using Plot Frames

Plot frames are a set of tools within 12d Model that permit a series of plan plots to be readily generated and regenerated as required. The plot frames are superimposed over data in a view and the various frames plotted. All plots are clipped to size by the plot frames and will contain only the data that is on display in the plan view being processed. The user decides to plot one or more frames individually or plot a complete set.

We now need to assemble the data we want to plot in a view. We will use view Plan view 1 for this purpose. Make sure that the following models are turned on in view Plan view.

Your view ‘Plan 1’ should look as follows.

We want to create plot frames that encompass the various roads in the view. We will probably need more than one plot frame. In our case, each plot frame will represent an A1 sheet.
17.17.1 Creating Plot Frames

We will create our first plot frame.

User defined plot frames can be placed over the data in the view. These frames show both the sheet size and plot area borders.

From the 'Plot Frames' menu Plot => Plot frames => Create
Navigate to the folder C:\12d\10.00\Training\design\getting started basic and choose the title file Plan Plot.tbf and the panel will be filled out as follows:

Then select the Create button.
12d will transform the panel into the ‘New Plot Frame Edit’ panel (so that you only get one chance at creating that plot frame). It can be edited later if there is an error.

You will notice that the Edit panel is very similar to the Create panel.
To see our plot frame, you need to use the ‘+’ in the ‘Plan 1’ view to turn on model **pfalsurvey**. Do a **Fit** on the view.

![Image](image1.png)

Clearly our first guess at the scale is incorrect. We need to scale down our plot frame.

In the ‘New Plot Frame Edit’ panel, opposite the ‘Scale 1:’ field, change the 1000 to **500** and click LB on the **Set** button.

![Image](image2.png)

Click LB on **Fit** to fill the view.

![Image](image3.png)

In the ‘Plot Frame Edit’ panel, click LB on **Rotate**. Move the cursor into the ‘Plan 1’ view and notice that you can rotate the plot frame about its insertion point. When you have the cursor positioned appropriately, click LB and MB to confirm the selection.

Similarly, click LB on the **Translate** button and move the plot frame in view ‘Plan 1’. You will notice that the rotation angle is maintained as you move the cursor. When you have the cursor positioned
appropriately, click LB and MB to confirm the selection.
The final position of your plot frame pf1 should look as shown below.

You are trying to arrange the sheet to maximise the amount of information shown on it i.e. minimise the number of sheets.

Notice that the rotation angle and origin now have non-zero values.
That finishes the development of our first plot frame.

Click LB on **Set** and **Finish**.
We will now create the second plot frame.

Click LB on **Plot => Plot frames => Create** again.

The panel will initially come up blank.

- Click LB on the **Same as** button, position the cursor near any one of the corners of the *pfa1survey* plot frame and click LB to select it. When it highlights, click MB to confirm the selection.
- Change *pfa1survey* to **pfa1survey2**
- Change the Colour from red to **green**
- Click LB on the **Create** button.

As before, click LB on **Rotate**. Move the cursor into the “Plan 1” view and rotate the plot frame about it’s insertion point. When you have the cursor positioned appropriately, click LB and MB to confirm the selection.

Then click LB on the **Translate** button and move the plot frame in view ‘Plan 1’. You will notice that the rotation angle is maintained as you move the cursor. When you have the cursor positioned appropriately, click LB and MB to confirm the selection.

Click LB on **Set** and **Finish**.
Repeat for the third plot frame using name pf1survey3 and colour blue

The finished position of your plot frames should look as shown.

17.17.2 Using the Plot Frame Editor

If you ever want to make changes to one of your plot frames and the panel is not currently on display, you can use the Plot Frame editor to do this.

Click LB on Plot => Plot frames => Editor

Position the cursor near any one of the corners of the plot frame you wish to edit and click LB to select it. When it highlights, click MB to confirm the selection. The ‘Plot Frame Edit’ panel will appear as seen earlier.

To shut down the ‘New Plot Frame Edit’ panel click LB on Finish.

17.17.3 Create Plot using Plot Frame PPF Editor

Plotting using the plot frame ppf editor can be started using the plan view plotting icon

This brings up the View Plotting panel

This then brings up the Plot frame PPF Editor panel.
This panel has a tree structure, much like the Windows explorer type functionality. The + symbol near the *Plot Frame* text in the left of the panel indicates that there are levels below. To access lower levels, simply LB click on the + symbol to expand the tree. Expand the tree so there are no more + symbols and every level is shown.

To go from one level to another, simply LB click on the text headings on the tree structure. Click LB on the
Plot Frame level. Fill in the fields to the right of the tree using the relevant icon buttons where possible e.g. select the model `pfa1survey` from the model choice box. The fields should look as follows:

![Plot Frame PPF Editor](image)

The plotter type to select is model, as we want to inspect the plot before sending it to the actual plotter. In our example, we want to plot more than one Plot frame so we have chosen the Model of plot frames method. If we wanted to plot a single plot frame, we can select the frame using the Single plot frame selection tool.

Type in `preview plan` as the plot file stem. The plot stem specified will form the prefix for the plot name. This is important for plotting of a number of plot frames. For this example we have 3 plot frames so the 3 plot files produced will be "preview plan 1", "preview plan 2" and "preview plan 3".

Click LB on the Title block heading. Tick the Use title file checkbox as follows. This specifies that a Title file will be used for the plotting.
Click LB on the User title info heading and select the title file Plan Plot.tbf from the folder C:\12d\10.00\Training\design\getting started basic.

Once selected, a valid title file will populate the grid with user defined title file aliases. These are prompts for title box text and once filled out, will be substituted into the title block. Fill out the value part of the grid as follows. Fill out the form to suit your requirements.
This panel can be resized by moving the mouse to the extremities of the panel and whilst holding down the LB near the edge, moving the outline to the required size just like resizing any view. Resize the panel in both the horizontal and vertical so that it takes up most of the screen. **Note** Like any panel it can be minimised by using the standard windows minimise button.

Note that all the value fields do not have to be filled out.
A new option in version 10 allows us to add a symbol to a predefined location on the plot and also to be able to automatically rotate the symbol to match the plot frame.

Click LB on the Symbols heading.

In the example above we have selected the symbol NTHPT500. We select Native scale and then type in 500 for the Scale (Remember the plot frame was set up as 1:500).

To rotate the north arrow with the plot we select Yes for Rotate with plot.

The colour for the arrow will be magenta and the north point will be positioned in plot units. Type in 100 for the X and 500 for the Y values.

This will position the arrow up at the top left of each plot.

At any stage of the editing process, the user can write a binary PPF file that can be read into a panel at a later time. This is helpful if you want to close the Plot frame PPF Editor panel but want to save the changes. Simply type a file name into the Plot Parameter File box at the top of the Plot frame PPF Editor and press the enter key. This assigns the relevant file extension. Then press the Write button at the top of the panel.

To read an existing PPF file, the user can choose the file from the Plot Parameter File box, then press the Read button. This loads any existing parameters into the grid.
Prior to plotting

To generate a plot, press the **Plot** button at the bottom of the panel followed by pressing **Yes** to confirm cleaning the plot models.

In view Plan PREVIEW, turn OFF all models then turn on the model **preview plan 1**.

Select **prompt for clean** as the choice for ‘Clean models before hand’. This gives the user the option to clean at the time of creating the plot.

17.17.4 Previewing Plan plots and Managing Plan Plot Files

To preview a plot, just turn on the model containing the previewed plot in view Plan PREVIEW e.g **preview plan 1**. It is highly likely that you will need to change some of your plot parameters and repeat the plot and preview process several times before your plots are as you want them.

You are now in a position to make changes to your plot parameters and repeat the plot(s).

When you are happy with the plot, you can change the plotter option in the Plot Frame PPf editor to the desired plotter. Double click on the appropriate plotter to select.
Selection of the *windows* plotter option will utilise the current printers/plotter set up in windows.

Press the plot button to send the plot file to the selected device.

17.17.5 Saving PPF files for use with other projects

For a particular company or organisation, various styles/specifications may have to be consistent for all plots. If a standard PPF is created for a company this can be saved to the *User_lib* directory for easy access for any project. Then for more specific changes, such as the user text (that is substituted into a title file) the new value can be entered and a PPF saved again. e.g. The designers name may be changed and the PPF saved with a filename "designers_name" for example.

At any stage of the editing process, the user can write a binary PPF file that can be read into a panel at a later time. This is helpful if you want to close the panel but want to save the changes. Simply type a file name into the *Plot Parameter File box* at the top of the editor and press the enter key. This assigns the relevant file extension. Then press the *Write* button at the top of the panel. The write process will by default put the file produced into the current project folder.
If the user wants to save it to a User_Lib directory for example, they must click on [User_lib] to open that folder.

Type in the file name **Plan plot**

Select **Open**

The file name is placed in the ‘Plot parameter file’ text box.

Select **Write** to save the file.