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Preface
Preface
Why a ‘Getting Started for Surveying’ Manual ?
12d Model is supplied with a comprehensive on-line Reference manual which describes the function of 
each menu option in detail. It is a Reference manual however and makes no attempt to describe how to use 
12d for production surveying and civil engineering work.

This Getting Started for Surveying manual is designed to show you how to install 12d Model , work with 
the on-line help system, and then as the first section of Training, help you start to learn how to use 12d to 
achieve typical surveying tasks. The Getting Started for Surveying manual uses examples where possible 
to clarify usage. It complements rather than replaces the on-line Reference manual. In general, information 
in the on-line Reference manual will not be duplicated here.

The Getting Started for Surveying manual is available as a printed manual and as a PDF file on the 12d 
website 

http://12d.com.au/support/12d_model_updates.html

or from the 12d Model Forum:

http://forums.12dmodel.com/index.php

Training Material

The training tutorials assumes that a series of files are already on your hard disk. These tutorial files are 
installed during installation of the 12d Model software.

Getting Started for Design
There is also a Getting Started for Design manual which has the first seven chapters in common with the 
Getting Started for Surveying manual (context sensitive help and basic modelling) but then diverts to cover 
topics from the direction of a civil designer whereas the Getting Started for Surveying manual continues on 
with surveying techniques.

The Getting Started for Design manual is available as a printed manual and as a PDF file on the 12d 
website

http://12d.com.au/support/12d_model_updates.html

or from the 12d Model Forum:

http://forums.12dmodel.com/index.php
Page 9



12d Model Getting Started and Training Manual
Page 10



1 Installing 12d Model
The 12d Model 14 Installing Release Version notes are issued as pdfs and are used to install the 
Release versions of 12d Model 14.

There are separate pdf’s for each subversion of 12d Model 14 (C1a, C1b etc) as the links in the 
notes are different for each subversion.

The 12d Model 12 Installing Release Version pdf can be downloaded from the 12d website:

http://12d.com.au/support/12d_model_updates.html

or from the 12d Model Forum:

http://forums.12dmodel.com/index.php

Requirements for Installing and Running 12d Model 14

Before Installing and running 12d Model 14, you need the following:

(a) You must have Administrator privileges to install 12d Model

(a) Approximately 2 Gigabytes of disc space is required for the installation to succeed. 

(b) A 12d Model dongle for your computer

If 12d Model 12 is already running on your computer, the CodeMeter (or Wibu) dongle you 
already have will work with the new version of 12d Model 14 once you have a nodes file for 
12d Model 14.

If 12d Model has NOT been running on your computer then DO NOT ATTACHED THE 
DONGLE TO YOUR COMPUTER until after the dongle drivers have been installed as part 
of the Installation procedure.

(c) An email with the 12d Model 14 authorization file nodes.12d14n attached, or a folder with 
the 12d Model 14 authorization file nodes.12d14n or nodes.4d in it.

(d) This document which has the internet links to the required executables and files

(e) Access to the internet to download the required executables and files

Also note that:

(a) 12d Model 14 will not install on Windows XP or Windows Vista

(b) 12d Model 14 will not run with the Hardlock dongles which were used for V10 and earlier

If you have a 12d Hardlock dongle, please contact your 12d Model Reseller to obtain a 
replacement CodeMeter dongle.

(c) 12d Field will only run on CodeMeter dongles

If you are running 12d Field and have a 12d Wibu or 12d Hardlock dongle, please contact 
your 12d Model Reseller to obtain a replacement CodeMeter dongle.

(d) A three-button mouse is essential to efficiently use 12d Model
Page 11
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2 Before You Begin the Training

2.1 Installing the Training Files
If you have installed Training from the 12d Model Installation, then the Training folder will have been 
automatically created for you but where the files reside on the disk depends on whether you installed the 
Release version or the Practise version of 12d Model.

The Training manual dialogue assumes that the working folder (i.e. shortcut) of your 12d Model 14 or 
12d Model Practise icon is set to

c:\12d\14.00   for the Release version of 12d Model

The training files can be place in any sub-folder on your hard disk but for convenience in this manual, it is 
assumed that the training files are installed in

c:\12d\14.00\Training

Subfolders

c:\12d\14.00\Training\design

c:\12d\14.00\Training\survey

have been created and they contain all the required material needed for the Getting Started for Design and 
Getting Started for Surveying manuals.

Some of the material is common to both manuals and these files are in the folder

 c:\12d\14.00\Training\design 

2.2 12d Icons on your Desktop
It is recommended that you use the 12d Model 14 icon for the Release version  whilst initially working 
with this training manual.  The reason for this is that the icon points directly to the folder that containing 
the Training folder.
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2.3 Overview of 12d Model File and Folder Structures
Before you begin using 12d Model , it is useful to understand how 12d Model uses the file and folder 
structure under Windows.

12d Model  recognises long filenames up to 256 characters so you are not limited to the old DOS 
convention of 8.3 filenames. 

The 12d Model  software and its support files are installed on your hard disk, the program itself is 
installed into the folder c:\Program Files\12d or c:\Program Files (x86)\12d, and various subfolders 
below. The training data and user areas, are installed into the folder c:\12d\14.00 and subfolders below.

When the software was installed, the 12d Model 14 program icon is setup to point to the folder 
c:\12d\14.00.

The files required for the Getting Started for Design and Getting Started for Surveying courses have been 
set up in a folder c:\12d\14.00\Training.

As each 12d Model project you work on will have different files, it is strongly recommended that you 
keep each project in a separate subfolder. This can be anywhere on your hard disk or network. For 
convenience, you may prefer to keep them all under one major folder e.g. c:\12djobs. 

In the general case for production work however, if you were about to start work on a new project by the 
name ‘Highway’, you would like it to be in a new folder under say 12djobs i.e. c:\12djobs\Highway. This 
is simply done from within 12d Model where a folder of the same name as the project is automatically 
created with the project inside it.

 Either numeric or alpha characters and spaces can be used in 12d Model project names so you may prefer 
to use your job name as the project name. Also 12d project names are not case sensitive so ‘Highway’ is 
seen as the same name as ‘highway’.

2.4 Why Keep Projects in Separate Folders
12d Model  can have more than one project within the one Windows folder. For example, projects under 
‘Highway’ might be ‘Stage 1’ and ‘Stage 2’ or ‘Fred’ and ‘Bill’. Each project has its own data and 
configuration setup which controls the number of views, which models are on display etc.

However although most internal 12d Model  project files are kept separate another projects internal files, 
all input and output files, mtf files, chains, plots and reports go into the folder containing the project and 
are not held inside the project itself. Hence to prevent projects interfering with each other, it is best to 
create a separate folder and create each project in its own folder.

For example, if the Highway project has two stages, create the project Stage 1 in the folder Highway\Stage 
1 and the project Stage 2 in the folder Highway\Stage 2

Once inside 12d Model , from within any one project, it is possible to import any or all data from another 
project so there is some flexibility on a major job to move/copy survey or design data between stages if 
staging is used and then have multiple users perform parallel development. Model and tin sharing could 
later be used to subsequently assemble staged project data at the completion of a major job. Within any one 
project, model names must be unique so some planning is necessary if parallel development streams are 
subsequently to be reassembled. Models can be renamed at any time. Models are discussed in See Chapter 
3.11 (on page 43).

Provided no 12d Model  user is currently accessing a particular project, the project (and the folder 
containing it) can be copied, renamed, moved and deleted from within 12d Model.

WARNING - information inside the project itself should not be manipulated except from within 
12d Model since this may corrupt the project and data could be lost. For example, model names can only 
be renamed from within 12d Model. 

If you need to manually place any files on disk for a project (e.g. survey files from a total station or CAD 
files to get data into 12d Model, it is recommended that you place them in the folder containing the 
project. that way all the data and the project are in the one folder. 
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2.5 File Backup Procedures
To ensure that you can retrieve any job or project at any time from backup procedures, it is important that 
a complete ‘set’ of files is taken whenever backup is created. To backup the files associated with the 
‘Highway’, you would typically backup all files and sub-folders in and below

c:\12djobs\Highway

There are configuration files used that may be used in the Highway job, that are supplied by 12d Solutions 
and are automatically installed by the 12d Model Installation. These files are in 

c:\Program Files\12d\12dmodel\14.00\set_ups

c:\Program Files\12d\12dmodel\14.00\library

or when 32-bit 12d Model has been installed on 64-bit Window, 

c:\Program Files (x86)\12d\12dmodel\14.00\set_ups

c:\Program Files (x86) \12d\12dmodel\14.00\library

There are other user configurable files that 12d Model  may use and require to fully recreate all steps of a 
project. They are not created by the 12d Model Installation. These files are typically in 

c:\12d\14.00\user

c:\12d\14.00\user_lib

These folders may contain files that have been configured specifically for your site e.g. your corporate 
standard mapping, template and plot parameter files, your particular Total Station survey macros and any 
user defined macros etc. In general, such files are not project specific, however because these files are user 
configurable they may be changed at any time and hence particular project specific versions of them may 
be needed as part of the complete file set of a project.

In the above case, the folders shown are for 12d Model 14. As implied, the files in these folders will 
never be changed automatically by the installation process when you reinstall a later version of 
12d Model. 

The above paths are indicative only. It is possible that folders have been setup at different places for your 
site. For more information on exactly where all library and user folders are located, refer to the section  
40.1 Folder Structure Installed by 12d Model in the 12d Model Reference Manual and 12d Model 
Context Sensitive Help, and for information on the environment variables

USER_4D

USER_LIB_4D

SET_UPS_4D

LIB_4D

 that control where the various files are, see  6.6.3 Create/Edit env.4d and  40.4 Environment Variables 
in the 12d Model Reference Manual and 12d Model Context Sensitive Help
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3  Basic Operations

3.1 The Mouse
12d works best with a three button mouse (preferable a wheel mouse). 12d Model  will work with a two 
button mouse but the lack of the middle button means that you have extra mouse clicks to perform. 

All 12d Documentation uses the following notation for mouse functions.

LB = left mouse button  - used for picking screen items, menus etc.

MB = middle mouse button  - used to accept the highlighted item

RB = right mouse button  - used to pop up a list of alternatives

The left button is the Select button – typically used to select graphic items or text. The middle button (or 
wheel) is the Accept button, used to confirm a selection. The right button is the Menu button. It is context 
sensitive and often displays a list of alternatives available at that instant. 

With a two button mouse you achieve this functionality by clicking the right mouse button to pop up the 
Pick Operations menu and then clicking LB on Accept or by simply pressing the <Enter> key

The term clicking a button means pressing it down and releasing it again. The position of the mouse is 
taken at the time the button is released. In this tutorial manual, items that are selected by a mouse click are 
in bold.

As we get more experienced, we will also introduce the term dragging the mouse for some advanced 
12d Model operations. We do this by pressing down a button and whilst still holding it down, moving the 
mouse so that the screen cursor moves. Once a definite distance has been achieved, just a millimetre or two 
is sufficient, release the button. 12d Model notes the vector you defined and can use this information to 
detect the direction in which you dragged the mouse.

Finally, we will use the term double clicking. This is where we press the button twice in quick succession. 
This is often used for short-cuts.
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3.2 Starting Up - The Project Selection panel
When you installed 12d Model a 12d Model 12 icon will have been created on your desktop. 

If you click on the 12d Model 12 icon, the 12d Model front screen appears.

Click LB on New button at the bottom of the panel to bring up the Open/Create panel with the New tab 
selected.

Click LB on the folder icon at the end of the Folder name field and browse to:

C:\12d\12.0\Training\design\getting started basic.

Type STAGE 1 into the Project name field and tick on Create working folder.

Then click LB on the New button.

Then a folder with the same name as Project name is created (called the Working Folder), and a new 
project called Project name is created inside the Working Folder.

icon for 12d Model 32 bit exeicon for 12d Model 64 bit exe

By clicking the LB on the folder icon, navigate to the folder 
C:\12d\12.00\Training\design\getting started basic

Type in STAGE 1 in to Project name

Leaving the Create working folder? check box ticked will create a new 
folder of the same name (the Working Folder) and then create the 
project folder inside the Working Folder.
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Note

It is important to select names that are meaningful to your job as you may have several projects associated 
with a large or complex job.

Once a project is selected, the graphics screen will display, with the Setup Project Details panel open. Fill 
in the panel with the relevant required details

Click on Set to save the 
details and Finish to 
close the panel.

RULES FOR ENTERING DATA INTO PANELS

Important: The cursor must be locked into the appropriate data entry field when typing data into a 12d panel. 
Often this will happen automatically. If you cannot see the cursor flashing in the data field in which you want 
to enter data, use the mouse to position the cursor anywhere over the data field and click the LB to lock the 
cursor into the field before typing any data. Terminate the data entry sequence by pressing the <Enter> key.

If you make a mistake, you can always select the erroneous entry by double clicking over it with the mouse 
LB. The text should then appear highlighted. As you retype it, the old entry is deleted.

When filling in data in any 12d panel, it is not essential to terminate the entry of data by pressing <Enter>. 
You can use the <Tab> and <BackTab> keys to move from field to field. You can also use the mouse to move 
between fields. 

If you do press <Enter> to terminate the entry of data into a field, 12d will immediately validate the data in 
that field and if required, write an error message.
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3.3 The Initial Screen Layout
The default background colour for a view is black because black is the best colour for reducing eye strain 
and for distinguishing colours displayed in a view. 

To make the Getting Started manuals easier to print on in-house printers, many of our illustrations have a 
white background colour.

The names we use for the various parts of the screen are shown on the diagram below. Your screen may not 
appear exactly as shown as most components on the screen can be moved or turned off by user 
configuration options, or you have a different screen resolution.

Note that the View in the image with the white background has a title and it is Plan 1. This says that it is a 
Plan view with the name 1. The View names must be unique.

Each View can be Minimised, Maximised or Closed. 

The Plan View 1 can be maximised by clicking LB on the square button in the top right hand corner of the 
view menu.

Screen maximise, minimise
and delete buttons

Drop down Main Menu bar

View coordinates box

Screen message box

view workbook tabs

Output Window

CAD control bar

View button area

CAD tool bar

    Snaps tool bar

View type and name

View title area

Recalc panel

Search bar

View maximise, minimise
and delete buttons
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This then takes up the entire viewing area. Alternatively, you can double click LB on the plan view title 
area to maximise the view (The blue area to the left of the View Minimise button). 

To reduce it back to its original size you can hit the restore icon.

The Recalc panel is used to quickly rerun design calculations and will be discussed later. We will move the 
panel down to the bottom left of the screen by holding LB down over the menu title are Recalc and then 
moving the cursor to bottom left hand corner of the screen and then releasing LB wen the Recalc menu is 
where we want it to be.

The view should then look as shown below.

     Minimise      Maximise

 Close

Restore icon
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3.4 How to Find Your Way Around 12d Menus
12d options are run by a number of methods. The Drop Down Main Menu system from the bar running 
across the top of the screen is the main way we access 12d programs.

In addition to the Drop Down Main menu system, there is a floating 12d Model menu that can be pinned. 
This is found at Projects=>12d Model menu.

12d Model  has a unique graphical user interface (GUI) involving hundreds of menu items. These are 
logically grouped by function in a Walk Right and Tear Off menu system. 

Walk Right menus are menus designed such that if you move the mouse cursor right on a menu item 
containing a right arrow, a further menu will pop up, usually on the right hand side. 

Tear Off menus means that a menu can be torn off it’s parent menu and relocated elsewhere on the screen 
for clarity of operation. In general, it is possible to have multiple copies of the same Tear Off menu on the 
screen at one time.

Notice that the order of items left-to-right on the Drop Down Main Menu bar is the same as the top-to-
bottom order on the Walk Right 12d Model menu. You can select menu items from either one of these 
sources – the end result is the same.

The Drop Down menu bar conforms to normal Microsoft standards so it can be dragged and placed at any 
of the four sides of your desktop. It is probably most usable left at the top of your desktop. 

The following comments apply to ALL menus. To move any menu around on the screen, you drag it by 
depressing the LB in the View Title area at the top of the menu, anywhere other than over the X in the top 
right hand corner. With the button still depressed, move the mouse to the desired location and release the 
button to repin the menu. The same procedures also apply when moving panels and views. When doing 
this just make sure that LB is clicked in the general heading area and not on a View button.

click on 12d Model Menu 

 

brings up a pinable menu
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To ease the learning and usage process, a menu description system has been adopted in this manual that 
describes where to look to achieve a specific function. For instance, to import an AutoCAD DXF file of 
point and line data into 12d, you Walk Right on the 12d Model menu or from the Drop Down Main Menu 
bar, through two submenus and select DWG/DXF. This instruction is documented as…

File =>Data Input =>DWG/DXF/DXB 

To display submenus from the Walk Right, you do not need to use the mouse buttons. Simply position the 
mouse cursor over the 12d Model menu and once File I/O is highlighted, slide the mouse right over the 
arrow and the File I/O menu will pop up. Slide further right on the Data input menu item and the Data Input 
menu will pop up. 

Your screen should appear as follows

Alternatively, you can use the Drop Down menu bar to get to the same point …

To get to this same point using the pull down system, you need to click LB on [File] on the Drop Down 
menu bar and then proceed as before on the walk rights as shown below.
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Regardless of which menu selection method you used, place the cursor over the words DWG/DXF/DXB 
and click the left mouse button (LB) once. The Read DWG/DXF Data panel will appear.
Page 24



Chapter 3  Basic Operations

Once the panel is selected, the Walk Right menu system should collapse and be removed from the screen. 
If you move and repin any of the menus however, they will not collapse automatically.

If a menu is in the way, you can move it as already described. Any menu can be removed by clicking LB 
on the X button in the top right hand corner. 

You would normally now start entering data into the panel. At this time, we will not proceed further with 
this panel. Shut down the panel by clicking LB on the  in the top right hand corner or clicking LB on 
Finish at the base of the panel.

The panel is placed on the screen at the location 
where the mouse cursor was when LB was clicked.
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3.5 Toolbars and Controlbars
See

Chapter 3.5.1 CAD Toolbar and CAD Contolbar

Chapter 3.5.2 CAD Text Toolbar and Text Controlbar

Chapter 3.5.3 Symbol Controlbar

Chapter 3.5.4 Search Toolbar

Chapter 3.5.5 Snaps Toolbar

3.5.1 CAD Toolbar and CAD Contolbar
In 12d Model there are CAD options which are available under both the CAD menu and on the CAD 
Toolbar on the left hand side of the 12d Model screen.

The CAD options create various elements using a number of methods. These options make use of Tool 
bars and Control bars. Tool bars just have icons on them but Control bars have icons and also controls 
such as a model box on them. The method groupings are shown on the toolbars (e.g. Points, Lines etc.). 

The user can select an icon on the tool bar and a Flyout for all options of the grouping are displayed. This 
can be done by selecting the appropriate group symbol by holding down the left mouse button on the icon. 
This shows all the different options for that grouping in a flyout panel. Whilst still holding down the left 
mouse button, the user can move along the flyout toolbar to the appropriate option. 

The elements created from the CAD options will have attributes as defined by the Cad Control Bar. This 
control bar is placed on the top left hand side of the screen under the Main Menu control bar on the 
creation of a project

CAD toolbar

CAD String
flyout toolbar

CAD Controlbar
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The fields and buttons used in this control bar have the following functions.

Field Description Type Defaults Pop-Up

name box base names.4d names

name of string. If a valid name already exists in names.4d, the [N] button can be used to bring up a 
choice box of available names. On selection of a valid name, the rest of the values in the control bar 
will be filled out. e.g. colour, linetype etc.

model box base existing models

this field can be recognised by the model icon button on the right hand side of the field. The user can 
select an existing model by selecting the model icon. If a new model is to be used, the user simply types 
the model name into the field.

colour box red standard 12d colours

this field can be recognised by the colour icon button on the right hand side of the field. The user can 
select a 12d standard colour model by selecting the colour icon, typing in a a colour name of number, 
or even typing in he RGB of a colour in the format rgb (red_integer,greeen_integer,blue_integer).

height input Measures menu

this field allows a height or z value to be assigned to the created elements. If a valid value exists, this 
value will be applied to the created element. This is regardless if the z value was specified in an XYZ 
box. 

If no value is specified, the level will be interpolated where possible. A value of null can be entered into 
the height field as well so that created points will be given a null height value.

linetype box 1 valid linestyles

this field can be recognised by the linestyle icon button on the right hand side of the field. The user can 
select a valid linestyle by selecting the linestyle icon

weight box

this field allows the user to type in a line weight for the cad item created

tinablility box no, yes, points

the Tinable field sets whether:

yes - the vertices and segments are tinable (used in triangulations)
no - not tinable (not used in triangulations)
points - only the vertices (points) are tinable.same as

 button same as

the same as (or eye dropper) allows the user to select an existing element which will be used to define 
all the cad control bar values.
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The CAD options are available from the CAD toolbar or from the CAD menu.

When options are chosen from the CAD Toolbar, help messages are written to the Screen Message Box at 
the bottom of the 12d Model screen. 

Although there is no panel or menu involved with the CAD toolbar options, if the F1 key is pressed whilst 
the cursor is over an item on a toolbar, the context sensitive help will be called. 

Alternatively all the CAD options are documented under each of the walk-right menus of the CAD menu.

CAD Toolbar

CAD menu
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3.5.2 CAD Text Toolbar and Text Controlbar
The various Text options are:

Text can occur as a text string, on vertices of a 4d string, and on vertices and segments of a super string. 
Each type of text has 

(a) a vertex (these are displayed when Vertices are toggled on in a plan view)

(b)  a justification point, a rotation

(c) an offset

(d) a raise value. 

The vertex and justification point only coincide if the offset and raise values are both zero. 

All text on a 4d string must have the same height, colour, angle, offset and raise. 

Each part of the text on a super string vertex segment can be independently modified depending on the 
settings for the super string.

For text options, the created elements will have attributes as defined by the Text Control Bar. This control 
bar is placed at the top right of the screen under the main menu control bar on the creation of a project

The fields and buttons used in this control bar have the following functions.

Field Description Type Defaults Pop-Up

Textstyle data box 

On pressing the button a list of available textdata with predefined names read from the 
texstyle_names.4d file are displayed. 

CAD Text Toolbar

CAD =>Text   menu
Text Controlbar
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If you require a different textsyle, the user can edit the current settings by selecting the [Edit] button to 
bring up the Textstyle Data panel. This allows for definition of textstyle, units, height offset raise etc.
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textstyle box 1 available textstyles

the user can select an existing textstyle by selecting the textstyle icon or entering a value into the input 
box to the left of the button. 

text height box 10

the user can measure a height by selecting the text height icon or entering a value into the input box to 
the left of the button. The value units are defaulted to world units. This can be changed in the Textstyle 
Data box
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3.5.3 Symbol Controlbar
The Symbol Controlbar is normally at the top right of the 12d Model screen.

Users can define their own symbols to draw at vertices of super strings. The definition of symbols are 
stored in a file called symbols.4d.

The fields and buttons used in this control bar have the following functions.

Field Description Type Defaults Pop-Up

Symbol data box 

On pressing the Symbol data button a panel appears 

Symbol Control toolbar

If you require a different 
symbol, the user can edit the 
current settings by selecting the 
[Edit] button to bring up the 
Symbol Information panel 
(shown below).

The current symbol can be 
selected from the Symbols list 
and the colour, size and rotation 
can be manually set

Alternatively the size and rotation (anti clockwise) can be entered manually into the boxes in 
the Control bar
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3.5.4 Search Toolbar
The Search bar is normally at the top right of the 12d Model screen.

By simply typing text into the Search Bar, the option searches for matches of the typed text amongst the 
full path names of all the options on the menus, and then lists the menu items and the position of the 
menu that contains the menu item.

For example, typing in volu will bring up the list shown below.

Double clicking on an item in the list brings up the panel for that item.

Note that case is ignored when searching for matches.

3.5.5 Snaps Toolbar
The Snaps Toolbar is normally at the top right hand corner of the 12d Model screen.

Snaps are used when picking strings - see Chapter 7.4 ’Snap Settings’.

Typing volu in the Search Bar

List of matches for volu
in the full path to the name
of the option on a menu,
and the position in brackets
of the menu that contains
the text volu.

Clicking on any item
in the list brings up the
panel for the option

Snaps toolbar
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3.6 Status Bar
The Status Bar is an optional part of your desktop. It appears at the base of your desktop. The Status Bar 
contains the Screen Message Box and the View Coordinates Box. It is strongly recommended that you 
keep it turned ON. 

If desired, the Status Bar may be turned OFF at any time. 

From the View drop down menu bar, click LB on View, untick the Status Bar checkbox. To turn it back 
ON, repeat the selection but this time tick the checkbox.

3.7 Screen Message Box
The Screen Message Box contains messages that help you interact with the 12d menus. For instance, when 
importing a DWG/DXF/DXB file as shown previously, you have to select a file name to read. Let us 
investigate the messages 12d gives us to help us with this simple operation. 

If the DWG/DXF/DXB Data panel is not already showing, select it again as shown previously. 

Click in the ‘File’ name entry data field. Observe that the following response appears in the Screen 
Message Box

You interpret this help message as follows. 12d is asking you to supply a file name. The three sets of 
square brackets [ ] correspond to your response via the three mouse buttons, LB, MB and RB. 

The LB message ‘Caret’ indicates the position of the cursor if you want to type an answer using the 
keyboard. 

To type an answer, you must first make sure that the cursor is locked onto the field you wish to modify. 
The cursor must appear as a flashing vertical bar before 12d will accept any data from the keyboard. 

You can reposition the caret anywhere in the existing word by using the LB. You could then edit it by using 
the <Backspace> key. 

Alternatively you can use the <Delete> key to delete the character to the right of the cursor or the Arrow 
keys to move within the word. 

The <Home> and <End> keys take you to either end of the existing entry. 

To delete the entire entry, double click anywhere in the text to highlight it. Then press the <Delete> key to 
erase the entry, or just start typing to replace it.

The MB message ‘Same As’ indicates that you can point at any existing item on your desktop. This would 
not normally be used for a file name. 
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The RB message ‘Menu’ puts up a menu. At this time, no items are available. If another filename was 
copied to the windows clipboard then the ‘Paste’ would be highlighted.

Or finally, you can click LB on the folder icon to locate the required file

The Screen Message Box area changes dynamically with the position of the cursor on the screen so watch 
it closely for helpful messages.

3.8 View Coordinates Box
Note the location of the View Coordinates Box at the bottom right of the desktop (the right hand side of the 
Status Bar). 

This box displays the X-Y coordinates of the cursor when in a Plan view and Chainage-Height-X 
coordinate-Y coordinate when in a Section view.
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3.9 The Output Window
The Output Window appears as a tab at the bottom left of the screen and flashes if there are any messages 
that need to be reviewed. 

By default the Output Window is in Auto-Hide mode and when you move your cursor over the Output 
Window tab, the Output Window appears.

Auto-Hide mode can be turned off by moving over the Output Window and pressing RB to bring up the 
Output Window menu. Click on Auto-Hide to remove the tick and Auto-Hide is no longer on.

 

When Auto-Hide is turned off, the Output Window stays open permanently.

The Output Window menu includes the options:

Clear - clears the Output Window,

Copy to clipboard - copy any selected text in the Output Window to the Clipboard. 

Hide - removes the Output Window.

Float - makes the Output Window a floating window that can be docked on any of the sides of the 
12d Model screen. 

Convert to window - turns the Output Window into a normal Window which then appears on your desktop. 
It may be moved by clicking LB in the Output Window heading area, then dragging the cursor to another 
part of your desktop and releasing the LB to pin it down. 
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 When the Output Window is a normal Window or a floating window, then clicking on x at the top right of 
the window will remove the Output Window. 

The Output Window can be made taller or shorter by moving the bar at the top of the Output Window.

The Output Window can be turned off by Hide but also unticking the Output Window on the Window Main 
Menu will remove the Output Window.

Once the Output Window is removed, the only way to turn it back on is to click on Output Window on the 
Window Main Menu.
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3.10 Introduction to Views
There are three types available in 12d Model - Plan, Section, Perspective - and some subtypes. For 
example Perspective and Perspective OpenGL are both Perspective Views and most Perspective operations 
work identically on them.

It is possible to have multiple Plan, Section and Perspective views on the desktop at one time, each 
showing different information. There is no limit to the number of views you may create.

Each View has a View type icon and a must have a unique name such as SURVEY or 2 etc. The names 
can be any number of characters that must be either alphanumeric of spaces although for uniqueness upper 
and lower alphabetic characters are considered to be the same thing. View names will automatically have 
any leading or trailing spaces removed.

The name appears in the View Title Area. This is the heading at the top of each view. 

Just below the name is the View Button Area which contains the most common View buttons (i.e. a 
subset of the complete list of view options). The View buttons appears horizontally after the view name. 
The View Button Area appears automatically with each view as the view is created and each view type 
has different view buttons that reflect it’s characteristics. 

The View Name defaults to a number but can be over typed with any alphanumerics. The View Name 
must be unique for the project.

For example, the View Buttons shown on a Plan view called Survey to map to ADAC are:

Each view also has its own menu (the view menu) which can be brought up by clicking the LB on the view 
button called Menu.

The View menus can also be brought up in another special way:

if you click the RB in the View Button Area or the View Title Area, you will also get the View menu to 
pop up. Clicking RB again in the View Button Area or the View Title Area will remove the view menu.

So by using the RB, view menus can be accessed even if the Menu item is not visible in the View Button 
Area.

The View menu contains options available for that particular view type. It is a superset of the buttons that 
appear on the horizontal View Button Area. If the View is made very small or moved off the right hand 
side of the desktop, the various buttons on the horizontal View Button Area will not be selectable as they 
will not be visible. In such case, you have to use the RB in the View Button Area to get access to the 
various View menu items.

Hence there are four menu systems in 12d, one for each view type (Plan, Section and Perspective) and an 

Plan View Buttons

Menu Fit Pan
Zoom

Shrink
Toggle

Refresh

Plot
Add

Remove

Previous

Properties

Clone

View Button area

View Title area
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overall Main Menu.

Views may be created, resized, overlapped, moved, minimised, maximised and deleted. 

When you create a new view, 12d will automatically supply it an ascending number for reference purposes 
e.g. Section 2. This automatic name can be changed to any other unique view name.

To make Menus and Panels easy to see they will always be displayed on top of any views.

3.10.1 Basic View Operations
We will now practice some basic View operations

To create a new View, we can use the Views =>New or the Views =>Create option.

For example to create a new Plan view, select Views =>New =>Plan from the main menu to create a plan 
view with the next view number.

Alternatively, you can use Views =>Create =>Plan View. Pick Create with the LB after first supplying a 
View name or accepting the ‘number’ supplied by 12d as the View name.

Important note: Each view name must be unique.

Once the View is on display, the following operations can be performed from the View Button Area.

To MOVE a View to a new location on your desktop, depress the LB in the View Title Area – the area on 
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the top of the view showing the words Plan 2. Whilst you still have the mouse button depressed, drag the 
mouse and you will see the View move. Pin the View again by releasing the LB.

To RESIZE a View, use the standard Windows features to change the size of the View. Place the cursor 
near any corner or midside of the existing plan view and when the drag arrows popup, depress and hold 
down the LB and drag the mouse to see the Window size change. Pin the new location of the corner by 
releasing the LB.

A DISPLAY a view ON TOP of all the other views, click on any visible part of the view except in the 
view drawing area (the black part of the view). Or by clicking on the View tab for that view in the View 
tabs area at the bottom of the view display area.

To MAXIMISE a view, click on the Maximise button on the top right corner of the view. The view will 
then take the entire view display area and no other view will be visible.

If a view is maximised then clicking on any other View tab will bring that view to the TOP and hence it 
will become the MAXIMISED view.

When a view is maximised, the three buttons that normally appear in the top right hand corner now appear 
at the right hand side of the Main Menu area. Click on the Restore button to UNMAXIMISE the view.

current view on top

View tabs
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To MINIMISE a view, click on the Minimise button on the top right corner of the view. The view will be 
reduced to just an icon at the bottom of the View Display Area. To RESTORE the minimised view, 
simply click on the Restore button on the view icon or click on the View tab of the minimised view.

To DELETE a View just click LB on the X button in the top right hand corner of the view.

A Yes-No Confirmation panel will then appear and select Yes to delete the view.

Click LB on Yes to confirm the action

For the purpose of the tutorial, delete all the existing views EXCEPT Plan View 1 and maximise it to 

buttons for the Maximised View

Restore (unmaximise) the view

Minimised Views

Clicking on its Restore button
or its View Tab will 
Restore a minimised view
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leave just large Plan View called 1 on the desktop.

In the following chapters we will create and demonstrate the use of all the different view types, and how 
the various views are linked together.
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3.11 Introduction to Models
Models are a 12d concept and basically a model represents a repository for data. Each point or line that is 
created or imported into 12d is put into a model. A model is similar to the layering concept AutoCAD, or 
levels in Microstation

By adding models to, or removing models from, a view, it is possible to change the amount of information 
that is displayed on a view. And it is possible to have different models on display in different views.

There is no limit to the number of models used in any one 12d Project.

If you want multiple copies of a certain line (i.e. string), it is possible to copy the line from one model to 
another. The lines can then be displayed independently. If both models were on at once, the information 
will appear as one line instead of two since the strings are coincident. It is possible to selectively snap to 
and edit either line in such a case.

At any time, individual models can be Renamed, Duplicated, Cleaned (removes all points and lines but 
the name of the model is retained) or Deleted. 

By default, any deleted models will be stored in a Trash Bin as a back up. Models in the Trash Bin can be 
restored at a later time. An example of this will be shown later in the manual.

It is possible to copy models between projects (See Models=>Utilities=>Copy Project Models) or to 
Share Models from another project into you project so that you have the latest copy of the shared model. 
These are more advanced features of 12d that we will not look at in this manual.
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3.12 Introduction to Strings
12d is very much a ‘strings’ rather than ‘points’ based system. 

In it’s simplest form, a string can be just a single vertex (point), or a line between two ore more vertices. 

A string may be made up of many vertices, joined by straight line segments or arc or transition segments.

Strings vary in complexity from 2d (x,y and constant z value) to multidimensional, and an alignment string 
that has both horizontal and vertical geometry independently defined. 

In general, as well as x, y and z values, strings have properties such as string name, string type, string 
colour, line style, and chainage. 

Strings also have a point/line property that can be set such that they appear as disconnected points or 
connected lines.

From a design point of view, strings are much more useful than points. 

Vertices forming a string

denotes a string vertex

vertex A

previous vertex next vertex
to vertex A to vertex A

first vertex
last vertex

vertex index 1

vertex
index 2

vertex
index 3

neighbours of A

string links or segments
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3.13 Introduction to Panels
A panel is the means of supplying all the information required for a 12d Model option. 

Once a panel appears on the desktop, you can use the mouse or the Tab and BackTab keys (denoted by 
<Tab> and <Back tab>) to position the cursor over any data field. Remember, when typing data from the 
keyboard, the cursor must be flashing in the data field for characters to be accepted. 

When supplying data to a 12d panel, you do not need to terminate the entry of data into a field by pressing 
the Enter key (<Enter>). For instance, you can use <Tab> and <BackTab> or the mouse to move to 
another field after entering data. If you do press <Enter> to terminate the entry of data into a field, 12d will 
immediately validate the data in that field and supply an error message if appropriate. 

When validating supplied or previously entered data (i.e. where you do not need to change the data in a 
field), it is not necessary to place the cursor in the data field. Just press <Enter> to pass through each field 
in the panel in turn. 

When typing data into a field, please observe that the Delete key (<Delete>) deletes a single character to 
the right of the cursor. The Backspace key is also active. If you need to delete multiple characters, drag the 
LB across the characters to highlight them (or double click over a word) and press <Delete> to delete them 
or start typing to replace them.

In general, 12d has been setup so that data can be selected from lists rather than typed from the keyboard. 
When entering data into a field, if there is a list of alternatives already known to 12d, pressing the LB on 
the icon at the end of the field will display the list.

To practice this, bring up the Read xyzs Data panel - from the Main menu, click LB on 

File I/O =>Data Input =>xyz =>xyzs

Set the Default line colour in the above panel to dark green by clicking LB on the colour icon (the icon to 
the right of the word red in the fourth data field). A list of available colours will pop up. Use the mouse to 
click LB on dark green and then process it by clicking LB on the Select button at the base of the panel.

Alternatives: You can double click LB on dark green to short-cut this sequence. You could also have used 
the down arrow key to work your way down through the list to highlight the word dark green and then 
pressed < Enter>.

In a manner similar to the colour panel field just discussed, most panel fields have a pop-up list of choices 
available and the list is activated by clicking on the icon at the right hand end of the panel field. Some 
times there will be a special icon such as the colour icon in the previous example or the file box icon at the 

Click LB on a 
colour icon to 
bring up the list 
of colours
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end of the File to read field.

Some of the more common icons we will see are:

Note that there is a Message Area at the base of the panel (just above the Read button in the Read xyzs 
Data panel). 

Each panel has its own message area to help you interact with 12d. If 12d does not appear to be working 
the way you think it should, you will often get helpful information in the Panel Message area. Look in the 
Screen Message Box as well as it may also be updated when interacting with panels.

If a panel is in the way, you can move it as stated above. Any panel can be removed (shut down) by 
clicking LB on the X button in the top right hand corner or by clicking on the Finish button. 

If you want to keep a panel that is already filled in such that you can refer to it later, you may decide to 
temporarily minimise it by clicking LB on the ‘-‘ button. It can later be maximised again by clicking LB 
on the ‘overlapping windows’ button (where the ‘-‘ used to be).

As we don’t wish to proceed further with this panel click LB on Finish or click LB on the X button in the 
top right hand corner of the panel.

Colour icon

Message area

File icon

Model icon

View icon

choicemodel

file/folder tin textstyle info

line weight

colour colour when
none selected

view

line style polygon symbol
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4 12d Model Help
Position of option on menu:     Help =>12d Model

All the information in the 12d Model Reference manual is also available as electronic Help 
accessed from within 12d Model (also know as the 12d Model Context Sensitive Help).

The entire 12d Model Reference manual can be accessed by selecting 12d Model on the Help 
menu item on the main 12d Model menu.

 

The 12d Model Reference manual pdf is used as the Context sensitive (electronic) Help. The 
12d Model Reference manual is installed with 12d Model.

A link to downloading the 12d Model Reference Manual pdf is also given in the Installing 
12d Model pdf on the 12d website:

http://12d.com.au/support/12d_model_updates.html

or on the 12d Model Forum:

http://forums.12dmodel.com/index.php

For more information on using the pdf Help, see

4.1 Help Button on Panels

4.2 F1 Key for Menus, Toolbars and Panels

4.3 Navigating in PDF Help

4.4 Extra Help

12d Model  help pdf
12d macro programming language manual pdf
some of the new items in this version
a summary of the new items in this version
Getting Started for Design manual
Getting Started for Surveying manual

links to web site www.12d.com.
infor on 12d Model modules authorized, dongle number etc
email details of your 12d Model to 12d Solutions
dongle testing panel
check for new versions of 12d Model 
brings up Microsoft’s System Information panel
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4.1 Help Button on Panels
Most panels have a Help button which when selected goes to the topic describing that panel.

Note: if there is no Help button Help information may still exist and can be obtained by using the 
F1 key (see 4.2 F1 Key for Menus, Toolbars and Panels).

The default 12d Model Help is all in one pdf file but a method for displaying additional help 
information exists so 12d Solutions, 12d Distributors and Users can supply additional (extra) 
Help information.

If there is extra help available for an option, then Help* will appear instead of Help on the panel 
button.

Help button to go
directly to the Help
topic for the panel.
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Information on how the extra help is set up is given in the section 4.4 Extra Help.

Continue to 4.2 F1 Key for Menus, Toolbars and Panels or return to 4 12d Model Help.

the Help button will be replaced with a Help *
If there is any extra help documentation for the panel,

The * indicates that there is extra help available.
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4.2 F1 Key for Menus, Toolbars and Panels
Another method of invoking Help is by using the F1 key as follows: 

when a menu or panel is on the screen and has focus (the menu or panel title area 
will be highlighted), or the cursor is over an item on a toolbar, pressing F1 will bring 
up the help for that menu, panel or toolbar item.

Warning - some of the items on the Strings menu automatically start up a string select and 
change the focus from the panel to a View. This means that pressing F1 will bring up the Help for 
the View and not the Help for the panel. 

To get Help for such a panel, click on the panel to bring the focus back to the panel before 
pressing F1. The top of the panel will highlight showing that it has focus.

Continue to 4.3 Navigating in PDF Help or return to 4 12d Model Help.
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4.3 Navigating in PDF Help

Once in the pdf Help, the  buttons at the top of the pdf reader will go to the previous 
and next page respectively.

The pdf Help also contains many links to other sections of the pdf file and they are identified as 
green underlined text. Clicking on the green text will go to the link destination.

Once you have clicked on a number of links in a pdf session, the  buttons at the top of 
the pdf reader will go to the previous and next link destinations respectively.

Pages of the pdf Help can be printed by clicking Print icon   at the top of the pdf reader.

<Ctrl>+f brings up the pdf text Find panel.

<Ctrl>+<Shift>+f brings up the pdf Full Search panel which will search for all occurrences of a 
given word or phrase in the pdf file.

Continue to 4.4 Extra Help or return to 4 12d Model Help.
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4.4 Extra Help
The default context sensitive 12d Model Help is all in one help file supplied by 12d Solutions but 
a method for displaying additional help information exists so 12d Solutions, 12d Distributors and 
Users can supply additional (extra) Help information. This extra information can also be supplied 
by 12d Model PLs (macros) written by 12d Solutions or Users.

4.4.1 How to Set Up Extra Help
Any extra help for an in built panel (that is, one not created by a macro) is placed in a folder with 
the same name as the dump name for the panel without the ending after the “.” (to get the dump 
name, see Dumping a Panel, Creating a Screen Layout File or Default File in 12d Help or the 
12d Model Reference manual).

For macros, created by Users or 12d Solutions, there can only be the same Help button for any 
panels created by the macro and the extra help for the macro is placed in a folder with the same 
name as the macro without the ending "4do" after the “.” and with any blanks or non 
alphanumeric characters replaced by a underscore ("_"). For example, the extra help files for the 
macro called "testing help (3) system.4do" go in a folder called testing_help__3__system. Note 
there is an underscore for the blanks and the "(" and ")" in the macro name.

The extra help files for an in built panel or macro can have any name and can be a pdf, wmv, avi, 
txt etc.

For example, for the panel Project Tree brought up by selecting Project =>Tree, the extra 
documentation would be in a folder called Project_Tree. 

The folder of extra help for a panel, is then placed in any one of the three places:

(a) in the Help folder in the 12d Model installation area: For example, for version 12

c:\Program Files\12d\12d Model\12.00\Help

c:\Program Files (x86)\12d\12d Model\12.00\Help

(b) in a folder called Help inside the Set_ups folder in the 12d Model installation area. For 
example

c:\Program Files\12d\12d Model\12.00\Set_ups\Help

c:\Program Files (x86)\12d\12d Model\12.00\Set_ups\Help

or

(c) in a folder called Help inside the User folder in the 12d User area. For example

c:\12d\12.00\User\Help

For an in built panel an macro, each of these areas is searched and if any extra help is found, it 
is listed with the full path to each extra help file.

If there is any extra help for a in built panel or macro, the Help button on the panel will be 
replaced with a Help * button. The * indicates that there is extra help available.

When you click on the Help * button, you will get a list of all the extra help files for that in built 
panel or macro with the full pathname to the extra help. Clicking on the file name will bring up that 
extra help. 

For example, 
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Users Own Extra Help Files 
Note that users can also have their own extra help files and the files are simply placed in the 
correctly named folder under User\Help.

Return to 4 12d Model Help.

* indicates extra help
is available

standard 12d Model Help

extra Help in User\Help

extra Help in Help

extra Help in Set_Ups\Help
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5 Starting the Tutorial
Before starting your tutorial, it is assumed that your overall desktop layout is as shown at the end of 
Chapter 3.10.1 Basic View Operations, i.e. one large Plan view on display called 1.

5.1 Importing Point Data into 12d
The easiest way to understand the use of Models and Panels is to import some data into 12d and see by 
example.

Point and Line data can be imported into 12d from a variety of sources. For the purposes of the tutorial, we 
will use the simplest of these - a simple text file containing point number, x, y and z coordinates along with 
a code and string number.

We will begin by reading in a Points file called ‘DETAIL SURVEY.csv’.

This file lies in the folder C:\12d\14.00\Training\design\getting started basic

 

The format is one point per line containing a point number, x, y and z coordinate, string name and string 
number all separated by commas. 
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To read in the file, click LB on File =>Data Input =>x y z =>x y z general from the Main menu. 

12d gives you the ability to fill in this 
panel once and then save the setup to 
a parameter file. This allows you, on 
subsequent occasions, to call up the 
parameter file and then you only need 
select the data file to be read.

To make things easier we have already 
created a parameter file and stored it 
in Getting Started Basic folder.

Click on the folder icon at the end of 
the Parameter file field.

A blank folder panel will pop up, but we will browse for 
the parameter file

Click LB on [Browse] 

Click LB on the getting started basic to move back to 
the getting started basic folder

Note that if you have created the training project in a folder 
different to the one shown here then you will have to navigate 
to the required folder
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Double click on the file

OR

Click LB on the file then click LB on [Open]

Click LB on Read icon to load the parameters

Using the folder icon browse to the same folder that 
held the parameter file 
(C:\12d\14.00\Training\design\getting started 
basic) and locate the file DETAIL SURVEY.csv. 

You will have to change the File type display to Files 
(*.csv)
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Select the Basic tab
You will notice that the panel is 
mostly filled in from the parameter 
file (such as red and yellow). 
However, you still need to set the 
default text field

Select the choice icon and then select 
any of the text styles

Select the Format tab

The format for the file values are already set up by the xyf file.

 No user entry is needed for this tab
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Select the Mapfile tab

A user defined Map File uses the code found in the data file to set the parameters for the strings including 
the model name, linestyle, colour and more. 

The path name of the Map File GETTING STARTED.mapfile has also been set up by the xyf file. 

"GETTING STARTED.mapfile" already exists in C:\12d\14.00\Training\design\getting started basic.

A model prefix "survey *" (note that there is a space after the word survey) is used to group the survey 
models together after the map file has set the model names. This will help keep the survey data separate 
from the design. Using lower case for the word will send the models to the bottom of the listing

We’ll have a look at the Map File so that you are aware of how it works and what the Map File is doing.

Select the folder icon 
then select [Open]

To open the map file
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Click LB on Finish to exit the mapping file

Now that we’ve had a look at the Map file, we’ll read the data in using the Read X Y Z General panel

A tree structure is used to access the 
sections within the Map File

The Basic node sets the model, 
colour and more. It is shown in the 
next image. 
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On the Read X Y Z General panel, click on Read to import the data file.

You will notice that a new Plan view called DATA IMPORT view has been created and the models 
containing the data read in have automatically been added to the view. This is the default action when 
reading data in.
Page 61



12d Model Getting Started and Training Manual
Maximise Plan view DATA IMPORT and the screen should look like:

Pror
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5.2 Plan View Operations
Now that we have some data, we can begin to look at some more of the Plan view features of 12d. 

Bring up the Plan view Menu.

In the Plan View Button Area, you will observe a ‘+’ and ‘-‘. This is a shorthand technique for turning 
models on and off. 

Click on the ‘-’ sign button with LB. A list of available models to remove from the view pops up. Pick 
‘survey VEGETATION’ and click LB on ‘Remove’. You will observe the tree symbols in model ‘survey 
VEGETATION’ are removed from the view. The ‘+‘ works in a similar way to add models to the View. 
Practice adding and removing models from the view with the + and -. Remember, the models are not being 
deleted with the ‘-‘, merely removed from the current View. Turn back on the tree model survey 
VEGETATION.

After multiple pans and zooms, you sometimes wish to return to a point where all of your data appears in 
the view. This is equivalent to an AutoCAD Zoom-Extents. Click on Fit with LB to see all of your data.

This facility allows you to move the centre of the view but retain the current zoom factor. Click on Pan 
with LB. You then press down LB on a point in the View and then drag the mouse. The data in the view 
will move with the mouse until LB is released.

Select Zoom (to Zoom In) from the Plan View Button area with LB. Click LB on two diagonal points of a 
rectangle and then click LB once anywhere in the plan view. The information will appear enlarged based 
on the size of the rectangle.

If your mouse has a wheel as part of the middle button, then it can be used to dynamically zoom in or out. 
Simply click LB in the plan view at the point you want to zoom about and then roll the wheel forward to 
zoom in and backwards to zoom out.

This is equivalent to Zoom Out. It works just like Zoom but in reverse.

If you click LB on Previous, the view will appear as it was prior to the Zoom. 12d always keeps the details 
of the previous view setting available so that you can return to it quickly. Only one level of previous view 
settings is kept.

There are multiple items under the Toggle Pop Up menu. At this time, we will try only one of them. Select 
Grid with the LB. A rectangular grid should appear. If you click LB on Toggle =>Grid again, the Grid 
will be removed from the display.
The appearance of the grid can be changed by clicking LB on the Menu button in the View Button Area 

Menu

Adding/Removing models

Fit

Dynamic Pan

Zoom

MB Wheel Zoom

Shrink

Previous

Toggle
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and click LB on Settings =>Grid. You can change any of the settings in the panel. Try changing the grid 
spacing from 100 to 10 in both x and y directions and click LB on Set. You will notice that the Grid can be 
turned on and off from either the panel settings or the Toggle =>Grid switch. Click LB on Finish to 
terminate the panel.

All the information on the view will be redrawn. This can also be achieved by clicking MB anywhere in 
the View Title Area or anywhere in the View Button Area except over the ’+’ or ’-’ buttons.

Bring up the Plan view Plot Menu. This has options to generate a quick plot of what is on the screen, plot plot frames 
and drainage plan plots

Creates a copy of the view.

Brings up the Plan View Properties panel for this view.

If we clicking on the Fit icon on Plan DATA IMPORT, then we will get.

Refresh

Plot

Clone

Properties
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5.3 Birds-Eye Views and Throwing Between Views
To introduce some new concepts in 12d, we will need both of the Plan views on the screen at once.

First we’ll un-maximise Plan DATA IMPORT by clicking on the Restore icon for the current maximised 
View (there can only be one maximised view).

Now resize and move the views around so that Plan 1 is on the left and takes up half the area and Plan 
DATA IMPORT is on the right and is sized as per the image beloq.

In the View Plan 1, use the + view button to turn on all of the models. Do a Fit to both views.

From the Plan DATA IMPORT View Button area, click LB on Zoom and click a point in the lower 
left corner of the View Plan DATA IMPORT. Before selecting the second point of the Zoom rectangle, 
move the cursor into the other View i.e. Plan 1.

Notice that the second point of the Zoom rectangle is being taken from the second view and the view box 
is drawing in both views.

Restore the maximised view to its 
previous un-maximised state 
Page 65



12d Model Getting Started and Training Manual
Select the second point of the Zoom rectangle in either View, and take it at the bottom left hand corner of 
the data. 

After selecting the second point of the Zoom rectangle, you will notice the prompt Select destination view 
- RB to cancel in the Screen Message Box

12d is prompting you to select the View you want zoomed. That is, the view that you want to zoom 
rectangle to take up the entire view.

Click LB in View Plan 1. The zooming will then take effect in View Plan 1.

Notice that using this technique, it is possible to achieve a birds-eye effect where the smaller View displays 
the complete model whilst the larger working view is zoomed to an extent where it displays only the detail 
that you are currently working on. You would typically define all of your zoom rectangles in View Plan 
DATA IMPORT but have the zoomed details updated in View Plan 1.

You can even do this with different models turned on in each view. For example, in the birds-eye view, you 
would typically only turn on sufficient detail to enable you to zoom on known features.

To see this, click LB over the - button on View Plan DATA IMPORT and remove the model survey 
SURFACE POINTS. This will make the large scale details much easier to see on view Plan 1 and still 
have the full level of detail on the zoomed in view, Plan DATA IMPORT.
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Please practice zooming and throwing between Views as it is a powerful concept in 12d.

After completing this exercise, delete View Plan DATA IMPORT as it is no longer needed by using a 
second way to delete a View. 

Click LB on the Menu button in the View Button Area of Plan DATA IMPORT OR click RB anywhere in 
the View Button Area of Plan DATA IMPORT, to bring up the View Menu for the view.

Select Delete and then Yes to confirm the deletion.

Then maximise Plan 1 and do a Fit.
Page 67



12d Model Getting Started and Training Manual
5.4 Rolling Middle Mouse Button to Zoom In and Out
First click any button in the view to highlight the view (get focus on the view). Rolling the middle button 
forward will zoom in about the position that you clicked inside the view to get focus.

Rolling the middle button backwards will zoom out about the position that you clicked inside the view to 
get focus.
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5.5 Deleting a Model
As we now wish to look at an alternative (and preferred) way of importing data into 12d, we will delete the 
existing models as they will be recreated in the following option.

From the Main menu, click with LB on Models=>Delete=>Delete all models.

When Permanently delete? is NOT ticked on and models are deleted, they are sent to the Trash Bin in 
case they need to be restored at a later stage.

When there are models in the Trash Bin, a Trash Bin icon appears at the bottom right of the 12d screen

To access the deleted models, double click LB on the icon or select Project =>Management =>Trash Bin

To restore models, click LB in the Select column next to the models that you want to restore to turn on 
ticks for the models, then click LB on the button Restore.

To permanently delete models in the Trash Bin, click LB in the Select column next to the models that 
you want to permanently delete to turn on ticks for the models, then click LB on the button Delete.

To permanently delete all the models in the Trash Bin (like emptying the Windows Recycle Bin), turn on 
ticks in all the rows in the Select column by clicking LB then RB over the top of the Select column to 
bring up the Column operations menu.

Click LB on Delete 

Click LB on Yes to confirm
Page 69



12d Model Getting Started and Training Manual
.

Click LB on Set to turn on all the ticks and then click LB on the Delete button.

Click LB on the Yes button to confirm permanently deleting all the selected models.

5.6 Redraw - Fixing up a Modified or Erroneous View
Whenever data is removed from a View e.g. turning off the display of a model, the view does not 
automatically get refreshed. 12d typically removes a model by overdrawing the information using the 
background colour, usually black. This operation can leave the view looking speckled and unclear. 

You can force the view to refresh by clicking LB on the Refresh button , or click MB in the View 
Button Area anywhere other than over the ‘+’ or ‘-‘ view buttons. The whole View will be repainted to 
display the corrected information. 

It is also possible that some of the menus may at times become corrupted. Windows is a very complex 
multitasking environment and the menus are stored in memory which is being updated continuously. If you 
ever get parts of your desktop that don’t look correct, you can force your entire 12d screen area (all menus, 
views etc.) to be refreshed by holding the Ctrl and R keys down together (<Ctrl>+R).

Alternatively you can refresh just any one Menu by clicking MB in the Menu Title Area.

5.7 View Tabs
There is a tab for each view on a bar just above the Status Bar at the bottom of your 12d screen. If you have 
the Output Window in the default position (the tab at the bottom left of your desktop), the tabs bar is 
displayed just above the Output Window.

The View Tab has the icon for the view type and then the view name beside it.

To bring a 12d view to the top of all other views and to set the view as your active view, just click LB on 
the appropriate View Tab, or click LB in the view title area of the view. 

Each tab corresponds to a 12d View. 

View type View name

View tab
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Note that when a view is active, the View title highlights in blue.

When there is more than one view tab, the order of the View tabs can be changed by holding LB down on 
the View tab whose order you want to modify and then moving the cursor to the left or right until you 
reach the position that you want the selected view tab to be in.

5.8 Saving a Project
The current changes to the Project you are working on are only stored in memory. 

To make the changes permanent and update your files on disk you need to Save the Project. This can be 
done at any time by clicking LB on Save from the Projects Menu (Project =>Save), or by holding the Ctrl 
and S keys down together (<Ctrl>+S).

12d will also pop up a panel reminding you Do you want to save the project? 

Click on Yes with LB to force a Save to occur. 

The timing at which this message appears is set from the Defaults panel brought up by the menu item 
Project =>Management =>Defaults. The time in minutes is set in the field Save Interval (min) under the 
System Settings tab. 

The default is every 15 minutes. Set the time interval to zero to turn this feature off altogether.

If you ever crash out of 12d due to a power failure for instance, any changes since your last Save operation 
will be lost. 

5.9 Exit 
To terminate a 12d Model session, click LB on Exit on the Project menu (Project =>Exit). 

If you try to Exit 12d after changes have been made to your Project, 12d will remind you of the changes by 
prompting you for a further Save operation. 

5.10 Starting 12d When Projects Already Exist
When 12d Model is started and projects already exist and have been opened in 12d, the most recent 
projects will be listed on the left hand side of the 12d Model Front Screen.

Double clicking on a project in the Recent Projects list will open the project.

View title area

Recent projects list
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Also when you are in 12d Model, the walk right menu Project =>Recent projects will also list the recent 
projects and clicking on a project in the list will exit the existing project (asking if a Save is wanted) and 
opens the selected project.

When you return to an existing project, the appearance of the views and toolbars on the screen will be just 
as you last left them. 
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6 Basic Modelling

6.1 Alternative Data Entry
We will now repeat the process of importing data into 12d but this time we will use a 12d Archive file.

This option is the more common way of transferring data from Surveyor to Designer when both parties use 
12d. The Archive format will often include all of the strings with the correct model, colour and other 
properties so that no mapping is required. Also a tin (triangulation) can be included in this file format so 
that the Designer has no need to create a new tin from the survey data. In this instance we will assume the 
coding and models are correct different so that mapping is not required. Also a tin is not included.

We will import the file DETAIL SURVEY.12da. To read in the file, click LB on File =>Input 12d from 
the Main menu. 

Again a new view Plan DATA IMPORT is created with the models read in automatically added to it.

Transfer the models from View DATA IMPORT to View 1 by using the option View =>Model transfer. 

Delete Plan DATA IMPORT to just leave the one view, Plan 1

Click LB on the File to read folder icon then browse 
back up to the folder 
C:\12d\14.00\Training\design\getting started basic

Double click LB on the file DETAIL SURVEY.12da 
and the file name will be piped into the field File to 
read 

A map file is not required.

A model prefix "survey *" is again typed in to group 
the survey models away from the future design models.

Click on Read to read the data into 12d Model.
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Another great way to read in an existing 12da file into an existing project is to use Drag and Drop.

To Drag and Drop, in Windows Explorer, press LB down whilst over the file DETAIL SURVEY.12da and 
then move the cursor over the 12d screen area and then release LB.

A Read 12d Solutions Archive Data panel with the full path name to the file DETAIL SURVEY.12da 
automatically entered into the File to read field.

6.2 Saving a Model Listing to a File for Future Use
The current eight models on the view are exactly the models that are used to create the natural surface tin. 
We will now see how to record these models in a form that can be used in the future to restore those same 
models to another view.

To make the list, we first click on the Plan 1 view tab to make Plan View 1 the focus. The heading in view 
Plan 1 should appear coloured bright blue and if there were others views, will be brought to the forefront.

From the Main menu click LB on View =>Models Save/Restore

This file can be read at any future time by use of the Restore tab on the View (Save/Restore Models) 
panel. This will add the models in the vml file to any view. 

Type in the file name SURVEY. 
Pressing <Enter> will add the 
extension .vml

Click LB on the view icon then select 
view 1

Click LB on Save

Click LB on Finish to exit the panel
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6.3 Triangulation
We will now use this point and line information to create a 3d surface or TIN (Triangulated Irregular 
Network). 

One of the concepts in 12d is that a TIN can be created from a single model, a single view (and all the 
models on that view are used) or a model list.

In general, you will use Views to create models since you can control which models are on display in a 
View. 

It is important to understand that when creating a TIN from a View, only those strings in models added to 
the View will be used in creating the TIN and only then if the strings have been set to tinable. 

For instance, if you were forming a TIN representing the natural surface, you could leave models that 
represented underground surfaces on the view used to create the TIN if such data was non tinable (i.e. not 
used in a triangulation).

When using a mapping file to read in data, strings can be flagged as being tinable (and Breaklines) or non 
tinable. Only tinable strings are used in the triangulation. 

Breaklines are used to pick up the topographical features accurately. 

When forming triangles, 12d ensures that every straight segment in the breakline is the side of a triangle.

In this exercise we are assuming that the survey strings have already been checked for errors (See the 
Getting Started for Surveying manual on methods for checking the data).

For the purposes of the tutorial, please ensure that all models in view Plan 1 are on display prior to 
creating the TIN. Plan 1 should look as shown above.
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From the Main menu, click LB on Tins =>Create =>Triangulate data 

Fill in the first tab of the panel as shown.

The Triangulation function option is used to construct 
a function which, when recalculated, will run a 
retriangulation on the tin. Place the cursor in the data 
field with the LB and type in TIN GROUND

Each TIN requires a name. Position the cursor in the 
New tin name field and type in GROUND. If you press 
<Enter>, this name will also be used to fill in the Model 
for tin field but with the prefix "tin " (see panel). The 
TIN name is subsequently used to refer to this specific 
TIN.

Position the cursor in the Model for Tin field and type in 
the suffix ",1" after the name so that the model is added 
to the view 1, and hence displayed, as soon as the TIN is 
created. 

There is no problem if you don’t add the ",1"because 
you can always add the model containing the tin to a 
view at any time.

Click on the Data tab.

As we wish to triangulate all the data in plan view 1 and 
leave the tinabitily to determine which data to use, click 
LB on the view icon.        Select 1 from the list. 

Click on the Nulling tab.

There are two options here, you can set the parameters to 
null the external triangles, and/or you can use a polygon to 
null all triangles outside this polygon. 

The BOUNDARY TIN string will be used as the boundary 
for the tin. 

Click LB on the Null polygon string icon then click LB on 
the BOUNDARY TIN string followed by clicking middle 
button (MB) to accept the string.

(We will cover selecting strings in Chapter 7 String 
Picking Concepts.)

Click LB on Triangulate to create the TIN. There will be a 
short delay and then your TIN will be created and displayed 
as shown in the next picture.

 Click LB on Finish to terminate the panel. 
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If you didn’t use the ",1" after the model name in the Model for tin, now add the model tin GROUND to 
the view. View 1 should now look like:

Note that the TIN is clipped at the selected Null polygon ensuring only the surveyed data is included. 

Now that we have a TIN we can display the TIN data in a variety of ways.

Important Notes

1. Tin names must be unique in the project.

2. A tin can only be displayed on a view by adding a model that contains the tin to a view.

3. A tin can be in more than one model. Or even in no model.

4. More than one tin can be in the one model.

5. Deleting a model DOES NOT delete any tins in the model. Tins are deleted with Tins ->Delete
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6.4 Tin inquire
 

Notice that as you move your cursor over the tin, the aspect is being displayed in the panel message area.

Repeat this procedure with both the Height and Slope menu items.

Once all three panels are on the screen, move the cursor anywhere over the TIN and observe what happens. 

When the cursor is positioned over any one triangle, the three point coordinates of the triangle are being 

From the Main menu, click LB on Tins =>Inquire to bring up the Tin Inquire 
panel.

Click LB in the menu title area (where it says Tin Inquire), move the menu and 
Pin it with the LB. This operation is necessary to stop the menu from being 
automatically removed after the first menu pick.

Click LB on Aspect, and the Tin Aspect Inquire panel will pop up.

Move the cursor over the Tin icon button at right end 
of the Tin field and use the LB to pop up a list of 
Tins. Double click LB on GROUND. Then click LB 
in the menu title area (where it says Tin Aspect 
Inquire), move the panel to a clear area of your 
screen and pin it with the LB.

 Do not Click on the Finish button in the panel.
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used to linearly interpolate on the fly to calculate the exact x,y,z coordinates of the cursor. Also the aspect 
and slope of the triangle is shown in the respective panels.

We’ll now look at one option that combines all three, as well as Tin colour, and does not even need a Tin 
to be set.

On the Tin Inquire panel, click on Tins on a View (Tins =>Inquire =>Tins on a view) to bring up the 
Tins on View Inquire panel.

Now move the cursor around the view and any tins under the cursor will be dynamically listed in the panel 
and at the (x,y) position of the cursor, display the height of the tin, and the triangle colour, slope and 
aspect.

 

Click LB on Finish on all four panels to put them away.

Also click LB on X on the Tin Inquire menu to shut it down. 

We will now look at the various ways information in TINs can be viewed.
Page 79



12d Model Getting Started and Training Manual
6.5 Fast Contours
We now want to remove all of the models from the View except tin GROUND. From the View menu (in 
the View Button area), click LB on the - sign to pop up the Models to Remove panel. 

 

Click LB in the panel title area (over the words 
Models to Remove), move the panel and repin it 
with LB so that it doesn’t collapse after each 
selection.

Now click the LB on the first survey model. 
Drag the mouse down the list to highlight all the 
survey models and click on Select. 
Alternatively, you could double click LB on 
each model in turn except tin GROUND. Click 
LB on X to shut down the panel.

Now from the View buttons, 
click LB on the Toggle 
button to bring up the Toggle 
menu.

Then click LB on Tin 
contours. You should see the 
following red and green 
contour lines appear.
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 If you click Toggle =>Tin contours again, the View will revert to the green triangle display. 

The appearance of the contours can be changed by clicking LB on the Plan 1 Menu button in the View 
Button Area. Click LB on Settings =>Tins =>Contours and the following panel will pop up.

At the completion of experimenting it is suggested that you put the settings back to their default values (as 
above) at this time. 

Click LB on Finish to terminate the panel. Your new settings will remain in effect indefinitely until 
changed.

Plan 1 Menu button.

You can change any of the settings in the panel 
including colour. Click LB on the colour icon 
at the right end of the contour colour field to 
see a popup list of available colours. Select a 
colour by double clicking on it with LB.

Try changing the contour increment (spacing) 
from 1 to 5 and the bold increment from 5 to 
25. Click LB on Set to activate the changes. 
You will notice that the Fast contours can be 
turned on and off from either the Draw 
triangles contours tick box setting in the 
panel, or the Toggle=>Tin Contours switch.
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6.6 Fast Flow Arrows
It is recommended that you turn on the survey SURFACE model for this exercise. From the View menu 
(in the View Button area), click LB on the ‘+‘ sign button and double click LB on survey SURFACE. 
Make sure that the tin GROUND model is also still turned on. The easiest way to confirm this is to click 
LB on the ‘-‘ sign button in the View Button Area and look at the list of the models that could be turned 
off. Click LB on the X button to terminate the list.

Now from the Toggle button, click LB on Toggle =>Tin contours to turn OFF the contours and then 
Toggle =>Tin edges. The purpose of this is to outline each triangle. 

Then click LB on Toggle =>Tin flow. You should now see an arrow appear at the centre of each triangle 
representing the direction of water flow.

Try zooming in on a section of the view for a closer look. When you have finished zooming, click on Fit to 
again fill the View window.

The appearance of the flow arrows can be changed by clicking LB on the Plan 1 Menu button in the View 
Button Area. Click LB on Settings =>Tins =>Flow Arrows and the following panel will pop up.

Click LB on Set to activate the changes. You will notice that the Flow arrows can be turned on and off 
from either the Draw triangles flow tick box setting in the panel or the Toggle =>Tin Flow switch.

Click LB on Finish to terminate the panel. Your new settings will remain in effect for this view until 
changed.

Click both Toggle =>Tin edges and Toggle =>Tin flow again and the View will revert to the green 
triangle display. 

You can change the size of the arrow 
heads and their colour. Click LB on the 
colour icon for the Colour for arrows 
field to popup a list of available colours. 
Select one by double clicking LB.

Try changing the arrow length from 10 to 
5 world coordinates (in this case metres). 
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6.7 Perspective View
We will now look at the perspective view facilities in 12d to examine the surface we created above.

Create a new perspective view. Click LB on Views =>New =>Perspective from the Main menu and a new 
view pops up. Alternatively by selecting Views =>Create =>Perspective OpenGLview from the Main 
menu, a panel pops up. 

Note the new view is created immediately and is placed over the top of your existing windows. If a view is 
maximised then it will be unminimised when a new view is created.

You can use the standard windows features to Tile the views. For example, on the Main Menu select 
View=>Window =>Tile Vertical.

Your overall screen layout should now look like the image below.

Note that the highlighted view is placed on the left by Tile Vertical.

If necessary, put the cursor in the View 
name field, backspace over the existing 
entry (or use the Delete key) and type 2. 

Click LB on Create. 
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The view buttons on a Perspective view are

we now need to add the TIN to the perspective view. In the View Button Area of Perspective OpenGL 2, 
click LB on the ‘+‘ sign button and double click LB on tin GROUND. Click LB on the Fit icon.

Note that Zoom using the Zoom option and rolling the middle mouse button both work in a Perspective 
view.

So after your Fit, zoom in so that the tin almost fills view 2.

6.8 Pan and Zoom in Perspective Views
Pan and Zoom both work for a Perspective View.

Trying Zooming in and panning around.

Menu

Refresh                             Positions

PlotAdd

Remove

Eye

Walk                                      Favourites

Joy

Orbit                                                   Properties 

Fit
Pan

Zoom

Shrink

Toggle

Previous

DrivePlan Camera

Clone                     Controls
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6.9 Joy Panel
The Joy View panel (short for Joystick) provides a quick way of orientating your eye in relation to your 
data when manipulating a Perspective view.

The Joy View panel is accessed from the View Buttons Area. Click LB on the Joy button in the View 
Button Area of Perspective 2 and the Joy View panel appears. 

If you get lost or zoom in too far, you can always start again by clicking LB on Fit in the View Button 
Area.

The angular step between each up or down step defaults to 15 degrees. You can change this if you want 
smaller increments by entering a new value in the Angular Step field.

Similarly, the Distance changed on each In/Out movement defaults to 100 (metres in our case as all data is 
in metres).

The easiest way to reset a view so that you can see all of the data is to click LB on Fit from the View 
Button Area.

Try clicking LB on In and Out icons 

and observe what is happening. You eye is moving 
inwards or outwards from the data.

Also try Up, Down, Left and Right. icon
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6.10 Orbit
The Orbit is another way to orient your eye in relation to your data when manipulating a Perspective view.

The Orbit option is accessed from the View Buttons Area. Click LB on the Orbit button in the View 
Button Area of Perspective OpenGL 2. 

By holding LB down and moving your cursor around you will see the effect Orbit has.

The centre of the Orbit is displayed on view 2 as a white circle

The Orbit axis is shown at the bottom left corner to indicate the positive X, Y and Z directions.

A message with the instructions for Orbit is also written to the Screen Message Area.

So try holding MB down and moving your cursor around and then holding RB down and moving your 
cursor around.

Notice there are also key commands w, a, s, d and f. Plus <Esc> to terminate Orbit.

If you had created a Perspective view instead of a Perspective OpenGL view, you will not see the 
coordinate axes.

You can use either a Perspective 2 or a Perspective OpenGl 2 in the training and if there is any major 
difference then it will be pointed out.

Orbit

Centre of the Orbit

Positive xyz axes 
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6.11 Plan Camera
The Camera button links the Perspective view to all the unminimised Plan views (we’ll refer to them as 
just the Plan views).

The Camera (Eye point) and Target point for the current perspective settings of the Perspective view are 
displayed as icons in the unminimised Plan view and moving the Camera and Target icons around in a Plan 
view controls the perspective settings for the linked Perspective view.

Click LB on the Camera button in the View Button Area of Perspective OpenGL 2 and the Plan Camera 
panel appears. This panel displays which Perspective view the Plan Camera is running for and the colour 
of the Camera and Target icons.

Select the colour magenta in the Colour field to display the camera and target, and then select Set.

Important note - leave the Plan Camera panel up because the option terminates when the panel is 
finished.

The camera and target that define the perspective view are now shown in all visible Plan views. You may 
have to zoom out to see them both.

Holding down LB on either the Camera or Target icons and moving them around in a Plan view 
dynamically changes the settings for the Perspective view.

camera position

target

Camera

camera
target

camera position

target
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Move both the camera and the target around in the view to see how the Perspective view is linked to the 
Plan views.

Notice that if you have the Plan Camera panel up with the camera and target icons showing and then 
perform any operation on the Perspective view to change the perspective settings, then the camera and 
target icons will move to reflect the new perspective settings. For example, using Fit, Zoom, Pan or Orbit.

However after the other operations are completed, you will need to select the Set button again on the Plan 
Camera panel to be able to select and move the Camera and Target icons around.

When the Plan Camera panel is finished, the Camera and target icons are removed form the Plan views.

Note

If you have more than one Perspective view then you can have a set of Camera and Target icons for each of 
Perspective view and each set will be displayed on all visible Plan views. To avoid confusion between the 
Camera-Target sets, use a different colour for each set.

Although the Camera and Target icon sets are all visible, only one of them is can be active (and hence can 
be moved around) at the one time. To make set active, click on the Set button on the Plan Camera panel 
for that Camera-Target set.
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6.12 Fast Meshes in Perspective view
We will now see how to quickly display the TIN in mesh form. 

From the Perspective View menu, click LB on Toggle =>Tin mesh. You should see a coarse rectangular 
grid of red and green mesh lines appear. 

The appearance of the mesh can be improved by reducing the mesh spacing. 

Click LB on the Menu button in the View Button Area of the Perspective OpenGL 2 view and then click 
LB on Settings => Tins =>Mesh. The following panel will pop up.

Change the settings to those shown in the 
panel. Change the mesh spacing from 100 to 
10 in both x and y directions and bold x and 
y spacing from 1000 to 100. Click LB on 
Set to activate the settings.

You will notice that the Mesh can be turned 
ON and OFF from either the Draw triangles 
mesh tick box in the panel or from the View 
menu via the Toggle =>Tin Mesh switch.
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Click LB on Finish to terminate the Mesh settings panel.

The effect of the creeks superimposed on the TIN (shown above) is created by turning on the survey 
SURFACE model. 

Click LB on the + sign button in the View Button Area and double click LB on survey SURFACE.

Note that 12d always displays the models in the order that they are turned on with the + and - buttons. Thus 
to get the effect of survey SURFACE (and any other models) superimposed on your TIN, you first turn all 
models off, then turn the TIN on first and then any other models to be superimposed last. 

The drawing order on a view can also be modified by using the option from the View Menu 
Models =>Model order
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 Note that the Models walk right menu has a number of useful options, too many to have as button in the 
View Button Area.

For example Models =>Remove all models is a fast way to turn all models off.

The perspective view orientation will stay as it is unless changed by further Joy or equivalent perspective 
view operations. 

Toggle off the tin mesh via Toggle =>Tin Mesh.
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6.13 Fast Contours in Perspective Views
Sometimes it is useful to display contours in perspective views. 

You do this using the Toggle button like we did for the Plan view - simply click LB on Toggle =>Tin 
Contours.
 

The contour spacing and colours of the Perspective view can be changed just as we did before in the Plan 
view. This time however you would click LB on the Menu button in the View Button Area of the 
Perspective Open GL 2 view. 

As before then click LB on Settings =>Tins =>Contours. See 6.5 Fast Contours  on page 80. for more 
details. 

Click Toggle =>Tin contours again to revert to the green triangles display.
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6.14 Shaded Views
It is also useful to view a perspective as a colour shaded view or simple triangle view. 

In the default shaded view, the angle that each triangle makes with the sun (a point light source at infinity) 
is used to define a different shade of green. The angle of the Sun can be varied but 45 degrees (the default) 
gives the maximum contrast.

To quickly toggle tin shading on or off in the perspective view, simply click LB on Toggle =>Shade. 

Toggle the shading back on. 
To access the Shade View panel to modify the shade settings, click LB on the Menu button in the View 
Button Area of ‘Perspective OpenGL 2 and then click LB on Settings =>Shade.

Now every time the view is refreshed or the view changed, the shaded view will reappear. 

To get back to a green triangles rather than a shaded view, click LB on Toggle =>Shade to toggle the shade 
off. 

Clicking LB in the Shade tins tick box will toggle on and 
off the shading. A tick indicates the shade is activated.

Click LB on Set to create the shaded view. 

All TINs in the view will be shaded using the faces in order 
furthest to nearest the viewer. This has the effect of 
removing faces that are hidden from view.

Click LB on Finish to terminate the panel.
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7 String Picking Concepts
We will now investigate picking concepts and how the mouse is used to interact with 12d when pointing to 
and selecting items on your screen. Initially, do all picking (i.e. mouse clicking) with the LB. This uses the 
12d Model Tentative pick. Later we will look at Fast picking using MB (F snap) and Fast Accept (A snap).

In Plan View 1 turn on all the models except the triangulation (tin GROUND).

Check that Point snap, Line snap, Cursor snap and Info are on, and Fast pick and Fast Snaps cad accept  
snap are both turned off.

Zoom in to the left dam. Your overall screen layout including the ‘Plan 1’ view should now look as shown 
below.

Whilst the string picking concepts are used throughout 12d, especially during construction of design 
features where we want to connect into existing geometry, we will learn about them by example through 
the relatively simple String Inquire feature.

Fast pick off        Fast Snaps cad accept offPoint snap on Line snap on

Info on    Cursor snap on
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7.1 String Inquire
String Inquire is used to inquire and view the details of a typical line (i.e. string) that is already present in 
the View. From the Main menu, click LB on Strings=>Inquire to bring up the following panel. 

NOTE: the String Inquire panel can also be brought up by pressing the F2 key. This has been defined in 
the standard 12d Model function key short cuts (userkeys.4d).

Click LB on Pick and then move the cursor anywhere 
over one of the bank strings and click LB (press and 
release LB).

If you placed the cursor over a line segment 
between two vertices:

you should see the string go off yellow  and 
an off yellow square box appear at the 
location where you clicked LB. 

If you placed the cursor over a vertex at the 
end of a line segments: 

if you happened to snap to a vertex rather 
than a segment, you will see the string go 
off yellow and an off yellow diamond 
appear at the location where you clicked 
LB.
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The last pick couldn’t find any more strings to snap to (adjacent strings were outside snapping distance) 
and so no more information panels popped up. Instead, a circle showed at the pick location to indicate that 
a snap to the cursor location had occurred. That is, the only thing that 12d could find at the pick location 
was the cursor.

The above sequence will only happen this way if Point, Line and Cursor snaps are on. See below for more 
about snap settings.

Now if click LB a number of times on the same string without moving your cursor, you will end up getting 
the light yellow circle indicating a cursor snap.

The reason for this is that when you click LB the first time, 12d finds all the strings and pick types in the 
picking distance of the cursor and highlights the closest string with the closest pick type.

If you click LB again without moving the cursor, the next closest string and pick type is displayed. And 
if click LB again, the next closest string and pick type is displayed. This continues until there are no strings 
left that have not been rejected by clicking LB again.

The purpose of this behaviour is so that if there are (say) three lines on top of the other, it is possible to 
sequentially snap to each one in turn by looking at the Information panel details as you perform each LB 
mouse click. Even with the one string, the closest snap point may be a line snap, and when you click again 
you may get a Point snap on the same string.

 The fact that we could only snap to one string confirms that there is only one string present at this location.

A quick method of restarting a pick sequence is to move the mouse (i.e. cursor) a short distance from the 
last pick point. The picking mechanism is then reset and all strings can then be picked again. 

The next section shows how the mouse buttons can also be used to restart a pick sequence.

To terminate the String Inquire, click LB on Finish in the String Inquire panel.

In either case, an Information panel will pop up as shown at right 
(provided the Info snap is ON - See 7.4 Snap Settings  on 
page 99.). It reports such information as the name of the Model which 
contains the selected string (survey SURFACE), the string name (SF 
TOP), the type of string (Super), colour and linestyle. The number of 
points in the line are also returned along with it’s length. 

The x, y and z coordinates are those of the string where the pick 
occurred. And in this case the panel shows that the string was accessed 
via a Point snap.

If you move the cursor away from the string and pick with the LB again, 
you will notice that the Information panel changes, the string goes back 
to its original orange colour and the cursor is now replaced with an off 
yellow circle. 

This sequence may seem 
strange at first. What has 
happened is that the first 
pick located a string within 
snapping distance of the 
cursor so the string 
highlighted in light yellow 
and the Information panel for this string popped up. The pick 
location showed a diamond to indicate that a snap to the nearest 
vertex had occurred. 12d is in effect asking you ‘Is this the string 
you want?’. To reject the currently highlighted string, without 
moving your mouse, simply pick with LB again.
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7.2 Use of Mouse Buttons and Enter Key when using Tentative Picking
The three mouse buttons and the Enter key all have a function when picking strings. Those functions are

LB - Left Button Select the nearest string

MB - Middle button Accept the current highlighted string. This will also terminate the

current pick sequence.

RB - Right button Bring up the Pick Ops menu

Enter key (<Enter> Accept the current highlighted string. This will also terminate the

current pick sequence. This is the same as MB and is very useful if

you only have a two-button mouse (not advisable).

7.3 Pick Operations Menu via the Right Mouse Button
We will now focus on the use of the RB. Repeat the above picking sequence but now after getting the 
yellow square cursor (i.e. picking the string), click the RB and the Pick Ops menu will pop up

The Accept menu item needs special mention. During a picking sequence, once you have located the string 
you are after, you normally terminate the sequence by clicking the MB. This accepts the current string and 
terminates the pick sequence. 

The Accept menu item has the same function as clicking the MB during the pick sequence i.e. it is used to 
indicate to 12d that the string found is the one that you wanted. If you are using a 2-button mouse, this is 
another way around the lack of the middle button (using <Enter> for accepting was described in the 
previous section). You can accept a string by using the RB to bring up the Pick Ops menu and click LB on 
Accept. If you have a 3-button mouse, it is easier to use the MB to accept the string directly.

The Info menu item also has a special function. The Information panel that pops up when a string 
highlights is only displayed temporarily. If you move the mouse cursor a small distance, the information 
panel will disappear. This occurs even of you don’t click any mouse buttons. The Info menu item is used to 
pop up the Information panel (again) for the currently highlighted string.

The Cancel menu item is used to terminate many of the operations that are recursive. For instance when 
creating a string, 12d assumes that it will involve multiple line segments so it stays in create mode after 
each segment is placed. After the last point on the string is placed, use the RB to pop up the Pick Ops menu 
and click LB on Cancel to terminate the creation.

Click with LB on Restart. This resets the pick sequence to start over as if the 
previous pick sequence had never occurred. 

If you now click on the string with LB, you will notice that the string can now be 
picked again with the LB. The lesson here is that if you ever get confused during a 
picking sequence, the picking operation can be reset and start over again by either 
moving the cursor a given distance or click RB to bring up the Pick Ops menu and 
select Restart.
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7.4 Snap Settings
In the context of String Inquire, the snap settings are used to selectively choose from 12d data sets when 
inquiring on existing items. The snap settings can be toggled on and off from the snaps toolbar.

If you are new to 12d, it is easiest to first start using the full snaps menu until you get used to the 
abbreviations in the Snaps toolbar.

To bring up the full Snaps menu, click LB on Utilities=>Snaps=>Snaps.

On the Snaps menu, at any one time each snap setting is toggled either ON or OFF. If a tick appears, the 
snap setting is toggled ON. The settings shown are the default settings when starting 12d.

To change a snap setting, click LB anywhere from the snap name text to the snap tick box. The setting will 
toggle ON or OFF.

As shown above, it is possible to have multiple snap settings on simultaneously. For instance, if you want 
to be able to select a string on either the segments of the string, or the vertices of the string (the ends of the 
segments), you need both Point and Line snap ON.

You can generally leave Cursor snap ON. Most times, if all other snaps fail or are not set, you want the 
mouse cursor position returned. This is useful when free handing into 12d strings that are not connected to 
existing features e.g. the centreline of a new road. If you don’t have Cursor Snap ON, you will get a Failed 
Snap error message whenever all other snap settings fail.

Near the bottom of the Snaps menu is an Information tick box labelled Info. If this box is NOT ticked, the 
Information panel will NOT pop up as each string is selected.

Above the Information tick box is the menu item Pt tolerance 10. This figure indicates the current point 
snap tolerance setting is 10. To change the snap setting, click on Pt tolerance 10 with LB and the 
following panel pops up

Snaps toolbar

At this stage we will focus on 4 of the first 6 boxes: Point, Line, Grid and Cursor. 
Upon a successful snap, each snap type returns a unique appearance.

Point Snap - diamond 
Snaps to the nearest point or end of line

Line Snap - square 
Snaps to the nearest line

Grid Snap - circle 
Snaps to the nearest grid intersection point

Cursor Snap – circle
Snaps to the mouse cursor (x,y) position. This is used when drawing freehand.

The point snap tolerance is measured in screen pixels. 
In 1024 resolution, a point snap tolerance of 10 
represents about one hundredth of your screen width. If 
point snap is set, then the closest vertex within this 
distance of the cursor will be selected.
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To change the tolerance, lock the cursor in the Tolerance field by highlighting (double clicking on) the 
existing text, press <Delete> and type a new Tolerance value. Click LB on Set to activate the new setting. 
Click on Finish to terminate the panel.

Similarly for the Tolerance menu item - click on Tolerance and the Snap Tolerance panel pops up

NOTE - When Point snap is set on, any vertex of a string within the point snap tolerance box around the 
cursor when LB is clicked, is considered for selection before any other type of snap is considered. Centres 
of circles, centres of arcs and arc end points are considered to be vertices.

When Line snap is set on, the cursor only needs to be within the snap tolerance distance of any visible 
segment of a string when LB is clicked, and that string is considered for selection. Also arcs and circles are 
considered for selection.

In the area between the point snap box and the snap box, vertices and line snap positions are treated 
equally and the closest one to the cursor is selected.

As you use 12d0, you need quick access to turning snaps on and off but it is not that often that you need to 
change the other settings. So rather than having the large Snaps menu on display at all times, the Snaps 
toolbar and Snaps (Vertical) menus are available as abbreviated forms of the full Snaps menu. They take 
up less room on your screen and hence are useful to the experienced user.

The Snaps toolbar is normally in the top section of the screen, but if it has been deleted then it can be 
brought back again by clicking on View =>Toolbars to bring up the Customize Toolbars panel and ticking on 
H (for Horizontal snaps). 

snap tolerance

point snap
tolerance

line snap position

this vertex is selected rather
than the line snap position
because it is inside the
point snap box

Point Snap Box and Snap Box

Scroll down until 
the H tick box is 
visible and then 
turn it to to tick
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The Snaps toolbar will then appear on the screen

Similarly selecting Utilities =>Snaps =>Snaps (vert) on the Main Menu will bring up a Vertical snaps 
menu. Unlike the Snaps toolbar, the Snaps Vertical menu can not be docked.

At any one time each snap setting is toggled either ON or OFF. For the Snaps toolbar and the Snaps 
Vertical menu, the snap setting is OFF when the button is depressed or appears clear and ON when the 
button appears raised or blue.

To practice this further, do a Fit on your current View. Pick a feature in the view where lots of lines meet 
and without moving the mouse, do a series of String Inquires by repeated use of the LB and observe how 
12d will snap to adjacent items near to the mouse cursor. Note the cursor shapes returned that indicate that 
sometimes you are getting a Point snap and sometimes a Line snap.

Remember points are just a special type of string.

Point
Line
Text
Grid

Cursor
Height

Tin
Segment

Info
Data tip

Fast pick
Fast accept

Fast snaps cad accept
Lists all strings within 

snap tolerance

Snaps toolbar

Snaps Vertical menu
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7.5 Models and Snap Settings
Whilst it may appear obvious, it is important to remember that you can only snap to data that is currently 
on display. Models that are currently turned off will not participate in the selection process during 
snapping. If you find that you are snapping to unwanted items, consider turning off models that are 
irrelevant to your current operations

7.6 Fast Picking Snap (Q)
If Fast Pick Snap (Q) is on, instead of clicking LB to select a string, click MB or press <enter>, and the 
nearest string to the cursor satisfying the snap conditions is selected.

Hence using MB alone replaces a LB followed by an MB.

Note: If you are using Q snap then you get the first string only.

7.7 Fast Accept Snap (A)
If Fast Accept (A) snap is on, then if there is only one string that satisfies the snap conditions, then that 
string is automatically accepted.
However if there is more than one string then the normal snap selection is followed.

Note: A snap is a good compromise - if there is only one possible string then it is immediately accepted. If 
there is more than one possible string, then you get the choice to select which one.
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7.8 Modifying the String Highlighting Colour
12d has various default parameters for the display of data including the string highlighting colour. This is 
the colour a string is changed to whilst it is selected. 

The default highlight colour is white but this is not be very useful if you want to draw strings in white, or if 
you use a white background colour. In either case, it is important to change the highlight colour to a colour 
other than the white.

To check the highlight colour for the project, we select from the main menu Project => Management => 
Defaults and the Defaults panel pops up.

From this panel, the user can change various parameters for this project that 12d uses for calculations, 
display and data handling.

To change the default highlight colour, select the Systems Settings tab by clicking LB on the Systems 
Settings tab.
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The following panel should appear:

Note that the Highlight colour is set to off yellow.

To change this, LB click on the colour icon adjacent to the Highlight colour input box and select another 
colour such as cyan from the colour choice box. Then press Select on the colour choice box panel. Colours 
can more quickly be selected from the choice box by double clicking LB on the desired colour - the Select 
button is not required. 

To set the current values for the defaults press the Set button.

NOTE: When a new project is created, the values in the Defaults panel are loaded from the set-ups file 
defaults.4d which 12d Model looks for on start up in the standard 12d location (for more information on 
the search order, see 40.2.7.3 Defaults File (defaults.4d) in 40 Setting Up & Configuring 12d in the 
context sensitive 12d Model Reference manual). For an existing project, all the values in the Defaults 
panel are saved with the project so if any have been changed in the project after the project was first 
created, then the defaults for the project will differ from those in the defaults.4d file.

If you wish to keep the current defaults for a project to use as the initial defaults for future new projects, 
you can save the file defaults.4d to a suitable location by clicking on the defaults.4d tab and then the 
Write defaults button to bring up the Write Setup File "defaults.4d"panel. 
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Specify where you wish the defaults.4d file to be saved and then click on Write.

In this example select Current folder. If you wanted the changes to apply to any new project you create 
then you would select User folder and it would save the changes to the User folder.

Click on Finish to close the Write Setup File "defaults.4d" panel, and then Finish on the Defaults panel.
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8 Creating Strings with CAD
We will now investigate creating strings using the CAD options. We will create points (one point strings), a 2 
point line (single segment string) and a line string (multiple segments in the string).

First we will create a new plan view to work in.

From the main menu, click LB on Views =>New =>Plan. This will create View Plan 3.

Maximise the view by clicking on the Maximise icon on the top right hand corner of the view or by double 
clicking on the plan view title area.

8.1 Creating Points
The CAD options to create points, lines etc can be done by using the main menu system or by the use of the 
CAD toolbar, which is displayed on the left of the screen at start-up. Regardless of the method used to 
activate the CAD commands, the CAD controlbar as outlined on in 3.5 Toolbars and Controlbars  on 
page 26.will be used to define the characteristics of the created elements. We will change the values in the 
controlbar as follows.

Click LB in the model field and type in CAD. Click LB on the colour icon and choose the colour red from the 
choice box by double clicking on red in the pop-up list of colours. Enter 20 into the height box and leave the 
linestyle type as 1.

Note: We are only using red because it will show up on a white background in the images. Use whatever 
colour you prefer.

To create a point string (i.e. one vertex string) we will use the CAD toolbar flyout. Pick the points section of 
the toolbar by clicking LB over the CAD Point symbol and keep LB depressed.

The points flyout menu is displayed which has all the options in the points section of the CAD creation tools. 
This is displayed as a horizontal bar consisting of all the icons that make up all the options in the points section 
of the CAD tools. Whilst holding down LB move the cursor over each of the icons and the tooltip function 
tells what each of the options does. 

To select an option, keep the LB depressed until the cursor is placed over the specific option you want and 
then release the LB. We will select the Point option which is the first icon in the flyout.

     Minimise      Maximise

 Close

               model                                                height                                      weight                     same as

name                                              colour                                        linestyle                         tinability
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On selecting the Point option, or any other CAD option, the user is prompted for the relevant data in the 
screen message box located on the bottom left hand corner of the 12d Model application window

The user can select a position with the mouse and on accepting that point (Middle mouse button or enter) 
the point is created at the selected position. The model, colour, height etc. are defined in the   Cad 
Controlbar.

The snap mode will influence the mouse selection. For example if Cursor snap is on, the user can choose a 
position not yet defined. If Point snap is on and the selection snaps to an existing point, the option will 
place another point at that location. 

Ensure that the Cursor snap is activated in the Snaps toolbar. Click LB at a position roughly in the middle 
of the view.
 

 Click MB. The point is then created with the model CAD being added to the view automatically.

To see the height of the point we must toggle on the Z values. To do this click LB on the toggle button on 
the view menu to bring up the toggle menu. Then click LB on the Z values [off] position. 

Don’t walk right on the arrow near this position - this is to specify individual models to turn the Z values 
on or off. By clicking LB on the Toggle menu, you turn on (or off) all Z values in that view for all models.

      Message area
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The default colour for the height text is yellow but to make it clearer on our white background, we will 
change the text colour to red (as depicted in the image above).

To change the colour of the height text, click LB on the menu icon from the Plan 3 View menu to bring up 
the Plan View menu. From that menu click LB on Settings =>Z values =>Single to bring up the 
Z Values for Plan View panel. 

From this panel, for the Draw textstyle data field, select the Textstyle Data icon and then click on [Edit].

The Z value is shown near 
the point that we created. 

Click LB on 
Z values

Click on [Edit]
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:

Change the Colour field to red and then click Set and Finish to close the panel. 

Finally click Set on the Z Values for Plan View panel and Finish to close the panel. The colour of the 
height text will then be red.

The change is made only for View 3 and when any other points are added to the view, they will also have 
their height text shown in red. 

There are various ways of selecting a position when creating a point. For the first point we just selected 
anywhere on the view.

Specification of a position can also be done by the direct input of the xyz coordinate of the point.

Select CAD Point again to begin creating a new point and when over the view either press the space bar or 
start typing the x value and the Enter XYZ panel will come up. 

The user then enter the X, Y and Z values into the box each value separated by a space. e.g. 200 150 40. As 
we have already set a Z value in the CAD controlbar, you only have to specify a X and Y value into the 
box. NOTE: The Z value will default to the value entered into the CAD controlbar whether or not it is 
specified in the XYZ box. If no height value exists in the CAD controlbar or the XYZ box, then a value 
will be interpolated if possible, otherwise a 0 value will be assigned.

We will again create a point by using the CAD toolbar. 

Firstly, change the Z value in the CAD controlbar to 50. Then repeat the steps outlined above to choose 
the CAD Point option. Instead of selecting a point with the mouse we will type in the coordinate values. 

To pop up the XYZ box, press the spacebar. Then type into the box, 200 100 and then press <Enter>. We 
did not have to specify a Z value in XYZ box as it was already defined in the CAD controlbar. NOTE: A 
space must be placed between the X and Y values.

A new point is created. Click LB on the Fit icon on the view menu  to fit the data in the view.

It should now look like as shown below:
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8.2 Creating Two Point Lines
We will now create a simple one segment line. To do this we will again use the CAD toolbar but this time 
use the CAD Line flyout. 

Pick the Cad Line section of the toolbar by clicking LB over the CAD Line symbol and keep LB 
depressed.
The Cad Line flyout menu is displayed which has all the options in the lines section of the CAD creation 

tool. Select the 2 points option which is the first icon in the flyout.

On selecting the 2 points option, the user is prompted for the relevant data in the screen message box 
located on the bottom left hand corner of the 12d Model application window

We will pick a position with the mouse to define the start of the line. Pick a position with LB about 
halfway between the two existing points and then MB to accept. After accepting the start point, the user is 
told in the message area to pick the second position (the end of the line). You will also notice when you 
move the mouse around that a line is drawn rubber banding to the cursor position. 

We now select a point going south east to define the end of the string with LB and MB to accept. The 
created string will be shown using the parameters given in the CAD controlbar at the time of construction. 

Message 
area
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8.3 Creating Line Strings
We will now create a multi-segment string. 

Although we could use Line String option on the CAD Line flyout, this time we will use the CAD menu 
from the Main Menu system rather than from the CAD toolbar 

From the Main Menu, click LB on Cad =>Line =>Line string. The Line String option will now be 
running. NOTE: These CAD options have no panels. 

On selecting Line String the user is prompted for the relevant data in the screen message box located on the 
bottom left hand corner of the 12d Model application window

We will pick a position with the mouse to define the start of the line.

Pick a position with LB any where on the view and accept with MB. Then move the cursor to a new 
position and pick and accept a second point. Pick and accept a third point and so on. 

To finish the string simply press <Esc> on the keyboard, or alternatively RB to bring up the Pick Ops 
menu and then select Cancel from it

The string will be created using the parameters given in the CAD Controlbar at the time of construction. 

This has given a small introduction to the use of the CAD options. For a more detailed explanation of these 
tools see the chapter CAD in the 12d Model Reference manual.

We will now finish this section by deleting the current view. As the view is maximised, select 
View =>Delete and select view 3. Alternatively, we could have restored the view and clicked LB on the X 
icon at the top right of the view. 

This should then leave two views, Plan 1 and Perspective 2. If either Plan 1 or Perspective 2 are left 
maximised, select the restore button on the top right hand side of that view to leave two views as they were 
at the start of this chapter.

Message area
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Clear the value for the default height in the Cad Controlbar. Leaving the height there may create problems 
when creating strings at a later stage. Also change the default model to one of the existing survey models 
as we will be deleting the CAD model and don’t want it being created again.

Finally, to delete the CAD model click LB on the Delete model option from the Main Menu 
Models =>Delete =>Delete a Model. 

This brings up the Delete Model panel

. 

Select the Model icon with LB and then double click LB on CAD. 

Tick on Permanently delete? and then click on the Delete button, and answer Yes to the confirmation 
panel for Delete Model. 

This deletes the model from the project.
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9 Survey Data Reduction

9.1 Coding

9.1.1Feature Codes
Feature codes and attributes are used to define surveyed points in the field. The code and attribute will be 
used to assign properties such as model name, colour, symbol and linestyle via a mapping file which will 
be discussed in detail later in the training (a mapping file is created and edited by the option File =>Map  
files =>Create/edit).

9.1.2Field Codes
Field codes are used to enhance the effect of feature codes. 

Field codes are defined for each data collector and are set up in the Survey.4d Create/Edit panel.

We will look at how to bring up this panel later (see 9.4.1 Creating/Checking/Modifying a 12d Data 
Collector Definition  on page 125)

In the Survey.4d Create/Edit panel, Field Coding 
is set up under the panel tabs: Templating, 
Shapes, Pipes/Culverts, Non Tinable, Feature 
Coding, Non Visible, Strings, Others and 
Features

The Field codes are user definable and can be any 
letters. It is advisable to ensure that the codes 
used are not the same as feature codes.

A list of Field codes can be found in the 
Reference manual.
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9.1.3String numbers
Numbers can be used to differentiate separate strings using the same code.

.

.

The string number position is 
specified under the Survey 
Data Setup menu under the 
Feature Coding tab 

String numbers may be 
omitted and a New String 
command can be included 
after the code. This is set 
up under the Strings tab
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9.1.4Delimiters
There are a number of delimiters used in 12d. Two commonly used ones are the code delimiter and the 
comment delimiter.

A Comment delimiter (space) 
is used to separate a feature 
code from a text description 

A code delimiter (*) is used to 
separate multiple feature 
codes and/or feature codes 
and field codes

The Delimiters can be defined 
under the delimiters tab of 
the Survey Data Setup menu
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9.1.5Attributes
Attributes are used to minimise the number of codes. For example a single code TREE can use attributes to 
define the species, trunk diameter and foliage size 

In the example Data collectoscreeshowabotheattribdss
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9.2 Setting up a New Project
Before we can reduce the survey data, we first we need to create a project to read the survey data into. We 
will create a new project called DETAIL SURVEY in the Survey Getting Started training area

C:\12d\14.00\Training\survey\getting started

Click on the New tab

For the Folder name field, select the Folder icon then browse to folder 

C:\12d\14.00\Training\survey\getting started

To create the new project, first, double 
click on the 12d Model 12 icon to bring up 
the Project Selection panel.

Type in DETAIL SURVEY 
for the Project name

Ensure Create Working 
Folder is ticked

Now select the New button to and 
the new project is created and 
opened.
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9.2.1Screen Setup
When the project starts up for the first time 
the Setup Project Details panel appears

The information typed in here can be used 
when plotting from this project

Fill in the values as required

Select Set then Finish to save the settings 
and continue

Maximise the plan view 1

Move the Recalc panel to the 
bottom left

If the Output window tab is 
highlighted blue you can move the 
cursor over the tab to display the 
error message if any. Normally 
when creating a new project there 
are optional files that are not found.
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9.2.2Project diary
It is useful to keep a record of operations performed in the project. 

Select option Project =>Details =>Diary

or select Diary icon from Project Managenat toolbar

Click on New

Type the details into the panel 

Select Save to save the typed input

Select Save and then Finish to exit the Diary panel 
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9.3 Survey Control Station Coordinate entry
Coordinates for the survey stations can be stored in the data collector file or created in the project by a 
number of methods. For this example we will read in an ascii file containing the Control Station 
coordinates. 

Select the option File =>Input 12d 

 

Select the File to read folder icon

Browse up one level to the folder 
C:\12d\14.00\Training\survey\getting started

Select the file SURVEY STATIONS.12da

Click Read and the Control station points will appear on a newly created view called DATA IMPORT

Note that the points for the 
stations will appear as the 
triangle symbol (Triangle-point) 
or just a plain cross depending 
on how far you have zoomed in 
or out on the plan view.
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Delete view DATA IMPORT and then add the model SURVEY MARKS to Plan view 1

The station names have 
been stored as Point id’s 
(Vertex id’s).

To display the Point id’s 
on the Plan view, select 
the Toggle icon then 
select Point id’s.

The Point id for each 
vertex will be drawn 
next to it.
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P

9.4 Data collection reduction

The raw survey data is either

(a)  downloaded from an instrument

or

(b) copied to the computer via a Memory storage device.

The reduction of the 
data collector file is 
handled under the 
Survey menu or the 
Survey reductions 
flyout toolbar
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9.4.1Creating/Checking/Modifying a 12d Data Collector Definition
To allow for a variety of data collectors and coding methodologies, 12d Model allows you to save a user-
specified set of data collector parameters away under a user supplied name

The data collectors defined within 12d Model include such information as:

(a) Instrument name, extension for the raw file and vertical circle information.

(b) Position of the feature code, tinability code and number of digits in the numeric code.

(c) Delimiters for commands, comments, offset codes, backsight and foresights, check measurements

(d) Field template codes.

(e) Communication settings for uploading and downloading.

(f) Coding for arcs, rectangles, closing strings, pipes and culverts.

Creating new or modifying existing 12d data collectors can be done by picking the Survey Setup Data 
icon

 or by using the option Project => Tree =>Survey Data Collectors 

We will use the option Project => Tree for this example

Select the + beside Survey data collectors to see the list of existing data collectors.

Double click on Create data collector to create a new 12d data collector definition, or double click on an 
existing data collector in the list to examine or modify it. The Survey.4d Create/Edit panel will then 
appear. 
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The example below is shown when selecting the Sokkia Feature String data collector type

To edit any of the parameters in the Survey.4d file 
select the relevant tab and change the values.

To save the edited file select Set and then Write 

Select Current folder to store the file survey.4d in 
the local working folder for use in this project only

Select Write then Finish

Select Finish back in the Survey.4d Create /Edit 
panel 

Select Finish back in the Project Tree panel 
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9.4.2Selecting the Data Recorder type
Select Survey=>Setup or Data Collector Setup icon

Select the Data collector choice icon then double click on the data 
collector Sokkia Feature String

Select Set and then Finish.
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9.4.3Downloading a Raw Survey File from an Instrument
The raw survey file we require for the training is already on the computer and does not have to be 
downloaded from a survey instrument. But for completeness, this section shows you how to download a 
raw survey file from an instrument. 

For the actual training, you can skip this section and go straight to the next section 9.4.4 Converting a 
Raw File to a 12d Field File  on page 129 where we use a file that has already been downloaded.

After doing a typical survey job, the raw file for the survey would still be in the data collector and would 
need to be downloaded using the following procedure:

Select Survey=>Download raw or the Survey Data Download icon

NOTE - you must have a data collector attached to the nominated COM port to be able to download data

The 12d Model Comms Download panel is automatically placed on the screen to display messages for the 
download.

The raw file is downloaded and the field file is created. Both the raw file and the 12d field file are stored in 
the working folder. In this project the working folder is 

C:\12d\14.00\Training\survey\getting started\DETAIL SURVEY

The values for the communication parameters 
have come from the data collector definition 
Sokkia String Feature. 

If required, the communication parameters can be 
modified in the panel before commencing the 
download. For example, the Port is the port that 
you have the data collector connected to.

Type in a name for the created Field file.

Select Download to commence downloading.

                                       To stop the download press Stop

To restart the download press Reset                                  To finish the download select Finish
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9.4.4Converting a Raw File to a 12d Field File
 If the field data was not created when downloaded from a data collector then the raw survey data needs to 
be converted to a 12d Field File before reduction.

For this training example a raw survey data file SURVEY.sdr is already in the getting started folder, 
ready for converting.

However, in real situations, the raw survey data file may have been copied from a Memory card.

To convert a raw file, select Survey=>Convert Raw or Convert raw to field icon

The field file name SURVEY.fld will automatically be filled in or can be user defined.

To create the field file select Convert then Finish

This will convert the raw SDR file to the 12d field file format ready for reduction.

 Note: The list of raw survey files are expected to have the extension “.sdr” as specified in the data 
collector definition Sokkia Feature String. It is recommended that any files manually copied to the 
working folder have the correct extension. 

Click on the Raw file folder icon

Browse up a level to folder 
C:\12d\14.00\Training\survey\getting 
started and select the file SURVEY.sdr
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9.4.5Running the Survey Data Reduction Function
The field file will now be reduced in 12d Model using the Survey Data Reduction function. The function 
will link the field file to all relevant information needed to create the features surveyed in the field.

These would include items such as the Control model, Mapping file and Geodetic datum. 

Select Survey => Create => Field File or select Reduced Field File icon

Type in the Function name DETAIL 
SURVEY

Type in unknown for the model name 
for strings that have unrecognised 
feature codes.

Type in report file name DETAIL 
SURVEY (when pressing [Enter] the 
file is given the extension.rpt).

Under the Field Files tab the newly 
created field file SURVEY.fld is 
displayed as the default 
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Map file tab

Advanced tab

Others tab

Select the Map File tab

Select the map file GETTING STARTED 
SURVEY V14.mapfile from the folder 
C:\12d\14.00\Training\survey\getting started. 
This will be used to map the survey readings to 
their correct model and other features.

The reduced data can be separated from other 
surveyed data by using a prefix which goes in front 
of any model name created using the mapping file.

Select the Advanced tab

12d can either reduce the survey readings from 
station information within the field file or by 
specifying the model containing the survey 
station points. In this case we have read survey 
points existing in the project.

Select the Control model choice icon and then 
select the model name SURVEY MARKS

Select the Others tab

Tick Explode point strings check box to ensure 
individual survey points are kept separate from 
other points with the same code

Tick Show check measurements check box to 
display check measurements during the reduction

Select the Backsight prompt mode choice icon 
and select Prompt to pause the reductions as 
each backsight reading is reduced

Select Reduce to process the field file
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Yes will apply the swing to the following readings until the next Bearing Datum Difference panel appears.

Yes to all will apply the swing to the following readings and bypass all following panels using Yes as the 
default. This is not a good idea unless the file is being re-reduced

No will apply no swing to the following readings until the next Bearing Datum Difference panel appears.

No to all will apply no swing to the following readings and bypass all following panels using no as the 
default. This is not a good idea unless the file is being re-reduced

Edit is used to activate the field file editor to view the reading to the backsight point. This is useful if the 
wrong backsight point ID is entered. The new ID can be edited and the reduction continued

Cancel is used if there is a major problem with the reductions and the process has to be terminated in order 
to fix the error.

Note: By pressing Cancel the process stops at that point in the reduction and an incomplete survey 
may appear in the graphics

You have to rereduce the survey after pressing Cancel

For this exercise select Yes

Each time a Backsight 
measurement appears in the 
reduction a Bearing Datum 
Difference panel is displayed.

The user has a number of 
possible responses which are 
selected each time by the buttons 
under Apply Swing.
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Continue will close the panel and the processing continues until the next check reading is encountered.

Continue all will close the panel and the processing continues with all following Check Measurement 
panels not displayed. This is not a good idea unless the file is being rereduced

Edit is used to activate the field file to view the check reading to the point. This is useful if the wrong 
check point ID is entered. The new ID can be edited and the reduction continued

Cancel is used if there is a major problem with the reductions and the process has to be terminated in order 
to fix the error.

Note: By pressing Cancel the process stops at that point in the reduction and an incomplete survey may 
appear in the graphics

You have to rereduce the survey after pressing Cancel

For this exercise select Continue each time the panel appears.

NOTE - When the survey data is being reduced, the Bearing Datum Difference panel and Check 
Measurement panels come up a number of times.

When the reduction is finished don’t press Finish until the report file has been checked for errors.

And how to check for errors is shown in the next section 9.4.6 Checking the Report File for Reduction 
Errors  on page 134.

If check readings are taken to known 
points a Check Measurement panel 
is displayed

Again the user has a number of 
possible responses which are selected 
each time by the buttons Continue, 
Continue All, Edit and Cancel.
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9.4.6Checking the Report File for Reduction Errors
We will now check the report for any errors found by the reduction process. This should be done prior to 
any other editing

The file DETAIL SURVEY.rpt will then displayed in the default text editor.

Select the Report file choice 
icon

 

Select Open to display the 
report file in the default text 
editor.

If the Survey Data Reduction Function panel has 
accidentally been closed the file can be loaded 
into the text editor by selecting option

 Reports => Edit 

Click on DETAIL SURVEY.rpt.
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Scroll down through the report file checking for any problems or errors.

At the end of the file is the list of Unknown Feature Codes.

These are the feature codes that appeared in the field file SURVEY.fld but were not in the mapping file
.

This may or may not be an error as not all codes need to be in the mapfile.

If SFTOM was a code that we never use, then that would be an error. For example when SFTOM was 
entered in error for the code SFTOB. Or maybe SFTOM is a valid code but we forgot to enter it into the 
mapfile. In both of these cases we need to correct the error.

Or maybe SFTOM is a valid code and we didn’t want it in the mapfile. In this case there is no error.

Quit from the text editor. 

After the report file has been closed, the Survey Data Reduction Function panel can be Finished

SFTOM is a code found in the field file SURVEY.fld 
but was not found in the mapping file GETTING 
STARTED SURVEY V14.mapfile.
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9.5 Graphically Editing the Field File Data
The detail survey can be edited graphically whilst maintaining a dynamic link to the field file and the 
resulting report file. This ensures that if the field file is re-reduced any changes will be maintained.

9.5.1View the Survey Data

Add on all models featured in the 
survey by selecting Models to add 
icon

Highlight all of the models

Press Add

Otherwise simply select Add all
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With all the text turned on, the survey is hard to read

The toggled text can be given user defined settings to allow the text to be viewed only when zoomed in to a 
preset scale.

Select Toggle icon

Select Z values to 
display levels at 
vertices

Select String names 
to display names 
(codes) at vertices

Select Fit icon 
to display the 
entire survey
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9.5.2Setup your text screen settings
Zoom into an area with a lot of text displayed

Repeat for Name (Size 0.5) and Pt ID (Size 1) as shown in examples below.

.

Select the Plan View Properties icon

Select Zvalue and type in 0.5 [Enter] for the Size max

Expand the Toggle Branch
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Zoom all to see a clean view of the survey 
strings

As you zoom in the point id’s will appear first followed by the Z values and String names
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9.5.3Graphically Editing the Field File Data
As we move along the survey, errors are detected and need to be changed in the field file if possible.

There are options that can edit both the graphics and the field file but update the field file reduction after 
these edit

The Graphical edits are selected from the Survey=>Edit menu or the Survey reductions flyout toolbar on 
the cad toolbar

The toolbar will be pinned up at the top of the main menu

Select Views=>Toolbars

Tick the check box for Survey Reductions

Pin the Toolbar under the existing toolbars at the top left of the screen
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9.5.3.1Tiling field file editor with plan view

Open the field file editor using option Survey=>Edit=>Field data or select Edit field file icon 

Place the field file editor on the left side of the screen with the plan view 1 on the right

The advantage of having the field file editor active when editing the survey is the ability to reset any edits 
that are performed either graphically or directly into the field file editor.

Field file editor link to graphics

The pick icon shown above can be used to select a point in the graphics and if the point is associated with 
the field file function being edited then the relevant measurement line will be highlighted
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Alternatively once the Pick icon has been selected the point number can be typed in manually. This can be 
done by either typing in the point number or pressing [space] bar to activate the input panel then typing in 
the point number.

The Pan check box can be ticked so that any point 
highlighted in the field file will be the centre of the plan view

WARNING. Field file edits are different from manual cad edits and you must not edit the survey 
data with cad edits while performing field file edits. The reason for this is that after each field file 
edit the function is rerun and the edits are remembered by the function. Manual cad edits are not 
linked to the function and will be lost if the function is re-reduced. Duplicate data can also result in 
the incorrect use of cad edits while the field file reduction is running

The point number will be highlighted.

If the point was not in the initial window then 12d 
pans to the point centring it in the view

If the point was in the initial view then the point is 
highlighted only

Once the point is confirmed the point is shown in the 
field file editor
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9.5.3.2Find and Replace

When reducing the field file the code SFTOM was listed as incorrect in the report file

We will use the Find / Replace option in the field file editor to fix the error

Select Find/Replace icon

Type in the incorrect code 
listed in the report file

Type in the correct code 
SFTOP Select Find

The first occurrence of the incorrect code is found and highlighted. If you have the Pan check box 
ticked the view will move to that point. To replace the code select Replace. Select Replace once 
again. The rest of the string will be fixed with the next option

When the code is corrected the line in the field file is coloured magenta indicating that the 
reading has been changed.

We will look at the audit trail options in more detail later in this chapter
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9.5.3.3Changing codes

In addition to the Find/Replace option we can change a point’s code by simply locating the measurement in 
the field file editor and editing the point. We will go through the individual point edits later. In the mean time 
we will use a menu option to type in a new code or by matching another point with the required code

Select the option Survey=>Edit=>Coding=>Quick change or select Quick code edit icon 

Locate point 2739 (the next point on the SFTOP string)

Type in correct code SFTOP or by 
selecting the Sameas button and 
selecting a point with the required 
code

Tick on All points on string

Select Pick button then select the 
point to change

The function is rerun and the point 
now displays the properties of the new 
code.The relevant lines in the field file will also be highlighted magenta
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9.5.3.4Target heights

Another common error made during a detail survey is to incorrectly record the target height.

Instead of amending the level of the reduced point, a new target height can be entered into the field file 
reduction either manually or graphically

Select the option Survey=>Edit=>Target height=>Insert or select Insert target height icon 

Locate point 1044 by using the Pick icon in the field file editor

Select Pick button then select the 
first point with the incorrect target

The target height is displayed at the 
bottom of the panel. 

Type in the correct target height

If only one point has an incorrect 
target height then tick the Just one 
point wrong check box prior to 
selecting Set

Otherwise select Set

The function is rerun and the point 
now has the correct height. All 
subsequent points will also be 
updated until the next height of 
target line occurs 

In the field file a new line appears 
stating the target height.

The line will be highlighted blue
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9.5.3.5Reversing strings

If a string is surveyed in the wrong direction it can be reversed using the following option.

Select the option Survey=>Edit=>Stringing=>Reverse

 

Pick the string to reverse

The function is rerun and 
the string is reversed.

A Reverse string command 
will be inserted at the 
measurement line and this 
will be highlighted in blue
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9.5.3.6Re-order string

If a string has been surveyed incorrectly the string can be re-ordered using a number of options including 
Order by points

Zoom in to point 2357

In the example here the point 2357 has been 
surveyed in the wrong order. Rather than 
stopping the string to take a single reading at 
point 2358 we simply string to point 2358 and 
then 2359 and so on.

To re-order the string by points use the option 
Survey=>Edit=>Order=>by points

or Order by points icon

Select point 2356. Then pick point 2358. At this 
point the string order is correct when 
reprocessed.

If the string order is done incorrectly the original order can be reinstated using the option 

Survey=>Edit=>Order=>Remove

or Remove order icon

Pick on the string to restore the order and retry the ordering
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9.6 Direct Editing of the Field File
Although the previous options were graphical, each change has been recorded in the field file reduction.

Data in the field file 
that has been changed 
in any way is coloured 
magenta.

Data which has been 
entered directly into the 
field file or added via a 
command such as the 
Target Height option is 
coloured blue

This colour coding 
gives an audit trail of 
any field file editing
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9.6.1To Find data in the Field File
The find option gives the user a number of methods to find data in the field file

NOTE: You have to clear the current Find values before commencing a new search.

Select the Find icon
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Named

A search can be performed on data in the field file using filters Code, String number, Named point, 
Point number or attribute.

Type

A search can be performed on data in the field file given a particular command type. 

To search for an Arc Fitting Start command 

To search for point number 
2735

Select Named tab

Type in point number 2735

Select Find

The line in highlighted

This example is generally 
not used as the user can 
locate a point by simply 
clicking on the Find by 
Pick icon at the top of the 
panel and typing in the 
point number

Select Type tab               Select Command choice Arc fitting start
 

Select Find

The line in highlighted
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State

A search can be performed on data in the field file given a change of state including added, changed, 
deleted or field. To search for a changed state 

                                               Select State tab               Select Command choice Changed

Select Find

The line in highlighted
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9.6.1.1To Edit a Field File Line

Double click on the line in the Field File to edit.

A panel appears with editable fields

Any data can be changed

To set the changes press Apply. 

The field file reduction will rerun updating the graphics and the field file line will appear in 
a magenta colour.

Select Finish to save the change or select Reset to cancel the change and then Finish.
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9.6.1.2 To Insert a command

A command can be placed in the field file. Often any graphical field file edit can be substituted with an 
Insert command. 

To insert a Vertical circle correction put the cursor on the line below where entry is to be made

Press Insert icon Select the Command choice and select the Command

Vertical circle correction. Select Create

Type in the correction as 0.0020 as the 
decimal point is the degree marker and 
the minutes and seconds are typed 
together. Make sure you type in the 
trailing zeroes.

The correction is applied to all 
subsequent readings

Select Apply to insert the command

The command is inserted in to the field 
file editor and is highlighted blue

Select Finish
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9.6.1.3Deleting a Line

To delete a line in the field file put the cursor on the line to be deleted

Select the Delete icon

To undelete a line simply highlight the deleted line and select Delete again

You should now Delete the Vertical Collimation line created in the previous option

We can now finish editing the field file. Click on [Finish] to exit the editor

When a line of 
measured data is 
deleted a red cross is 
placed at the start of 
the line.

When the function is 
rerun, Backsight and 
Check measurement 
prompts will redisplay. 
Select Yes to all and 
Continue all to accept 
the default settings on 
the panels
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9.7 Printing the Report File
When the field file edits are complete print the Report file

.

 

The report file is displayed in your default text editor and can be printed to keep a record of the survey 
reductions

Select Report => Edit 

or Print Report icon
Page 155



12d Model Getting Started for Surveyors Manual
9.7.1Locking the Data Reduction Function
After all field file edits have been made it is important to ensure that the data reduction function can 
not be rerun.

This is because if any non-field file operations are performed on the reduced data and then the reduction is 
rerun, the non-field file operations may be lost

Once the function has been locked it can’t be rerun by mistake resulting in data integrity problems

To lock the Data reduction function

 Select Utilities=>Functions=>Lock

or Lock Function icon

Select the Lock Function choice icon and 
select the function name DETAIL SURVEY

                 Tick the Lock mode check box

Select Set and Finish

If the function is rerun, the following 
error message occurs
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9.8 Graphical Edits
We now edit the survey graphically to perform tasks either not available in the field file editor or in some 
case easier to do graphically.

Most of the options used in the following examples are duplicated under the Strings=>Cad menu

9.8.1Joining strings

9.8.1.1Join

Select Strings=>Strings Edit=>Join 

or Join icon

Points can be joined in a number of ways. 
The first type of join will result in two 
strings of the same type being combined 
into one string. If the two strings are 
different, then the resulting string uses the 
properties of the first string selected

Zoom in to point number 1232

This string will be joined to the string 
starting at point 2112

Hold down the left button and drag a short 
distance along the left string with 
direction towards point number 1232. 
Release the left button then select middle 
button to accept

Select the right string in the same way 
with direction away from point 2112 and 
accept

The strings are joined to make one string. 
In this case the string will require 
reversing which is explained later

Repeat for all of the other gaps in the 
survey where the two strings have the 
same properties and you are joining the 
ends (not joining from an end to a 
corner of a string)
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9.8.1.2Append

Select Strings=>Points Edit=>Append 

or Append icon 

This option is used to append 
the end of a string on to another 
point on a string

Zoom in to point number 1100

Select point 1116 and accept

Select point 1100 and accept

Press [Escape] to finish picking

The first strings is appended to 
point 1100
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9.8.1.3Cad Create Line

A line string taking its default properties from the Cad Controlbar can be created. This will create a 
single line string independent of the two points selected.

Firstly update the properties for the new string in the CadControl bar by selecting the name of the new 
string to be created

Select the Name icon and then navigate to 
the required name

Once selected the Cad Controlbar and Symbol Controlbar (if applicable) are setup up.
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Zoom in to point 1185

Select option Cad=>Lines=>2 points or select 2 points icon

Select point1185 and accept

Select point 1163 and accept

A new string is created between the two points
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9.8.1.4Close

If a gap appears between the end and the start point of a string then we join these points together (or close 
the string) to form a polygon. This option is also available in the field file editor. It should be noted that as 
many field file edits as possible should be used instead of manual edits as there is no audit trail in manual 
edits

Zoom in to point 1213

To close the string select option 
Strings=>Strings Edit=>Close

or the Close icon

 

Select anywhere along the string and 
accept. 

When inquiring on a closed string, the 
area is displayed in the information 
panel
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9.8.2Reverse String
If strings are created with the linestyle shown on the wrong side then the string can be reversed.

Zoom in to point 1238

Select option Strings=>String 
Edit=>Reverse

or Reverse icon

Select the string and accept

The string direction is reversed
Page 162



Chapter 9  Survey Data Reduction
9.8.3Add arc to curve
An arc can be placed in to a string by selecting the middle point of a 3 point curve.

Zoom in to point number 2286

Select option Strings=>Points 
Edit=>Add 3 Pt curve

or Insert 3-points Curve icon

Select point 2286 and accept

A curve is created
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9.9 Triangulation
The survey is almost ready to form a triangulation from the tinable data that is displayed in the view.

Ensure that all models are turned on in view 1.

9.9.1Check for Crossing Breaklines
Prior to forming the triangulation we need to check for any overlapping breaklines.

If not corrected these will cause errors in the triangulation. 

Coloured diamond shapes can be created around the errors along with a report file 

Select option Tins=>Check/Clash=>Check Breaklines

Select the View icon for the data source

We want to check all data in View 1 so select 
View icon and select view number 1

Type in model name xbreaklines to create 
strings around the errors

The report file name xbreaklines is typed in. 
Press [Enter] after entering the text and the 
extension .rpt is added

Select the colour red for the strings

Tick check box to Clean models beforehand

NOTE - report files are not available in 

the12d Model Practise Version

Select Check

The report is generated and displayed in the default text editor

At the middle of the report the intersections are listed giving the model names, coordinates and 
codes of the intersection strings

Exit the text editor
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Drag the Check breakline panel over to the bottom edge of the screen as we will rerun the option later 

Lastly delete the diamond string surrounding the crossing breakline. We delete the diamond string as it has 
levels at the vertices and if the Check Breakline option is rerun without the Clean models option ticked, 
more crossing breaklines would result 

Select Strings=>Delete or String icon

Pick the diamond and accept

As the Crossing Breakline panel is still active rerun the option to confirm all crossing breakline have been 
fixed

Turn on the model xbreaklines

Zoom in to the red diamond at point 2275

A red diamond appears centred at the 
intersection of the two strings

To correct we will insert point 2275 into 
segment from point 2065 to point 2066

Select option Strings=>Points edit=>Insert

or Insert icon

Pick and accept the string between point 2065 
and 2066

Pick and accept point 2275

The string now has a vertex at point 2275
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9.9.2Delete empty models
When triangulating a view of data it is important to delete any empty models.These are models containing 
no strings. If the tin was to include these models and the models were deleted at a later stage the tin 
function would not work. The user would have to edit the triangulation and remove the models from the 
list 

Select option Models=>Delete=>Delete empty unlocked models

9.9.3Triangulate data
All tinable data in View 1 will now be triangulated. In this example we will triangulate a view of data. Turn 
off the model name Trash model if it exists. This model may have been created as a result of certain string 
edits. The edit panels may have given the user the option to send the affected string to the Trash model

Select option Tins=>Create=>Triangulate data

Select Delete All then Finish

This will delete the model 
xbreaklines and unknown which 
was created during the field file 
reduction

Select the General tab

Type in the function name TIN 
GROUND

Type in GROUND as the tin name. Press 
[Enter] and the Model for tin will use the 
same name prefixed with the word tin

Select a tin colour green

Tick the check box to Preserve strings. 
This will ensure that the triangles run 
along the edge of the breaklines
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Select the Data tab

Select the view icon

Select view 1

Select the Nulling tab

Type in a length of 50. This will delete 
any triangle with a side longer than 50

The angle and combined length / angles 
are explained by pressing Help

We are going to manually create a 
boundary at a later stage so there is no 
Null polygon

Select Triangulate

The panel changes to a Retriangulate 
Tin panel. 

We will use this panel again later to select 
the tin boundary so it can be moved over 
to the edge of the screen 
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Turn on the model tin GROUND

9.9.4Nulling Triangles
When deleting triangles it is important to be able to see the survey strings. As the tin was the last model 
turned on, the green triangle lines cover the survey strings. We can put the green tin strings to the back by 
selecting View =>Send tins/rasters to back

The triangles around the edge of the data have been partially nulled by the Triangulation function but we 
need to trim the triangles even further to be able to create a boundary around the edge of the survey.

There are a number of ways to null triangles including By points and by strings

The triangulation is shown with preliminary nulling around the edge
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9.9.4.1Null by strings

Triangles can be deleted by dragging a line, polyline or lasso through the ones that are incorrect.

Select option Tins=>Null=>By strings

Select the Tin icon and select tin existing

Select Use a string

Tick Null on accept of string

Right click on the String choice icon

Select Polyline icon

Zoom in to point 1482

These two triangles need to 
be nulled
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The final trimmed triangles should look like the example below

Holding down the left 
button, drag a polyline 
through the triangles as 
shown. Release the left 
button then press middle 
button to confirm the delete

The triangles will be 
deleted

Pan around the edge of the 
survey deleting triangles in 
this manner

Pay particular attention to 
the triangles where the 
creek beds meet the 
boundary. The triangles 
often cross from one top of 
bank to the other.
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9.9.4.2Tin Solid

To ensure there have been no errors while deleting the triangles, the surface can be coloured with a solid fill. This 
enables any errors to be easily seen

Zoom to the extents of the survey data

Select Toggle 
icon 

Select Tin 
Solid
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9.9.4.3Reset triangles

To “Undo” a wrongly deleted triangle select the option Tins=>Null=>By Points

Select tin ground

Change the Null mode to 
Reset

Select Pick

Select and accept the centre of 
the triangle to reinstate

The triangle will be restored as 
seen by the solid fill
Page 172



Chapter 9  Survey Data Reduction
9.9.5Tin Boundary
Once the triangles have been trimmed around the edge of the survey a string can be created around the 
extents of the triangulation. This is then used to as a Null polygon for the triangulation.

Toggle off Tin Solid

Select the option Tins =>Boundary=>Boundary

Select the tin ground 

Select tin model tin ground then 
add BDY to the model name

Leave check boxes ticked

Select Create

Turn on the model 
tin GROUND BDY

A cyan string is 
created around the 
extent of the 
triangulation
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Now we need to include the boundary string in the triangulation

Return to the Retriangulate Tin panel

Select the Nulling tab

Clear out the previous nulling 
values

Select Null Polygon pick icon

Pick and accept the boundary string

Select Retriangulate then Finish
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9.9.6Viewing fast contours
We will now turn on the fast contours to analyse the triangulation.

Select Toggle=>Tin Contours

The contour increment can be changed for the view. 

The contours should be checked for any errors

Select the Plan View Properties icon

Select Tin settings. All features for the contours can be changed
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To update the triangulation select Tins=>Edit=>Retriangulate=>GROUND

Or by using the new recalc the function using the recalc panel

Walk right on Recalc then 
double click on TIN GROUND
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9.9.7Perspective Views

To help analyse the triangulation a perspective view can be used. The surface can be shaded and viewed 
from any angle

Select View 3d

Add all the 
models to be 
viewed
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To move around the view select the Orbit icon

Hold the left button down 
while moving the mouse 
to move around the view
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9.9.8Section views
A section view will be used to view profiles along existing strings or to create dynamic sections through 
the survey

Select Section view LS

Place the section view beside the plan view 1 as shown below using the View control icons
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P

In the section view turn on model tin GROUND

 The profile of the string is displayed

Now turn on the model DRAINAGE in the section view

Zoom in to point 2056 where the drainage pipe crosses the road

Select the Vertical exaggeration icon and set the vertical exaggeration to 2

Zoom into the part of the section view to see the pipe under the ground

Close the section view

                                                                Select Profile icon
Select and accept the crown of the road string
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9.10 Plotting

9.10.1Create New Plan View
We will firstly create a new plan view on which the data will be set up for plotting. 

Select option View=>Create=>Plan View

Type in the name PLOT

Select Create

Maximise the view

Turn on all models to be plotted. We will 
not turn on the tin models as we will be 
creating separate contours to plot

Zoom to the extents of the survey data
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9.10.2Feature labelling
The points in the survey can be labelled according to their names (codes). Labelling can be text such as 
heights, codes and point numbers

Firstly we will look at the label map file

Select option File =>Label Map Files =>Create/Edit

For each code the feature can have user defined text parameters including text style data, width, 
precision (number of decimal places) and prefix or suffix text.

Select the Label map file folder 
icon

Select Read

Select the file DETAIL SURVEY 
v14.label_mapfile from the 
Getting Started folder

Select the Height Text Data branch
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The other lines can be filled in in a similar manner

Select Finish to exit the editor

To label the data select File =>Label Map Files =>Apply

Select the View icon

Select the View Plot 

Select the Label map file 

DETAIL SURVEY v14.label_mapfile 
from the Getting Started folder

If the Use models for labels check box is 
clear then the user is prompted for a model 
prefix so that each label is placed in a 
separate model

Clear the check box

Type in txt ptno as prefix for height models

Type in txt ht as prefix for height models

Type in txt cd as prefix for code models

Type in txt att for both the Vertex attributes

Note that a space was placed after the 
prefixes above

Select Label
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Prior to turning on the label models we need to delete any empty models (models with no data) created 
with this option. This is done by selecting option Models=>Delete=>Delete Empty Unlocked Models

To see an example of the attribute text turn on the model txt att VEGETATION

To delete all of the models simply select Delete All
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9.10.3Setting the correct plot scale for the view
The plot is to be done at a scale of 1:500 so to view the paper unit text in the correct scale we need to set 
the view plot scale 

Select the Plan View Properties icon

Select Settings. Type in the new plot scale 500
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9.10.4Creating Smoothed labelled Contours
The contour lines displayed in plan view 1 are “fast contours”.

The fast contours are not editable features and don’t have labels

To create contours select Tins=>Contour=>Contour, Smooth and Label

Type in function name CONTOUR 
GROUND

Select Tin to contour choice icon 
then select tin ground

Select the Contours tab

Type in contour minor for Model 
name

Type in contour interval 1

Select colour red

Tick the Smooth contours box

Select the Major Contours tab

Type in contour major for Model 
name

Type in contour interval 5

Select colour magenta
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Select the Range tab

Leave this panel unaltered

Select the Labels tab

Tick check box to Label major 
contours only

Type in label model contour label

Select label method Centre line read 
from below

Type in 0 for number of decimal places

Select textstyle Text Whiteout 2.5mm

Type in start distance of 30

Type in separation of 30

Select Process

Don’t press Finish until you have 
verified the contour labelling
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Turn on the newly created 
models contour label, 
contour minor and 
contour major

The major contour appear 
to be crossing the labels. 
This is because the model 
contour label was turned 
on prior to the other contour labels. This can be rectified by moving the contour label model to the top of 
the model list 

Select the Plan View Properties icon Select Models. Highlight model contour label 
and select Move to top icon
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9.10.5 Text Editing
In this section we will add new text and edit existing text 

9.10.5.1Adding text

Text can be added to the view to describe features. 

Firstly we need to set the default text properties including the model, colour and font. 

Type in name and model name text, select colour magenta and select Text Data favourite 

Text Whiteout 2.5mm

From the Cad Text toolbar select Create icon. Select and accept the insertion point for the text.

Type in the text in the Input box 
and click OK

Press Esc as we will edit the text 
in the next topic
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9.10.5.2Editing text

We will now look at editing the text

Scaling texth

.

Select the Edit icon

Select the piece of text to edit at the insertion point at the bottom left.

     

Pick the top left node

 

As you move the 
cursor the text is 
resized. Accept with 
middle button 

Alternatively select H 
key and type in height  
[Enter]
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Moving text vertex

.

     

Select V key to 
ensure text is moved 
with the vertex

Pick the bottom left 
node. 

As you move the 
cursor the text 
moves along with 
the nodes. 

The reason for 
moving the vertex of 
the text is to ensure 
the new text position 
does not move if 
changing plotting 
scale

Pick and accept the 
new position
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Rotating text

.

     

Pick the bottom right 
node

As you move the 
cursor the text rotates. 

To rotate to a set angle 
select A key and type 
in the value and press 
[Enter]

Additional keystrokes 
displayed at the bottom 
of the screen can be 
used to rotate 
tangential or 
perpendicular to a 
selected string

In the example here the 
key T was pressed and 
the fence string was 
picked to align the text 
to the fence line 

Accept with middle 
button to confirm 
rotation.
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9.10.6Grid display
A grid can be displayed and plotted with user defined attributes such as grid type, spacing, text placement 
and prefix / postfix additions to values

Firstly toggle on the grid

To configure the grid settings

Select the Plan View Properties icon

Select Grids. Type in the new grid settings as shown below
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9.10.7Quick sheet plot

Fill in the panel as shown. Make sure that the plotter type is 
model so that we can preview the plot.

Type in preview quick plot for the model name

Select always clean as clean model mode

Type in Scale 500

Select the Origin icon and select a point in the graphics for 
the lower left corner of the plot sheet. Alternatively a 
coordinate can be typed in. For this workshop we will type 
in coordinates as shown below

There are two types of plotting methods. The first is Fixed 
in View

Using this option the view can be zoomed in or out and the 
plot frame size stays linked to the view edge

Fixed in Data uses the parameters in the panel such as Scale 
and origin coordinates

We are using Fixed in Data for the following plot

Fill in the rest of the panel as shown

Select Plot

A section of the survey can be easily plotted without the need to set up a plot frame. 

Zoom in to the eastern pond

Select Print icon then select Quick sheet plot
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Create a new view called PREVIEW and turn on the model preview quick plot

Once the plot model has been checked the plotter type can be changed for output to a printer or pdf file

In the example below a colour pdf file will be created.

Select Plot to create the pdf file
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9.10.8 Plotting Using Plot Frame

9.10.8.1Create Plot Frame

User defined plot frames can be placed over the survey. These frames show both the sheet size and plot 
area borders.

Select option Plot=>Plot frames=>Create. 

Select title file SAMPLE A1PLAN.tbf 
from the Getting Started folder

The panel is filled with data read from the 
title block file

Type in the proposed plot scale

Select the Origin selection icon then 
select and accept a point at the lower left 
of the survey

Select Create

The panel is converted to an Edit panel
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Turn on the model pframe a1plan

To move the plot frame over the survey select Translate 

and move the plot frame manually to the required position. 

Select and accept that position

To rotate the plot frame type in a rotation angle or select 
Rotate and use the cursor to change the rotation. Select 
and accept the position. 

Select Set then Finish
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9.10.8.2Create Plot Using Plot frame PPF Editor

Select option Plot=>Plot frames=>Plot or select the plan view plotting icon

Select the option Plot frames

This brings up the Plot frame PPF Editor panel

Read in the sample plot parameter file from the Getting Started folder called SURVEY 
PLOT.plotframeppf

Select Read

The Plot Frame screen is 
filled in from the parameter 
file

The plot will be sent to a 
model called plot preview
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Select Title block

We are using a title file so the Use title file check box is ticked
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Select the [+] symbol to expand the next option

                     Select User title info to specify title file and title block text

The prompted values for the 
title file SAMPLE 
A1PLAN data are filled in.

To change any of the data 
simply type over the top of 
the existing value
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Select Symbols

A rotating North point symbol called Circular Nth pt has been selected to sit just left of the title file logo. 
This symbol will automatically rotate with the plot frame

Prior to creating the plot we need to create a new 
Plot parameter file that sits locally in the project. 
We don’t ever update the one we have read in as it 
may be a template for other users

Select the Plot parameter file icon

Select Browse Reset to change the folder to the 
current project folder

Type in a new plot parameter file name PLAN PLOT and then select Write
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Once the parameter file is created select Plot to create the pdf file
Page 202



Chapter 10  Volumes
10 Volumes
In this chapter we will look at various types of volume calculations including:

10.1 Stockpile volume  on page 203.

10.2 Multiple stockpiles  on page 215.

10.3 Dam Capacity  on page 219.

10.4 Surface Comparison  on page 223.

10.1 Stockpile volume
This topic deals with calculating the volume of a stockpile given data for both the existing surface prior to 
the stockpiles creation and the surface of the stockpile

A volume will be calculated between the triangulations (tins) of the two surfaces

To begin create a new project called STOCKPILE in the Survey training area

First, double click on the 12d Model 14 
icon to bring up the Project Selection 
panel.

Select New button to bring 
up the New project panel.
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Create a project under the folder C:\12d\14.00\Training\survey\volumes called STOCKPILE

With the Create working folder check box ticked a working folder with the same name as the project will 
be also created

Select New to create and open the project.

Screen Setup
When the project starts up for the 
first time the Project Details panel 
appears

The information typed in here can be 
used when plotting from this project

Fill in the various prompts if 
necessary

Select Set then Finish to save the 
settings and continue
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10.1.1Existing surface
We will read in the data for the existing surface. The data is in the form of a 12d archive file

10.1.1.1Read in data

We will drag and drop the 12d archive file straight into a 12d Model view 

 

Highlight plan view 1

Select the Explore working folder icon and 
move up to the Volumes folder

Pick the file to import 
and then holding 
down the left button, 
drag the file onto 
View 1

The Import panel will 
automatically appear with the 
file name prefilled.

Type in ORIGINAL 
(with a space at the end) 
for Pre*postfix for 
models

This will help separate 
data from multiple 
surveys

Select Read.
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The survey points in model ORIGINAL SURFACE POINTS appear

10.1.1.2Triangulate the existing surface

We now form a tin using the points from the original surface.

Select Tins=>Create=>Triangulate data

Type in the function name TIN ORIGINAL

Type in the tin name ORIGINAL [Enter] 

Select colour green for tin

When selecting [Enter] key after entering tin name 
the model name is automatically created with tin as 
the prefix

The only check box needed to be ticked is Preserve 
strings which will ensure breaklines are inserted at 
the time of triangulations
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Select the Data tab

Turn on the model tin ORIGINAL to view the triangulation

Select the Nulling tab

Select the view icon

Select view 1

Tick on Apply nulling

Change the length to 50

Select Triangulate

The panel changes to Retriangulate tin. 

Select Finish
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Toggle on the contours
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10.1.2Stockpile surface
We will now read in the data for the stockpile surface. The data is again in the form of a 12d archive file 
and this file includes the tin of the stockpile surface

10.1.2.1Read in data 

Read in the STOCKPILE.12da file from the folder C:\12d\12.00\Training\survey\volumes by dragging 
and dropping from the Explore working folder icon as shown previously.

The file STOCKPILE.12da includes a preformed tin of the data.

                 

The survey points of the stockpile along with the tin will appear in view 1. 

As Tin contours is toggled on, the contours are displayed for the new tin.

      

The only issue with importing tins inside 12da files is that if the you tried to retriangulate the tin it will not 
work as the model names have changed due to the prefixing. Also the tin function name is not held in the 
12d archive file. So remember not to try to retriangulate the data. 

Also the tin model shouldn’t really have a prefix as it is preferable to group them in the model list.

Type in SPILE (with a space at the end) 
for Pre*postfix for models

Select Read
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We can rename the tin model using the option Models=>Rename

10.1.3 Check stockpile tin lies within existing tin
We will now turn on both triangle models to check that the stockpile tin sits inside the tin created from the 
existing surface points. 

 If this is not the case then the volume calculation will only cover the area where the two tins 
coincide.

Select the model SPILE tin STOCKPILE

Rename to tin STOCKPILE

Turn on model tin ORIGINAL

Toggle off Tin contours.

Ensure the outline of the 
stockpile triangulation lies 
completely inside the original 
surface triangulation
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10.1.4Calculate volumes by exact method
The volume between the two tins can now be calculated and written to a report file

Select Volumes=>Exact=>Tin to tin

The report is activated in the default text editor (Notepad is the default)

Exit the text editor and select Finish on the Volume panel

Select ORIGINAL for original tin 
model

Select STOCKPILE for new tin 
model

Leave the report type as <Legacy>

Type in Stockpile Volume for report 
file name 

NOTE - report files are not available 

in the 12d
Model Practise Version

Select Polygon choice icon and then 
pick and accept the string around the 
edge of the stockpile

Select Volume to calculate the volume 
between the two surfaces

The volumes of cut and fill are 
displayed at the bottom of the panel

The two surfaces used are listed in the report header

The volume of cut is listed along with the fill volume and the balance (Fill - Cut) 

The polygon plan area is the horizontal area of the outline of the stockpile
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10.1.5Calculate volumes by End area
Another type of volume calculation is the end area method. Volumes are calculated between cross sections 
generated through the stockpile. An alignment is not necessary to produce the sections.

Strings will be created at each cross section for viewing in the section view

It important to note that the smaller the separation of the sections the more accurate the volume

Select option Volumes=>End area=>Tin to tin

 As per the previous option the report is displayed

Select Volume

Select Append to append the volume results to the end 
of the previous report

NOTE - report files are not available in the 12d
Model Practise Version

Select ORIGINAL for original tin name

Select STOCKPILE for new tin name

Type in the angle 135 for the cross sections

Typed in 10 for the distance between sections

Type in xs original as existing section model 
name

Type in xs stockpile as stockpile section 
model name

Tick check box to clean section models

Select the Poly icon. Select the String pick 
icon then pick and accept the string around 
the edge of the stockpile (shown previously)

Leave the report type as <Legacy>

Select Report mode icon then pickprevious 
report file Stockpile Volume.rpt 

Select Summary

Select Volume mode choice icon then select 
Average end area
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The original report is amended with the volume by end area placed at the end of the report

The distance between the sections is displayed along with the direction of the section strings
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Turn on the cross section model xs stockpile and turn off the tins

10.1.5.1View stockpile sections

The cross sections can be also be viewed in a section view XS

Place section view XS to the right of plan view using the view control icon shown previously

Turn on the two tin models in the section view
To view the cross sections select the profile icon 
Select one of the section strings in View 1
                                                                                             Select Prev and Next icons to change sections
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10.2 Multiple stockpiles
In this example multiple stockpile volumes can be calculated with one option automatically creating all 
necessary tins of the bases and tops of the stockpiles.

A Volume report will be created for each stockpile and volume text will be placed over each pile

Create a new project as shown previously called MULTIPLE STOCKPILES in the folder

C:\12d\14.00\training\survey\volumes

10.2.1Read in Stockpile surface data
Read in the 12d archive file C:\12d\14.00\training\survey\volumes\MULTIPLE STOCKPILES.12da 
file by dragging and dropping using the Explore working folder icon as shown previously   

Select the New button at the bottom of the panel to create and open the project.

Select Read then Finish
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10.2.2Run Stockpile option
For this program to work, the strings around the bases of the stockpiles MUST share a unique code. 
This code should not be used within the stockpile as it is used to determine the extent of each pile.

In this example, the bases of the stockpiles are all named SF TOE.

Select option Volumes=>Stockpile

Select view icon

Select view 1

Type in the model name for tins created. 

Tick check boxes where applicable

Type in the model name for the volume text.

Type in or select the code for the stockpile 
bases. The bases must all have the same code. 

Type in the report file name

Select view 1 to add the tin and text

Select a text style

Select colour for tin triangles

Type in the number of decimal places for the 
volume

Type in start stockpile number

Select Process to calculate the volumes
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Each stockpile displays a base and surface tin along with a text box containing values chosed in the previous panel

A HTML Report file is generated and opened in the default web browser.
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After the final stockpile volume has been reported select Finish on the volumes report panel

Turn off all the model tin stockpiles 

To move the volume text outside each stockpile select option Cad=>Drafting=>Multi string translate

Reselect Name before moving each block of text

Pick and accept the text to move

Drag the text to the new position and accept

Select Name
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10.3 Dam Capacity
In this example the storage capacity of a dam will be calculated

Create a new project as shown previously called DAM VOLUMES in the folder

C:\12d\14.00\training\survey\volumes

10.3.1Read in Dam surface data
Read in the 12d archive file C:\12d\12.00\training\survey\volumes\DAM VOLUMES.12da file by 
dragging and dropping using Explore working folder icon as shown previously

Select the New button at the bottom of the panel to create and open the project.

Select Read then Finish
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Toggle on Tin contours
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10.3.2Calculate volumes by Storage Calcs method
The volume from the dam bottom surface up to a nominated height can now be calculated

Select Volumes=>Exact=>Storage Calcs

NOTE: The painting (colouring) on the view is only temporary and if the view is refreshed, it is lost.

Select GROUND for tin

Leave the minimum height 
unaltered to calculate the volume 
from the lowest point of the tin

Type in 4.5 as the max height

Type in 0.5 for the height 
increment. The volume will be 
broken into 0.5 metre slices

Select view 1 to shade the extent 
of the volume area

Type in the report file DAM 
VOLUMES.

NOTE - report files are not avail-

able in the 12d Model Practise 

Version

Select the Poly icon then pick and accept the string 
named TBL around the edge of the top of the dam wall

Select Volume

The area within 
the selected 
polygon is 
highlighted
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The report file is opened in the default text editor and the volumes are listed in the specified slices
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10.4 Surface Comparison
This topic deals with not only calculating the volume between two surfaces but also comparing the 
surfaces by depth shading

Create a new project as shown previously called DEPTH SHADING in the folder

C:\12d\14.00\training\survey\volumes

10.4.1 Read in Surfaces
Read in the 12d archive file C:\12d\14.00\training\survey\volumes\DEPTH SHADING SURVEY.12da 
file by dragging and dropping using the Explore working folder icon as shown previously

Select the New button at the bottom of the panel to create and open the project.

Select Read then Finish
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Turn off the Stripping survey models, STRIPPING SURFACE, STRIPPING SURFACE POINTS and tin 
STRIPPING.
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10.4.1.1Check original data

Toggle on Tin contours. 

The contours are not visible as the surface is very flat. We need to change the contour interval to a smaller 
increment 

Change the contour interval to 0.1

Select the Plan View Properties icon

Select Tin settings. Change the Contour increment to 0.1 and the Bold 
Contour to 0.2
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10.4.1.2Save model list for original data

The original models can be saved away to a model listing file

Select View=>Models save/restore

10.4.1.3Check stripped survey data

Turn off all models then turn on the Stripping models STRIPPING SURFACE, STRIPPING SURFACE 
POINTS and tin STRIPPING.
 

Type in file name ORIGINAL SURVEY

Select view 1

Select Save then Finish
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10.4.1.4Save model list for stripped data

The stripping models can be saved away to a model listing file

Select View=>Models save/restore

10.4.2Check Stripped tin lies within existing tin
To check that the Stripped tin sits inside the tin created from the existing surface points, we will now turn 
on both triangle models and toggle off Tin contours. If this is not the case then the volume calculation will 
only cover the area where the two tins coincide.

Type in file name STRIPPED SURVEY

Select view 1

Select Save then Finish

Ensure the outline of the stripping tin lies completely inside the original surface tin
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10.4.3Calculate volumes by exact method
The volume between the two tins can now be calculated and written to a report file

Select Volumes=>Exact=>Tin to tin

Select original for original tin model

Select stripping for new tin model

Type in STRIPPING VOLUME for 
report file name

NOTE - report files are not available 

in the 12d
Model Practise Version

Select Polygon icon Pick and accept the string SF CG around the edge of the stripping survey

Select Volume
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10.4.4Create depth shading
The two surfaces can be compared by colouring the height differences between the two tins.

Select option Tins=>Colour=>Tins depths colour

Move the panel to the side of the survey 

Turn off the tin models

Select original for original tin

Select stripping for new tin

Select Range file icon then browse to the 
folder

C:\12d\14.00\training\survey\volumes 
then select the file DEPTH SHADING.drf

Select view 1 to paint

Type in model DEPTH FACES for the 
colouring model. 

DO NOT ENTER A MODEL NAME IF 
USING PRACTICE VERSION AS A 
LARGE NUMBER OF STRINGS ARE 
CREATED

Tick check box to clean faces model 
beforehand

Select Poly choice icon and then pick and accept the edge of 
the stripped surface (SF CG)
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A preview of the colouring appears temporarily and this will disappear when the view is refreshed.

The view can then be refreshed and the colours remain as they are represented by the faces in the model 
DEPTH FACES.

The model of faces holds a permanent record of the colours.

Turn on the model DEPTH FACES
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10.4.5Create tabulation of range file
A table can be created to tabulate the depth colours in the depth range file DEPTH SHADING.DRF.

Select Cad=>Drafting=>Text and tables=>Tabulate range file

Select Range Type icon and select Depth

Select file DEPTH SHADING.drf from the 
folder C:\12d\14.00\training\survey\volumes

Type in metres for the range units

Select Position icon. Pick and accept a point for 
the upper left corner of the propose table

Type in STRIPPING DEPTHS

Select Font

Type in model name for table txt depth table

Select the colour for the table

Type in an appropriate size for the text.

Note that the text size is in world units

Select text style Arial

Select Set then Finish to return to the previous 
panel

Select Process

Turn on the model txt depth table
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10.5 Progressive volumes
In this topic we will look at the use of super tins to combine surfaces after each survey of an excavation. 

Create a new project as shown previously called QUARRY in the folder

C:\12d\14.00\Training\Survey\Volumes

10.5.1Read in multiple surveys
We will read in the data for the three surveys of a quarry taken as the excavation develops. The data has 
been given in the form of three 12d archive files. This time we will read the files in together in one option

Select option File =>Input 12d

Select the New button at the bottom of the panel to create and open the project.

Tick the Many files 
check box

Select the Volumes 
folder used previously 

Change wildcard to 
*12da

All of the 12d archive 
files in that folder will 
populate the panel

Clean all of the prefix 
values by clicking right 
button on Pre*post

Select Clear

Untick all 
check boxes 
except for the 
Quarry files

Select Read to import the 12da files
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10.5.1.1View March survey

In Plan view 1 turn on 201703 models 201703 BOUNDARY TIN, 201703 SURFACE, 201703 SURFACE 
POINTS and tin 201703.

Then toggle on the Tin contours
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10.5.1.2View April survey

Turn off all models and then turn on 201704 models 201704 SURFACE, 201704 SURFACE POINTS and 
tin 201704.
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10.5.1.3Save the April model list

The April survey models can be saved away to a model listing file

Select View  =>Models save/restore

10.5.1.4View May survey

Turn off all models then add the 201705 models 201705 SURFACE and tin 201705.

10.5.1.5Save the May model list

The May survey models can be saved away to a model listing file

Select View =>Models save/restore

Type in file name APRIL SURVEY

Select view 1

Select Save then Finish

Type in file name MAY SURVEY

Select view 1

Select Save then Finish
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10.5.2Check April and May tin lies within March tin
Turn off all models then turn on all of the tins, and toggle off Tin contours.

Ensure the outline of the April and May triangulations lies completely inside the March triangulation
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10.5.2.1Shade tins

Shading the tins can help with the checking of the overlapping

Toggle on Tin solid

As the April tin is smaller in area than the May tin it is hidden by the May tin colouring. To make the April 
tin visible we can move the April tin model to the top of the model list 

Toggle off the Tin solid

Select the Plan View Properties icon

Select Models. 

Select model tin 201704 and then select Move to top icon
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10.5.3Calculate volumes from March to April survey
We will now calculate the volumes between the March and April survey.

Now that we have the tins they do not have to be seen again but we will continue to add them to the views 
so you can see we are definitely using the correct tins. We will also show how to use the model lists that we 
have saved for each month.

Firstly turn off all models and then we will add back all the models for the April survey by reading in the 
model list previously created

10.5.3.1Restore the April model list

Select View =>Models save/restore

Select the Restore tab

Select the file APRIL SURVEY

Select view 1

Select Read then Restore
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10.5.3.2Calculate EXACT TIN TO TIN volumes

The volume between the two tins can now be calculated and written to a report file. We will calculate using 
the Exact tin to tin exact method.

Select Volumes =>Exact =>Tin to tin

Select 201703 for original tin model

Select 201704 for new tin model

Select Report type html report

Type in APRIL VOLUMES for report file 
name

NOTE - report files are not available in the 12d
Model Practise Version

Select Volume to calculate the volume 
between the two surfaces

The volume html report is opened showing 
combined volume between the March and 
April surfaces
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10.5.4Combine the March and April surfaces
We need to combine the March and April tins in order to calculate the volumes for the May survey against 
what the quarry was like at the end of April.

This is done by creating a super tin which dynamically combines multiple tins into one.

10.5.4.1Create super tin of March and April surveys

Select option Tins =>Create =>Supertin

Check the supertin in the Perspective view 3D with shade toggled on

Type in the name for the Supertin <Enter>

Select the tins from earliest to latest. Set 
mode for each tin to replace and set Active 
for each tin to yes

Select Create
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10.5.5Calculate volumes from April to May survey
We will now calculate the volumes between the combined April supertin 201704 COMBINED to the May 
survey tin 201705

Firstly turn off all models then read back in the models for the May survey by again using the previously 
created model list.

10.5.5.1Restore the May model list

Select View =>Models save/restore

Select the Restore tab

Select the file MAY SURVEY

Select view 1

Select Read then Restore
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10.5.5.2Calculate EXACT TIN TO TIN volumes

The volume will now be calculated from the super tin of the combined March and April surveys, to the 
May survey

Select Volumes =>Exact =>Tin to tin

Select 201704 COMBINED for original tin model

Select 201705 for new tin model

Select Report type html report

Type in MAY VOLUMES for report file name

NOTE - report files are not available in the 12d
Model Practise Version

Select Use a polygon and then pick the top of bank 
string SF TOP

Select Volume to calculate the volume between the 
two surfaces
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11 Setout
In this chapter we will look at various types of setout calculations from features constructed in the graphics 
to imported strings and tins. Setout files are created for each topic.

The types of setout include:

Building creation and setout. See 11.1 Building setout  on page 247.

Imported building from cad file. See 11.2 Cad House Setout  on page 269.

Setout for evenly graded string. See 11.3 Setout for evenly graded string  on page 277.

Creating 3d setout for imported 2d cad strings. See 11.4 Setout for polyline culdesac string  on 
page 284.

Triangulation setout. See 11.5 Triangulation setout  on page 292.

Road setout from imported strings. See 11.6 Road Setout  on page 294.

QA Reporting of point, string and tin setout. See 11.7 Setout reports  on page 296.

11.1 Building setout
In this topic we will create a lot outline and position a building on the lot for setout. 

To begin, create a new project called HOUSE SETOUT in the Survey training area.

Select the New tab

Create a project under the folder C:\12d\14.00\training\survey\setout called HOUSE SETOUT

With the Create working folder check box ticked a working folder with the same name as the project will 
be also created

First, double click on the 12d Model 14 
icon to bring up the Project Selection 
panel.
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Select the New button at the bottom of the panel to create and open the project.

11.1.1  Create the lot outline
We will use plan view 1 for the house setout. 

The lot outline will be created in a model called LOT

Select option Cad =>Line =>Traverse

or Traverse icon

 

You will see the following message in the message area at the bottom left of the 12d Model screen:

<Pick start position for traverse> [picks][fast][Menu]

This is to tell you to pick the start point for the traverse. The rest of the traverse is then entered as bearings 
and distances.

Instead of picking from the screen, we will be using typed entry to place the traverse.

Press the Space bar to activate the coordinate entry panel Enter X Y Z.

 Press the Space bar to activate the bearing input panel

When the project starts up for the 
first time the Project Details panel 
appears

The information typed in here can be 
used when plotting from this project

Fill in the various prompts if 
necessary

Select Set then Finish to save the 
settings and continue

Type in the name and model name LOT in the CAD controlbar. Select the colour Red 

Type in the coordinates 1000 5000 [Enter]
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Press the Space bar to activate the distance input panel

Type in the bearing 12.1810 [Enter]

NOTE - This is the dms method for 
entering the bearing 12°18’10".

Type in the distance 35.818 [Enter]

When pressing the space key for the next bearing input the previous 
bearing is shown highlighted in the panel. 

For example, the next bearing is 90.0000 so it would be typed in over 
the previous bearing 12.1810 and then [Enter] to input the new bearing.

Other options to amend the previous bearing will be discussed when 
entering the house outline

Repeat the entry of bearing and 
distance using the following 
dimensions

90°00’00"    23.870

192°18’10"   35.818

192°18’10" is entered as 192.1810. 
Remember to input the trailing zeroes. 
After typing this line press [Esc] to exit 
option
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If the bearing and distance between the points are correct, close the string by using option 
Cad =>String =>Close

or select Close icon

Check the misclose of the last line by selecting option Utilities=>Measure=>Bearing/Distance

or Measure Bearing/Distance icon

Select and accept the start and end points of the lot traverse
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From this point on we will be using the cad icons only. The menu options are available under the Cad 
menu 

Select and accept anywhere on 
the string

The string will be closed
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11.1.2Create building outline
In this option we will create the outline of the building using the previous traverse routine and explore 
some other traverse editing features

Select option Traverse icon

 

We are going to start the house corner 7.0 metres up from the lower left corner of the lot and offset 1.8 
metres in from the side boundary

 

Type in the name and model name as HOUSE in the CAD controlbar. Select the colour blue 

      7.0

Prior to picking the 
start point select 
the Snaps offset 
icon from the 
snaps toolbar

Select the left 
boundary with 
direction dragging 
towards the top

Select the bottom 
left corner of the 
lot as the control 
point. This will be 
the point where the 
measurement is 
taken from

Type in the 
distance 7 [Enter]

Type in the offset 
1.8 [Enter]

1.8
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Press the Space bar to activate the bearing input panel

Press the Space bar to activate the distance input panel

We will now look at some options to speed up the traversing process. 

For the next bearing we are going to traverse at right angle to the previous bearing

Press the Space bar to activate the bearing input panel

Press the Space bar to activate the distance input panel

For the next bearing we will traverse tangential to the left boundary line.

The point is created in a 
model called constructions 
snap data and is 
automatically turned off.

The end of the string now 
locks to the cursor position

Type in the bearing 12.1810 [Enter]

 

Type in the distance 15.4 [Enter]

The previous bearing appears. Press [Page 
Up] to add 90 degrees to the bearing (We 
could have pressed [Page Down] to 
subtract 90 degrees. 

Press [Enter] to confirm the bearing

Type in the distance 11.1 [Enter]
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At the bottom of the screen there are a number of options that can be activated by selecting the letter 
following the option

To traverse tangential select [T] from the keyboard then pick the left boundary line

Sometimes an error occurs when entering the traverse so the traverse has to be stopped and restarted.

Press [Escape] to exit the traverse or click right button then select Cancel from panel

The proposed direction is highlighted. 
This may be in the opposite direction to 
that required so simply select [N] to 
reverse the direction line if necessary.

Press middle button or select [Enter] to 
confirm the direction
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Select option Traverse Append icon

 

Pick and accept the end of the house string

The traverse can continue

The remaining lines are:

Bearing 192.1810 (or tangential to left boundary) Distance 3.0

Bearing 102.1810 (or [Page Down] after last bearing) Distance 6.0

Bearing 192.1810 (or [Page Up] after last bearing) Distance 5.0

Bearing 282.1810 (or [Page Up] after last bearing) Distance 8.2

Bearing 192.1810 (or [Page Down] after last bearing) Distance 7.6

Press [Escape]
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The last line has an incorrect distance and this can be edited using the following

Select option Traverse Edit icon

 

Pick and accept the last traverse line

The bearing is displayed. As the error is in the distance press [Enter] to accept the bearing

Type in 7.4 [Enter] for the corrected distance
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We can now check the misclose of the house by selecting Measure Bearing/Distance icon

Select and accept the start and end points of the house traverse

The bearing and distance are displayed

If correct, close the string by using the Close icon as shown previously on the lot string
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We can now check offsets from the building corners to the boundaries. 

To ensure the offsets are from the selected segment only, we turn on the segment snap 

Zoom in to the left side of the building

Select the String to Point - Offset icon

Repeat for the other house corners

Select the boundary string and then 
the house corner 
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11.1.3Dimension text scaling
Prior to adding text we will set up the view scale to 1:250

11.1.4Create dimensioned offset lines from house corners to boundaries
In this topic we will use an option to dimension the offsets

Change the model name to text dimension

To create the dimensions select Create Drop Segment Dimension icon

Select the Plan View Properties icon

Select Settings. Type in the new plot scale 250
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Pick and accept the 
left boundary line

Pick and accept the 
house corner.

Press Escape to finalise the change
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Repeat for the other corners
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11.1.5Create dimensions for lot and building lines
We will add bearing and distances to the lot edges and distances only to the building edges. 

The text type for the dimensions will be read in from a stored parameter file

11.1.5.1Lot dimensions

Select option Cad=>Drafting =>Bearing/distance labelling (2)

Select Parameter file icon

Select file TRAINING.lbf from the setout 
folder 

Select Read

Select the Model icon

Select model LOT

Make Label style bearing and distance

Tick check box to label all segments

Select Process

Turn on the text bearing and distance 
models
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11.1.5.2House dimensions

To annotate the house outline

Change the model to HOUSE

Delete the Model name in the Bearing tab

Select Process 
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11.1.6Setout points
Up until now the strings created around the lot boundary and building do not have point numbers

We will now generate point numbers for the vertices for the building and lot boundaries

Turn off all models except for HOUSE and LOT

 

Select option Utilities =>Super strings =>Point id

Select the View icon

Select View 1

Select Run
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Toggle on the Point ids
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11.1.7Create upload file
The upload file of the points and strings can be used on a variety of surveying instruments

In the example below we will create an upload file for the Leica instruments

Select option Survey =>Leica =>1200 =>Strings

Type in File name

Tick check box to use 12d point ids

Select the View icon

Select view 1

Select Write to create the files

Once copied to the instrument the lot 
and house are able to be set out
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11.1.8Sharing the Lot model for other projects
In the next exercise we will be sharing the LOT boundaries from this project

To share the boundary model select Models =>Utilities=>Sharing =>Share

Tick the Share check box for model 
LOT

Select Set then Finish

In the model listing the shared model is 
highlighted in a different colour 
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11.2 Cad House Setout
Create a new project as shown previously called CAD HOUSE SETOUT in the folder

C:\12d\14.00\training\survey\setout

11.2.1Share the lot outline from the previous project
Select option Models =>Utilities=>Sharing =>Add

The model is referenced to the project

Browse to the folder 
C:\12d\14.00\training\su
rvey\setout\HOUSE 
SETOUT

Select HOUSE SETOUT

Tick next to model LOT

Select Add to share the 

LOT model
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Turn on the model LOT and note that shared model has a blue model name
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11.2.2Read in the CAD file
Read in the file C:\12d\14.00\training\survey\setout\HOUSE.DWG file by dragging and dropping using 
the Explore Working Folder icon as shown previously

The house outline has been created in plan millimetres and will result in the house being scaled by 
1000 if opened in the same view as the model LOT. 

We will also rename view SURVEY to view 2 using option View =>Rename

In view 1 turn on the model LOT only and in view 2 turn on all of the other models. Tile Vertically the two 
view using Window =>Tile Vertical.

Select the relevant format for the your import 
method 

Type in DWG <space> as the prefix for the loaded 
models

Type in 0 to ensure any 2d data is nulled

The rest of the panel can remain unchanged

Select Read then Finish
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11.2.3Scale the house models
The imported building has its base units in millimetres rather than metres so we will firstly scale the 
building from millimetres to metres

Select option Utilities =>A-G =>Factor

Select Move to original model
icon

Select Factor then Finish

Zoom all of the house models

Select View icon

Select view 2

Type in an x factor of 0.001

Type in a y factor of 0.001

Leave the z factor as 1

The Origin centre point is not necessary as the house 
will be shifted to the correct position in a later option

Tick check box to Factor text size
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11.2.4 Rotate the building
We will now rotate the house.

Select the option Utilities =>H-Z =>Rotate

Select View icon

Select view 2

The rotation centre point is not necessary as 
the house will be shifted to the correct 
position in the next option

Type in the rotation. In this example we have 
typed in the bearing of the house edge and 
subtracted the bearing of the left side 
boundary line

Untick Clockwise check box to rotate anti 
clockwise

Select Move to original model icon

Select Rotate
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11.2.5Translate the house
We will now position the house into the lot and place the corner at a predefined position

Select the option Utilities =>H-Z =>Translate

Select View icon

Select view 2

Select the Position icon

Select and accept the lower left corner of the 
house in plan view 2. In plan view 1 pick a 
point 7 metres up from the bottom left corner 
and in 1.8 metres in from the left boundary. 
This is explained in the previous setout option

Select Move to original model icon

Select Translate
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In plan view 1 turn on the DWG...house models
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11.2.6Create outline of house for setout
We will now create a string around the outside edge of the cad house. This is done in a model called 
HOUSE

Select option Cad =>Line =>Line string

or Line String icon

 

The dimensioning and setout numbers can be created as per the previous chapter

Type in the name and model name HOUSE in the CAD controlbar. Select the colour Green and linestyle 1

A weight of 3 will help identify the string from the underlying string 

Pick and accept the corner points of the cad 
house

Don’t create the string back onto the start 
point. Press [Escape] to exit the string 
option

To close the string select Strings=>Strings 
edit=>Close

or Close icon
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11.3 Setout for evenly graded string
In this exercise we will manually import a polyline from cad, regrade the string and create an alignment 
upload file for setout.

Create a new project as shown previously called DRAIN SETOUT in the folder

C:\12d\14.00\training\survey\setout

11.3.1Read in the polyline from cad
Read in the file C:\12d\14.00\training\survey\setout\DRAIN.DWG file by dragging and dropping using 
the Explore Working Folder icon as shown previously

Select Read then Finish

Select the relevant import method

Type in DWG <space> as the prefix for the loaded 
models

The rest of the panel can remain unchanged

NOTE:
later we’ll see the effect of leaving the Null level 
value as -999
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11.3.2 Convert the polyline to a super alignment string
The imported polyline has no height but the string is to be evenly graded from level 20.0 to level 25.0

We will convert the polyline to an super alignment to grade the string.

11.3.2.1 Convert to Superalignment

Select Strings =>Convert

The Super Alignment Properties panel comes up for the created super alignment.

Turn on the model DWG DRAIN

Type in a new name and model name for the 
alignment

Change Mode to keep string so that the 
original string is not deleted during the 
conversion

Select Pick

Pick and accept the drain string

Select Super alignment
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Click on the Label node and change the Label style to full.

Remove the model DWG DRAIN from view 1 and add on the model DRAIN ALIGN.
 

Select full for the 
Label style

Select Set then Finish
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11.3.3Create heights for each end of the alignment
We will use the Section view LS to profile the drain string

Minimise all views except Plan 1 and Section LS.

Click on Plan 1 to make it the active view and then Tile Vertically using Window =>Tile Vertical.

NOTE: Because Plan 1 was the active view, tiling vertically puts it on the left hand side.

You can both profile the super alignment and also bring up the super alignment editor by using the option 
Utilities =>VG Edit on the menu on Section LS.

Or you can do it in two steps by select the View Profile icon on Section LS and then pick and accept the 
alignment string in the plan view 1. And then edit the super alignment by clicking on the Edit icon, or click 
on the option Strings =>Editor, or press F6.

Either the VG Edit String or the Edit String panel is brought up, and you Pick and Accept the alignment 
string in Plan 1.

The Super Alignment editor then appears and the alignment string is profiled on the section view.

View Profile
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The alignment has vertical geometry consisting of two VIPs at zero because the original string from CAD 
only had zero heights.

NOTE: If the Null level value has been set to 0 rather than -999 in the Read DWG/DXF Data panel then 
there would have been only null z-values and then no VIPs created (See 11.3.1 Read in the polyline 
from cad  on page 277).

To add or modify vertical IP points, hold the left button 
down over the Part Editors icon then select VIPs Editor
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Type in 20 for the height of Chainage 0 and 25 for the height of chainage 414.1158

Press Set and the bottom of the Vertical IP Properties panel to save the values and then press Finish to 
remove the panel.

The Vertical Geometry of the alignment will then no longer be a flat line but rises from 20 to 25.

To exit the super alignment Editor hold the left 
button down over the Save & Finish icon then 
select Finish.

Select Yes to confirm finishing
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11.3.4Create Upload file

The alignment string can now be converted to an upload file for a number of survey instruments. 
We will create a Topcon upload file as an example

Select the option Survey =>Topcon =>Write RD3 file

Select the Alignment pick icon and then 
pick and accept the alignment string

Type in the file name DRAIN

Tick check box to Report Vertical 
Alignment

Select Write to create the upload file

Once copied to the instrument the alignment string can be setout
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11.4 Setout for polyline culdesac string
In this exercise we will import a 2d lip of kerb polyline from cad and create heights from a provided layout 
drawing

Create a new project as shown previously called CULDESAC SETOUT in the folder

C:\12d\14.00\training\survey\setout 
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11.4.1Read in the polyline from cad
Read in the file C:\12d\14.00\training\survey\setout\CULDESAC.DWG file by dragging and dropping 
using the Explore Working Folder icon as shown previous

Select the relevant Import Method

Type in DWG <space> as the prefix for 
the loaded models

Type in 0 to ensure any 2d data is nulled

The rest of the panel can remain 
unchanged

Select Read then Finish
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11.4.2Filter the string
We will filter the imported string to ensure there are no duplicate vertices at the tangent points

Toggle on the vertices and Vertex indices

Occasionally duplicate vertices will occur. These are highlighted by the overlapping Vertex numbers
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We can filter (remove) vertices on a strings which will prevent problems when paralleling strings at a later 
stage.

Select option Utilities =>A=G =>Filter =>Vertex filter

Select the String icon

Select the String pick icon then select 
the string

Select Dimension 3d

Type in tolerances 0.001

Set target to Move to original 
model/replace

Select Filter then Finish

The duplicate vertices are removed. 
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11.4.3Segment the string
We now segment the string into the equal parts shown in the diagram at the start of this topic. 

Firstly toggle off the vertex indices.

Select option Strings =>Strings edit =>Segment strings

Select Pick then select the first segment

          Type in 4 as number of parts

Select Process

.Repeat for each segment of the string

8 parts

4 parts

4 parts
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11.4.4Add heights to string
Heights will be added from the diagram

Toggle on the Z values (No levels appear yet as they are all null) and Vertex indices.

To edit the string select Edit height icon or CAD =>Vertex =>Edit height

Repeat for all of the vertices in the string using the z-values shown in the next image.

It may be easiest to toggle on Vertex indices again to help show which vertex has what z-value.

To finish Edit height, press <Esc>.

Pick and accept the first vertex. The Height value will come up as null so type in the 
new height 34.07 and press [Enter]. 
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11.4.5\Parallel the lip string for setout
The lip will be paralleled to create setout points. The heights will be raised 0.11 to relate to the kerb level 
and the offset will be 0.5 behind the back of kerb

Select String Parallel icon or CAD =>String =>Parallel

 

The creation of the point numbers for upload is discussed in the previous chapters.

Add a new name and model KB OFFSET 500 to the cad control bar

Select and accept with direction the kerb in a 
clockwise direction

Type in offset -1.1 [Enter]

Type in offset height 0.11 [Enter]
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11.5 Triangulation setout
In this topic we will use a triangulation of a surface to create an upload file to be used in a data collector

Create a new project as shown previously called ROAD SETOUT in the folder

C:\12d\14.00\training\survey\setout 

11.5.1Import 12da file
Read in the file C:\12d\12.00\training\survey\setout\ROAD SETOUT.12da file by dragging and 
dropping using the Explore Working Folder icon as shown previous

This reads in the models ROAD CL, SMITH ST SECTIONS, SMITH ST STRINGS and the model tin 
SMITHS ST which includes the tin SMITH ST. All the models are on view Plan 1 but the triangles 
dominate what you see on the view.

Select Read
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11.5.2Create upload file of the triangles
The triangles can be written to an upload file. We will create a Trimble TTM triangle file 

Select option Survey =>Trimble =>Write TTM file

Select Write to create the file

The number of triangles selected are 
displayed

Select Yes to continue 

The file is created

Select the tin SMITH ST

Type in Job name for the tin

Type in a file name
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11.6 Road Setout
In this topic we will create an upload file of the horizontal and vertical alignment along with the strings or 
cross sections. We will use the previous project or you can create a new project and read in the ascii file 
described in the previous chapter

Remove the model tin SMITH ST from view Plan 1 which leaves the models SMITH ST SECTIONS, 
SMITH STRINGS and ROAD CL on the view Plan 1.

11.6.1Create upload file of road alignment for Leica
The Leica 1200 Road Runner program can accept the alignment and strings for a road setout

Select option Survey =>Leica =>1200 =>Roads

Type in SMITH ST as job name

The file SMITH ST.xml will be created 
along with the database files

Tick the check box to Create database

The road will be a simple one with only the 
finished surface layer to be uploaded

Pick the Alignment string icon then select 
the alignment string ROAD CL.

There is a string at the crown so the 
alignment won’t be used in the layer

Select the model of the strings

Type in layer name FSL

Select Write
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On board the Leica the strings are cut at the 
required chainage and a section can be 
viewed
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11.7 Setout reports
The final position of the Setout points can be checked against the design in a number of ways

We will look at three ways

11.7.1Read in Ascon survey
We will read in an ascii file of the ascon survey. The file also contains some design positions of light poles

Create a new Plan view using View =>New => Plan

The new Plan view will be automatically named 2.

Read in the file C:\12d\14.00\training\survey\setout\ROAD ASCON SURVEY.12da file by dragging 
and dropping it onto view Plan 2 using the Explore Working Folder icon as shown previous.

This reads in the models DESIGN LIGHT, ELEC LIGHT, ROAD EDGE PAVEMENT and TOPO 
SURFACE LEVEL and adds these models to view Plan 2.

Select Read
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11.7.2Calculate the differences between the design and as constructed data
Select option Report =>QA Reports =>Check survey points vs design points

Note that some of the strings being selected are on view Plan 1 and others are on view Plan 2, and models 
(and tins) can be selected without being any view at all. So you have full control over what data is on 
which views.

Select the model ELEC LIGHT for the survey 
model

Select the model DESIGN LIGHT for the 
design data

Type in report name LIGHTS ASCON

Type in distance from the design point to look 
for a corresponding as-constructed point

Select Chainage-Offset as the tolerance 
method

Select the Chainage String button then select 
the alignment string to report the chainages 
and offsets from

Type in the tolerances in chainage, offset and 
elevation

Tick box to Report design coords and untick 
Report as csv

Select the Settings tab

Select Run
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Now return to the Main tab and click LB on the folder tab and select [Open] to edit the report

.
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11.7.3Check As Built strings against design strings
From view Plan 1, remove the model SMITH ST SECTIONS and then we’ll use the option Models 
transfer to add all the models on view 2 to view 1.

Select View =>Models transfer

to bring the panel Models transfer which is asking you to select a view to take all the model names from.

Just click and accept anywhere inside view Plan 2.

NOTE: the models are still left on Plan 2 as well.

The models DESIGN LIGHT, ELEC LIGHT, ROAD CL, ROAD EDGE PAVEMENT, SMITH ST 
STRINGS and TOPO SURFACE LEVEL are now on view Plan 1.

Zoom into the top right hand side of the road.

The panel Model transfer again comes up but this 
time asking for the destination view

Now click anywhere inside view Plan 1 and all the 
models on view Plan 2 are also added to view Plan 1

As built string shown red

Design string (orange)

Control line - alignment

SMITH ST (dark green)
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11.7.3.1Calculate the difference between the ascon string and the design string

Select option Report =>QA Reports =>Check asbuilt string vs design string

Now return to the Report file field and click LB on the folder tab and select [Open] to edit the report.

Select As built string button then pick and accept the red 
ascon string

Select Design string button then pick and accept the 
design orange string

Select Control string button then pick and accept the 
dark green alignment string SMITH ST

Leave the reporting differences as shown

Tick all of the check boxes

Set the difference units to Metres (3dp)

Type in 3 for the number of decimal placesl

Type in 5 for the report interval

The start chainage is kept as 0 but the end chainage is 
changed to 40

 Type in 100 (mm) for the range to check

Type in the report name PAVEMENT EDGE ASCON

Select Report

Open the report file
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11.7.4Check as constructed points against the design tin
Add the model tinSMITH ST to the view Plan 1 

11.7.4.1Calculate the difference between the ascon points and the design tin

Select option Report =>QA Reports =>Check points vs tin

Now return to the Report file field and click LB on the folder tab and select [Open] to edit the report.

Select TOPO SURFACE LEVEL as 
the model of shots

Select SMITH ST tin to check against

Type in above and below tolerances in 
mm

Type in 0 as the layer depth

Type in 3 for the Coords and Vertical 
diff decimal places

Type in report name PAVEMENT 
ASCON

To reference the points to a control line 
tick the check box

Pick Select Align then pick and accept 
the alignment string SMITH ST

Select Report

Open the report file
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Chapter 12  Subdivision Design
12 Subdivision Design
In this exercise we will create a subdivision using a defined outline and explore the various options 
involved in creating and reporting lot layouts.
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12.1 Setting up a New Project
To begin create a new project called SUBDIVISION in the Survey training area

Create a project under the folder C:\12d\12.00\training\survey\ called SUBDIVISION

First, double click on the 12d Model 14                                                          
icon to bring up the Project Selection 
panel.

Select New button to bring up the New project panel.

Select the New button at the bottom of the panel to create and open the project.
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To begin we will create the front and back boundaries for the lots.

We will use CAD and other commands to increase your familiarity with how 12d Model works and 
demonstrate a variety of the 12d Model commands.

What we are first trying to achieve is to create the boundaries for the subdivision.

Then we will use various methods in 12d Model to create lots within these subdivision boundaries.

back boundary 
string for the lots

front boundary 
string for the lots

first edge
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12.2 Create the surrounding boundary
We will firstly create the string around the edge of the subdivision

Select option Survey =>Extras =>Bearing/Distance Entry

We are now able to type in the bearing and distances around the edge of the boundary

Type in a model name SURROUND

Select the colour purple

Select linestyle 1

Type in Scale Factor 1

We will not be using point numbers so select 
none

Type in start co-ordinates 1000 5000

We will not be using heights so untick the 
check box

Type in the bearing and distance of the string around the 
surround boundary

Select the Enter or Tab key to move between cells.

After typing in the distance press Enter to create the next 
line

Use the bearing and distances as shown in the example on 
the right

NOTE that the bearings as in HP notation and are in the 
format ddd.mmss

When all the lines have been entered select 
Process then Finish
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In plan view 1 turn on the model SURROUND and zoom all

To check the distance between the start and end point (the misclose) select

 Utility =>Measure =>Bearing/Distance or Measure Bearing/Distance icon

Zoom right in to the start point, and then making sure you only use a point snap, select and accept the start 
and end points

If the values are not the same as in the image above then you have made an input error.

To find and correct the error, select the option Survey =>Extras =>Bearing/Distance Entry again and this 
time click on the Select button and then pick and accept the purple boundary string.
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The Bearing/Distance grid will be filled in with the information for the selected boundary string line and 
this can be compared to the values that were suppose to be typed in. Once the error is found, the relevant 
line can be corrected in the Bearing/Distance Entry panel and then Process precessed to re-create the 
string with the corrected values. Select Finish to exit the panel

The string now needs to be closed to form a polygon

Select the option Cad =>String =>Close or String Close icon

Select and accept the surround string to close it. Press <Esc> to terminate the option if chosen by the icon.

12.3 Duplicate the surround
The surround string is to be duplicated in a new model called BDY. This new model will be used in the 
subsequent lot calculations.

Select Strings => Strings edit => Duplicate

Select and accept anywhere on the SURROUND string. Select Finish.

Now turn off the model SURROUND and turn on model BDY

Type in new name and model 
name BDY

Select colour Red

Select Start
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12.4 Open the new Boundary string
To help with future calculations using the boundary string BDY we open the string at this point.

Select option Cad =>Change Strings =>Open or the Cad string open icon

then pick and accept the boundary string. Press <Esc> to terminate the option if chosen by the icon.

12.5 Create Road Centreline
The centreline of the road reserve will now be created

Type a new model name CL in the cad control bar and change the colour to blue

Select the option Cad =>Lines =>Traverse create or the Traverse icon

 

Type in the next bearing as 273.45 [Enter] and the distance as 103 [Enter]

Press [Esc] key to exit the traverse entry

Press the space bar then type in 965 (space) 4998 [Enter]

The is the start point for the traverse.

Press the space bar then type in distance 90 [Enter]

Press the space bar then type in 350.3000 [Enter]
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To insert a curve into the centreline string select option Cad =>String =>Join fillet or select the Join fillet 
icon

Select up the first straight with 
direction and accept. Pick along the 
second straight with direction and 
accept

Type in the radius -20 [Enter]

The curve is inserted
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12.6 Create Road boundaries

12.6.1Parallel centreline string
The road boundaries will be created parallel to the road centreline

We will set the name and model to BDY in the CAD Control bar by matching an existing BDY string.

Select the Same as icon

The cad control bar will self populate

Select the String parallel icon

Pick and accept one of the 
boundary strings

The default parallel type is full 
(f) parallel

Select the string with direction 
and accept

Type in the offset for the right as 7.5 [Enter]

Type in the offset for the height as 0 [Enter]
Page  313



12d Model Training Manual
Press <Esc> to terminate the parallel command.

The centreline string is 
paralleled

Repeat this for the other 
side of the road using 
offset -7.5 to parallel to 
the left.

NOTE: remember to pick 
with direction.

Both sides are now 
paralleled
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12.6.2Convert arcs to chords
The arcs along the road boundary are to be converted to chords. These are created on the outside of the 
right hand curve and inside the left hand curve

Select the option Strings =>Strings edit =>Arc to chords

Repeat the process for the outside arc creating three chords on the outside

Select Pick

Select and accept the arc segment 
that is the inside curve

Set the Convert Method to inside

Set the Method to no. of chords

Type in 2 for No. of chords

Select Process

The arc is converted to 
two chords
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Toggle on the Vertices and Vertex indices

Select Pick

Select and accept the outside 
curve

Set the Convert Method to 
outside

Set the Method to no. of 
chords

Type in 3 for No. of chords

Select Process
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Two vertices are now redundant

To delete these points select 
Cad =>Delete =>Vertex

or Vertex delete icon

Select and accept the two points

The points are now 
deleted

Press <Esc> to terminate 
the delete vertex 
command.
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12.6.3 Splay the road intersection boundaries
The road intersection boundaries have to be splayed using 3 chord truncations. 

Zoom in to intersection of the three road strings and the boundary string.

12.6.3.1Trim and delete boundary lines

We will use an option to split the strings at the intersection points

Select option Cad =>String =>Cross Split or the Cross Split icon

 

Select and accept the two 
intersecting lines

Repeat for the other side 
of the road

The strings are split at the 
intersections of the 
selected strings.
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We will now delete the redundant strings

Select option Cad =>Delete =>String or the String Delete icon

 

Pick the three strings

Press <Esc> to terminate the 
delete string command.
Page  319



12d Model Training Manual
12.6.3.2Fillet corners

Before splaying, the corners the segments have to be joined to create one string. Filleting the strings with a 
zero radius will join the strings and remove any duplicate points

Select option Cad =>String =>Join fillet or select the Join fillet icon

Select with direction and accept the 
first segment

Select with direction and accept the 
second segment

Type in radius 0 [ENTER]

Repeat for the other side
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12.6.3.3Create corner splays

Select the option Strings =>String edit =>Corner splays

Type in 3 for the number of chords

From the Convert mode choice list select 
tangent length

Type in a tangent length of 8

Untick the Keep original string check box

Select Pick

Select and accept the left side 
intersection point

The splays are created
Page  321



12d Model Training Manual
If a Fit in now done on view Plan 1, it will look like:

Repeat for the other side of the road 

Select Finish

We will create a segmented 
culd-de-sac bulb on the 
end of the road using CAD 
commands
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12.6.4Create Cul de sac head
We will now create a cul de sac head manually. Before continuing ensure the current model is BDY and set 
the default colour in the Cad Control bar to red

12.6.4.1Create Circle

Zoom in to the end of the subdivision road

Select option Cad =>Circle =>Centre and Radius or the Centre and Radius icon

Select and accept the point at the end 
of the road

Press the space bar and type in the radius of 12.5 [Enter]

The circle is created
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12.6.4.2Create boundary lines around cul de sac head

Prior to creating a polygon of a circumscribed circle we need to create an offset point for the orientation of 
an edge the polygon.

Select option Cad =>Points =>Offset or the Offset icon

Select the top edge of the road 
boundary string with direction

Select and accept the start point of 
the string

Type in the distance 0 [Enter]

Type in the offset -5 [Enter]

The offset point is created at the edge 
of the circle
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We now create an 8 sided trapezoid about the circle

Select option Cad =>Polygons =>Polygon Circumscribed or the Polygon Circumscribed icon

 

Select and accept the point at the 
centre of the circle

Type in the number of sides as 8 
<Enter>

Select and accept the offset point 
to position the shape
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Press <Esc> to terminate the Delete segment command,

The polygon is created around 
the outside of the circle with the 
offset point as a mid point of an 
edge.

Select Vertex delete icon and 
delete the offset point

Delete the circle using the option 
Cad =>Delete Strings or the 
String Delete icon 

Delete the right side of the polygon using 
the option Cad =>Delete Segments or the 
Segment Delete icon 
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Fillet the circumscribed polygon to the road boundary strings.

Select option Cad =>String =>Join fillet or Join Fillet icon

Press <Esc> to terminate the Join fillet command,

Pick and accept the two strings 
with direction

Type in the radius 0 [Enter]

Repeat for the lower edge
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12.7 Create lots

12.7.1Split string at starting edge
Before we start creating lots, the one boundary string needs to be split so that there are separate strings for 
the front and rear boundaries of the lots. This is achieved by splitting the string either end of the start and 
end edges of the lots.

Select Cad =>String =>Split or the Split icon

Zoom in to bottom right of the subdivision, We will split the string at vertex2. 

The red string 
starts with vertex 
1 and goes 
around the culd-
de-sac bulb and 
back around to 
end up at vertex 
35 which is only 
a millimetre 
from vertex 1

Select and accept string 
between 1 to 2

Select vertex 2 as 
the split point
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We’ll change the colour the new string so it is easier to see what happened.

Select Strings =>Strings edit =>Change

Select Finish to close the Change String panel.

The red string has now been split 
and the first vertex is now at what 
used to be vertex 2 and there is a 
new string going from the original 
vertex 1 and vertex 2. All the 
vertex indices in the red string will 
have changed.

New vertex 1 of the long boundary 
string that now have only 34 vertices

The vertex index 1 is hard to see 
because vertex 2 of the new string is 
right on top of it.

NOTE: it is possible to show the 
vertices of selected strings rather than 
for all strings on the view.

New two vertex string

Set New colour to green Select the new string and it will turn green
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We will now split the red string at vertex 24.

Select Cad =>String =>Split or the Split icon
 

Use the option Strings =>Strings edit =>Change to change the colour of the string that contains the vertex 
24 in the view above to purple.

After doing a fit on view 1 we now have the subdivision boundary strings that the lots are created within.

Select and accept the red string

Select and accept vertex 23 as 
the split point

Press <Esc> to end the split 
command

back string

front string

first edge
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If we change the purple back string back to red and toggle off the Vertex indices, we will begin to place the 
lots.

back string

front string

start edge
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12.7.2Create lots by different methods
The first three lots will be created by specifying a minimum area of 800 for the new lots

Select option Design =>Estate-Lots =>Create lots =>Create lots

Select Process to create the first lot.

Type in model name LOTS

Select view 1

Select colour purple

Type in 800 as minimum area

Type in 8 as the minimum frontage

Select Pick front and select and accept the front boundary 
string with direction

Select Pick back then select and 
accept the rear boundary string with 
direction

Select Pick edge then select and 
accept the start edge

Select Method for lot choice icon 
then select perpen start pt.

The Pick a point field then appears.

Pick a point on the front string, a 
little away from the corner splays.

start edge

front string

back string
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The first lot is created with the new 
edge perpendicular to the road frontage

first lot

Now change the Method for lot to 
parallel pick

Select Pick an edge and select the 
previously created lot edge

Select Process again

A second lot is created
second lot
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The next lot to be created will not have a minimum area but will have a new edge bound by two existing 
vertices on the front and rear boundaries. We will use a different option to create this lot.

Minimise the Create Lot panel 

The new edge of the new lot is 
automatically made the 
selected edge.

Select Process again

The third lot is created

third lot

Pan up to the top right of the 
subdivision

The new boundary edge will be 
created from the shown vertices
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Select option Design =>Estate-Lots =>Create lots =>Create lots by picking segments

Select model LOTS

Select colour purple

Tick the check box to Join first and 
last segment

Select Pick sides

Pick the segments with direction 
clockwise from top right vertex

Take care to zoom into the small 
segment 3 at the front

The no. of segments: 4 is shown

Select Process to create 
lot

Select Finish to exit

The fourth lot is created

segment 1

segment 2
segment 4

segment 3

fourth lot
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To display the area press F2 or select Strings=>Inquire or the String Inquire icon

The next lots will be created using the minimum area panel again

Pan left from the last created lot

Restore the Create Lot panel

Select anywhere on the lot edge but do 
not confirm

If the lot polygon is highlighted the area 
is displayed in the Information panel.

Your area may be different depending 
on how you split your strings etc.

Press Finish to exit the String Inquire 
panel
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Select Method for lot choice 
icon then select pivot pick

Select Pick a point then select and accept the 
next vertex

Select Process

Change the Min area to 1100

Select Pick edge then select and accept the 
last side boundary line

The fifth lot is created with the new edge 
pivoted about the selected vertex

fifth lot
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Now change the minimum area back to 800

Set the Method for lot to perpendicular.

The Pick font/back field is then displayed 
and either the front or the back string is 
selected to go perpendicular to 

Select Process to create lot 6

Select Pick front/back and then pick the 
front string

lot 6
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Now change the Method for lot to parallel pick

Select Process twice

Select Pick an edge and 
select the previously created 
edge of lot 6

lot 6

lot 7lot 8
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Zoom in to the end of the cul de sac

The next lot will be created 
with an area of 900 and the 
new boundary edge to pivot 
from this vertex

Change the minimum area to 900

Set the Method for lot to pivot 
pick

Select Pick a point

Select and accept the pivot point

Select Process then Finish

A new lot is created

lot 9
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Pan around to the bottom of the cul de sac

 Select option Design=>Estate-Lots=>Create lots =>Create lots by picking segments

The next lot will be a 
park lot.

We will use the option 
to create lot by 
selecting the sides.

The final edge will lie 
between these vertices

Minimise the Create Lot 
panel again

Type in model PARK

Select colour green

Tick the check box to Join 
first and last segment

Select Pick sides

Select and accept the sides with 
direction in a clockwise direction 
from this vertex

1

2

3
4

5

6

7

After accepting segment 7 
select Process then Finish
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Turn on the model PARK

For the next six lots we will use the Create lots option

Pan along the right as per the example below 

Park
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The new lot is created

Type in 800 as minimum area

Select Pick edge then select and accept the side boundary 
line

Select Method for lot icon then select pivot pick

      Select and accept point at next vertex

Select Process

lot 11
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P

Select Process three times

For the next three lots we will 
generate the side boundaries at 
a bearing of 3°45’ 

Change the Method for lot to 
Parallel bear 

Type in bearing 3.45 (3°45’)

The three new lots 
are created with the 
new side at bearing 
3°45’

lot 12 lot 13 lot 14
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To create the last lot we will use an option to form a lot polygon from picking the centre of a series of strings. A 
search distance is entered to find all strings within the search distance radius.

Pan down to the last lot.

Pan down to the last section of 
the subdivision

The next lot will have its new 
edge pivot from a rear vertex

Change Method for lot to 
pivot pick

Select Pick a point then select and 
accept the next vertex on the rear 
boundary

Select Process to create new lot

The new lot is created

Select Finish on Create Lot 
panel

lot 15
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Select Design =>Estate-Lots =>Create lots =>Create lots by picking point inside

Select view 1

Select model name LOTS

Select colour purple

Type in search distance 50

Select Pick and select and 
accept a point inside the 
area to create the lot. Ensure 
the position you pick can 
see to each vertex of the lot

The new lot is created

lot 16
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This completes the house lots.

We will now create a lot for the 
road. 

Zoom the whole of the 
subdivision 

Turn off models LOTS and 
PARK and CL

Turn on the model SURROUND

Turn off the vertices

To create a polygon bound by the 
boundaries and the surround edge select 
Design =>Estate-Lots =>Create lots 
=>Create lots- polygon discovery

Select the Mode icon

Select Create all found

Select Pick then pick inside the road area to create the road boundary

Set the cad control parameters as shown below

Select Finish to close the Polygon 
Discovery panel
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12.8 Lot numbering
The lots can now be numbered according to the type of lot.

 Lots, parks and roads will be numbered separately.

Remove all the models from the view and then add on LOTS, PARK and ROAD. Do a Fit.
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12.8.1Create lot numbers
Select option Design =>Estate-Lots =>Number Lots =>Create lot numbers

 

Select the Data source icon then select view

Select view 1

Type in 1 for Next lot no.

Select Lot type choice icon

            Select lot

Select colour orange

Tick Auto increment check box

            Type in 1 as Lot increment

Tick Display lot number check box

Select Pick

Select and accept a segment of 
the first lot

Point number 1 (in white) 
should appear in the middle of 
the lot

Repeat numbering 
lots until reaching 
the park

Continue numbering 
the lots from the 
other side of the 
park
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To create the description for the park change the following settings

To number the road change the following settings

Type in PARK as Next lot number

Select Lot type choice icon and select park

Change the colour to green

Select Pick

Pick and accept the park string

Select Pick

Pick and accept the road string

Note that because the label ROAD is placed 
at the centroid of the polygon, it is not inside 
the polygon. 

Select Finish to exit the panel. The 
temporary numbers will disappear

Type in ROAD as Next lot number

Select Lot type choice icon and select road

Change the colour to red
Page  350



Chapter 12  Subdivision Design
12.9 Lot labelling
The lot annotation can now be created. Features such as bearings, distances, lot numbers and areas are 
created for each lot

The annotation settings can be stored in a Lot annotation file which is loaded prior to creating the 
annotation

Ensure that the models LOTS, PARK and ROAD are the only models on view Plan 1.

Do a Fit on view 1 to show all of the subdivision

Select option Design =>Estate-Lots =>Label Lots =>Lot labelling

Select the Lot annotation file 
choice icon

Select the file TRAINING.laf 
from the survey folder

The laf file sets up how Areas, 
Lot numbers, Bearings etc are 
to be labelled.

Select Read

If there are parameters in 
the laf file to define how 
an item is to be labelled, 
then the incomplete will 
change to completed. 
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Select Finish to close the Create Lot Annotations panel.

The parameters for each type of annotation 
can be edited by selecting the edit icon

To create the different text types tick the 
relevant check boxes

A short line table can be created which 
will tabulate any line where the distance of 
the line is less than a user defined value

Select Lot type choice icon and select 
ALL TYPES

Select Data source icon and select view

Select view 1

Select Process

Turn on the annotation models
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Select the Plan View Properties icon on view Plan 1

Click on Settings node and type in a new Plot scale of 500 and then <Enter>
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12.9.1Edit the annotation
For the ROAD polygon, the type (ROAD) and area have been placed at the centroid of the ROAD polygon 
but unfortunately the centroid is outside of the ROAD polygon.

We need to move the text so that it is inside the ROAD polygon.
The annotation text can be edited by using options on the text flyout toolbar.

Using the Edit option, move the two pieces of text so that they are in the ROAD polygon.
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12.9.1.1Reverse Bearing

To reverse the direction of a bearing label select option

Design =>Estate-Lots =>Lot Utilities =>Reverse Bearing

Select and accept the bearing to be reversed. You may need to turn on the vertices to see the insertion point 
of the text or you can turn on the text snap [X] from the snaps toolbar to click anywhere in the text 
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12.9.2Create Short Line table
The short lines have been identified with a circled number 

We now need to create the short line table

Select option Design =>Estate-Lots =>Lot Utilities =>Short line/arc table

Select Finish to remove the panel.

Select model textShortsegments

Select ARIAL for Text style

Select the Table position icon

Select and accept a point on the screen 
representing the top left corner of the 
table

Select view 1 to show the table

Select Process to create the table
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The bearing and distances of the short lines are displayed along with the relevant lot number

To move the table select option Drafting =>Multi strings translate

Select and accept a piece of text in the table

Move the table to a new location and accept the position

Select Finish to exit the option

Select Name 
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12.10 Lot Reporting
We will now generate a report on the subdivision

Turn on the SURROUND model to use as the Boundary

Select option Design =>Estate-Lots =>Report Lots

Select Boundary then 
select and accept the 
SURROUND string

Type in 3 for number of 
decimal places

Type in 0 for number of 
decimals for the 
seconds in the bearing

Type in report file name 
LOTS

Select Process

Select Data source icon 
then select view

Select view 1

Select Report type icon then 
select sort by 
type

Select Report file folder icon

Select LOTS.rpt

Select Open
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The first section of the report deals with the lots of type LOT

The number, area and dimensions are displayed along with the vertex co-ordinates

After the last lot is displayed, the number of lots along with the total area, average area and percentage of 
the boundary (SURROUND) are listed
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The PARK is listed

The ROAD is listed
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At the end of the report the total number of lots are listed along with the area

Any errors in the lot creations should yield a percentage difference to the boundary

Exit the report file
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